Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


ML on sony (i5 520M / GT330M), help anyone?

17 posts in this topic

Recommended Posts

Hello, im disperately trying to make ML run on my DAMN vaio (vpcf11m1e)

specs are:

cpu i5 520m

8gb ram

nvidia gt330m


i tried so far with chameleon but i got stuck on pci configuration error, tried a gigabillion of flags, and as SMBIOS i've set MAcbook Pro 6.2 (the macbook pro with similar specs, i5, gt330m..)

any one could direct me to a working way, possibly with easy drive through? i'm new to this world..

thanks in advance and please help me i hate windows :P

Share this post

Link to post
Share on other sites

updates: i fixed the pci configuration error with a iosupcifamily kext but now im stuck in a stupid error, i think it's cause of the hard drive (there is windows 8 in it), should i format it before trying to install ML?

Share this post

Link to post
Share on other sites

Here's the situation:

i have an hard disk with two partition, in C: there's windows, and D: is formatted

if i boot now I still have the


error but it's not stuck, it goes until the ntfs-fs error again but this time mentions a hibernate status of Windows (WTF?). Windows is not hibernated and i ran chkdsk but I still have this error. (see attach.)



Share this post

Link to post
Share on other sites

Can't see your photo, but nothing you described as an error, normall stuff. Use boot flags -x-f -v and whatever the correct bus ratio would be, then wait

Share this post

Link to post
Share on other sites

thanks, i tried (busratio=18 I have i5 520M) but I'm stuck at

BootCacheControl: Unable to open /Var/db/BootCache.playlist: 2 No such file or directory

Share this post

Link to post
Share on other sites



the problem is u graphics


first graphics card is intel hd , i think 8086:0046 not supported


see with system info here in forum




if so, just remove appleintelhd*.kext from installer, and boot


but u graphics never work


good hack

Share this post

Link to post
Share on other sites

tried removing the 4 AppleIntelHD* kext but it is the same thing..stuck on the bootcachecontrol :(


sometime when I boot i get over that bootcache error but right after I have the error with the hibernate windows (?!) as seen here



can i install ML on an external USB drive? (so inserting two usb while booting, one for the usb stick one with the destination hd)

Share this post

Link to post
Share on other sites



have u windows in suspension or hibernate mode if so shutdown the system.


is only 4 kext ?


remove all appleintelhd*.kext


and boot


-f -v GraphicsEnabler=No


good hack

Share this post

Link to post
Share on other sites

remove nvidia ones too


BootCacheControl: Unable to open /Var/db/BootCache.playlist: 2 No such file or directory - even appears on real macs when verbose booting, not an error for basic config

Share this post

Link to post
Share on other sites



that is so messy , the installer


try another thing


-f -v UseKernelCache=No GraphicsEnabler=No


some versions of chameleon have problems with the flag -f and no ignore the caches


the msg DSMOS arrive and stop is graphics, and now if u don't have kext, only thing i can remember is the caches


btw what metode u use to prepare the installer ?


good hack

Share this post

Link to post
Share on other sites

yup, a graphics driver is still loading from somewhere. add -x bootflag too as I first mentioned, it should prevent some from loading. there's also some vaio tutorials and threads since they can be a pita

Share this post

Link to post
Share on other sites

thanks for helping me guys.

here's what I did so far:


created the USB stick by formatting it then restoring the base system dmg, then mach__kernel text into the new usb + partitions folder + fakeSMC + NullPowerCPU + IOSPCUFamily.kext then used chameleon to install the smblist for macbook pro 6.2 (the pro with gt330m and i5) removed all graphics kext (tried also with)

booted using a lot of flags combinations (f v x pcirootuid graphics enabler=no npci=0x2000/3000 busratio=18, not all at the same time :) )


tried with -v -x -f UseKernelCache=No GraphicsEnabler=No this is the result (same as usual)



this is my extension folder


Share this post

Link to post
Share on other sites

the 5 kexts after NullCPUPowermanagement are the nvidia ones, all start with NV in the name. Those are the ones that need deleting

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By artkondrashov
      Hi My name is Vova please help me settings clover and dsdt tabel for laptop..
      Installed version of the system OS X 10.12.5
      Does not work:
      1. Mouse treckpad (no multipad), usb mouse Work;
      2. After Sleep mode, not work Audio and Micro, before sleep mode Audio and Mic true;
      3. Battery It works then does not work;
      4. This poppy does not open because of SMBios;
      5. The hotkeys of the backlight do not work;
      Thank you dear friend that did not pass by
      Here is a system dump, laptop data, a clover data.... in file check..
      Motherboard: Intel Cougar Point HM65, Intel Sandy Bridge
      CPU: Mobile QuadCore Intel Core i7-2670QM, 3000 MHz (30 x 100) CPU @ 2.20GHz
      Video adapter: Intel HD Graphics 3000

      IDE Controller: Standard SATA AHCI Controller

      WIFI network adapter: Atheros AR9285 Wireless Network Adapter
      Ethernet network adapter: Realtek PCIe GBE Family Controller

      Audio Adapter: Conexant Cx20590 @ Intel Cougar Point PCH - High Definition Audio Controller [b-2]
      Audio Adapter: Intel Cougar Point HDMI @ Intel Cougar Point PCH - High Definition Audio Controller [b-2]
      diagnotic sony vaio.zip
      Folder CLOVER.zip
    • By fantomas1
      Update - 06.15.2016
      A minor update of this topic - Clover (r3561) patch on the fly works fine with macOS 10.12 Sierra.

      Update - 08.18.2015
      with Download-Fritz help, I’m finally able to patch my kexts with new method.

      it works fine with Clover r3259 + DB6
      but in my case, I still have to use FakeSMC trick... I tried with ForceKextsToLoad feature but it didn’t work... not yet.

      Update - 08.17.2015
      Hi there!  
      almost a year later, I'm about to update this topic, not because I was too lazy to do it but just because the "patch on the fly" method  has a little bit changed since Clover r3154  and which I was not able to make work.
      not really happy with being unable to use this method, I decided to do some tests with older versions of OS X and Clover... Bla bla bla... bla bla Bla...

      ... as I expected, the old method still work... and it works fine with ElCapitan DB1  

        I even was able to install ElCapitan with Clover r2850 and boot well on it         but to have success with it, the most effective trick for now is to inject the details of my kexts (AMD5000Controller.kext and AMDRadeonX3000.kext) inside the FakeSMC Info.plist as additional IOKitPersonalities. With this trick, my kexts are always loaded.
        with the standard loading method, the patch doesn't work      

      Update - 03.28.2014
      just to tell that since Mavericks, we need no more those 3 kexts, only 2 of them (AMD5000Controller.kext and AMDRadeonX3000.kext) to enable QE_CI for HD6770 cards
      even if you use those 3 kexts, AMD6000Controller.kext will not be loaded

      to do this with chameleon, use GraphicsEnabler=Yes and edit 0x68B81002 -> 068BA1002 in both kexts
      if you want to do this with clover, use clover configurator and KernelAndKextPatches tweak:

      don't forget to put 'Inject Kexts' to 'Yes'

      if it does not work, it is because the kexts are not presents in kernel cache. 
      The most effective trick for now is to inject the details of your kexts inside the FakeSMC Info.plist as additional IOKitPersonalities. With this trick, your kexts will be always loaded.
      I did it with QE_CI Exotic patch for HD48xx series cards with my old HD4830 and it works!
      see here for more details: http://www.insanelymac.com/forum/topic/296949-tuto-qe-ci-exotic-patch-via-clover/
      here, more screens


      Method 3: if you're using Clover, you can make this card work with a Fake ID injection
      <key>Devices</key> <dict>         <key>FakeID</key>         <dict>             <key>ATI</key>             <string>0x68B81002</string>         </dict> </dict>
      Method 2: since OS X 10.8, you no longer have to edit those kexts, just inject your ID via dsdt: http://www.insanelymac.com/forum/topic/282687-radeon-hd-6770-full-qeci-mountain-lion/?p=1902721 (credits go to RampageDev)
      *This method also works very well with OS X Mavericks         Method 1: i can confirm it, with the last Chameleon-2.1svn-r2054.pkg, it work well on 10.8.2 Build 12C43 !!!

      No more need to flashing HD 6770 into HD 5770 to have QE/CI !!!

      So just add your ID (0x68BA1002) into ATI5000Controller.kext and AMDRadeonAccelerator.kext
      <key>AMDJuniperGraphicsAccelerator</key> <dict> * * * <key>IOPCIMatch</key> <string>0x68BA1002 0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002</string>
      * the story started with this original topic
    • By viruz solar
      hola amigos quisiera saber que targesta wi-fi usb me pueden recomendar ya que reciente mente instale mountain lion y no puedo hacer que funcione ninguna de las dos wi-fi que tengo  todo corre bien en mi hackintohs usb, mause,sonido, graficos menos los wifi cual me recomiendan??
      o me recomiendan actualizar a una vercion mas resiente?
    • By Nikita123
      Hi everyone,

      I have been trying for a while now to install Mac OS X El capitan 10.11.4 on the Sony Vaio VPCEB1M1E with limited succes.
      I am using Clover (latest version)
      The biggest problem is no LVDS detected and the notebook has a blackscreen as soon as OS X starts.

      I have created several config files, and if I disable Inject ATI i can login to the system without QE/CI. Wi-Fi works, AR9285.

      So I installed teamviewer, reboot, enable ATI config, got blackscreen, but logged in with teamviewer and QE/CI is working. I created an IOREG this way with IORegistryExplorer 2.1 and I have also attached my entire EFI partition, all unpatched ACPI tables are included. I think the problem is wrong connector info. Have tried several different framebuffers, Hoolock, Orangutan, Vervet, all give blackscreen on LVDS.

      Device ID: 68c1

      There are several config files, config4 is the bootconfig I used to make the IOreg.

      VGA is not working , have not been able to test HDMI (yet).
      Here is my entire EFI Folder: https://www.dropbox.com/s/ig134fl6pdq193a/Archief.zip?dl=0

      I found the following topics about the problem and there only seems to be a chameleon solution:



      I hope someone can solve this.
      Good hack to you all,

    • By Я.B
      I have installed 10.10.0 Yosemite to my Sony VAIO E Series VPCEH25EN. 
      Boot flags used -v dart=0 -f
      After installation, I have installed the 10.10.5 Combo Update.
      After reboot I have installed some kexts, Basic Boot Options, Chimera bootloader, SMBIOS into my Yosemite SSD.
      FYI, Full Graphics and native resolution along with Graphics Chipset detected was present at the first boot. I didn't have to add any kexts.

      Boot time has reduced. I have full Graphics, native resolution, App store access. 
      The only thing I want to work is HDMI. 
      No HDMI output, I have tried my AOC monitor and Sony Bravia TV. Not working.

      Before I play around with tools, I wanted an expert opinion on what should I try.
      Graphics chip is NVIDIA GeForce 410M 512 MB.

      I have tried booting with GraphicsEnabler=Yes/No . No change.

      Should I try Nvidia Web Driver?
      And what is EDID Injection? Is it necessary for HDMI to work?