Jump to content

Intel DG33TL Sleep Question

2 posts in this topic

Recommended Posts

Hey Everyone,


So I decided to build another hackintosh based off of the Intel DG33TL board - it's VERY solid and is one of the few LGA775 mATX boards with four RAM slots.


For informational purposes, here are my components:



Intel Core2Quad Q6600

Intel DG33TL Motherboard

8GB Mushkin Silverline DDR2

Mushkin Chronos 240GB SSD (OS)

WD Caviar Black 750GB (Storage+Windows)

AeroCool 620W Modular PSU

Sapphire Radeon 5770 Vapor-X

Lian-Li PC-V353A mATX Case

OSX Mountain Lion 10.8.2 (Apple Store-bought)


Apple Pro Keyboard (USB, white)

Apple Mighty Mouse (USB)





BIOS Settings:

-AHCI Mode

- HPET Enabled

- Power Mode to S1

- Latest BIOS Update Applied


I got sound and networking functional without much issue, and everything seems to be working nicely. Sleep, however, has NOT been friendly. You can take a look at my sleep worklog here: http://www.tonymacx86.com/general-help/77557-intel-dg33tl-sleep-question-mountain-lion.html


Sleep was working fine under Lion 10.7.X and also Snow Leopard 10.6.X, and all my settings are the same! That said, I know things change from OS version to OS version, so I didn't expect everything to work OOB.


If anyone could help me out, confirm it working on their DG33TL Mountain Lion machine, or even point me in the right direction, I would be much obliged!


For those who don't feel like clicking through, this is what I have tried regarding sleep:


Attempt 1:

DSDT Only. On sleep command, screen would turn off and fans would slow down, but no sleep. Reboot needed for response.


Attempt 2:

Applescript called "RIP". No difference from above.


Attempt 3:

Sleepenabler.kext - the correct one for my OSX (10.8.2). I was happy to see that the computer went to sleep, and even woke up, but on awake it froze (no visual KP, just frozen keyboard and mouse) with the following console:




It seemed to me that it was related to initializing the voodoohda audio kext, so I deleted that and tried again.


Attempt 4:

Sleepenable.kext with deleted voodoohda kext. This time it slept, and KP'ed on wake (visual multi-language KP screen present), with the following console:




Attempt 5:


Tried deleting NullCPUPowerManagement.kext, as recommended here: Sleep Tips. Repaired and rebooted. Tried sleeping, again it went to sleep without issue. On wake, black screen and unresponsive. Console:





According to the osx86project wiki, sleep is supported in both Kabyl and Vanilla kernels...it doesn't say when the last time that was confirmed (I suspect Snow Leopard, Lion would be stretching it seeing as I added the Lion information on that wiki!).

Link to comment
Share on other sites


  • Create New...