Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sammity

ML on Samsung NP530U3C Ultrabook

40 posts in this topic

Recommended Posts

Hi All,

 

So after several different Hackintosh computers I'm at my latest. Shame it seems I've forgotten most of what I've learned before, but I'm up for more learning!

 

Well the computer at hand, was up for a good price in the UK, all things considered it should hopefully work out after rebate at £375 but I digress as this topic is about getting Mountain Lion on the device.

 

As you can see from my signature I'm not new to this, having a few computers which have been tinkered with over the years. Hopefully the experts, amateurs and the other lurkers will help me into getting mountain lion installed and fully functional on this Samsung Ultrabook.

 

Some tech specs first:

 

13.3" LED (1366 x 768) Intel HD 4000, 6GB DDR3, Wifi Swapped for Atheros AR9285, Li-Polymer, 3rd Gen (Ivy Bridge) Intel i5-3317U Processor (3M Cache, u 2.60 GHz), 24GB I-SSD, 500GB HD

 

lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation Device [8086:0154] (rev 09)

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:0166] (rev 09)

00:14.0 USB Controller [0c03]: Intel Corporation Device [8086:1e31] (rev 04)

00:16.0 Communication controller [0780]: Intel Corporation Device [8086:1e3a] (rev 04)

00:1a.0 USB Controller [0c03]: Intel Corporation Device [8086:1e2d] (rev 04)

00:1b.0 Audio device [0403]: Intel Corporation Device [8086:1e20] (rev 04)

00:1c.0 PCI bridge [0604]: Intel Corporation Device [8086:1e10] (rev c4)

00:1c.3 PCI bridge [0604]: Intel Corporation Device [8086:1e16] (rev c4)

00:1d.0 USB Controller [0c03]: Intel Corporation Device [8086:1e26] (rev 04)

00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:1e59] (rev 04)

00:1f.2 SATA controller [0106]: Intel Corporation Device [8086:1e03] (rev 04)

00:1f.3 SMBus [0c05]: Intel Corporation Device [8086:1e22] (rev 04)

01:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:002b] (rev 01)

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)

 

Story so far:

Purchase Mountain Lion £13.99 App store, long download!

Try all sorts of methods to get unibe@st to work on making a USB bootable stick and get frustrated at it not booting.

Eventually remove the HD from the Samsung Laptop and install ML 10.8.1 to it from another computer (GUID partiition)

Install Chimera 1.11 to HD to enable booting from HD

 

Boot From HD, lots of errors on verbose boot, so many graphics errors I can't remember them all.

Finally I've settled on the following:

1)Fresh install of 10.8.1

2)Install Chimera 1.11

3)Use the following as my chamelon bootlist data

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1366x768x32</string>
<key>Kernel Flags</key>
<string>-v</string>
<key>RestartFix</key>
<string>No</string>
</dict>
</plist>

 

4)I'm using the Macbook pro 9,2 SMbios plist

5)Install the Following attached kexts to get Wifi (but no success with bluetooth).

 

Problems:

a)Graphics :

So this is where I'm upto, the internal screen works but I don't have QE/CI. I've tried all the available options on the IntelHD platform ID (from 0-9 and AB) but am unsuccessful.

On one of them, string no 3 I believe and Graphics enabler off I get full QE/CI on my HDMI connected monitor but my internal laptop screen is blank/black.

b)If I boot from the HD, the trackpad doesn't work. After finally getting a unibe@st installer working, I can boot from it and select it to boot the HD then the trackpad works.

c)USB ports don't work aswell as a whole lot of other stuff.

 

If someone could please assist me in helping to fix this laptop I would really appreciate it.

Also I'm trying to get back into editing my DSDT, but I'm failing miserably so help is appreciated! :worried_anim:

 

As far as I can understand the spec is very similar to the ASUS UX32VD.

 

Thanks in advance for help received.

 

Sam

Samsung dsdt.aml.zip

Atheros AR5B195 pack.zip

Share this post


Link to post
Share on other sites

Seems like everyone is busy to help :|

 

Anyhow I'm still attempting to fix this install.

 

Progress since my las post, I fixed the keyboard and trackpad not working issue by installing AppleACPIPS2Nub.kext into S/L/E

I've patched AppleIntelCPUPowerManagement.kext and have extracted the EDID information from my screen.

 

I've then altered my DSDT to input the EDID data and and now having the laptop screen boot with the EDID data. It shows up as Intel HD 4000 384MB but I've still not got QE/CI.

 

On checking kextstat it seems that the graphics kexts are just not loading, so I'm obviously missing something critical.

 

Sleep,USB and QE/CI not working.

 

Powerup/Power down/Keyboard/Trackpad(no multitouch)/Wifi all work.

 

Anybody willing to guide me? I'm not asking for someone to do the work. I'm willing to learn and do it myself!

Share this post


Link to post
Share on other sites

Ho do you swapped WiFi card, do you have any picture of that card? And if you changed that bluetooth works?

 

ON the NP550P5C swapping was a bit tricky since the chassis is a bit cheap. Needed to unscrew all screws and then prise the plastic clips apart using a small screwdriver.

 

http://www.ebay.com/...-/320947862446?

 

Yes the bluetooth works as well apart from after sleep which is a known problem.

Share this post


Link to post
Share on other sites

I have the same ultrabook, and i have in bios AHCI mode enabled or disabled, everytime i have still waiting for root device :/ - i tried this solution: http://blog.yerkania...-mountain-lion/ but it doesn't work.

 

Installer was built with myHack tool.

thak you for replies.

 

ps.

my usb stick plugged in on USB 2.0 port.

 

Sent you a PM

Share this post


Link to post
Share on other sites

HD4000 not working for that model - Black Screen on any string 0-9 checked. DSDT modified.

In my opinion the problem is memory attached in boot, in all tutorials we can see 64MB cards, Chameleon shows 63MB for IvyBridge Graphics Processor. (not QE/CI, resolution provided in Chameleon)

Addictionally mouse and trackpad kexts from voodoo makes system not showing anything without QE/CI.

 

Please help... :(

Share this post


Link to post
Share on other sites

Sent you a PM

 

Hi I have the same problem as Kamille 

when trying to install ML 2 on (I Think ) the same laptop. 

specs below, 

Can someone help me out with this one ? 

Share this post


Link to post
Share on other sites

Hi all,
 
Sorry for the extremely long absence but I've got some updates.
 
So I've tried to persist with the NP530U3C and have finally got QE/CI working. 
 
The process:
Disable UEFI in Bios
1)Install ML onto Drive (I did this with an external HD)
2)Update to 10.8.4
3)Customise clover boot loader install with boot0af in mbr option selected.
4)Copy clover config.plist to /EFI/CLOVER/ from samsung530U3C.zip folder overwrite the existing config.plist when prompted.
5)Copy dsdt.aml  and ssdt.aml to /EFI/CLOVER/ACPI/Patched from samsung530U3C.zip folder
6)Install with kext wizard into S/L/E the attached kexts:
AppleSmartbatterymanager.kext
FakeSMC.kext
ApplePS2Controller.kext
ApplePS2ElanTouchpad.kext
PXHCD.kext 
and if you have swapped the wifi card like me to an atheros ar9285 the IO80211Family.kext
 
7) Using Kext wizard repair permissions and rebuild cache.
8) Put the drive back into the laptop and boot.
9) Rejoice that the laptop finally boots into OSX.
 
Ok no further testing has been done but QE/CI works, battery works, Wifi works.
 
Nothing else has been tested.
 
The following file is attached: 
Samsung 530U3C.zip Contains the DSDT.aml, SSDT.aml, and the required kexts.
 
Please note I can't claim credit for all this as a lot of people have attempted to get this to work and I've just pieced it all together with my own tinkering.

Please search for Clover_v2_r1974.zip as this file is too big for me to upload.

 

Post edited to include attachments.

Samsung 530U3C.zip

Share this post


Link to post
Share on other sites

Sammity, <br /><br />Would you be able to tell me what other things work with your test? <br /><br />It would be great if everything works. <br /><br />Do you know if the wifi and display works fine after sleep/hibernation? <br /><br />Thanks

Share this post


Link to post
Share on other sites

Is there any more updates for this laptop?

 

Using Sammity's files etc I have managed to get mavericks running almost flawless - Display, touch pad(no multitouch), keyboard, sound work perfect. Have swapped out the wifi card with an atheros card (will send the model if you want - not the same as Sammitys though as I didn't need to install the kext for it and it worked natively - though it doesn't have bluetooth). 

 

The only thing I would really love to get working if anyone can help is sleep - when I put the unit to sleep the screen goes black but is still lit and the fan's don't slow down or stop. If I move the mouse the unit wakes fine etc I have tried sleepenabler.kext but this caused a panic at boot. Wondering if anyone has got it working correctly? 

 

I have noticed also noticed that usb 3 isn't working but usb 2 does(I had usb 3 working on a different install I did prior to finding this thread - though nothing else worked then ;p)

 

Also a big thankyou to Sammity as his folder full of config files, kext etc's has made the process so much easier!

Share this post


Link to post
Share on other sites

Excellent mate. Yeah if you would send me the model of the wifi card.

 

Btw for multitouch mouse pad you can go here:

http://forum.osxlatitude.com/index.php?/topic/1948-Elan-Touchpad-Driver-(Mac-OS-X)

 

The developer here has created a working multitouch kext.

 

Great! works brilliant thank you so much- I used version 3.5 if anyone is interested  :D

 

The wireless card I am using is AR5B93 and as I said worked straight out of the box (also as stated has no bluetooth but I don't need it so doesn't bother me)

 

Need to do some more research into sleep (also noticed after installing the touchpad kext the power button stopped putting it into any kind of sleep).

 

Also For your info i installed osx on an external hdd (as a backup boot option) while I had a mac and also updated to 10.9.2 before applying clover and the files Sammity provided and can confirm everything still working sweet with the latest update.

Share this post


Link to post
Share on other sites

That's so cool. Thanks. I hope you manage to resolve the sleep issue.

 

Btw, does QE/CI work OK on the laptop screen?

 

Cheers mate!

 

Qe/CI seems to work fine - tested with playing chess, checking a screen saver and enabling the ripple effect on widgets (that's what google told me to do ;p)

Share this post


Link to post
Share on other sites

Awesome!! I'm so looking forward to trying this on my ultrabook.

 

If I get stuck I will PM you.

 

Update this thread if you get anything else working better than before.

Share this post


Link to post
Share on other sites

Awesome!! I'm so looking forward to trying this on my ultrabook. If I get stuck I will PM you. Update this thread if you get anything else working better than before.

 

Hope it goes well for you mate :D quick update for you as it seems like its just me and you now ;p (sorry for the Hijack Sammity if your still about!). I used the machine all evening - surfing, installing apps, downloading, watching some tv shows etc and no problems  so must say I am chuffed! also got usb3 working with a modded kext (will share later which one later but in work at the mo) but still no dice with the sleep mode though - tried lots of different settings in config.plist (some manual edits and also using clover configurator) and did have a little dabble with dsdt (couldn't get the mods to compile - need to read more on dsdt)  also tried swapping chameleon with clover as well (alot of it stabbing in the dark to be fair) needless to say had a lot of kernel panics and failed boots (where the bootable usb came in very handy to fix any mishap!)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×