Jump to content
31 posts in this topic

Recommended Posts

Hi!

 

I just installed Mountain Lion GM successfully on my system (ep45-ds3l, 4GB RAM, 8600GTS) and it runs very well and quite vanilla. Just added fakesmc and changed applertc kext because of BIOS resets. Cartri BIOS works well too..

Still I'm looking for a working JMicronATA.kext for 10.8. Can someone help me? I didn't found a working one. Sleepenabler.kext would be nice to have too (needed this in 10.7 although the usage of Cartri BIOS. old one creates kernel panics..).

 

Overall it performs much better than 10.7.4 on both: my hackintosh and mac mini.

Not very vanilla, but works, thanks.

 

Edit:

Interesting: My hackintosh went to sleep (forgot to turn off) and woke up on keystroke just fine. Looks I don't need Sleepenabler.kext any longer. Like in Snow Leopard it works just fine! Still I'm using Cartri Bios, without DSDT. Just to mention.

I tried using the original ML jmicronATA.kext and the one I have in lion but no luck till now.

Hi MacGTO. Thanks for the fix! It seems to be working good here on my JMicron 363 (with a DVD-RW drive). It's nice to be able to leave the original JMicron kext untouched now :)

 

I've added the remaining JMicron devices to the kext. It now supports 361, 363, 365, 366 and 368.

ApplePCIIDE.kext.zip

  • Like 1
  • 2 weeks later...

Funny, JmicronATA never worked for me before yet in the final release of Mountain Lion, I suddenly noticed my IDE DVD drive was picked up. Peeped inside which extensions were loaded and low and behold Jmicron wanted to finally load itself up in my system. Sporting a board very similar to yours, GA-EP43-UD3L.

I only had problems with the GM because that was the first time the stock kext had been updated since 10.6, breaking the previous edited JMicron one.

 

Your board has the JMB368 which is the only chipset the Apple kext supports. Mine has the 363 so it's always needed an injector kext of some kind.

 

Actually, the only component our boards have in common is the iTE sensor chip. Everything else is different.

 

Does your drive show up as internal (in System Profiler)? The GM kext seems to be relegated to a card reader driver now so I think anything it loads will be treated as removable storage.

Thanks, I fixed it with a DSDT edit. I am not really sure how what I did fixes it but my ICH10 is now reported as a ESB2 AHCI and the DVD drive now ejects and DVD player works ok.

Yeah that's just how OS X treats the ESB2 controller. I managed to break that by using an injector kext to change the device name back to my ICH8. So it seems if OS X sees the controller as ESB2 it will treat attached devices as internal.

  • 2 months later...

Why is it that (IDE only) when I plug in 80 conductor cable, my Mountain Lion will boot, but if I plug in 40 conductor cable, it will be stuck at Still waiting for root device.

 

Is there any way to enable more debug messages from the JmicronATA kext? I tried debug=8 but it didn't show any more information.

 

Also where to find the source code for ApplePCIIDE?

 

Is there a 1.1.3 version of JmicronATA source code?

 

 

thanks

  • 3 months later...

Riley Freeman, you're a God-send. After updating to ML flawlessly, your kext/attachment in post #7 got 10.8.x to recognize my IDE drives on my Gigabye EP45-UD3P. Mucho gracias!!

 

And I just popped my post virginity just to say Thanks. Well worth it!

  • 1 month later...

I've now compiled the kext in 10.8. It shouldn't make much difference really, except that it's now 64-bit only.

 

Here it is if anyone wants it. Like the one above, it has ids for all the JMB36x chips.

 

Thank you!!

It now works on my P5B (JMicron ATA JMB363) 10.8.3

  • 3 months later...
  • 1 year later...
  • 4 months later...
×
×
  • Create New...