Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Working Bluetooth adapters in ML (dp4?)

7 posts in this topic

Recommended Posts

My old asus bluetooth adapter no longer works with Mountain Lion.


Can anyone suggest a working USB (maybe BT 4.0+) bluetooth adapter that works with Mountain Lion?



Share this post

Link to post
Share on other sites

Well it's not 4.0, but I just wired in one of these, it's a bit older model available on G5 and early MacPro and intel iMac's. The proprietary connector on it that would go into the Mac's motherboard is not used and is instead wired by soldering to the contact patches shown. The overall size of the board is very small, making the patches to solder on tiny and I needed a magnifying glass to help me see my work. Used onboard USB header for data and ground and used 3.3v from power supply's sata connectors instead of power from USB bus with some form of voltage regulator. It works native and apple bluetooth keyboard can even be used in the BIOS. Similar methods can be done with BT cards from newer macs which have friendlier pinouts with plugs on them along with newer BT spec revisions, but this was more fun :)



Share this post

Link to post
Share on other sites

This USB adapter works OOB but requires a dummy kext (BroadcomAppleBluetooth by AnV) to get sleep working properly. Can't really say about sleep cause I don't really use it.




They've got a Bluetooth 4.0 adapter too (http://www.iogear.com/product/GBU521/) but I don't know if it's compatible with OS X.

Share this post

Link to post
Share on other sites

I use a D-link DBT-120 Wireless USB Bluetooth Adapter (USB 2.0) and OSX sees it as native and loads the correct drivers. Working just fine in ML.

Share this post

Link to post
Share on other sites

IOGear GBU421


Confirmed working on my system running 10.7.4. Added idProduct 8680 idVendor 2652 to the following kext: /System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/BroadcomUSBBluetoothHCIController.kext/Contents/Info.plist

Share this post

Link to post
Share on other sites

I have attached a System Report as well as a picture.

The manufacturer is Broadcom, it's inexpensive and works 100% in SL, L and ML DP1 up to DP4 all updates.

They come in different colours, choose the red one, the others colours don't work.

No idea why not, no idea.


Hope this helps.





Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By hguandl
      I used BCM943602CS for my Hackintosh. On High Sierra, the WiFi works well, however, the bluetooth doesn't work. I cannot find the bluetooth icon on the system preference pane. From the system report, I can see that the Device can be recognized as 'Bluetooth USB Host Controller'. From IORegistryExplorer, I've found that the device for it has a UsbConnector value of 0x0, which is weird. And the IOResources part says the device is not built-in. I don't know whether it has something to do with my MSI B350 Tomahawk (an AMD platform) motherboard. If someone has some advice, please help me out.

    • By junausp
      Hi my IOGEAR Bluetooth 4.0 USB Micro Adapter (GBU521) never worked well. My bluetooth speakers does not work, always lost connection and my bluetooth headphones the same problem!
      Does anyone have an adapter that really works?
    • By Nancy10
      I have macos Sierra 10.12 on my Asus X556U, and i am having problems with my Bluetooth. it doesn't detect any other device and i can't detect it from any other device. 
      my bluetooth is at most integrated with my WIFI card an Atheros AR956X which is not supported natively by OS X. So i used to say that maybe it is the source of my bluetooth not working. But One day it worked, I was trying to install new kexts to try and make my Wifi work. It didn't  but my bluetooth did and i got to even connect to a wireless earbuds. Since that time i was trying to recreate the same settings i did at that time but still couldn't. 
      So i am asking for some help to make my bluetooth work again.
      i attached gen_debug output, has most needed files for debugging.
    • By Trung_Nguyen
      Hello everyone, 
      I have a built in BT4 module DW380, how can I enable continuity on this device?
      Using bcrmpatchram2 * firmwareREpo
      Tried C.A.T: Boot progress went about 60-70% then Panic.
      PS: BT information in System Information app
        Hardware, Features, and Settings:
        Name: Trung’s MacBook Pro //MBP9,2
        Address: XX-XX-XX-XX-XX-XX
        Bluetooth Low Energy Supported: Yes
        Handoff Supported: No
        Instant Hot Spot Supported: No
        Manufacturer: Broadcom
        Transport: USB
        Chipset: 20702A3
        Firmware Version: v14 c5543
        Bluetooth Power: On
        Discoverable: Off
        Connectable: No
        Auto Seek Pointing: On
        Remote wake: On
        Vendor ID: 0x413C
        Product ID: 0x8197
        HCI Version: 4.0 (0x6)
        HCI Revision: 0x15A7
        LMP Version: 4.0 (0x6)
        LMP Subversion: 0x220E
        Device Type (Major): Computer
        Device Type (Complete): Mac Portable
        Composite Class Of Device: 0x38010C
        Device Class (Major): 0x01
        Device Class (Minor): 0x03
        Service Class: 0x1C0
        Auto Seek Keyboard: On
    • By grisno
      Hi people,
      This is a preliminary installer to activate the Combo Mini PCIe AZUREWAVE AW-CE123H in MacOS.
      AIRPORT : OK AzureWave AW-CE123H (14e4:43b1) [Broadcom BCM94352 HMB] Mini PCIeBLUETOOTH : OK AzureWave AW-CE123H (17cf:0b05) [Broadcom BCM20702A1] USB 2.0AIRDROP : OKHANDOFF : OKCONTINUITY : OKWOL : Not TestedIMESSAGE : OKFACETIME : OKICLOUD : OKAPPSTORE : OK
      I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
      I would appreciate comments and suggestions!!