Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
JBX

[Solved] F12 to Open/Close tray? (see page 4)

76 posts in this topic

Recommended Posts

I don't remember what I did in Lion... But now in Mountain Lion DP4, how do you set the F12 key to open/close optical drive tray? :worried_anim:

 

btw, I changed Dashboard shortcut to F10 & I don't have an eject button on this apple keyboard.

 

edit: download and use AHCI_3rdParty_SATA.kext... see page 4 @janel_f's post.

Share this post


Link to post
Share on other sites

I've read that somewhere... but no I don't have an FN key. btw forgot to say I'm using my old Apple G3 desktop keyboard.

Share this post


Link to post
Share on other sites

My experience is that if you tap F12, Dashboard opens. Depress and hold F12, the drive tray opens (this is without making any changes in shortcuts).

Share this post


Link to post
Share on other sites

@everdone: I tried that dose not work for me. So I changed Dashboard to F10. I usually kill Dashboard all together but since it's DP, I kept it on to check out.

Share this post


Link to post
Share on other sites

Do you have the Eject icon in the menu bar? If you click and hold on that icon it should indicate "Open Drive F12".

 

If no Eject icon, is you drive recognized under Disk Burning?

Share this post


Link to post
Share on other sites

I tried using an Apple keyboard and holding F12 will indeed not open the drive. Only the Eject key will open the drive. I have several Windows keyboards and the two I have tried will both open the drive by holding F12.

 

Obviously there is a difference, but I don't know why or how!

Share this post


Link to post
Share on other sites

What actually appears in Keyboard Preferences apparently depends on the keyboard attached. I have a Windows style keyboard attached and it has neither the F1, F2 choice nor the Bluetooth setup that eep shows (I bet he has a bluetooth keyboard attached that has the Fn key).

 

If I connect an Apple keyboard the Change Keyboard button is not present. My conclusion is that Mac OS senses the keyboard and its features and configures accordingly.

 

Apparently Apple keyboards are not mapped the same as Windows keyboards as far as the F keys are concerned, hence F12 on the G3 keyboard will not active the drive tray.

Share this post


Link to post
Share on other sites

Yeah I don't see those settings either.

 

I have a Logitech Wave OSX/Windows keyboard that uses Logitech software on both OS.

On this keyboard, the F12 key also has the eject symbol on it and I can open/close my DVD drive by pressing Fn+F12 in both OS X and Windows. In OS X pressing F12 by itself opens Dashboard.

Share this post


Link to post
Share on other sites

interesting, that screen shot was from my hackintosh which has both apple bluetooth keyboard and a dell usb keyboard attached(for bios and stuff), my mac book with just built in keyboard has exact same settings panel except for the change keyboard type and battery meter in the lower left, both have the setup bluetooth keyboard option while bluetooth is disabled on macbook atm so it doesn't steal my keyboard/trackpad when pairing with the hack, it's running 10.7.4 cause it can't run ML :(. Gonna try disabling apple bluetooth keyboard and reboot with just the dell USB keyboard in a little while and see what happens. Also have a Logitech s510 OSX wireless USB keyboard I gave to my roommate I'll re-confiscate and try out too

Share this post


Link to post
Share on other sites

OK, without apple bluetooth keyboard, check box is gone. Booting with only the dell windows keyboard, holding F12 will eject DVD and then 1 more press to close tray, otherwise F12 gives dashboard. Logitech apple keyboard, older model, s 510 (circa 2005) without any logitech software installed, F12 will only show/hide dashboard but it has separate eject button that works fine, also it's power button works to shut down and sleep as well as wake. I know it doesn't help anyone much to say mine all works just fine, but there you go.

Share this post


Link to post
Share on other sites

Well I also tried my Win keyboard... which is recognized as a Dell USB keyboard (I don't usually have it connected) but even so F12 dose not open tray.

post-238467-0-09097500-1340243629_thumb.jpg

Share this post


Link to post
Share on other sites

F12 not working on Mountain Lion GM with my Daskeyboard, works fine in 10.7. Tried using the Keymap4Macbook pref pane but no dice.

Share this post


Link to post
Share on other sites

Any new info about F12? I hate to click with mouse to

open/close drives?!

:angry:

Share this post


Link to post
Share on other sites

Just checked again using my Dell usb keyboard under the GM and even with apple bluetooth keyboard connected, holding f12 for about 2 seconds opens the tray just fine still. I wish I knew why mine works when nobody else's does. Got pretty standard stuff going. USB keyboard is enabled in bios, ECHI handoff is disabled. USBBusFix=Yes in boot.plist. No PS/2 kexts installed. Don't know what else to say.

Share this post


Link to post
Share on other sites

@eep357 - do you have your AHCI controller configured as ESB2 via DSDT? I made that change recently and my F12 eject works, not sure if it is related.

Share this post


Link to post
Share on other sites

Seems an odd correlation, but I can't argue with my brother and mentor :)

Share this post


Link to post
Share on other sites

While posting on another mostly unrelated topic, it just clicked for me why this works, without SATA set as ESB2, OSX sees DVD drive as external which can cause DVD player errors, so F12 to eject is also not working because OSX is seeing your DVD drive as an external one rather than a built-in internal drive. Fix that and F12 to eject should be fixed too.

Share this post


Link to post
Share on other sites

Ok that makes sense. My DVD Player app was not working and throwing an error as it thought the internal DVD drive was external. I fixed that problem by editing /System/Library/Frameworks/DVDPlayback.framework/Versions/A/DVDPlayback with 0xED app and replacing any reference to "Internal" with "External"

 

My DVD drive is on the Intel ICH10 AHCI controller, what bad things will happen to my HDDs if I change it to ESB2?

Share this post


Link to post
Share on other sites

I've yet to have any bad things, just always be cautious and back up anything important. I think editing frameworks is worse :) GV had a slightly more elegant solution to achieve the same results once it's set up, keeping the controller recognized as native ICHx , but I haven't had the time to look into it more quite yet.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×