Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.

Recommended Posts

I have just successfully set up Mountain Lion DP4 on my Asus P8P67-m Pro and decided to share what I found with the community. I used a patched version of the latest BIOS (3602) along with the DSDT and SSDT for that version. A modified BIOS is not necessary but should help with speedstep and sleep, and NullCPUPowerManagement will no longer be needed. By using this method I have gotten everything working except sleep (but its close).

 

I found all of this information here and on other forums. I am in no way claiming any of this as my own work, I am simply bringing it all together in one place.

 

Things you will need:

  • A working install of OSX Lion or Snow Leopard
  • A spare USB flash drive, USB hard drive, or internal hard drive (at least 8GB)
  • A copy of Mountain Lion DP4 (Please don't ask me for it. I'm assuming you are a registered developer)
  • Lnx2mac ethernet driver (get it here http://lnx2mac.blogs...osx-driver.html)
  • A mountain lion compatible chameleon boot loader (get the pkg here)
  • My P8P67-m Pro package (attached file)

This pack includes (You do not need to download the following list, this is just to give credit):

Installing the new BIOS (DO THIS AT YOUR OWN RISK!! I AM NOT RESPONSIBLE FOR BAD BIOS FLASHES)

1) In your existing Lion or Snow Leopard install, replace your existing DSDT with samisnake's DSDT from the download package.

2) Remove NullCPUPowerManagment.kext from S/L/E.

3) Use Kext Wizard to repair permissions. In maintenance section check "System/Library?Extensions". This should automatically check the two sub entries as well. Choose the target disk, it should be the Lion/SL install you are currently in.

4) Install the new BIOS. I did this by putting the BIOS ROM on a flash drive and booting into the flash utility.

*****FLASH THE BIOS TWICE******

I'm not sure why this is necessary but according to Asus, IT IS! If you do not do this zombies will eat you.

I updated from the flash utility, then rebooted. The system forced me finish the flash, then rebooted again. I then repeated the whole process. No zombies.

5) Reboot as normal into your Lion/SL install.

 

 

Creating your Mountain Lion installer and installing.

To do this I followed eep357's guide from right here on insanelymac: http://www.insanelym...dpost&p=1826183

 

"My super fast easy method requires you don't install to MBR and that you have a hard drive with chameleon on it already that is new enough revision to boot ML. first, make empty partition available for installing onto on guid only drive, hfs+ formatted. RT click install ML app, mount InstallESD.dmg, navigate to basesystem.dmg and mount it. restore basesystem.dmg from ML install app(to usb or another small partition) via diskutility. Eject basesystem.dmg so u dont get it mixed up with new restored one as it will have same name.

 

[delete packages alias in System/Installation on the new USB drive]

 

Fire up ye mighty terminal and go to bash shell with:sudo -s

then copy packages folder from installESD.dmg to System/Installation/ on your newly restored usb like this:cp -R (drag packages folder here) (drag installation folder from usb here)

 

give it a few minutes to finish

 

then do the same copy technique, but this time for mach_kernel from InstallESD.dmg to / of new usb:cp -R (drag mach kernel here) (drag entire usb installer volume here)

 

and done with terminal-yay

 

create /Extra folder on usb and only put in your smbios and org.chameleon.boot.plist, leave your DSDT out

 

use kext wizard to install fakesmc and nullcpupowermanagement [not needed if you used the patched BIOS] to s/l/e on your usb drive, then use kext wiz repair and rebuild cache options

 

reboot as normal, do not change boot drive in bios. At your normal chameleon prompt, choose instead to boot to your new installer (OSX Base system) and use boot flags -v add any other bootflags you normally use that are not already in your org.chamleon.boot.plist

 

install DP4 and reboot back to your old OSX. From there use kext wiz again to install fakesmc to your new DP4 and any other kexts you know are required to boot and copy /Extra folder from installer to your completed installation. I still didn't put my DSDT in it yet

 

reboot, and this time from chameleon prompt choose new OSX DP4 and have fun. Should always use -v to boot until your install is rock solid (with dev preview just always use it)."

 

Thanks, eep.

 

Some notes:

  • My copy of ML was a .dmg file, not an .app file. If you have this, mount the dmg. BaseSystem.dmg is a hidden file at the root directory. You will need to show hidden files. In terminal type "defaults write com.apple.finder AppleShowAllFiles TRUE". Return. Then type "killall Finder". Return. To unshow the hidden files do the same thing but use "FALSE" instead of "TRUE".
  • The packages folder that needs to be copied is also in the root of the mounted ML installer image.
  • I needed to use boot flag PCIRootUID=1 to boot the installer disk, and the installed ML.

Installing P8P67-m drivers

Once into your new Mountain lion install:

  1. Install the chameleon boot loader from the P8P67-m Pro Pack
  2. Use Kext Wizard to install all kexts in the P8P67-m Pro Drivers folder of the pack. You can drag multiple kexts into kext wizard. (IOAHCIFamaily.kext is patched for TRIM support and only needed if you use an SSD)
  3. Install the Lnx2Mac driver if you need ethernet support
  4. Copy the DSDT and SSDT to /Extra (Use the SSDT that is appropriate to your CPU). Add kernel flag PCIRootUID=1 to the boot.plist in /Extra
  5. Reboot. You should now be able to boot directly from your new ML install.
  6. If you want hardware monitoring such as CPU frequency and temps, use Kext Wizard to install the fakeSMC plugins that were included in the P8P67-m Pro Package. I used ACPISensor and IntelCPUMonitor. Others may be needed depending on what hardware you have and want to monitor.
  7. Of course you're on your own for video cards and other hardware. I use an ATI 5750. If you want to see what i did with that, check it out here: http://www.insanelym...dpost&p=1826652

 

P.S. This is my first guide, so please let me know if there's anything i need to fix. I hope it helps someone.

P8P67-m Pro Pack.zip

Share this post


Link to post
Share on other sites
Advertisement

Sorry. I did not realize that i was not allowed to mention that site. I am trying to delete it, until I can rewrite without those references. I can't find a delete option, so please delete it if you need to.

 

EDIT: All done. Thanks. :angel_not:

Share this post


Link to post
Share on other sites

No, I still have no sleep on this machine. I believe this will require a sleepenabler.kext for 10.8 or someone with dsdt knowledge far greater than my own.

 

Yes, the i5 ssdt should work for any stock sandy bridge i5, including the 2500. If you are overclocked use the ssdt for overclocked i5/i7. It is prepatched for speeds up to 4.0ghz. If needed it could be modified further for faster speeds. I'm not exactly sure how to do that, but there's plenty of info here and on other sites.

Share this post


Link to post
Share on other sites

Have you tried getting rid of the USB 3.0 drivers? I've found that those prevent sleep to work on my Lion install with the same DSDT...

Share this post


Link to post
Share on other sites

Remember, when flashing the bios, you must also perform a CLRTC. Basically you have to reset the BIOS by pulling out the CMOS battery from the motherboard. I didn't do this at first, and whenever I'd shutdown, my computer would still be on, but not doing anything. Apparently this was an incompatible configuration issue in the BIOS.

 

I also just tested this with sleeping after reseting the CMOS. It works!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



  • Posts

    • Try this folder: EFI_24042018.zip If you're booting to the installer, while in clover menu, go to options > graphics injector and change ig-platform-id to 0x12345678
    • both, because as i have seen you don't have FakeSMC plugin's,  but you still need some things in config.plist 
    • Test this https://www.dropbox.com/s/j800jusbzh370ox/Ace - EFI.zip?dl=0 Let me know how it goes.
    • Would this help solve my low scores on my machine or just my video laggy issues?
    • Hello artur_pt,   What changes did you make and also I have a new DSDT that I have uploaded (V0.2), maybe we can work with that?   Thanks, Q Hello Allan, Below is the link to my EFI Folder and i ran another debug tool created by "black.dragon74",  but i have attached the output from that tool as it also takes the copy of my IOREG. Please note that, this download is considered "V0.2" because I have used my own DSDT that i have managed to patch with the fixes below:   - Asus G75VW Battery Patch (supposed to work on Asus Q550LF) - SMBUS Fix - Fix _WAK Arg0 V2 - Fix Mutex - Fix Parseop - Added EMIyDinEsH Patch for AsusFN keys. -Add IMEI -Add MCHC   With the above fixes, I have keyboard backlight working along with the fn+F3, fn+F4 working to increase/reduce keyboard backlight. Also the battery meter now works if i unplug the laptop. But if i plug it back in then that change is not registered and the battery meter doesnt update in the menu bar. The battery is meter does not show unti li do not unplug the laptop so i am assuming DSDT needs more fixing. No screen brightness/slider and DGPU still seems active(powered on).   Also the SSDT-DGPU you provided, i renamed it to SSDT.aml and dropped it in the same folder with my DSDT.aml, is this right? because now when i boot, i can still see the Nvidia card from my "system report" and systems temps are high 60 celcius so im assuming its not working?   https://drive.google.com/open?id=1GsUReWE5cmWyN7ClyZkkNmsynUBTk6pK   Thank you all
×