Jump to content
InsanelyMac Forum
nunzer

Problemas con el Sonido, cuando hay mucho ruido "chispea"

Recommended Posts

Buenas,

 

Hace unas semanas instalé en mi i5 con placa asus P7H55-M Le con Iatkos L2 (10.7.2)

Los resultados son una maravilla, no he visto tan rápida mi máquina con ningún otro S.O, todo increíblemente bien, excepto el sonido:

 

El sonido se escucha, los fallos son que cuando hay mucho ruido (Una canción heavy, una película en escenas de acción) "chispean" los altavoces (he probado con otro s.o y es mac), también me he dado cuenta, que el control de volumen de la barra de tareas funciona como un simple interruptor ON/OFF, le bajo y le subo volumen y los altavoces suenan igual, solo hace efecto cuando bajo del todo el volumen...

 

¿Alguna sugerencia? Estoy encantado en como funciona mi maquina con este s.o, si pudiera conseguir hacer funcionar esto sería la re-ostia.

 

Muchas gracias de antemano!

Share this post


Link to post
Share on other sites
Advertisement

Busca en /System/Library/Extensions a ver si tienes un archivo llamado VoodooHDA.kext.

Share this post


Link to post
Share on other sites

Hola... A mi me pasa lo mismo.

Uso Voodoo, aunque en el panel de control de Vodoo.. no me permite habilitarlo.

Me parece que voy a probar instalar en hda de apple a ver que pasa... u otra version de Voodoo, porque en uno de los tantos intentos que hice pude configurar las opciones avanzadas de Voodoo en las Configuraciones del Sistema. Me aparecia un boton verde (como para encenderlo) y podia manejar los graves - agudos - etc... elegir la salida por hdmi y todo... pero ahora no.

De paso les pregunto si saben de alguno con problemas con la placa de red Realtek 8139 o 8102/8103, me esta volviendo loco.

Saludos.

Share this post


Link to post
Share on other sites

lo mas facil del mundo es habilitar el audio en este tipo de placas base, la tuya lleva el chipset:

Realtek® ALC887 8-Channel High Definition Audio CODEC

hay dos opciones sin tener que recurrir a vodoo que siempre es la mas mala opcion de ellas, no es que no valga pero es la peor solucion.

 

1ª AppleHDA parcheado + HDEF en el DSDT

2ª AppleHDA parcheado + Enabler 887

 

cualquiera de las dos opciones es valida, si no usas DSDT la segunda, si usas DSDT la primera, saludos

Share this post


Link to post
Share on other sites

Buenas! si creo que es el mismo problema que tenia yo, esta relacionado con el voodoohda, el problema es que cuando se carga el kext en la configuracion de Audio MIDI los Hz se ponen al máximo (192000,0 Hz). Esto da a que el audio crispee, la solución es bajarlo a 44100,0 Hz. El volumen de audio no se ve afectado y veras que simplemente deja de crispear.

 

A mi me pasa lo mismo y me volví loco para encontrarlo, también he estado probando diferentes voodoohda's y solo me funciona uno, pero la cagada es que cada vez que arrancas el ordenador tendrás que cambiar la configuración de Audio MIDI, he estado buscando algún modo de que quede a 44100 Hz pero no la he encontrado.

 

Espero haberte servido de ayuda.

Share this post


Link to post
Share on other sites

Buenas! si creo que es el mismo problema que tenia yo, esta relacionado con el voodoohda, el problema es que cuando se carga el kext en la configuracion de Audio MIDI los Hz se ponen al máximo (192000,0 Hz). Esto da a que el audio crispee, la solución es bajarlo a 44100,0 Hz. El volumen de audio no se ve afectado y veras que simplemente deja de crispear.

 

A mi me pasa lo mismo y me volví loco para encontrarlo, también he estado probando diferentes voodoohda's y solo me funciona uno, pero la cagada es que cada vez que arrancas el ordenador tendrás que cambiar la configuración de Audio MIDI, he estado buscando algún modo de que quede a 44100 Hz pero no la he encontrado.

 

Espero haberte servido de ayuda.

 

Yo tengo el mismo problema con el audio, ¿como cambio la configuración de audio MIDI?

 

Vale, ya lo he encontrado, en la carpeta Aplicaciones>Utilidades, pero no me deja ponerle 44100, sólo me deja poner 48000 y me sigue crispeando, ¿alguna otra solución?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Cool! Do you have a link? Googled and didn't see anything yet.   Never mind... you're quick! I just noticed you updated it on the 1st page THANKS!!!!!!
    • I resolved the problem. Just set this coding in your config.plist:   "
      <key>KextsToPatch</key>
              <array>
                  <dict>
                      <key>Comment</key>
                      <string>USB 10.13.4+ by PMHeart</string>
                      <key>Disabled</key>
                      <false/>
                      <key>Find</key>
                      <data>
                      g32UDw+DlwQAAA==
                      </data>
                      <key>InfoPlistPatch</key>
                      <false/>
                      <key>MatchOS</key>
                      <string>10.13.x</string>
                      <key>Name</key>
                      <string>com.apple.driver.usb.AppleUSBXHCI</string>
                      <key>Replace</key>
                      <data>
                      g32UD5CQkJCQkA==
                      </data>
                  </dict>
              </array>     "
    • New Web Driver - 387.10.10.10.30.107 for 10.13.4 build 17E202
    • I guess having pre{max-height: 500px;overflow: auto;} in CSS was too much for IPS Devs' tast.  Until an admin has hands on this, you still can use stylish plugin to accomplish it.     In fact, it is pretty easy than it appears - Just apply a simple click on the codebox (it will highlight it), then 'delete' key.
    • all the possible frequencyes i have added seems to work fine at the moment, i have added a lot of different frequencyes to support better all kinds of professional applications, inclunding strange sampling rates and goes from 8khz up to 176.4 khz, unfortunately 192 khz does not seems to work even on cards which should support it like the audigy rx, but other frequencyes just works fine and at the moment i have tested only the sound blaster audigy rx and the audigy sb0090 (1st gen audigy) and i can confirm that all the frequencyes from 8khz up to 176.4 khz does work on that card, so i think that such frequencyes should work on all the audigy 2, 2sz, 4 cards as well, tomorrow i will test with my sound blaster live! cards and i will let you know, but here are also some photos (pro tip: use cmd + alt/opton + 4 and then press space to make a screenshot of a single window):


×