Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
kernnell

ATI 6870 Audio por HDMI e problemas no Sleep / Wake

19 posts in this topic

Recommended Posts

Edit: Gráfica trocada por uma ATI 6870, problemas no sleep / wake e audio por HDMI a partir do post 7

 

Caros amigos.

 

Estou a fazer uma instalação do Lion numa máquina com as seguintes características:

 

GA-EX58-UD5

i7 920

9800GTX+

 

A instalação do Lion corre bem, consigo instalar o chameleon com o DSDT.

 

Quando ponho "GraphicsEnabler=yes" o computador inicia normalmente, mas assim que chega à tela de entrada do MAC (onde se coloca a password) o monitor deixa de mostrar imagem e aparece "NO SIGNAL".

 

Consigo ouvir o disco a trabalhar normalmente e o led da rede pisca a mostrar que esta a comunicar.

Parece que tudo esta a funcionar normalmente mas não dá imagem.

 

Já tentei arrancar com: npci=0x2000 e PciRoot=1, mas não resolve o problema

 

Esta ligado com um adaptador DVI --> HDMI

 

Alguém me dá uma ajudinha, por favor?

Share this post


Link to post
Share on other sites

ola..

 

coloque a sua assinatura por favor..ajuda...

 

quem tem porta HDMI ? a tv ou monitor e pl video ?

 

quem tem porta DVI e quantas se for na pl video?

 

e o obvio...trocou o "source" na TV?

 

c.frio

Share this post


Link to post
Share on other sites

olá

 

a porta hdmi n funciona

 

devidamente testado, esse assunto está amplamente coberto, essa gpu hdmi não funciona

 

bom hack

Share this post


Link to post
Share on other sites

Ok. Troquei a placa por uma ATI 6870

 

Funciona tudo nativamente OOB, mas não transmite som pelo HDMI...

 

Alguém me dá uma ajuda a fazer o som sair pelo HDMI?

 

Edit: estou a utilizar um roleback do AppleHDA.kext (old patched AppleHDA.kext) será disso ou do DSDT?

Share this post


Link to post
Share on other sites

Obrigado. Estive a ler. Mas pareceu-me que estava tudo relacionado com o Snow leopard e não lion... estarei enganado.

 

Reparei também que o HDMI só funciona com GraphicsEnabler=No. Caso contrário não passa da tela branca ao iniciar.

 

Outro daqueles bugs que me está a tirar do serio é o wake:

 

Quando fiz a troca da 9800 para a 6870, o sleep / wake ficou a trabalhar perfeitamente, mas dede que tenho andado com estas experiências do HDMI a máquina deixou de acordar... encrava no écran preto.

Já tentei de tudo para recuperar o sleep / wake! até já reinstalei completamente o lion e não consigo voltar a por como estava :(

 

Podem ajudar-me por favor?

Share this post


Link to post
Share on other sites

Sim estão todas carregadas e tenho aceleração gráfica ( 45 frames no cinebench 11)

 

64	2 0xffffff7f80b80000 0x17a000   0x17a000   com.apple.kext.ATISupport (6.3.4) <62 9 8 7 5 4 3 1>
65	0 0xffffff7f80cfa000 0x40000	0x40000	com.apple.kext.ATI6000Controller (6.3.4) <64 62 9 8 5 4 3 1>
89	0 0xffffff7f81033000 0x297000   0x297000   com.apple.ATIRadeonX3000 (7.1.8) <74 62 9 7 6 5 4 3 1>
97	0 0xffffff7f813a6000 0x14000	0x14000	com.apple.kext.ATIFramebuffer (6.3.4) <64 62 9 8 7 5 4 3 1>

 

Não posso ter GraphicsEnabler=Yes ou levo com tela branca da morte no boot

 

Será que é por não ter o GraphicsEnabler=Yes que o computador não acorda do sleep correctamente?

Share this post


Link to post
Share on other sites

ok... consigo ter o GraphicsEnabler=Yes se utilizar:

 

key>AtiConfig</key>
<string>Duckweed</string>

 

Mas não resolve o problema do sistema não acordar... as ventoinhas rodam, os discos ligam, o monitor liga... mas o écran fica preto.

 

Fiz uma instalação clean, em outro HD, com NOVO DSDT utilizando o DSDT Auto-Patcher.

fica exactamente com mesmo problema. dorme mas não acorda correctamente.

Share this post


Link to post
Share on other sites

olá

 

esse problema tens tu e milhares de outros

 

como eu

 

do sleep

 

mas como n utilizo...

 

quanto a isso n te sei dizer mais nada, pode ser um problema de dsdt, como pode ser da própria gráfica

 

quando kero desligo o pc..

 

bom hack

Share this post


Link to post
Share on other sites

o que me faz confusão, é que quando troquei a 9800gtx+ por essa, sem fazer mais nada tinha sleep / wake e aceleração gráfica.

Se já esteve é pq dá. Agora... saber voltar a por mas sem a 9800 é que tá pior.

 

Se eu soubesse que era assim não tinha trocado, dou muito valor ao sleep / wake pela economia energetica que permite.

Share this post


Link to post
Share on other sites

olá

 

é bom ver alguém k se preocupa com a ecologia do planeta

 

mas para isso desligas o pc, ke nem tem consumo nenhum... mas continua a tua pesquisa sobre isso e posta se conseguires uma solução.

 

bom hack

Share this post


Link to post
Share on other sites

eu vou dormir com o pc ligado, normalmente a ver um filme...

normalmente também me deixo dormir antes do filme acabar...

é nessa situação que o sleep me poupa resmas de electricidade.

outro exemplo... estou no pc e vou só almoçar ou jantar. Carrego no speep e num segundo ele "apaga"

Quando volto, num segundo ele acende.

Desligar e voltar a ligar não tem viabilidade em pausas pequenas, e acredita que durante o dia há muitas pausas de 15mim que podem ser aproveitadas.

 

Explicada a minha necessidade de poupar energia...

 

Se mais alguém quiser dar ideias para resolver isto ficaria muito agradecido :help:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×