Jump to content

8101E/8102E in Lion


12 posts in this topic

Recommended Posts

Greetings people,


I have a H61ML Motherboard. So far I got everything installed used I47K0Z L2.

Mac OS X 10.7.2

Kernel: 11.2.0


Except for 1 thing:


Realtek RTL8101E/RTL8102E Ethernet


The problem:

When I go to System Preferences -> Network -> Assist me -> Diagnostics

Ethernet - Red

Network Settings - Orange (sometimes Green)

ISP - Green

Internet - Red

Server - Red


it says Connected.


My IPV4 IP adress is 169.254.XXX.XX. (Self Assigned-IP)


I tried googling and searching everywhere, but people seem to random fix this. By installing iTunes or resetting there routers. I tried them all, still no help.

I know the internet works, because it works on my windows laptop, also on the OSX86 PC, because if I start up Windows 7, everything works fine.


And I have tried absolutely everything:

RTGMac v2.0.6ForLion -> Best Option until now.

RTGMac v2.0.6

RTGMac v2.0.3

RTGMac v2.0.4

Lnx2Mac Realtek RTL81XX v0.0.90





*It seems that only RTGMac does actually something, all the others have little to no effect when installed.

*I have some sort of "Built-in Serial Port (1)" in Networks that I am not aware of that I have...

*Tried everything in 32bit

*Tried deleting everything in IONetworkingFamily.kext and trying 1 of the above.

*Tried manually configuring

*Tried "PCI Root Magnifying Glass"

*Tried EthernetBuiltIn=Yes

*Tried Resetting Router

*Tried Snow Leopard

*Wake on LAN - Enabled

*Onboard PCIE Giga Lan - Enabled


My System Info:




My BIOS: American Megatrends, inc. Version: 2011 version (Latest BIOS)

My Motherboard: H61ML :: Motherboard :: BIOSTAR


2 possible problems:

1. Something is wrong with my BIOS.

2. Something is wrong with my Router. -> Pending, I'm gonna try a different router soon.


Can someone help me please?

Link to comment
Share on other sites

I already bought a new mouse, keyboard and ethernet cable. I don't feel like spending another 20 bucks...


Are you sure there is no way around? Because if I search the internet then I see that some people have it working. Maybe there is something wrong with my router?


This person got it to work:



I have no idea what he did....

Link to comment
Share on other sites

Thanks for your response.


It says that I am connected, but my IP is still 169.XXX.


I have no idea what the problem could be in my Bios. The DHCP is on, what else to check? Also my router doesnt detect the osx86


If I boot into windows it works perfectly...

Link to comment
Share on other sites



I have the same motherboard and I got it working with


RTGMac v2.0.6




Thanks! Now I atleast know that I have to use RTGMac v2.0.6.


Do you use Lion?

Are there any Lan Settings I should change in BIOS?

Do you boot with


Is it all 64bit?


Thanks in advance!

Link to comment
Share on other sites

I erased and installed osx86. Downloaded the driver, installed it. Still the same error.


So I think its my BIOS or Router...


So if C.Frio confirms that its not my BIOS then I'll have to search for problems on my router...


Even though that would be strange. Because my Windows/Linux dualboot laptop works fine.

My Windows 7 installation on the same PC as my OSX86 detects my internet properly and everything works. Same for my Ubuntu Live CD.

Link to comment
Share on other sites

  • 2 years later...

  • Create New...