Jump to content
InsanelyMac Forum
barney-geroellheimer

GeForce GTX460 and CUDA

Recommended Posts

Hey,

 

I'm now running my hackintosh for about a year and now I tried to use some CUDA-Software. I installed the CUDA driver shortly after the Lion installation but now I tried some software. CUDA-Z shows the Card correctly as the "GeForce GTX 460", but I tried to use Blender (with Cycles Render Engine using CUDA) and Adobe GPUsniffer, which both didn't found any CUDA device in my system.

 

Then I updated the CUDA driver to the current 4.0.50, but no change. Also I saw now that the card is shown as "Unknown nVidia card" in System Information. OpenCL instead of CUDA seems to work in Apps supporting it.

 

Does anyone have an idea what could go wrong here and what's the best way to tackle with this? What additional information about my system could be helpful?

Share this post


Link to post
Share on other sites
Advertisement

Does CUDA-Z shows benchmark values in the performance TAB?

If yes then CUDA is running in general on your system.

It may a problem of your used apps (Blender / Adobe) , not CUDA itself.

TOAST 11 uses CUDA if you convert an video into h.264.

 

Also some Blender / cycles engine builds may NOT have CUDA aktivated.

perhaps try:

http://graphicall.org/511

Share this post


Link to post
Share on other sites

The GTX 460 doesn't work with the Mercury Engine right away because it's not on the list of supported cards - there's no GTX 460 for Mac.

Here's how to add it: http://www.insanelymac.com/forum/index.php?showtopic=223244

Maybe you have to do something similar to get Blender to work.

 

"Unknown video card" just means your injection method doesn't know the device ID of the GTX 460. It normally does not make any difference as far as performance is concerned.

 

GTX 460 works with Chameleon GraphicsEnabler, if you want to see the info in System Profiler then trash your current injection method and use GraphicsEnabler instead.

 

There is one caveat; If you ever have to boot any Snow Leopard install media, remember to type GraphicsEnabler=n on the bootprompt, otherwise it will boot with no video. This happens because the drivers that ship with Snow Leopard has no support for Fermi architecture cards (no GF100Hal.kext).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×