Jump to content
InsanelyMac Forum
Fiox89

[Guida] Chip RT73 wifi su ML, Lion e Snow Leopard

Recommended Posts

Dal momento che ho avuto bisogno di questi passaggi per attivare la mia scheda wifi sul mio hackintosh, e ci sono arrivato dopo un pò di test e tentativi falliti, posto questa breve guida che magari sarà utile ad altri

Questo procedimento non è necessario per Snow Leopard. Per il chip RT73 su Snow Leopard scaricate ed installate semplicemente questo package --> Link

Per Lion invece sembra essere necessario questo procedimento, in particolare dalla 10.7.2 (grazie ErmaC per la segnalazione)

Io uso questo procedimento anche su Lion 10.7 altrimenti non riesco a far andare il wifi

1) Scaricare il pacchetto zip ed estraete il contenuto --> Link

2) Installate il kext RT73USBWirelessDriver.kext in /System/Library/Extensions e riparate cache e permessi

N.B. il kext deve essere caricato prima di procedere con il punto 4)

Pertanto o riavviate il computer, oppure lo caricate manualmente da shell

3) Copiate l'intera cartella RaWLAPI.framework nella directory /Library/Frameworks/ del vostro hard disk con Lion

4) Usate il programma Ralink WirelessUtility per cercare nuove reti wifi e connettervi

5) Se non volete collegarvi alla rete ad ogni avvio, inserite l'applicazione Ralink WirelessUtility fra quelle che si avviano automaticamente all'accensione del pc

E' tutto, buon hack ;)


n.b. sembra che il procedimento sia valido anche su ML, quindi, buon test
---

Testata su

- TP-Link WN321G
- D-Link DWL-G122
- Asus wl-167g

- D-Link DWA-110

- Ed altre con chipset RT73

Share this post


Link to post
Share on other sites
Advertisement
Dal momento che ho avuto bisogno di questi passaggi per attivare la mia scheda wifi sul mio hackintosh, e ci sono arrivato dopo un pò di test e tentativi falliti, posto questa breve guida che magari sarà utile ad altri

 

Ciao Fiox.

 

uso anche io questo kext per la mia D-Link DWL-G122

 

Usando la versione per Snow (10.6) non riscontro nessun problema su Lion...

 

Specificheresti esattamente quali problemi hai avuto con l'attivazione della tua scheda...?

 

Fabio

Share this post


Link to post
Share on other sites

Ciao Fabio

 

Io ho riscontrato problemi nell'attivazione della mia periferica, che comunque non è una D-Link

 

Può essere che occorrano versioni diverse del driver?

 

Con il package per snow non riuscivo ad attivare la scheda, non riuscivo a cercare reti e quindi a connettermi. Se avrò del tempo proverò nuovamente con il package per snow

 

So che esistono 2 versioni di questo driver, per chip rt73, su sistemi gnu/linux, ma sinceramente non so se è la stessa cosa su osx

Share this post


Link to post
Share on other sites
Ciao Fabio

 

Io ho riscontrato problemi nell'attivazione della mia periferica, che comunque non è una D-Link

 

Può essere che occorrano versioni diverse del driver?

 

Con il package per snow non riuscivo ad attivare la scheda, non riuscivo a cercare reti e quindi a connettermi. Se avrò del tempo proverò nuovamente con il package per snow

 

So che esistono 2 versioni di questo driver, per chip rt73, su sistemi gnu/linux, ma sinceramente non so se è la stessa cosa su osx

 

Ciao Fiox...

Mi riferisco ai driver ralinktech...

riporto qui sotto la prima pagina con il link di Giorgio...

Parliamo dello stesso "driver"?? (magari ho confuso io)

 

Sono in linea i kexts per Snow Leopard 32 e 64 bit (provati e funzionanti) per DWL-G122

http://www.ralinktech.com/support.php?s=3

 

Giorgio

 

ralinktech.jpg

 

Fabio

Share this post


Link to post
Share on other sites

Il chip della scheda è quello nel titolo, RT73, fra quelli linkati da te non c'è, al massimo hanno nome diverso?

 

Il mio adattatore wifi è il Tp link TL-WN321G (sono abbastanza sicuro monti chip RT73)

 

I driver da te linkati sono questi

 

USB(RT2870 /RT2770 /RT3X7X /RT537X)

USB(RT257X/RT2671/RT2500)

 

con l'RT73 mi sembra centrino poco :D

Share this post


Link to post
Share on other sites

Dal link che ho marcato nel cerchio rosso della foto... (quella del post prima)

scarico il dmg

RTUSB D71w-1.3.0.0_UI-3.0.0.0_2010_04_13.dmg

lo monto e questo è il contenuto...

dmg.jpg

ora apro il pkg con pacifist e questo è il kext di cui parlo....

pacifist.jpg

coincidenza?

 

Fabio

Share this post


Link to post
Share on other sites

Azz...praticamente tu dici che i driver per RT73 sono contenuti là dentro

 

Questo non l'ho verificato, ma il tuo adattatore wifi che chip ha? hai provato se vanno su Lion?

Share this post


Link to post
Share on other sites
Azz...praticamente tu dici che i driver per RT73 sono contenuti là dentro

 

Questo non l'ho verificato, ma il tuo adattatore wifi che chip ha? hai provato se vanno su Lion?

 

La mia USB è una revisione C1, basata su chipset Ralink RT73 , (le precedenti A1, B1 e B2 erano basati su altri chipset)

Su Lion funziona perfettamente come anche su Snow...

 

Ora non voglio confondere le idee più del dovuto... ma potresti fare una prova con il pkg suggerito prima... se la procedura ti funziona, ti risparmi tutto il procedimento...

 

Che poi magari sono due kext che hanno lo stesso nome.. (probabile)

 

Fabio

Share this post


Link to post
Share on other sites

Ho impostato la discussione su invisibile (spero non ti dispiaccia), se questi passaggi sono inutili non serve che stia qui

 

Appena avrò un pò di tempo provo con il package, in passato avevo già provato ma senza successo (il mio package forse era diverso?)

Share this post


Link to post
Share on other sites
Ho impostato la discussione su invisibile (spero non ti dispiaccia), se questi passaggi sono inutili non serve che stia qui

 

Appena avrò un pò di tempo provo con il package, in passato avevo già provato ma senza successo (il mio package forse era diverso?)

 

Nessun problema...

 

se il pacchetto era diverso non saprei...

il kext è quello ... che cambino le utility che lo accompagnano?

 

Se provi fai sapere...

 

Se poi il tutto non ha niente a che fare... ripulisci tranquillamente la discussione.. :lol:

 

Fabio

Share this post


Link to post
Share on other sites

Devo trovare solo un pò di tempo, il kext base sembra lo stesso, appena provo ti farò sapere

 

Grazie per l'info Fabio

Share this post


Link to post
Share on other sites

Ciao Fiox.

 

Volevo informarti che dalla versione 10.7.2 il pacchetto che usavo precedentemente (quello "originale" della Ralink) non funziona!

Premetto che funziona a metà nel senso che il dispositivo non salva/aggancia le reti.

 

Risolvo utilizzando il tuo metodo (manuale) oppure uno similare

USB Wifi (RT73) Fix for Lion 10.7.2

 

 

 

Fabio

Share this post


Link to post
Share on other sites

Strano. Beh mi ero ripromesso di verificare questa cosa, ma poi non ho più avuto tempo...colpa del mio hack dannatamente maledetto nel reparto video

 

Se mi confermi che la "guida" è necessaria sulla 10.7.2 la possiamo riaprire, specificando i dettagli che al momento sono conosciuti

 

 

Edit: non vorrei dire...ma la guida che mi hai postato è una copia spudorata della mia guida... e ti dico anche da dove è stata copiata... --> Link

 

Quando ho inserito la guida qui sul forum, l'ho inserita anche su kexts.com (che osa si è fuso con osx86.net)

 

il tipo ha pensato bene di copiarla e metterla sul forum prendendosene i meriti

Share this post


Link to post
Share on other sites

Strano. Beh mi ero ripromesso di verificare questa cosa, ma poi non ho più avuto tempo...colpa del mio hack dannatamente maledetto nel reparto video

 

Se mi confermi che la "guida" è necessaria sulla 10.7.2 la possiamo riaprire, specificando i dettagli che al momento sono conosciuti

 

 

Edit: non vorrei dire...ma la guida che mi hai postato è una copia spudorata della mia guida... e ti dico anche da dove è stata copiata... --> Link

 

Quando ho inserito la guida qui sul forum, l'ho inserita anche su kexts.com (che osa si è fuso con osx86.net)

 

il tipo ha pensato bene di copiarla e metterla sul forum prendendosene i meriti

 

Possiamo fare una cosa.

Visto che l'hai anche segnalata nella sezione italiana dello staff, ripulirei e riaprirei questa segnalando che è necessario (nel mio caso) dalla 10.7.2

e per la "plagiata" la possiamo chiudere o oscurare oppure giustamente dichiarare che la guida è tua ed è stata copiata senza citare la fonte originale.

 

Fabio

Share this post


Link to post
Share on other sites

Esatto. Credo sia la cosa migliore. Sistemo la guida e in serata la riapro segnalando sull'altro topic all'utente che è bene citare la fonte quantomeno

Share this post


Link to post
Share on other sites

Guida riaperta, degli ulteriori test sono stati fatti, e sembra che dalla versione 10.7.2 di lion questo procedimento sia necessario. Sono molto graditi dei feedback sul funzionamento/non funzionamento del metodo

Share this post


Link to post
Share on other sites

ottima guida, con lion iakatos L2 10.7.2 e chiavetta usb D-Link AirPlus G DWL-G12 Wireless USB Adapter(rev.C)

Funziona perfettamente

Share this post


Link to post
Share on other sites

Grazie per il feed federico121, io al momento non la posso testare meglio di così, quindi ogni ulteriore test è ben accetto ;)

Share this post


Link to post
Share on other sites

ma funziona anche con la dlink-dwa140? perché attualmente su lion per farla funzionare devo aprire preferenze di sistema accessori dwa140 si apre una schermata dlink scelgo il profilo e attivo finalmente la chiavetta.......invece da pc all'accensione andava direttamente in rete ............

Share this post


Link to post
Share on other sites

5) Se non volete collegarvi alla rete ad ogni avvio, inserite l'applicazione Ralink WirelessUtility fra quelle che si avviano automaticamente all'accensione del pc

 

Questo è il modo più immediato. Il tuo profilo dev'essere salvato, comunque la guida non è riferito a questo, quello è un problema dell'applicazione che usi tu, sempre che la tua chiavetta wifi abbia questo chipset

 

Stai usando il programma della ralink?

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By superq
      Hello everyone,
      My hack(HP Elitebook 2570p) works perfectly exept for one thing:Wifi.
      It has a BCM943142 Combo card,is there any way to get that card working?
      I'm running HS.
      Thanks in advance!
    • By bojarek8
      Hi! 
       
      I'm Kris!  I hope my topic is in a good section.
      I am asking you guys for help in this difficult hackintosh problem. 
      For a very long time I tried to solve it myself but I have no idea how I can solve this problem.
       
       
      Description of the problem
       
       
      My problem is that I do not have access to any apple service. I am unable to log into the App Store using my Apple ID. I am unable to log into iCloud account in system preferences. iMessage and Facetime also do not work.  Messages that I get when I try to log in: "An error occurred during activation. Try again" 
       
      in iMessage: "An error occurred during activation. Try again" 
      in App Store: "This device or computer can not be verified. Contact the support department for help"
      in Face Time: "There was an error during activation. Try again"
       
      In summary, I am unable to log in to any apple network service. 
       
      My Specification 
       
      Motherboard:  Acer MG43M
       
      Processor: Intel(R) Core(TM)2 Duo CPU  E7600  3.06GHz
       
      Graphic card: Gigabyte GeForce 9600GT 515MB 
       
      Wi-fi: TP-LINK  TL-WN881ND
       
      Ethernet: (not supported) 
       
      Audio: (rather, it is not needed here)
       
      Files: 
       
      My config.plist: https://drive.google.com/drive/folders/1vlYJC329sz6yuTwFr-k0fOs3rfhKeI6l
       
       
       
       
       



    • By Angelo_
      Ciao ho acquistato questo adattatore wifi in quanto sembrava essere compatibile fino a sierra e mi serve per un altro hackintosh in casa non raggiungibile da ethernet e per il prezzo(circa 20€) era meglio degli edimax da 300mbps solo che sto riscontrando dei problemi nel farlo funzionare, ho installato il kext per l'mtk 7610u da qui 
      e installato con kext wizard(manualmente non dava risultati) per poi installare il software di asus solo che quest ultimo non riesco a farlo funzionare dato che si avvia e compare per poco l'iconcina in alto a destra per poi scomparire e non si apre mai l'utility come su windows, qualcuno ha questa o usb simili e sa come sistemare questo problema? osx mi vede l'esistenza di un wifi ma non mi sembra mi dia modo di connettermici in alcun modo. 
      Grazie


    • By Angelo_
      Non sono sicuro di essere nella sezione giusta ma stavo cercando un adattatore wifi usb compatibile con high sierra per un paio di hackintosh(di mio fratello e di un amico) che non possono essere connessi in lan e non riesco a trovare niente né nei negozi di elettronica né su amazon, avete qualche suggerimento? Ho anche provato una breve ricerca su google sia in italiano che in inglese senza ottenere risultati :v
×