Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
ScorpionX41

[How To] Lion (10.7) Retail via USB Stick installieren!

21 posts in this topic

Recommended Posts

Hey,

 

hier eine wirklich SEHR SEHR EINFACHE Anleitung um Lion auf eurem PC zum laufen zu bekommen! Das ist kein Upgrade, d.h. euer PC muss nicht schon Snow Leopard oder sonstiges haben, jedoch wird zur Erstellung des Bootbaren Sticks ein Mac benötigt!

Ich persönlich habe ein MacBook Air dazu verwendet.

 

Ihr könnt es auch mit einer Externen Festplatte installieren, wichtig ist nur, dass ihr sie im GUID Schema partitioniert!

 

Erstmal möchte ich noch erwähnen, dass diese Anleitung von MaLd0n geschrieben, von shoxxxi übersetzt und von mir lediglich etwas bearbeitet wurde! Großen Dank also an MaLd0n und shoxxxi!

 

Man braucht:

 

Einen Mac (Hackintosh oder Original)

USB Stick mit mind. 8GB. (Ich selber habe eine 8GB SD Karte mit einem USB Kartenleser benutzt)

Lion Image (Empfehlung)

Chameleon RC5

Lion Extra Installer

[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

Ein paar simple PC Kenntnisse

Ich würde euch empfehlen eine Leere Festplatte zu benutzen/kaufen, da ihr diese während der Installation Formatieren müsst um das GUID Partitionsschema herzustellen.

Achtung: Ist möglich, dass die Downloads erst beim 2.-3. Anlauf starten!

Also nicht wundern, wenn beim ersten mal die Seite nicht verfügbar ist.

 

Kurze Zusammenfassung meiner Vorgehensweise:

 

1. Am Mac mit dem Festplattendienstprogramm den großen USB Stick zu Mac OS Extended (Journaled) formatieren. Danach in den Reiter "Wiederherstellen" wechseln.

Achtung: Den kompletten USB-Stick! Nicht nur 1 Partition.

Sonst bleibt das Partitions Schema MBR. Es wird jedoch GUID benötigt!

 

2. Das Lion Image mounten.

 

3. Folgendes im Terminal eingeben.

open /Volumes/Mac\ OS\ X\ Install\ ESD/BaseSystem.dmg

 

4. Auf dem Schreibtisch sollte jetzt "Mac OS X Base System" zu finden sein. Das ziehen wir jetzt einfach per Drag&Drop in das "Quelle"-Feld des Festplattendienstprogramms. Als Ziel fungiert natürlich der USB Stick (kann man auch per Drag&Drop vom Schreibtisch einfügen).

 

5. Jetzt auf "Wiederherstellen" klicken. Der USB Stick sollte nach der Prozedur auch Mac OS X Base System heißen. Wir öffnen ihn, wechseln zu System/Installation, löschen den Packages Link und erstellen einen neuen ordner namens Packages.

 

6. Es erfolgt wieder eine Eingabe ins Terminal:

open /Volumes/Mac\ OS\ X\ Install\ ESD/Packages

 

7. Danach öffnet sich ein weiterer Ordner, dessen gesamten Inhalt wir in den eben erstellten Packages Ordner kopieren.

 

 

8. Jetzt könnt ihr alle Ordner schließen und es gilt nur noch die 2 oben downloadbaren Pakete (Extra Lion Installer & Chameleon RC5) zu installieren. Wichtig dabei ist, dass ihr als Installationsort den USB Stick auswählt!!!! Ansonsten installiert ihr den Bootloader auf dem aktuellen System.

 

9.Jetzt einfach nur auf dem Ziel-PC vom USB-Stick booten und Lion installieren!

 

10. Nach der Installation einfach nochmal vom USB Stick booten, diesmal allerdings die Festplatte auswählen.

 

11. Nach der Installation habe ich mit [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] die restlichen Kexts installiert um Netzwerk, etc. lauffähig zu machen. (In jedem Fall während der Installation [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Install auswählen, das installiert automatisch die nötigsten Sachen. Außerdem würde ich den Kexthelper installieren. Danach könnt ihr nach Belieben weitere benötige Kexts aus der Liste mit einem Haken auswählen. Welche Kexts ihr noch für Audio & Netzwerk etc. benötigt könnt ihr hier nachlesen

Speziell für mein Board (Asus P5Q):

 

In [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] hab ich [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Install, Ev0reboot, NullCPUPowerManagement, VoodooHDA, FakeSMC, ElliotForceLegacyRTC, IOAHCIBlockStorageInjector, jMicron 36x und eben den Kexthelper angekreuzt.

 

12. Das wars eigentlich. Lion sollte ohne USB Stick problemlos starten und funktionieren.

 

Ich kann natürlich keine Garantie geben, dass bei euch auch alles so reibungslos läuft, aber die Erfolgschancen stehen meiner Meinung nach ziemlich hoch.

 

Mein Ergebnis :D

 

Mein System:

Asus P5Q

Intel E8400@4Ghz

4GB DDR2 Ram@891Mhz

1TB Festplatte (Mac) + 640GB (Windows)

Gainward GTX275 896MB

 

Sagt mir ob es bei euch geklappt hat!

 

Viel Spaß :)

Share this post


Link to post
Share on other sites

Hi,

Das hast Du ganz gut gemacht. Nun läuft meine Versuchskiste. Hatte noch eine alte 2,5 Zoll Platte aus meinem

Leppi. Der Start geht etwas schleppend, aber dann Ok :D

ich wollte dann mal die Kiste im 64 Bit modus starten, aber da bleibt er immer hängen.

ich schreib mal die Fehlmeldung auf.

JMicron ATA: JMB363 ( CMD 0xc0000xc100 IRQ 17, BMOxc408 )

Was kann das sein.

 

Meine Kiste Gigabyte EP35-DS4. Core Duo 2x2,8, 6GB 800 DDR2 speicher, HDD 250 GB

Also noch mal Dank für Deine Arbeit. ;)

Share this post


Link to post
Share on other sites

freut mich, dass es geklappt hat soweit :)

 

hmm... ich bin mir nicht sicher, hatte dieses Problem selber noch nicht. Denke aber es hat was mit PCI zu tun.

Hast du irgend welche PCI Karten auf deinem Board angeschlossen?

Probier mal PCIRootUID=1 in com.apple.boot.plist einzutragen...

 

nebenbei: wozu willst den im 64 bit modus starten?

Bei mir startet der 64 bit Anwendungen im normalbetrieb in 64 bit.

iBench zeigt auch an (64-bit).

Share this post


Link to post
Share on other sites

Hi ,

Du hast geschrieben, dass Du folgende kext mit [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] nachinstalliert hast.

ElliotForceLegacyRTC, IOAHCIBlockStorageInjector, jMicron 36x und eben den Kexthelper angekreuzt.

Den jMicron habe ich nicht installiert.

Zu Deiner Frage: Eine PCI Karte steckt da nicht drin.

Ist ja erst ne Art testfase.

Auf meinem Studiorechener ist 10.6.8 drauf da läuft alles unter 64 Bit stabiel.

Logic kann dan die Speicher besser nutzen.

Ist auch ein P35 Chip drauf.

Share this post


Link to post
Share on other sites

Hallo, ich bin es noch mal. ich poste mal meine com.apple.Boot.plist

Schau mal rein,

 

 

<plist version="1.0">

<dict>

<key>Graphics Mode</key>

<string>1440x900x32</string>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string>arch=i386</string>

<key>GraphicsEnabler</key>

<string>Yes</string>

<key>Timeout</key>

<string>5</string>

<key>PciRoot</key>

<string>1</string>

<key>Legacy Logo</key>

<string>Yes</string>

<key>EthernetBuiltIn</key>

<string>Yes</string>

</dict>

</plist>

 

 

Hi ,

Du hast geschrieben, dass Du volgende kext mit [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] nachinstalliert hast.

ElliotForceLegacyRTC, IOAHCIBlockStorageInjector, jMicron 36x und eben den Kexthelper angekreuzt.

Den jMicron habe ich nicht installiert.

Zu Deiner Frage: Eine PCI Karte steckt da nicht drin.

Ist ja erst ne Art testfase.

Auf meinem Studiorechener ist 10.6.8 drauf da läuft alles unter 64 Bit stabiel.

Logic kann dan die Speicher besser nutzen.

Ist auch ein P35 Chip drauf.

Share this post


Link to post
Share on other sites

Hallo tidow

 

Ich habe ein ähnliches Board, und habe auch nach obiger Anleitung von MaLd0n installiert, allerdings hab ich das ganze [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]-Zeugs weggelassen, sondern nur Chameleon installiert, und in den Extra-Ordner meine alte DSDT und die com.apple.boot.plist reingepackt, funktionierte bis auf audio alles out of the box, startet im 64bit mode

 

Für Audio musste ich ne ältere AppleHDA nachinsten mit Kext Helper

 

Hänge Dir zum Vergleich mal meine com.apple.boot.plist ran, vielleicht hilft dir die ja weiter

com.apple.Boot.plist.zip

Share this post


Link to post
Share on other sites
Hallo, ich bin es noch mal. ich poste mal meine com.apple.Boot.plist

Schau mal rein,

 

 

<plist version="1.0">

<dict>

...

<key>PciRoot</key>

<string>1</string>

...

</dict>

</plist>

 

heisst das nicht PCIRootUID?

Share this post


Link to post
Share on other sites

Moin

 

ScorpionX41: ja, habe ich sieh Zeile 11.

Nixwiz: Dank für Deine c.a.B.plist. Ich glaube die passt nicht ganz für meine Graka. Versuche Sie aber mal. :) Dank

Share this post


Link to post
Share on other sites
Moin

Nixwiz: Dank für Deine c.a.B.plist. Ich glaube die passt nicht ganz für meine Graka. Versuche Sie aber mal. :P Dank

 

Die war nur zum Vergleich der gesetzten Optionen gedacht. U.a. steht da die UUID meiner Platte drin, und eben meine Graka, das musst du also schonmal auf jeden Fall ändern.

 

 

Dazu brauchst dann auch eine angepasste DSDT, die sieht auch von Board zu Board anders aus

 

 

 

 

Grüße

 

N.

Share this post


Link to post
Share on other sites
Moin

 

ScorpionX41: ja, habe ich sieh Zeile 11.

Nixwiz: Dank für Deine c.a.B.plist. Ich glaube die passt nicht ganz für meine Graka. Versuche Sie aber mal. :wacko: Dank

 

du hast da aber PCIRoot stehen, nicht PCIRootUID...

Share this post


Link to post
Share on other sites

Hab es mit einem P5Q Pro versucht, jedoch keinen Erfolg gehabt. Erst musste der USB Stick dran glauben und danach die interne HDD.

 

Bei beidem bleibt es jedoch bei dem Bild stehen und ich weiß beim besten Willen nicht wieso.

 

dscf2916w726.jpg

 

Hab genau nach der Anleitung gearbeitet (hab mir auch die Englische angeschaut) aber der Erfolg blieb dann leider aus :/ Jemand ne Ahnung an was es liegen könnte?

Share this post


Link to post
Share on other sites
Hab es mit einem P5Q Pro versucht, jedoch keinen Erfolg gehabt. Erst musste der USB Stick dran glauben und danach die interne HDD.

 

Bei beidem bleibt es jedoch bei dem Bild stehen und ich weiß beim besten Willen nicht wieso.

 

dscf2916w726.jpg

 

Hab genau nach der Anleitung gearbeitet (hab mir auch die Englische angeschaut) aber der Erfolg blieb dann leider aus :/ Jemand ne Ahnung an was es liegen könnte?

 

 

Ich glaub ich weiß was das Problem ist.

Du hast sicher ne ATI Grafikkarte, nicht?

 

Wenn meine Vermutung stimmt dann fehlt

<key>GraphicsEnabler</key>
<string>Yes</string>

 

in deiner com.apple.boot.plist.

 

Hast du noch Windows nebenbei installiert?

Unter Windows kannst du dir MacDrive 8 (bringt Schreibrechte auf Mac Partition) besorgen und plist-editor for Windows.

Damit kannst du diese Datei unter Windows bearbeiten und an die richtige stelle speichern.

Share this post


Link to post
Share on other sites
Ich glaub ich weiß was das Problem ist.

Du hast sicher ne ATI Grafikkarte, nicht?

 

Wenn meine Vermutung stimmt dann fehlt

<key>GraphicsEnabler</key>
<string>Yes</string>

 

in deiner com.apple.boot.plist.

 

Hast du noch Windows nebenbei installiert?

Unter Windows kannst du dir MacDrive 8 (bringt Schreibrechte auf Mac Partition) besorgen und plist-editor for Windows.

Damit kannst du diese Datei unter Windows bearbeiten und an die richtige stelle speichern.

 

Ja genau ich habe eine ATI Karte.

 

Windows ist auf einer anderen HDD installiert, hab noch eine SL Installation auf meiner anderen Partition wo auch Lion drauf soll. Ich editier das ganze mal eben und schau ob es funktioniert. Danke schonmal!

 

 

Vielen dank, hat alles wunderbar geklappt :( brauch nur noch eine kext für meine Netzwerkkarte und dann läuft alles ohne Probleme.

 

Nur eine Frage noch, in der bootlist steht ja i=386 was ja bewirkt, dass der 32bit kernel geladen wird oder? kann ich die zeile einfach löschen um 64 bit zu nutzen oder bringt das irgendwelche nachteile?

Share this post


Link to post
Share on other sites
Nein, dass muss in der Zeile heißen :.... arch=x86_64.....

Pobiers??

 

Wird gemacht sobald ich einen Netzwerktreiber gefunden habe. Ohne Internet macht Lion auch nicht soviel Spaß ;)

 

Atheros L1E suche ich

Share this post


Link to post
Share on other sites
Ja genau ich habe eine ATI Karte.

 

Windows ist auf einer anderen HDD installiert, hab noch eine SL Installation auf meiner anderen Partition wo auch Lion drauf soll. Ich editier das ganze mal eben und schau ob es funktioniert. Danke schonmal!

 

 

Vielen dank, hat alles wunderbar geklappt :D brauch nur noch eine kext für meine Netzwerkkarte und dann läuft alles ohne Probleme.

 

Nur eine Frage noch, in der bootlist steht ja i=386 was ja bewirkt, dass der 32bit kernel geladen wird oder? kann ich die zeile einfach löschen um 64 bit zu nutzen oder bringt das irgendwelche nachteile?

 

Freut mich, dass ich dir helfen konnte ;)

 

Da du ja die selbe Netzwerkkarte hast wie ich, wird die Kext die ich nutze sicher funktionieren ;) (Siehe Anhang).

 

Was für Vorteile bringt 64bit denn?

Also bei mir steht in der boot.plist auch nur ...386, aber iBench zeugt mir: 10.7 x86 (64bit)

AttansicL1eEthernet.kext.zip

Share this post


Link to post
Share on other sites

hey.

ich hab ein abit ip35pro, intel quad core q9450, ati radeon hd3780.

denkt ihr osx 10.7 lässt sich ohne probs mit scorpionx41s anleitung installieren?

 

ich hab jetzt seit 3 Jahren 10.5.8 drauf läuft ganz gut - aber jetzt will ich mal aktualisieren.

 

 

falls ich eine dsdt.aml braucht, denkt ihr diese ist brauchbar? http://www.mataporkoz.com/index.php/compon...or-snow-leopard

 

danke, lg

Share this post


Link to post
Share on other sites

@notnotnotnot wieso soll das nicht gehen ? deine hardware reicht für LiON, nur du muss dich damit wirklich befassen und lesen. Meiner Meinung nach könntest du nur Probleme mit der Grafikkarte bekommen. Sonst nix weiter!

 

Halte dich etwas an dieses Tut hier [Desktop]: Lion on GA-EP35-DS4 – Retail Installation + Upgrade von Nexos das sollte in etwa gleich mit deinem board sein.

Share this post


Link to post
Share on other sites
Hi,

ich schreib mal die Fehlmeldung auf.

JMicron ATA: JMB363 ( CMD 0xc0000xc100 IRQ 17, BMOxc408 )

Was kann das sein.

Gigabyte EP35-DS4.

 

Wenn du die JMicron SATA-ports (sind die 2 Extra auf dem Mobo) nicht benutzt, schalt sie im Bios

einfach aus. Gab immer Probleme mit denen und mehr als 4GB RAM.

Share this post


Link to post
Share on other sites

Hallo,

 

leider hat das ganze bei mir nicht ganz so reibungslos funktioniert. Die Vorbereitung des USB-Sticks wurde wie im Tutorial beschrieben erledigt. Ich scheitere nun an der Installation (Punkt 9). Nach Booten des USB-Sticks wird der Bootvorgang nach einigen Sekunden mit folgender Fehlermeldung abgebrochen/beendet:

 

ACPI table not found: DSDT.aml
No DSDT found, using 0 as uid value.
Using PCI-Root-UID value 0
Read HFS+ file: [hd(0,2)/Extra/smbios.plist] 574 bytes.
Scanning SMBus [8086:27da], mmio: 0x0, ioport: 0x18c0, hostc: 0x1
CPU is Genuine Intel® CPU	T2300 @ 1,66 GHz, family 0x6, model 0xe
Customizing SystemID with: 2149de85-b13f-3300-f684-000fb0f2da83
efi_inject_get_devprop_string NULL trying string data
ACPI table not found: DSDT.aml

 

Was mich nur wundert, dass in andern/ähnlichen Tutorials die USB-Sticks noch weiter modifiziert wurden (wahrscheinlich hinsichtlich Hackintosh-Kompatibilität). Ist das hier vergessen worden oder liegt der Fehler woanders? Musstet ihr vor der Installation den USB-Stick mit weiteres Kext's, System- bzw, Konfigurationsdateien ausstatten?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×