Jump to content

Personal File Sharing & Samba


StarForge
 Share

33 posts in this topic

Recommended Posts

I thought I'd make a new thread about this as I think it maybe affecting others as well.

 

the JaS 10.4.7 DVD is great, installs fine and everything pretty much works straight after install, only there's two things I can't get working:

  • Personal File Sharing
  • Samba (via smb:// )

In the System Preferences, Sharing, if I click on 'Personal File Sharing' the checkbox is ticked, but with a grey tick and to the right "File Sharing starting up...", however it never does start up.

 

With accessing my Windows shares, I'm unable to do so via the CMD+K command in Finder. No matter what I type in, it just doesn't appear to respond. The 'connect' button reacts, but that's all. No error message either.

 

I tried the Samba Fix for 10.4.6, but that didn't appear to have any affect. I've since removed the files it placed in /System/ (the Locations folder).

 

Is anyone else experiencing these two issues, or perhaps just one?

 

Any help in either matter would be greatly appreciated, thanks!

Link to comment
Share on other sites

Though I'm no closer to finding a solution, its good to know that I'm not the only one and that if I re-installed things it probably wouldn't help :P

 

Personal file sharing is the only thing that fails. What systems are you trying to share data between? As a workaround use windows file sharing: \\ip\shortname for access. Also, smb through the connect to server does work for me.

 

I'm using the JaS 10.4.7 DVD.

Link to comment
Share on other sites

The odd thing is that whatever I type into the 'Connect to Server' box it doesn't do anything. No error at all.

 

I've tried:

//IP/share

smb://IP/share

doesthiswork? (and other strings)

 

When I click 'Connect' the button depresses, but nothing happens. Its very weird.

Link to comment
Share on other sites

Starforge, I face the exact same problem that you described. For now I've gone back to JaS 10.4.6 DVD. I have tried everything I can think of (which really is not that much) but nothing works.

 

mir...

Link to comment
Share on other sites

I still can't get personal file sharing to work, but with regards to the 'connect to server' and Windows shares issue Harietje posted a solution:

 

Example:

 

server=192.168.10.100

username=john

password=secret

share=myshare

mountpoint=~/myshare (~ = homedir.)

 

1. mkdir ~/myshare

2. mount_smbfs //john:secret@192.168.10.100/myshare ~/myshare

 

That's it. I'm using this on a clean JaS 10.4.7 install. Check if you've spaces in your sharename. In that case you have to use quotes.

Link to comment
Share on other sites

Personal File Sharing does not work. AppleFileServer it is not started

 

Temporary solution for check:

sudo /System/Library/CoreServices/AppleFileServer.app/Contents/MacOS/AppleFileServer

 

The reason:

The link /usr/sbin/AppleFileServer.lnk is spoiled!!!

 

Correction:

To delete the link and to create new!

After that Personal File Sharing starts to work.

 

I shall continue the researches later....

It is necessary to check up all links to files.

Link to comment
Share on other sites

Ok, I fixed the file sharing issue with the above method :gathering::D

However, when I try to connect to any of the network drives located on my other 2 PCs, I getthis error 119fs695465.png . This is after I installed JaS 10.4.7 full iso. When I had 10.4.6 and patched with 10.4.7 patch I didn't have any problems. Anyone else having this issue? Any known solutions?

Link to comment
Share on other sites

Similar workaround to the Samba fix, use the afp_mount command to mount the volume.

 

I created a /Volumes/mount1 dir, and then used the following command:

 

afp_mount afp://user:pass@192.168.1.40/username /Volumes/mount1

 

and success..

 

I just made a batch file that mounts my network samba and afp dirs and set it to autorun on bootup.. gross but ok for now.

java script:emoticon(':(',%20'smid_2')

Link to comment
Share on other sites

Greetings,

 

I am also experiencing this problem.

 

Identical as Above, I do notice a coreservicesd crash in the system console, I think it has to do with the decrypted binaries JaS threw in the 10.4.7 install DVD, this is a fresh install. Connect to button is clickable but does nothing, will populate local computers but you receive the alias error when clicking connect in the finder network browser.

 

Regards,

 

{censored}-x

Link to comment
Share on other sites

I Also have the AppleFileServer issue if anyone has a fix yet that would be Awsome Im Using the JaS 10.4.7 full iso install, i get the sharing started with the sudo /System/Library/CoreServices/AppleFileServer.app/Contents/MacOS/AppleFileServer

command but atill cant surf other computers on the network. Although they show up but wont connect.

Link to comment
Share on other sites

Well the reason why I posted here is because I just could not find the solution. Believe me, I wouldn't ask unless it was necessary. If someone could please let me know where this solution is located on the forum I would appreaciate it greatly. Unfortunately, every time you do a search in the forum it gives you and error or such. Anyways, thanks for the help, but like I said, is not a big deal, I was just trying to see if anyone else had the same problem and apparently some do.

post-43528-1157048343_thumb.png

Link to comment
Share on other sites

 Share

×
×
  • Create New...