Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
raggedjagged

Hiding Windows's "System Reserved" partition in SL

22 posts in this topic

Recommended Posts

Hi all,

I just did a near-perfect installation of Snow Leopard 10.6.3 on my GA-X58A-UD3R machine, now however, I have one problem:

 

How can I hide the Windows 7 created "System Reserved" partition from the SL desktop? Don't ask me to reinstall Windows to try and not let that partition be created (i'd rather leave that partition present in SL than to reinstall Windows).. so are there any real solutions to this within SL?

 

There are 2 methods that I have tried with no success:

1) SetFile method: Using the terminal tool SetFile (included when you install Xcode development tools), you can hide a partition by issuing the command: SetFile -a V /Volumes/System Reserved however, it didn't work for me, it gave me an error: No write permission (-61).. and I can't seem to fix that.

 

2)/etc/fstab method: I don't know how to prevent the drive from loading using this method because the partition does not have a UUID in SL, and the path name has a space in it.. so I don't know how to get it working.

 

If anyone has any ideas of fixes for this, please let me know, much appreciated, thanks!!

Share this post


Link to post
Share on other sites
Hi all,

I just did a near-perfect installation of Snow Leopard 10.6.3 on my GA-X58A-UD3R machine, now however, I have one problem:

 

How can I hide the Windows 7 created "System Reserved" partition from the SL desktop? Don't ask me to reinstall Windows to try and not let that partition be created (i'd rather leave that partition present in SL than to reinstall Windows).. so are there any real solutions to this within SL?

 

There are 2 methods that I have tried with no success:

1) SetFile method: Using the terminal tool SetFile (included when you install Xcode development tools), you can hide a partition by issuing the command: SetFile -a V /Volumes/System Reserved however, it didn't work for me, it gave me an error: No write permission (-61).. and I can't seem to fix that.

 

2)/etc/fstab method: I don't know how to prevent the drive from loading using this method because the partition does not have a UUID in SL, and the path name has a space in it.. so I don't know how to get it working.

 

If anyone has any ideas of fixes for this, please let me know, much appreciated, thanks!!

 

SetFile -a V "/Volumes/System Reserved" is pretty much your only option without hiding all attached drives/partitions; what file system is that partition using? If it's NTFS, that's why you're getting a Write error.

Share this post


Link to post
Share on other sites

The solution is simple.

 

By default, Snow Leopard doesn't put any hard drive icons on your desktop.

 

Go back to the default setting of not showing drives on the desktop, then create aliases on your desktop for the hard drives you want there. Just like you would in Windows.

 

Personally I just use the shortcuts in the toolbar to the left of a Finder window when I need something on any of my NTFS drives. If you don't want to see your 'System Reserved' partition there either, just drag it off of the toolbar and it will disappear in an intuitive and user friendly puff of smoke.

Share this post


Link to post
Share on other sites

Well, I gave that a look and it's not that much of a fix for this case. (By the way, I never touched any Finder preferences, everything is default right since Snow Leopard's installation. I did not do anything special for the Windows and System Restore to be shown)

 

Unfortunately, the Windows and the System Partition drives are grouped as "CDs, DVDs and iPods" (and not "Hard Drives").. which I'd rather not have hidden in case I plug in my iPod or insert a CD or DVD.

 

There should be a way to stop Snow Leopard from even mounting select drives on boot.

Share this post


Link to post
Share on other sites
Unfortunately, the Windows and the System Partition drives are grouped as "CDs, DVDs and iPods" (and not "Hard Drives").. which I'd rather not have hidden in case I plug in my iPod or insert a CD or DVD.

There is something wrong then.

What does System Profiler say under Serial-ATA?

Share this post


Link to post
Share on other sites

Have you tried installing NTFS support and then running the command thus:

 

sudo SetFile -a V /Volumes/system\ reserved

 

I have not tried it. Just a thought.

 

What I do to deal with spaces in command lines is as follows

 

type your comand in terminal first like this

 

sudo setfile -a v

 

at this point i grab the drive icon from the desktop into the terminal window. this way terminal creates the correct path for you and adds it to your command line.

 

and I end up with this

 

sudo setfile -a v /Volumes/system\ reserved

 

I hope that helps

 

P.

Share this post


Link to post
Share on other sites
There is something wrong then.

What does System Profiler say under Serial-ATA?

I've attached a screenshot of the Serial-ATA section in System Profile, is it not normal?

 

post-69650-1271804318_thumb.png

 

Is there something wrong with that? I've always seen Windows and NTFS drives not being under "Hard Drives" in Finder on multiple computers.. Help!!

Share this post


Link to post
Share on other sites

Well it says 'unknown', do you have ICH9R or ICH10R? (assuming the R in your motherboard model name refers to RAID)

Share this post


Link to post
Share on other sites

Beerkex'd: Okay I got the 'unknown' showing the text of my SATA now.. which is ICHR9 .. I just put in AHCIPortInjector.kext in my /E/E/ ..s it now shows ICH9R in that System Profiler section. However, the NTFS drives are still being shown as "CDs, DVDs, and iPods" in Finder Preferences.. The only drives that show as "Hard Drives" are OSX and Time Machine! What's going on? :thumbsup_anim:

Share this post


Link to post
Share on other sites

Look in System Profiler or Disk Utility and check if your NTFS drives are 'external'. If your drive icons are orange then don't bother, that means I'm right :thumbsup_anim: When the drives are seen as external, they get grouped with "CDs, DVDs and iPods" and are shown on the desktop.

This is normal, it happens on a real Mac as well when you connect an external drive.

 

You can use the IOAHCIBlockStorageInjector.kext that comes with Chameleon to make your drives 'internal'.

Share this post


Link to post
Share on other sites

sudo su

nano /etc/rc.local

add line:

diskutil unmount "/Volumes/System Reserved" ("System Reserved" - name of partition)

save Ctrl+X.

Share this post


Link to post
Share on other sites

This method involves utilizing the File System Table (fstab) for the BSD subsytem.

 

First you need to know the mount points of the partitons you don't want to see. I'll use "winxp" and "backup" for the examples. If you didn't know, the partition on which OS X resides is mounted to / (root), and all subsequent partitons are mounted to /Volumes/. You can find the mount point of any given partiton using disk utility, selecting the partiton and hit the info button up top. I have 2 drives. One with 2 partitions and one with 3 partitions. The primary drive has my OSX partition and one for winxp. The second drive has a documents partition, and media partition, and a backup partition. For day to day use in OS X I don't want to see the winxp nor the backup partions. From disk utility, I find their mount points are /Volumes/winxp and /Volumes/backup respectivley.

 

The first thing we need to do is to crate the fstab file in the /etc folder. Open up a Terminal and:

CODE

sudo nano /etc/fstab

 

 

now we need to edit to suit our needs. The typical entry line in fstab contains on line for each mount, with the data in the format :

file system mount-point type options

So to tell it to not mount a specific drive or partition, we just need to specify not to do so.

 

CODE

LABEL=winxp none ntfs ro,noauto

LABEL=backup none HFS+ ro,noauto

 

 

In the example,

"LABEL=winxp" is my windows partition, "none" is the mount point, "ntfs" is the type, and "ro,noauto" are the options.

 

You must use the appropriate type for the partiton, ie: ntfs HFS HFS+ msdos etc.

 

The options "ro,noauto" mean read only, don't auto mount. For read / write of supported file systems use rw.

 

If your partition name has a space on the name, you need to replace the space with "\040" ie. "LABEL=Win\040XP" for Win XP.

 

Once you have the code entered, hit cntrl-x and it will ask if you want to save. Hit y for yes, and it'll ask if you want to save it as fstab. Hit enter.

 

Now just restart, and the drives won't auto-mount.

Share this post


Link to post
Share on other sites
Look in System Profiler or Disk Utility and check if your NTFS drives are 'external'. If your drive icons are orange then don't bother, that means I'm right :) When the drives are seen as external, they get grouped with "CDs, DVDs and iPods" and are shown on the desktop.

This is normal, it happens on a real Mac as well when you connect an external drive.

 

You can use the IOAHCIBlockStorageInjector.kext that comes with Chameleon to make your drives 'internal'.

I already have OrangeIconFix.kext, and my drives don't appear as orange icons, they appear as internal hard drive (shiny metal) icons. However you are right, all of my Hard disks, including the OS X one itself, appear as "External" types.. (but its weird how OS X drive, eventhough seen as External in Disk Utility, is grouped with Hard Drives in Finder prefs.) So now I need the IOAHCIBlockStorageInject.kext to fix this?

 

Thanks for your help!!

 

sudo su

nano /etc/rc.local

add line:

diskutil unmount "/Volumes/System Reserved" ("System Reserved" - name of partition)

save Ctrl+X.

 

 

This method involves utilizing the File System Table (fstab) for the BSD subsytem.

 

First you need to know the mount points of the partitons you don't want to see. I'll use "winxp" and "backup" for the examples. If you didn't know, the partition on which OS X resides is mounted to / (root), and all subsequent partitons are mounted to /Volumes/. You can find the mount point of any given partiton using disk utility, selecting the partiton and hit the info button up top. I have 2 drives. One with 2 partitions and one with 3 partitions. The primary drive has my OSX partition and one for winxp. The second drive has a documents partition, and media partition, and a backup partition. For day to day use in OS X I don't want to see the winxp nor the backup partions. From disk utility, I find their mount points are /Volumes/winxp and /Volumes/backup respectivley.

 

The first thing we need to do is to crate the fstab file in the /etc folder. Open up a Terminal and:

CODE

sudo nano /etc/fstab

 

 

now we need to edit to suit our needs. The typical entry line in fstab contains on line for each mount, with the data in the format :

file system mount-point type options

So to tell it to not mount a specific drive or partition, we just need to specify not to do so.

 

CODE

LABEL=winxp none ntfs ro,noauto

LABEL=backup none HFS+ ro,noauto

 

 

In the example,

"LABEL=winxp" is my windows partition, "none" is the mount point, "ntfs" is the type, and "ro,noauto" are the options.

 

You must use the appropriate type for the partiton, ie: ntfs HFS HFS+ msdos etc.

 

The options "ro,noauto" mean read only, don't auto mount. For read / write of supported file systems use rw.

 

If your partition name has a space on the name, you need to replace the space with "\040" ie. "LABEL=Win\040XP" for Win XP.

 

Once you have the code entered, hit cntrl-x and it will ask if you want to save. Hit y for yes, and it'll ask if you want to save it as fstab. Hit enter.

 

Now just restart, and the drives won't auto-mount.

Thanks for the info guys! I'll try that

 

Orwell: I have to try that, my earlier experimenting with fstab didnt quite work, lets see how following your instructions will result. ;)

Share this post


Link to post
Share on other sites

OrangeIconFix does just that, it only fixes the icons and does not change the actual status of the drives. Hotplugging works.

 

IOACHIBlock(...).kext sets the drives as internal, which in turn make the icons change but you lose hotplugging.

 

Don't use both at the same time, there's no point.

 

If you have a ICH9 or 10 SATA controller, you could also set the drives as internal via DSDT.

Share this post


Link to post
Share on other sites

Thanks for the reply Beerkext'd.. well since I do not use esata, I think hotplugging is of no use to me.. so I'll replace OIF to IOAHCIBlock...kext. However, I think DSDT will be better, do you know what changes to dsdt I have to make? I have an ICH9R controller.

Share this post


Link to post
Share on other sites

You can get the general idea from reading this:

http://www.insanelymac.com/forum/index.php?showtopic=168014

 

The initial post is about USB but you can apply the same trick to your SATA controller. The device ID for the ICH10 that Apple uses (it's 3a22) works well with our ICH10/9/R. See post #26, #46 and the comments that follow.

 

Actually, come to think of it you will still need the BlockStorageInjector when patching device IDs in the DSDT like this. It's the other ICHx kext you can ditch, I get confused easily trying to remember all these things.

 

Anyway if you're new to DSDT patching, try this, it's a good exercise for a beginner :thumbsup_anim: and do the USB controllers too.

Share this post


Link to post
Share on other sites

Just figured this one out, in terminal type "sudo nano /etc/fstab"

 

then paste the following line minus quotes

 

"LABEL=System\040Reserved none ntfs rw,noauto"

 

then hit control+x, type "y" then hit enter, the system reserved partition will no longer mount in OS X but can be mounted via disk util if the need is ever there.  Be advised if you do mount this volume you have read and write access to it with the above.  My first post WOOT! :(

Share this post


Link to post
Share on other sites

This method involves utilizing the File System Table (fstab) for the BSD subsytem.

 

...edited...

 

 

Yes, thank you orwell! This is the best solution so far... As the original poster learned.

 

An improvement to this suggestion would be to use the volume UUID instead of the label. It's a more secure method much less prone to breaking (like if you end up with more than one HD with a "System Reserved" partition on using the UUID is the only thing that works). But that's a bit more tricky since the Disk Utility does not display the UUID for NTFS formatted partitions (thanks Apple!). However, this doesn't mean there isn't one. You can learn that with the command:

 

CODE

diskutil info /dev/diskXsY ##substitute X & Y for the disk and partition numbers which you can learn with the command: diskutil list

 

This command will not succeed if you have a 3rd party driver installed for NTFS (Tuxera or 3g are two that come to mind). You must disable any non-apple file system drivers for the partitions in question and reboot.

You must also either have the partition mounted or dismounted when you run the command- I don't recall which but I remember it being the opposite of what the tutorial actually said.

If you still can't determine the volume UUID, you can use an Ubuntu installation disc to boot into Ubuntu and there are a number of ways to reveal the UUID- gparted is one.

 

Then add the following lines to fstab as described by orwell:

 

CODE

UUID=(you know what to paste here- no brackets or anything) none ro,noauto 0 0

 

reboot and viola! no unwanted partitions...

 

As you've most likely learned, the orange icons issue is almost certainly just a cosmetic thing which can be "solved" in a number of ways- however, it will not affect the functioning or performance of your system or disks.

 

Anyway, I hope this helps someone at some point. It took me a long time to figure out how to reveal the UUID despite the simplicity... And although it is merely a cosmetic thing, and I've developed some work arounds like scripts that unmount the volumes, etc. But this is by far the cleanest and most effective solution. And very simple once you know how...

Share this post


Link to post
Share on other sites

No, orange icons are not a cosmetic issue. Orange icons indicate that OS X sees your hard drives as external, just like on a real Mac when you plug in an external drive.

 

I'll repeat what Beerkex'd said, because it looks like nobody understood it.

 

If you don't like orange icons but still want hotplugging to work, use OrangeIconFix.kext to get "normal" grey drive icons and the solution orwell posted to never mount unwanted partitions.

 

If you don't care about hotplugging use AHCIPortInjector.kext in /S/L/E. This will make your drives "internal" (grey icons, not appearing on your desktop) and you'll only see your System Reserved partition when you open your "[username]'s xxMac" folder. To remove unwanted partitions from the sidebar, use Finder Preferences.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×