Jump to content

ASUS G72GX Notebook - Perfect Hackintosh!


141 posts in this topic

Recommended Posts

Did any of you guys have any problems getting the audio to work?.

 

That's the only real problem I'm having so far managed to get it updated to 10.6.4 without any problems and got everything else that needs to work working but the on board audio is still being a pain in the ass.

 

From what I've been able to figure out the G72GX has:

Realtek ALC663 @ Intel 82801IB ICH9 - High Definition Audio Controller

 

Here's a little bit about my install:

OSX 10.6.3 Retail

Installed with Empire Efi v1085

 

The only extra Kext's I've used were for the video & wireless

 

 

Any suggestions would be greatly appreciated & thanks for the help ahead of time.

 

 

-Mike

 

I never had a problem with the audio after any install. Even when installing with retail disc booting that with '[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]' the audio worked fine. Perhaps you should try VoodooHDA.kext ??

Well after trying to load 10.6.4 on my dell xps 1645 and dell 1640 and haveing some luck with that but the video cards were giving me all kinds of trouble. So today I sold my 1645 and decided to buy a G72GX and try that one out. I should arive tomorrow and I am trying to collect every thing that i will need to get it up and running 10.6.4 asap. I only hope I have as much success as most of yall have had with this hackentosh setup.

Well after trying to load 10.6.4 on my dell xps 1645 and dell 1640 and haveing some luck with that but the video cards were giving me all kinds of trouble. So today I sold my 1645 and decided to buy a G72GX and try that one out. I should arive tomorrow and I am trying to collect every thing that i will need to get it up and running 10.6.4 asap. I only hope I have as much success as most of yall have had with this hackentosh setup.

 

 

 

Good choice. I've had this badboy 4 almost 6 months the only things I didn't like were the ram speed, hdd speed and the weak air fan but it's a perfect hackintosh! :D if you need any help just ask this forum knows all

Ok my G72GX arived today and I was able to install using the retail 10.6.3 disc using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] nvidia to load it. Every thing installed without any problems. So far audio, video and wifi are working out of the box. So now I am at the confusing part. How to I get my laptop to boot up without using the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] cd.

Ok my G72GX arived today and I was able to install using the retail 10.6.3 disc using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] nvidia to load it. Every thing installed without any problems. So far audio, video and wifi are working out of the box. So now I am at the confusing part. How to I get my laptop to boot up without using the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] cd.

 

Just download Chameleon bootloader, it should be somewhere here in the forum... I think last release was RC4... Some installs come with kexts that may not work on this laptop (I got lots of kernel panics before it worked fine) but if you make sure to install ONLY bootloader you should have absolutely no problem =) (at least i didn't)

please let me know if there is anything else you need =)

 

by the way... I've written about this before but, is anyone else having trouble with battery status and charge/time left ... or is it just me?

Just download Chameleon bootloader, it should be somewhere here in the forum... I think last release was RC4... Some installs come with kexts that may not work on this laptop (I got lots of kernel panics before it worked fine) but if you make sure to install ONLY bootloader you should have absolutely no problem =) (at least i didn't)

please let me know if there is anything else you need =)

 

by the way... I've written about this before but, is anyone else having trouble with battery status and charge/time left ... or is it just me?

 

 

 

Nope your not the only one I also posted same minor issues still looking for a fix. But the time remaining on mine works fine it's the icon itself that I'm having issues with oh and my trackpad doesn't want to expand my folders to full screen. How about yours?

For me I had trouble getting the OSX install to boot from hard drive. I tried the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] method, tried Manually installing Chameleon, tried Chameleon with PC-EFI.. no luck. I think I must have been doing something wrong though as my current install which bunc sent to me pre loaded is a hazard distro and it uses Chameleon/PC-EFI and works great.

Nope your not the only one I also posted same minor issues still looking for a fix. But the time remaining on mine works fine it's the icon itself that I'm having issues with oh and my trackpad doesn't want to expand my folders to full screen. How about yours?

 

about the battery: its exactly as yours... works perfectly, but the icon seems to be unable to tell me exactly the quantity of time/percent that is left... it says 70, then after some time it goes down to 56% or whatever... I just wish I could know exactly how much time is left at any moment and not when the icon decides to change ¬¬

 

and about trackpad: mine is working as a simple, 10 year old trackpad... no zoom, no horizontal scrolling, it doesn't even accept a single touch as a click... it just moves the cursor and scrolls on the right side

I really don't know what happened... I'm pretty sure it worked perfectly after installing SnowLeopard 10.6 retail... I then updated to 10.6.4 through software update and maybe changed some kexts, but I don't remember replacing my trackpad kext :( ... I don't know what went wrong...

 

perhaps some other forum user can help us with this... anybody there? :)

 

 

 

EDIT: solved the touch=click problem... I only needed to enable it in Trackpad under System Preferences ¬¬... I feel so stupid... but I still don't know about zoom or anything else.

I feel like such a newb. I was able to get my laptop working using the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] disc and a retail copy of 10.6.3. But when I installed a bootloader to the hard drive, when my system boots i have no keybord or mouse. I'm sure I am missing something or some steps. I did not install any kexts when setting up the system, I just booted with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and installed. What is it that i need to do to get the laptop to boot from the hard drive with out using a boot disc, and keep my system running?

Ok So I decided to try the hazard disc again.

I am going to install using hazard and only add the bootloader in customization.

Then I am going to use a the kext zip file that was posed in this topic and run the dsdt thing.

I will post the results in about an hour.

@Knowskills

Ok would like to know results if your battery is working well and your trackpad can zoom along with it's other features. Good luck ;)

 

@capo_Saric

Yeah it does feel like an ancient trackpad with it's limited features hope someone can help

@Knowskills

Ok would like to know results if your battery is working well and your trackpad can zoom along with it's other features. Good luck ;)

 

@capo_Saric

Yeah it does feel like an ancient trackpad with it's limited features hope someone can help

 

Results= EPIC FAIl

the install is fine but when i reboot and try and boot from the hard drive i get a grey screen telling me to reboot.

I tried cpus=1 MAXMEN-4096 and praying to the little people but nothing has helped.

Results= EPIC FAIl

the install is fine but when i reboot and try and boot from the hard drive i get a grey screen telling me to reboot.

I tried cpus=1 MAXMEN-4096 and praying to the little people but nothing has helped.

 

I can't imagine what's causing this problems... I just used Empire EFI as bootCD, then used SnowLeopard 10.6 retail, disk utility to format the drive to GUID, made 3 partitions (macosx, windows7, myfiles), installed SnowLeopard and after install used Empire EFI again for the first boot just to install Chameleon and that's it....... I haven't had any problems

 

whenever I try to install better kexts and get kernel panic, I just run the computer on Windows7, use MacDrive to navigate through my Mac partition, and eliminate those problem-causing kexts or replace them by the older ones (always backup your files :thumbsdown_anim: )

 

I don't know if any of this will be useful in your situation... but please let me now if it does or else try to explain everything as detailed as possible so we can work out some solution...

Ok so here is my current progress.

I installed via [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and a retail 10.6.3 disc.

Installed

 

smbiosresolver

uuid

macam

nvinject

 

 

and pc efi 10.5

 

but now i have no keyboard or mouse :/

Ok so here is my current progress.

I installed via [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and a retail 10.6.3 disc.

Installed

 

smbiosresolver

uuid

macam

nvinject

 

 

and pc efi 10.5

 

but now i have no keyboard or mouse :/

 

 

try this one... worked for me :blink:

VoodooPS2Controller.kext.zip

Yes i was able to install the bootloader but no keyboard or trackpad when i boot from it...

 

have you tried the kext I attached in my last post?

You could also try the kexts in the package IMUSXx uploaded in this same thread...

have you tried the kext I attached in my last post?

You could also try the kexts in the package IMUSXx uploaded in this same thread...

nope I have not tried that kext yet, but i have tried that package imusxx uploaded but it crashed my computer every time

Try just the PS2 kext. Then repair permissions using the kext utility and reboot.

that ktext did not help :/

 

 

***EDIT***

ok so I am on install 15 or so.

 

and this is what i did.

 

 

booted with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] nvidia

installed 10.6.3 using a retail disc

updated to 10.6.4

installed pc efi 10.6

 

installed the recommend kexts from this topic.

 

so now for the good stuff.....

the computer will boot from the hard drive via pc efi 10.6

 

but the track pad and keyboard will not work for some reason.

 

but if i put the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] cd in and boot from it the keyboard and track pad work just fine. Even 2 finger scrolling and 2 finger secondary click, so i know this trackpad can work.... But why wont it work if i boot from pc efi???? what is the difference between [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and pc efi?

 

I have noticed that when i boot from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] it shows kernel version 10.0.0 and 32bit

but if i boot from pc efi it shows kernel 10.4 or something and has 64bit...

 

Anyone have any idea whats going on here?

Ok this question shouldnt be hard. What options do you use too install this with hazard?

 

I got the mac installer working with the cpus=1 command at boot but wat options in there do I install? I tried to just install it with no boxes clicked and doesnt work. I just need too know thanks. ohh and can you install windows 7 on the other 200 gig. my laptop came with 480 gig drive split in half with two 200 gigs. would be great to have osx and windows 7. let me know then.

 

 

Logic

@logic54

dual-booting is easy especially if you have to hdds because you won't gave to partition anything. All you have to do is a clean install of windows on your spare hdd. After install set your osx hdd as primary boot so you can take advantage of the bootloader options. As for the kext I installed during the installation process with the hazard distro are the following:

 

-atheosfix

-elliottforcelegacy

-achisatafix

-smbiosresolver

-uuid

-efi 10.5 bootloader

-nvinject

-macam

 

good luck :o

Thanks joker for the reply I tried wat U said and im getting a flight script error. Do you use the two updates at the top 10.6.1 10.6.2 or watever with the charmeleon efi 10.5? or just the 10.5. I had it installed before sumhow but I updated in mac osx and then it restarted and wouldnt boot. Im gonna try just the 10.5 bootloader and nvidia and thats it and see wat happens. After I install mac how can I find out if I have all the kext's I need loaded right? is there software or sumthing. I know its hard for mac on intel but just wish there was a little more support. I will let you know wat I come up with and twiddle with it for awhile i should get it too work. but yeah lemme kno I wanna kno if I got all the kexts installed and everything installed right liek it should.

Logic

×
×
  • Create New...