Jump to content

Dell Inspiron 1100 Successes and Failures


6 posts in this topic

Recommended Posts

So let me say that I used the generic DVD patcher and got it installed using a rather ugly greyscale installer.



P4 2.4ghz 533mhz FSB

512mb DDR2100 - 2xdimms 256

30gb 4200rpm 2.5" HDD internal

14" LCD



After the install I updated the Bios from revision a06 to a32 to get the options for 8mb of video memory. Now it looks fabulous and is as stable as my mac mini with absolutely no crashing of any kind.


I had to add the ac97 kext file and chmod it 755 for audio to work but now it loads correctly and even the keyboard volume keys work with the os perfectly. To get the USB mouse to work I followed the directions someone else posted "To get the USB mouse working, go into the "/System/Library/Extensions" delete the files "AppleFPMemDriver.kext" this seem to work on computer that have usb mouse problem." which worked perfectly.


I still have no wireless using my WPC54G Rev 2.0 card and I tried several other pcmcia cards made by other vendors including netgear, dlink, cisco and a generic 802.11b device.


I plan on trying another Linksys card model WPC11 and hopefully it will be recognized.


Also my network connection fades in and out of working when plugged in, the network control panel loses the ip and gives me a local 169.x.x.x loopback ip.


I do not have the sleep feature nor do I really care to have it.


So meanwile i'm gonna keep working on this wireless because its unacceptable that I can't get this working. I don't care about the sleep functionality and I certainly can live without my monitor turning off when I shut the lid as this thing is always on anyway.


Here are some pictures of the install

just screen



entire laptop



entire laptop - color



just screen - color


Link to comment
Share on other sites

The only Apple designed and mass produced wifi is the Airport and Airport Extreme cards, these are designed with Broadcom chipset's and thefore only similar chipsets work in OSx86. Unfortunatly no one has had any luck getting other drivers loaded for the time being. I am going to go tomorrow to bestbuy and I'll buy one of these USB WIFI sticks people are having luck with.


Damn Shame though.. these wifi sticks are fragile... and they take up one of my two usb jacks.

Link to comment
Share on other sites

I got my Inpsiron 1100 to work yesterday, too.


My specs :

Celeron 2.4Ghz (P4-based, SSE2)


CD drive (no DVD)

Bios A29 (=no video problems)

40Gb drive (not the stock Dell drive. I think mine is a bit faster)


I used deadmoo's image (the 1.29 GB tiger-x86.tar.bz2) since I don't have a DVD drive.

I did it using a Knoppix Livecd.


A little gotcha about the 1100 : on Linux, the hard drive is not /dev/hda, but /dev/hdc.


The image was stored on a Windows NTFS partition, so I started by mounting the partition :

mkdir /mnt/windows; mount /dev/hdc1 /mnt/windows


I followed the instructions on the page Install On A Partition Simple And Accurate.


The first time, I forgot to fill with zeroes the beginning of the OSx86 partition, it made my OSX unbootable. Here's the command I forgot to do the first time, it should be done after creating the partition in cfdisk (and rebooting if cfdisk recommands it) :

dd if=/dev/zero of=/dev/hdcn bs=512 count=1

(Replace hdxx with your partition)


I dd'ed directly from the archived .tar.bz2, here's the command I used :

tar -jOxf /mnt/windows/tiger-x86.tar.bz2 tiger-x86/tiger-x86-flat.img | dd of=/dev/hdcn bs=512 skip=63

in -jOxf, it's an uppercase o, not a zero.

I believe it took me about two hours to do it. Remember that dd doesn't give you any feedback while it works.


I used Windows bootloader, using the method with the chain0 file and editing boot.ini.


The first bootups caused some problems - crashes, screwed up graphics. I rebooted it a few times with different arguments every time, -v, -s, -s-v,... Everything ended up working eventually, and it now boots correctly without any argument.


I then trashed the files that were reported to cause problems on the 1100 in the HCL.


I finished getting it to work using the Maxxuss v0.5 patch (answered 'y' to the 3 steps).


I may have forgotten one or two steps I did, sorry about that. (I think I forgot a step that involves trashing even more files, maybe something about video).


After the install, I moved my Osx partition using Acronis PartitionExpert on windows, it didn't cause any problem.


Pretty much everything I tested works, and is fast, but I have not tested as much as I'd like to. Here are a few things I got to work :


Ethernet networking works. Got an IP from my router without any configuration.

My Logitech for notebooks USB mouse and the trackpad work.

The sound output works. Have not tested input yet.

The battery indicator works and is accurate

Gui stuff is quite smooth when the load is low : moving windows, dock hiding and magnification, minimizing windows.... as fast as if it were accelerated. One of the steps I did took care of the green lines visual glitch when using menus - not sure which one did. Exposé is not very smooth. Of course, video acceleration doesn't work since no drivers are available yet.

The key shortcut fn+Esc (suspend) will put the computer to sleep, but the screen is not blanked.

Closing the lid will blank the screen and put the computer to sleep.

The fn+[PageUp|PageDn|End] will work to change the volume as in Windows, and a bezel is shown, with a sample sound, when changing the volume using those shortcuts.

Fn+F10 does not eject the CD, so you must hold F12 to eject.

Rosetta works. PPC programs are a little bit slow and take bloody ages to load.

Mounting shares from a Mac works well.

Spotlight is very slow. I believe its index must be screwy because I used an image, I've not yet searched about the problem.


I have yet to do anything that requires serious computing power, but I found this setup performant enough for desktop use. I just hope it will stay stable.

Link to comment
Share on other sites

I got my 'Spiron 1100 working 3 and a half weeks ago, however I need Windows for work. I reinstalled and did a dual-boot setup for a while, but that got too repetitive and annoying to boot. Congrats to all you other 1100 users out there, the fan on mine is dead so it can last about half an hour before shutting off.



Link to comment
Share on other sites

  • 4 years later...

Can somebody give me some insight to installing on this poor old {censored}? It was a recycle computer donated from my sister. What did you have to pick during the install to get it running? Every attempt I make I end up with a machine that will not boot (for various reasons)



Link to comment
Share on other sites


  • Create New...