Jump to content

[SOLVED] snow kitty refuses to leave dreamland

dj nitehawk

25 posts in this topic

Recommended Posts

hi guys,


thanks to the many guides in this forum, ive been able to get SL 10.6 running fine on my pc except for one little thing which has been driving me nutts for almost a week now.


you guessed it right... it's none other than "SLEEP" :-)


before i go any further, here's my configuration:

  • intel dg33fb (ich9-r chipset) mobo
  • core2 quad cpu @ 2.4ghz
  • 4gb ram (2 x ddr2 800mhz)
  • nvidia 8500gt 512mg (dvi/vga)
  • 2 x 320gb hdds in apple softraid
  • atheros 5006 wifi card
  • builtin lan (intel 82566 chip)
  • chameleon 2 rc2.r640 (installed manually to both helper partitions of the raid)
  • boot plist:
    • arch=x86
    • GraphicsEnabler=Yes

    [*]patched dsdt.aml with new hpet fix (dsdt patcher gui)

    [*]kexts used:

    • voodoops2controller + AppleACPIPS2Nub
    • fakesmc
    • openhaltrestar
    • voodoohda
    • intel82566mm

at first, i was unable to put the computer to sleep at all. it would only switch off the hdds. the power led and fans remained on.


so i manually patched the dsdt uhc1-6 + ehc1-2 devices with the device ids from ich10 as explained here.


that only solved half the problem. now the machine goes to sleep just fine, but never wakes up.


when i try to wake it up by either clicking a mouse button or the power button, the hdds spin up and nothing happens. the screen stays blank.


one other observation is, the mouse doesnt fully light up like it is normally. it does however emit light as i click the mouse buttons while in this "stuck in sleep mode".


here's some of the things ive tried but to no avail:

  • use chameleon rc1.r430 with pc-efi 10.1 boot file :-(
  • nullcpupower + sleepenabler kexts :-(
  • ahciportinjector kext :-(
  • efi string for graphics in boot plist :-(
  • removing iousbfamily kext :-(
  • booting with no graphics or efi strings :-(
  • booting without dsdt.aml :-( wont boot at all. KP on boot...
  • nvinject and corevidia :-(
  • set sleep state in bios as S1 :-(
  • slice's latest iousbfamily.kext :-(

the weird thing is this same machine sleeps and wakes fine under iatkos v7 wih slice's iousbfamily.kext.


is anybody else having the same problem as me?


has anybody with an intel dg33fb mobo managed to get their machines to sleep and wake properly?


any assistance you can provide will be greatly appreciated...



Link to comment
Share on other sites

here's what my current _WAK looks like... i added the return part at the end...


is that the fix u r talking about or is it something else?


    Method (_WAK, 1, Serialized)
       \_SB.PCI0.LPC.WAK (Arg0)
       If (CondRefOf (_OSI, Local0))
           Store (0x21, OSTY)

       Notify (\_SB.PCI0.UHC1, Zero)
       Notify (\_SB.PCI0.UHC2, Zero)
       Notify (\_SB.PCI0.UHC3, Zero)
       Notify (\_SB.PCI0.UHC4, Zero)
       Notify (\_SB.PCI0.UH42, Zero)
       Notify (\_SB.PCI0.UHC5, Zero)
       Notify (\_SB.PCI0.UHC6, Zero)
       Notify (\_SB.PCI0.EHCI, Zero)
       Notify (\_SB.PCI0.EHC2, Zero)
       If (LEqual (Arg0, 0x04))
           If (LEqual (WAS4, One))
               Notify (\_SB.SLPB, 0x02)

[b]Return (Package (0x02)



im attaching my whole decompiled dsdt.dsl below, so maybe you or someone else could spot what's actually wrong...


im really starting to suspect that my video card could be the culprit... is this possible?


i've tried efi strings from efi studio/ osx86 tools. and also the chameleon r640's GraphicsEnabler=Yes as well as injectors like corevidia/ nviject...


do u have any other suspicions?


Link to comment
Share on other sites

I'm having the same problem. I've patched my dsdt. Here's what my _WAK looks like.


Method (_WAK, 1, NotSerialized)
	Store (0xFF, DBG1)
	SALD (Zero)
	If (OSFL)
		Notify (\_SB.PWRB, 0x02)
		If (LEqual (RTCW, Zero))
			Notify (\_SB.PWRB, 0x02)

	Notify (\_SB.PCI0.USB0, Zero)
	Notify (\_SB.PCI0.USB1, Zero)
	Notify (\_SB.PCI0.USB2, Zero)
	Notify (\_SB.PCI0.USB3, Zero)
	Notify (\_SB.PCI0.USB4, Zero)
	Notify (\_SB.PCI0.USB5, Zero)

Link to comment
Share on other sites

EVGA x58 760 mobo


Chameleon 2 RC2 640

Using DSDT with -newHPET, not manual fixes (RTC length was already 2 and didn't need changing).










Link to comment
Share on other sites

well... ive made a little bit of progress after a lot of messing around with things...


im now able to get the machine to resume occasionally, but not every single time...


it almost never wakes up after the machine's had a cold boot (power off > turn back on)...


here's what happened...


1. i restored the snow retail dvd to an external usb drive

2. installed chameleon rc3 + kexts to the restored "Mac OS X Install DVD" partition

3. booted into the snow install dvd on the usb hdd


i didnt have a dsdt.aml file on the usb hdd.


the install dvd still booted (slowly due to a lack of dsdt.aml i suppose) and i saw an error in the verbose mode that said something like:


"USBF: xxxxxxxxx Unable to initialize UIM" or something like that...


after booting into the installer, there was no usb mouse support... so what i did was, i unplugged the mouse from the current usb port and plugged it into a different port... and walla... the next time i booted into the installer, my usb mouse was detected and working...


this made me curious... could my mouse/usb port be blocking my pc from resuming from sleep?


that in fact was the case...


and after a bit more playing around, i have come to a conclusion that having a properly patched dsdt.aml for my mobo and chameleon's USBBusFix=Yes flag has certainly increased my success rate of sleep/resume...


so i suggest you try some of the things ive mentioned and see if any of it works for you...


good luck!!!

Link to comment
Share on other sites





you guys are not gonna believe this....


i was doing some more playing around and i've hit the jackpot...


it is something so insignificant and unrelated it's hard to believe how it could affect such an important thing such as sleep/resume...


ive tested this over and over and it works now every single time, cold boot or not!!!!!!!!!


to get this result, i've simply added a "-v" flag to my "com.apple.boot.plist"


that's it....


now every single time i boot with -v, it sleeps and resumes just fine.....


and every single time i boot without the -v flag, it doesnt wake from sleep...


i have repeatedly tested this and i can confirm that chameleon2 rc3's -v flag was the changing factor for me...


now i dont even need to use the "USBBusFix=Yes" flag...


my boot plist looks like the following now:


<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">





<key>Kernel Flags</key>

<string>-v arch=x86 GraphicsEnabler=Yes</string>







so guys, go ahead and see if the "-v" flag makes a difference for you? and do report back...


thanks for all ur help...



Link to comment
Share on other sites

Didn't fix my problem.


When I put my computer to sleep the display shuts off and the ambient lighting on the keyboard shuts off but the computer fans keep going. When I try to wake it up the ambient lighting on the keyboard comes back on but the display never comes back.

Link to comment
Share on other sites

the computer fans keep going.


that means ur comp doesnt go to sleep fully...


does ur "system profiler" > "usb" show all ur usb ports as "built in"?


if any of ur usb ports are shown as "expansion slot", u might need to patch ur dsdt so that snow thinks ur chipset is ich10. guide here: http://www.insanelymac.com/forum/index.php...amp;pid=1254289


if dsdt patching with uhci/ehci ich10 device ids doesnt do it, something else may be preventing ur comp from sleeping...


also dont forget to use the latest chameleon2 rc3 release... and try to match ur "com.apple.boot.plist" to mine...


OH WAIT.... i just noticed something....


u seem to be running NullCPUPowerManagement.kext...

as far as i know this kext disables power management features...


so in order to get sleep support while using the NullCPUPowerManagement.kext u have to also run another kext called "SleepEnabler.kext"


see if that helps...

Link to comment
Share on other sites

I have the same mobo as you dj nitehawk and this USB issue is driving me crazy. I'm going to try your method out right away.


PS: One more thing, may be off the topic, what kext are you using for ALC888 on DG33FB? I seem to have no luck with VoodooHDA or AppleHDA.

Link to comment
Share on other sites

on dg33fb, i have a fully functional snow leo now... here's what you need...


1. need to patch ur dsdt to pretend ur usb device id's are ich10 ids... (im attaching my patched dsdt.aml so u can just use that)


2. voodoohda needs to be in /system/library/extensions.... didnt work for me from /extra/extensions


3. if cant resume from sleep, u need to use the "-v" boot flag in chameleon 2 rc3 and also try removing/swapping around ur usb mouse/keyboard and remove all other usb devices.


i've written an integrated pre-install script that takes care of all the pre-install woes...


give it a try:



make sure u patch ur dsdt or use mine before running my pre-install script...


if my script doesnt fully work on the first go, try a clean install... ie: fully erase the target disk :-)


note: my script doesnt install any kexts to /S/L/E. so u need to manually add them (sound + lan kexts) to /S/L/E after u boot into your virgin snow...


after adding anything to /S/L/E make sure u do the following in terminal:


1. sudo chown -R root:wheel /system/library/extensions

2. sudo chmod -R 755 /system/library/extensions

3. sudo diskutil repairpermissions /volumes/NAMEOFSNOWVOLUME

4. sudo touch /system/library/extensions


good luck!!!


ps: i was really close to throwing my dg33fb out and getting new gigabyte p45 series mobo when i discovered the -V flag thing...


so dont give up on the 33... if it works for me, it can work for every 33 user :-)


may the hackintosh gods bless us :-) hehehe


Link to comment
Share on other sites

thanks dj nitehawk, I'm on 10.5.8 but I will move to Snow kitty once I am done with a project. I'll definitely try your script and will let you know about the results. Apart from that, my USB issue doesn't seem to correct itself even after the DSDT. I'm using chameleon rc2 with pc_efi 10.2. This problem with my USB devices also makes my system hang on each restart and shutdown when the system is unable to detect them. This may be because the system can't shutdown the USB devices.


The VoodooHDA and PS2 controllers solved my random panics and THANKS FOR THE VOODOOHDA idea. I somehow stumbled upon the following thread:




They have linked a newer version of VoodooHDA that gave me Mic and Line in with HiDef stereo sound.

Link to comment
Share on other sites

so guys, go ahead and see if the "-v" flag makes a difference for you? and do report back...


thanks for all ur help...




thanks for your share, but unfortunately it doesn't work for me. i patched UHCI and EHCI in my DSDT so in the System Profiler it reads USB built in and use -v in boot plist, but my machine still won't wake up from sleep.


whenever i put the machine to sleep, the fans and display switch off. but if i tried to wake it up, it starts to turn on but come back to sleep again. so it's turning on and off indefinitely. i have to switch off the power completely by switching off the back power switch. in my usb there are 1 ext hd, keyboard and mouse + webcam. i still haven't found which one of those things that is causing this problem.


btw, if i use your boot plist, i lose my 1680x1050 resolution (it fixed on 1024x 768) and experienced a bad freezes in mouse movement. maybe because i'm not using EFI strings for my graphic cards?

Link to comment
Share on other sites



y dont u try removing your usb devices one by one and put the machine to sleep?


i think ur usb webcam might be the problem... not sure... try a process of elimination...


when u have ur mouse unplugged, u can put ur machine to sleep with the following terminal commands.


1. pmset sleepnow

2. shutdown -s now



or if ur power button works for sleep, can try removing ur keyboard too :-)

Link to comment
Share on other sites

y dont u try removing your usb devices one by one and put the machine to sleep?


i tried those things...removing my usb device one by one, and removing NullCPUPowerManagement from Extra, but the result is still the same.

now i'm as sleepless as my machine... :(


btw, what hibernate mode that you're using now?

my hibernate mode default is 0, but i tried hibernate mode 3 and it still doesn't work.

Link to comment
Share on other sites

  • 3 weeks later...


I got my sleep working using your patched dsdt..thanks so much

my problem now is my onboard ethernet, it is working fine using sleepwatcher but the problem is ethernet only wakes the first time i wake my computer. After the first sleep and wake ethernet is unusable. Can you help me with this?


Also, if i buy a usb to ethernet adapter, will it work fine after sleep?




Snow Leopard 10.6.1

Intel DG33FB

Core 2 Duo


Nvidia 8500GT 512MB

Link to comment
Share on other sites

I have been trying hard to correct my dsdt.dsl, but to no avail. I have already spent useless hours and could really need some help with this. If somebody kind could look at my dsdt and correct it I would be forever grateful. I would even be willing to contribute something back.


The dsdt.dsl for my Toshiba Satellite P100 is attached.


Hoping .. ,



PS: My USB devices do not mount at all now all mount in SnowLeo. In Leo I have been using the EHCI mods from orByte, Slice or AnV. In Snow Leo I just tried the entire IOUSBFamily.kexts instead of adding the EHCI sub kexts modded for Leo to the Snow IOUSBF., and it works 100% :(



Link to comment
Share on other sites



i have same mobo as you have - but sleep is not working right. I took your DSDT - file and use it for my Hack.


i removed all usb - devices and set sleep to 1 minute. Displays go off, but fan is still on. After 5 mins it wrote something to HD, but thats all. Fan for processor is still on !


I have a PCIe - card for USB too, it's in but no devices attached to it just now. It was needed earlier for DVB that did not work correctly from USB's that were on board.


After 7 mins something went down, my guess is HD -- you could hear it stopping.


after 10 mins i plugged my Wireless Logitech keyb/mouse back (keyb is usb, mouse ps2) and it woke up ok.


Any advice ?


Other thing; as we have same mobo - what kind of keyb/mouse you use ? I have a Apple USB keyb/mouse, but i cant go to BIOS (f2 at startup) with it, need this other keyb (has also a usb for keyb?) to use F2 at start up. I cant also use arrowkeys at Chameleon screen with Apple keyboard.


Now it went back to sleep, even when keyboard / mouse was on. But processor fan is still on !!!!








EDIT : tested "shutdown -s now" and it works correctly !!!! everything shuts down and it wakes up when i push any key .... ???


I removed NullCPU***kext from /Extra


But still it wont use sleep settings from Systemsettings ... when sleep comes, processor fan is full on.

Link to comment
Share on other sites

you're talking to me? I don't have a "mobo", I have a Laptop. Did not see in your sig that you have a Toshiba Satellite so guess you're talking to s.b. else ..



yeah, sorry ... Dj has same motherboard aka MoBo as I.



Link to comment
Share on other sites

@ dj nitehawk: do you manually boot Chameleon verbose to get proper wake-up from sleep? Because here, despite of the -v flag, I get the grey screen with the Apple logo on boot-up.


So you use Chameleon rc3 and not PC_EFI 10.3, based on Cham. 2rc3?

Link to comment
Share on other sites


  • Create New...