Jump to content

Marvell Yukon 8001 - the driver

409 posts in this topic

Recommended Posts

As much as I hate to ask for help...(usually the answer is staring at me in the face)...I can't get this driver to work with my DGE-530T.


I've followed both sets of instructions in this entire thread:


1.) I edited the info.plist with the DGE-530T deviceID (0x4C001186)

2.) Opened the terminal and typed...

3.) sudo -s (password)

4.) cp -R (location of skge.kext to be copied) /System/Library/Extensions/

5.) rm -R /System/Library/Extensions.kextcache

6.) rm -R /System/Library/Extensions.mkext


I rebooted and nothing. I checked the Network area. It's blank.


The second set of instructions:

1.) Copy skge.kext in to the /System/Library/Extensions/

2.) Open Terminal

3.) Entered these command lines:

4.) sudo chown -R root:wheel /System/Library/Extensions/skge.kext

5.) sudo chmod -R 755 /System/Library/Extensions/skge.kext

6.) sudo rm /System/Library/Extensions.mkext

7.) sudo rm /System/Library/Extensions.kextcache


Still nothing.


Am I missing something?



EDIT: Like I mentioned above ...I figured it out.


I was doing everything perfectly correct, BUT my device ID was different than the one in this thread.


To anyone trying to use a DGE-530T, check the card itself. There should be a revision number written on the top of the card as "REV-B1" (which is mine). That letter and number should replace the ones in this thread's device ID.

Example: 0x4C001186 changed to 0x4B011186.


It's nice to have the network up and running. All thanks to m.musashi!

  • 3 weeks later...


Just for the record: DFI LANParty UT NF4 Ultra-D (dunno which Marvell Yukon ver, but probably 88E8001 too)





Need your HELP in my DFI nF4-Ultra D don`t work,, i have installed MAC OS x 10.4.7 JAS Iso REpack, and the installer: Marvell.Gigabit.pkg freeze and can`t install it..


Sorry for my English im from Spain...

hi guys, i recently updated my 10.4.5 with internet (skge 0.2d) to 10.4.8 using JaS's 10.4.8 amd sse3 updater


my rig has an amd x2 4400+ (s939)


i tried to reinstall the skge 0.2d, but to no avail



when i check the network area, everything shows up like it did before, but internet in firefox or safari wont work.

I can get this working, however I also get A TON of "family specific matching fails" messages on virtually everything there is to get it on...


P0P4, ethernet, IDE0, USB1, USB2, USB3, USB4, EUSB, SBRG, P0P1, aci8086... then the nVidial HAL loads and I get a bunch more family specific matching failures.


However, the system does boot normally and everything seems to work... so, is this normal and if so, is there any way to disable it?



I dont think it works on 10.4.8 OSX Semthex Kernel

Its not working for me

Download and install XCode from Apple's website:



Download the source code from the first post on this thread, extract it and then open "skge.xcodeproj" to load the project.


When you run XCode for the first time just accept all the default values when it asks about configuration inforation.


Once the project is loaded change the dropdown at the top to "Release" from "Debug" then click the Build button.


I get two warnings about a struct being defined but never used, since they are warnings and not errors it does not seem to affect the extension in any way.


Once compiled you will find your new kernel extension at ./build/Release/skge.kext, copy that into the /System/Library/Extensions folder, set permissions, delete the cache files and reboot.


This worked for me, though the compiled version also worked for me on 10.4.8 with Semthex kernel... you may need to set your Vendor and Device ID's to make it work with your particular card. I know I did for my 3Com on an Asus P4P800.

i try to unzip it and then use the terminal and there is a msg like that

cp:illegal option -- /

usage: cp [-R [-H | -L | -P]] [-f | -i | -n] [-pv] src target

cp [-R [-H | -L | -P]] [-f | -i | -n] [-pv] src1 ...srcN directory



what should i do i have no idea at all thz

I have a DFI Lanparty NF4 with Marvell Yukon 8001 and now running semthex last kernel, works like charm with this driver :D


All I did was just installed a older version of IONetworkFamily.kext, like in this thread (http://forum.insanelymac.com/index.php?showtopic=33261&hl=marvell)


I don't know if this was relly needed, but I heard you guys complining about this driver not working under semthex kernel, so maby this could be a solution :)

i have the 88E8055 - could this work with this driver as well??

how do i install drivers under mac os x - i am a newbie to "hackintosh" ;-)

by the way:

which one is the better kernel - semthex or mifki kernel??

pls tell me

(private message also possible if this does not fit into this thread ^^)

thanks a lot

  • Create New...