Jump to content
AlainTox714

Intel HDA Audio Codec STAC9227 for DQ965xx, DP965LT, DQ963FX, D946GZxx Intel Board sound working (Mic,Headphone).

53 posts in this topic

Recommended Posts

UPDATE: v3 release

 

I guess the Layout is not the best for this Codec so i swap to LayoutID 2 and PathMapID 1

for v3 release.

 

IMPORTANT:

 

REMOVE the old HDAEnabler.kext and use the new one.

 

the new one use a different Layout.

 

STAC9227.v3.zip

 

UPDATE: v2 release

 

v2 Will normaly display correct labels in Audio System Preferences and in Audio System Profiler.

 

STAC9227.v2.zip

 

STAC9227 codec is used by:

 

- DQ965GF

- DQ965CO

- DG965MS

- DG965SS

- DP965LT

- DQ963FX

- D946GZAB

- D946GZTS

- D946GZIS

 

Intel Motherboards and should works with its.

 

What i will try to get is a fully working codec:

 

- Selection between Outputs: Headphone (front) and Line Out (rear).

- Selection between Inputs: Microphone and Line In.

- Mute button.

- Complete report in Audio System Profiler.

 

Currently you will have erroneous label in Audio System Preferences, but selection is working*.

Only a very concise report* in Audio System Profiler (3 lines).

Normally you will have Microphone, Line In and Headphones working*.

 

* Tested by wayover, thanks to him.

 

Check if you are using another AUDIO injector like EFI strings or ALCinject and remove it otherwise it will not works.

If you are using HDAEnabler.kext REMOVE IT and use the new one (different LayoutID).

AppleHDA.kext version is 1.2.4a21 from 10.4.9 and MUST stay in S/L/E otherwise it won't works.

 

If someone like to try here is the first release for test:

STAC9227.v1_toTest.zip

 

Please report as i didn't own any of these mobos,i can't obviously test it.

Share this post


Link to post
Share on other sites
Advertisement

I wonder if this will work from my Custom Desktop 945GMX board (details in sig) and HP laptop For Internal MIC .

Share this post


Link to post
Share on other sites
I wonder if this will work from my Custom Desktop 945GMX board (details in sig) and HP laptop For Internal MIC .

 

 

Sorry definitely not, 945GMX board use Realtek ALC888 audio codec.

Share this post


Link to post
Share on other sites
How to me to connect the headphones, what contacts need to be used for connection? thankful in advance

 

I am talking about the first pick (yellow one)

 

[5] = Headphone Right.

[7] = ground shield common left and right.

[9] = Headphone Left.

 

for the second pick don't know as i have never use it.

 

here is what the doc says:

 

Connecting to the HD Audio Link Header

 

See Figure 22, A for the location of the HD Audio Link header.

Table 9 shows the pin

 

assignments for the header.

 

Table 11. HD Audio Link Header Signal Names

Pin Signal Name Pin Signal Name

1 BLCK 2 Ground

3 RST 4 3.3V/1.5V I/O

5 SYNC 6 Ground

7 SDO 8 3.3V_CORE

9 SDI 10 +12V

11 No connection 12 Key (no pin)

13 No connection 14 3.3V/1.5V STBY

15 No connection 16 Ground

 

 

Hope this help.

Share this post


Link to post
Share on other sites
I am talking about the first pick (yellow one)

 

[5] = Headphone Right.

[7] = ground shield common left and right.

[9] = Headphone Left.

 

for the second pick don't know as i have never use it.

 

here is what the doc says:

 

Connecting to the HD Audio Link Header

 

See Figure 22, A for the location of the HD Audio Link header.

Table 9 shows the pin

 

assignments for the header.

 

Table 11. HD Audio Link Header Signal Names

Pin Signal Name Pin Signal Name

1 BLCK 2 Ground

3 RST 4 3.3V/1.5V I/O

5 SYNC 6 Ground

7 SDO 8 3.3V_CORE

9 SDI 10 +12V

11 No connection 12 Key (no pin)

13 No connection 14 3.3V/1.5V STBY

15 No connection 16 Ground

 

 

Hope this help.

i will try later, quality of a sound will be different?

Share this post


Link to post
Share on other sites

Subjectively, it became better sound, has varied positions of a toddler of loudness in the big side. Mute button, mic, line-in work! HDAEnabler work too, now shows in system profiler headphone, mic and linein connection.

In system options on Input tab when the cursor is on LineInput (InternalSpeakers?), it is visually visible that passes a signal from a microphone if to speak. On record it is not audible..

post-239576-1226336930_thumb.png

post-239576-1226336973_thumb.png

post-239576-1226336984_thumb.png

post-239576-1226336990_thumb.png

Share this post


Link to post
Share on other sites
There is a question on frequency. Whether really it works with frequency 96kHz 24 bit output?

 

I guess so, but can test as i don't use and have any Midi device.

 

Here are the pic's of my BadAxe2:

 

post-26592-1226352645_thumb.pngpost-26592-1226352661_thumb.png

 

On both pic's Input and Output 96Khz 24 bits are available.

Share this post


Link to post
Share on other sites
UPDATE: v3 release

 

I guess the Layout is not the best for this Codec so i swap to LayoutID 2 and PathMapID 1

for v3 release.

 

IMPORTANT:

 

REMOVE the old HDAEnabler.kext and use the new one.

 

the new one use a different Layout.

 

Attached File STAC9227.v3.zip ( 288.19K ) Number of downloads: 9

v3 doesn't work for me

Share this post


Link to post
Share on other sites

im try in leo and tiger, in system pref no input/output devices. System profiler also zero connections, but in logs:

localhost kernel[0]: HDAEnabler: Copyright (c) 2008 by Kabyl
localhost kernel[0]: HDAEnabler: Added SPAudio support LayoutID:2

kexstat:

69	0 0x3f7d6000 0x4b000	0x4a000	com.apple.driver.AppleHDA (1.2.4a21) <67 63 5 4 3 2>

Share this post


Link to post
Share on other sites
im try in leo and tiger, in system pref no input/output devices. System profiler also zero connections, but in logs:

localhost kernel[0]: HDAEnabler: Copyright (c) 2008 by Kabyl
localhost kernel[0]: HDAEnabler: Added SPAudio support LayoutID:2

kexstat:

69	0 0x3f7d6000 0x4b000	0x4a000	com.apple.driver.AppleHDA (1.2.4a21) <67 63 5 4 3 2>

 

OK thanks, will try to figure out where i did a mistake!

Share this post


Link to post
Share on other sites

Not sure what I'm doing wrong here so i figured I'd post... I'm building out a new quad core with a a DQ965GF motherboard... The only thing that I seem to be lacking is the sound..

 

So, I got v3, used Kext Helper B7, did both KEXT's at the same time in there, rebooted... now in "about this mac" under audio, it says Device ID 0x80862008 audio id: 4 and then Availible devices, it has nothing.

 

On my other hackintoshs, my normal sound test is to change the volume and listed for the beep... I am not getting any sound from any ports on this unit.

 

So, I also tried v2, installed both KEXT files with KEXT helper, still a no go after reboot.

 

am I missing something obvious? with all my other hackintoshes, the audio just happened to work, so this wasn't a big issue... Any help you guys can give is mucho appreciated.

 

btw, using a brand new install of itakos 4.1i 10.5.4.

Share this post


Link to post
Share on other sites
Not sure what I'm doing wrong here so i figured I'd post... I'm building out a new quad core with a a DQ965GF motherboard... The only thing that I seem to be lacking is the sound..

 

So, I got v3, used Kext Helper B7, did both KEXT's at the same time in there, rebooted... now in "about this mac" under audio, it says Device ID 0x80862008 audio id: 4 and then Availible devices, it has nothing.

 

On my other hackintoshs, my normal sound test is to change the volume and listed for the beep... I am not getting any sound from any ports on this unit.

 

So, I also tried v2, installed both KEXT files with KEXT helper, still a no go after reboot.

 

am I missing something obvious? with all my other hackintoshes, the audio just happened to work, so this wasn't a big issue... Any help you guys can give is mucho appreciated.

 

btw, using a brand new install of itakos 4.1i 10.5.4.

 

Check if you are using another AUDIO injector like EFI strings or ALCinject and remove it otherwise it will not works.

Go with v2 forgot v3 it's not working.

Share this post


Link to post
Share on other sites

Hi everyone,

 

I like to go further and have a working 10.5.x AppleHDA.kext working but i need some help.

 

I am looking for ioreg dump of MacBook pro 1st generation and 2sd generation with Sigmatel STAC9221 Codec.

 

I mean a full dump with in terminal:

 

ioreg -lw0 > ~/Desktop/MacbookXXX.txt

 

If someone can get this i will be very grateful to him.

Share this post


Link to post
Share on other sites

Thanks but my sound dont work i use 3 zip files but no one run correctly

 

 

UPDATE: v3 release

 

I guess the Layout is not the best for this Codec so i swap to LayoutID 2 and PathMapID 1

for v3 release.

 

IMPORTANT:

 

REMOVE the old HDAEnabler.kext and use the new one.

 

the new one use a different Layout.

 

STAC9227.v3.zip

 

UPDATE: v2 release

 

v2 Will normaly display correct labels in Audio System Preferences and in Audio System Profiler.

 

STAC9227.v2.zip

 

STAC9227 codec is used by:

 

- DQ965GF

- DQ965CO

- DG965MS

- DG965SS

- DP965LT

- DQ963FX

- D946GZAB

- D946GZTS

- D946GZIS

 

Intel Motherboards and should works with its.

 

What i will try to get is a fully working codec:

 

- Selection between Outputs: Headphone (front) and Line Out (rear).

- Selection between Inputs: Microphone and Line In.

- Mute button.

- Complete report in Audio System Profiler.

 

Currently you will have erroneous label in Audio System Preferences, but selection is working*.

Only a very concise report* in Audio System Profiler (3 lines).

Normally you will have Microphone, Line In and Headphones working*.

 

* Tested by wayover, thanks to him.

 

Check if you are using another AUDIO injector like EFI strings or ALCinject and remove it otherwise it will not works.

If you are using HDAEnabler.kext REMOVE IT and use the new one (different LayoutID).

AppleHDA.kext version is 1.2.4a21 from 10.4.9 and MUST stay in S/L/E otherwise it won't works.

 

If someone like to try here is the first release for test:

STAC9227.v1_toTest.zip

 

Please report as i didn't own any of these mobos,i can't obviously test it.

Share this post


Link to post
Share on other sites

 

 

Thank's for trying, i already look around in forum and on the net and didn't find anything, what i am looking for is MacBook2,1, macbook3,1 din't use sigmatel. So if you have a friend which own a macbook which fit that should be OK.

 

Thanks but my sound dont work i use 3 zip files but no one run correctly

 

 

More info please what mobo what OSX revision and so on, i am in the dark and can't help, read the forum i often ask different reports and see which one you could provide.

Share this post


Link to post
Share on other sites
Thank's for trying, i already look around in forum and on the net and didn't find anything, what i am looking for is MacBook2,1, macbook3,1 din't use sigmatel. So if you have a friend which own a macbook which fit that should be OK.

sorry, i see "AppleHDAWidgetSTAC9220" strings in body, incorrect way..

MA609LL, MA610LL, MA611LL in them this codec is established?

Share this post


Link to post
Share on other sites
sorry, i see "AppleHDAWidgetSTAC9220" strings in body, incorrect way..

MA609LL, MA610LL, MA611LL in them this codec is established?

 

Thank's for helping.

 

notice that AppleHDAWidgetSTAC9220 is 0

 

"AppleHDAWidgetSTAC9220"=0

 

if you look further:

 

+-o IOHDACodecDevice@0 <class IOHDACodecDevice, registered, matched, active, busy 0, retain 6>

| | | | {

| | | | "IOHDACodecVendorID" = 283904133

| | | | "IOHDACodecRevisionID" = 1048835

 

IOHDACodecVendorID is 283904133 and that is Realtek Codec.

 

What we are looking for is (STAC9220):

 

decimal

-2088470912

2206496384

hex

0x83847680

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×