Jump to content

[HOWTO] Boot Macs with Intel Chipset in AHCI Win7 Vista XP Linux


423 posts in this topic

Recommended Posts

As a footnote to my MBP 2011 AHCI mod, I did a bit of testing with the RST driver.


Using the newest bootcamp 5.1 software Intel RST drivers 11.2 and below the windows bootcamp control panel is still broken with the usual startup disk error, however if your chipset supports 11.7 and above hey presto the windows control panel works.


I know that means the panel is still broken for Mac Pro 3,1 users as is the newest driver supported, though can't confirm which is the newest on the 4/5,1 towers, until I get my 5,1 my clients for all are on the 1008 driver which doesn't suffer from the 3tb formatting bug and don't think would appreciate me asking to test on cheesegraters doing constant work.


The RST driver sets are here:




Update via Device manager, update driver, choose the path of the extracted driver. If supported it will update. The driver only is fine, the driver plus RST app requires .net, is slow to start and a waste of resources on startup. You'll need a 2nd restart after it loads the new driver for your boot drive.

Link to comment
Share on other sites

  • 2 months later...

Hi, i'm Italian, sorry for my english.

I have a 27" iMac 10,1 late 2009. I have installed a samsung 840 evo 250 GB instead superdrive.

I have 1TB mac original 7200 rpm hard drive and the sad instead superdrive. I have 2 partitions in SSD one with mavericks and the other with windows 8.1. 

Can i enable AHCI mode? What is the correct procedure? Exist a program? Thanks 

Edited by fantomas1
Link to comment
Share on other sites

  • 1 month later...



i added a Samsung 840 EVO 250GB SSD to my Mac Mini mid 2011 and Windows 8.1 Pro.

Got it working with the original patchedcode.bin and the following steps:


Process I used:
1. Checked the registry that
    HKLM/System/Current Control Set/Services/storahci -> Start = 0
    HKLM/System/Current Control Set/Services/iaStorV -> Start = 0

    Also in both keys /StartOverride -> 0 = 0

3. Reboot into the OS X setup disk, open the Terminal utility
4. unmount all volumes on my SSD

    "diskutil umount /dev/disk0"

5. Backed up old MBR

    "dd if=/dev/disk0 of=backup.bin bs=512 count=1"
5. Overwrite the MBR with

    "dd if=patchedcode.bin of=/dev/disk0 bs=440 count=1"


Also i did not have to install any SATA drivers.

Just wanted to share this because the first post mentioned that it would not work with the aluminium minis.


EDIT: Using the Intel RST driver nearly doubled the IOPS.

EDIT: Sleep doesn't work, second drive (HDD for me) works.

Link to comment
Share on other sites

  • 3 months later...

To all of you in that forum:


I like to say thank you!!


I have a Mac Pro 3.1 (early 2008) with a Samsung SSD 840 EVO in two boot partitions: one for OS Mountain Lion, one for Windows 7 Pro.

Your AHCI enabler worked perfectly and Win 7 bootcamp is running better and faster than before!




  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Hello! I need a little help here. I have a Macbook Pro 5,1 mid 2009, with the nVidia MCP79 chipset and i would like to enable the AHCI support on it, but im not really sure the steps i should follow in order to get it enabled. Can some help me making a step by step instructions on how to do it? I would really appreciate it.


I have read a lot of stuff and most of this thread, but im kind of confused. Saw the info on the first post about making it work on MCP79 chipset, but im not really sure what to do with it.

Link to comment
Share on other sites

  • 1 month later...

I modified the AHCI code in the script by johnsock and ludacrisvp to modify the reportedly necessary register for the nVidia MCP79 (9C=60h). I tested it on a Mac 10,1 and it sets the register as expected. This was verified under Win7 with pcitools.


However, I could not seem to get the AHCI working as the performance was unchanged. I tried the "standard AHCI 1.0 compatible controller" driver included in windows, as well as the nVidia nForce WHQL driver and even a Dell laptop driver just in case (each with the reg set/unset). The windows driver is stable, but the nForce drivers nope out to BSOD on boot.


If anyone knows of other registers or drivers that should be used please let me know.


I can't find how to attach the script so here is the necessary AHCI_CODE for now:

old AHCI_CODE=66B890FA0080BAF80C66EFB060BAFC0CEEC3              
                  9C580080            06
new AHCI_CODE=66B89C580080BAF80C66EFB006BAFC0CEEC3

Note, this AHCI code only works for the following configuration, which is on iMac 10,1:

bus number = 0
dvc number = 0B
fnc number = 0
reg number = 9C

Edited by cjm
Link to comment
Share on other sites

  • 1 month later...

As the forum seems to have suffered from some massive data loss I'm re-uploading the AHCI Enabler application.

If that code works I've added it to this version of AHCI Enabler.

I've also added definitions for various MCP79 chipsets so hopefully it will be able to patch those systems. As I don't have one of these computers this is a complete guess and may not work at all.


Please test it out and let me know.


AHCI Enabler - Beta MCP79.dmg.zip

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Unfortunately the Beta MCP79 AHCI Enabler did not work for me. I have a Macbook Pro5,1 running OS X Mavericks. The Enabler detected my chipset as MCP79 but said it was an unsupported chipset.

Link to comment
Share on other sites

  • 2 weeks later...

Hi, I have a Mac Pro3,1 running 10.10.3. I have a 250GB Samsung EVO 850 which has a split partition for OS X / Windows 7 Ultimate 64-bit.


I have followed the instructions found here (which seem to be mostly identical to the instructions on the first page of this thread.)


The Microsoft AHCI drivers were installed. However I could not proceed and install the Intel RST drivers -- the latest, and oldest version give me an error saying my platform (or computer requirements, in the case of the later) is not supported. I found the newest Intel Matrix Storage Manager driver and installed that correctly.


I'm getting 280MBps read/write and 50k/45k random Read/Write in Samsung's Magician software with MSM. (vs 35/30k with Microsoft's AHCI, vs 9/15k with IDE.)


Is there any way for me to update to the RST drivers? (I tried "automatically find drivers" in Intel's Driver Update Utility with no success, as well as installing RST after MSM.) Or should I just be content with the MSM drivers?

Link to comment
Share on other sites

Unfortunately the Beta MCP79 AHCI Enabler did not work for me. I have a Macbook Pro5,1 running OS X Mavericks. The Enabler detected my chipset as MCP79 but said it was an unsupported chipset.


There is a small bug in "Beta MCP79 AHCI Enabler", here is how to fix it to avoid the "unsupported chipset" error :


Edit the file "ahci.plist" that can be found in the folder "AHCI Enabler.app/Contents/Resources".

There you can see the Key "SupportedChipsets", remove every "0" before "abXX" for the MCP79 Chipsets.


This should look like this after modification :


pci10de,ab9		String		MCP79
pci10de,ab4		String		MCP79
pci10de,ab8		String		MCP79
pci10de,ab5		String		MCP79
pci10de,abc		String		MCP79
pci10de,abd		String		MCP79

Now the application will recognize the chipset and allows you to do the modification.




I can confirm that this tool can be used to successfully activate AHCI on Windows 7 with an MCP79 chipset.

FYI, I have an iMac 9,1 (MCP79 and SATA2) with Mavericks and Windows 7 64bits installed on a Samsung SSD 850 EVO 250gb


As you can see "06" has been successfully set on the 9C address when Windows is launched :

00:0b.0 SATA controller: NVIDIA Corporation MCP79 SATA Controller (rev b1)
00: de 10 b5 0a 07 00 b0 00 b1 85 06 01 00 00 00 00
10: d9 21 00 00 ed 21 00 00 d1 21 00 00 e9 21 00 00
20: c1 21 00 00 00 40 58 d3 00 00 00 00 de 10 79 cb
30: 00 00 00 00 44 00 00 00 00 00 00 00 15 01 03 01
40: de 10 79 cb 01 8c 02 00 00 00 00 00 00 00 00 00
50: 0f 68 78 60 00 00 00 00 00 00 00 00 00 00 00 00
60: 00 00 85 00 c0 8c 00 0f 01 0f 06 42 00 00 ff 8f
70: 2c 78 c4 40 01 10 00 00 02 10 01 08 34 00 20 19
80: 0f 00 c0 00 7c fc ff df 00 00 19 00 12 b0 10 00
90: 5f 02 00 00 00 00 00 00 05 ff 22 e6 06 01 00 00
a0: 6e 5a 00 62 00 00 00 00 00 00 00 00 63 31 00 02
b0: 05 00 86 00 00 00 00 00 00 00 00 00 00 00 00 00
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
d0: 00 00 00 00 0a 00 00 00 08 00 40 00 0a 00 00 00
e0: 00 08 28 ee 00 00 3f 00 fc 00 00 00 08 00 02 a8
f0: 00 00 00 00 00 00 00 00 00 c0 9e 50 00 00 00 00

And while I can't install any Nvidia drivers and have to use the Windows AHCI default driver, I do have exactly the same benchmark results under Windows and Mac OSX now !!!


Thanks a lot ludacrisvp for this wonderful tool !


Talking about drivers I noticed that all Nvidia MCP79 AHCI drivers for Windows are looking for this device id : 10de:0ab9 but my device id under Windows is 10de:0ab5 and there are no existing drivers for this device.

Even more strange, under OS X, when I run lspci, the SATA controller does have the good id : 10de:0ab9, but it changes to 10de:0ab5 when booting under Windows... I don't know if this is normal or not, I'm not an expert at those things.

Link to comment
Share on other sites

  • 1 month later...

I got AHCI working successfully on my iMac 2011 with Windows 7 x64 and Windows 8.1 x64 in Bootcamp (without efi) as described here.

My system is also suffering from the problem that it can not resume from SLEEP properly when ahci is turned on.

This has been painted out here before and some manuals even ask you to turn sleep-mode off as a workaround. Of course that's not my preferred solution.

As some of you have explained and it can be read here the root cause is that after a wakeup from sleep a standard-sata-controller and not the required ahci-sata-controller are provided by the mac.

Under Linux there seems to be a fix for this issue but there must be a way to solve this for windows too.

Did anyone have success using another patch, a loader like refind or a patched sata-driver?
I still hope that we can get SLEEP & AHCI working well together.

Link to comment
Share on other sites

  • 3 weeks later...

I have to say thank you all for this !


I've spent all the afternoon trying to get my SSD working correctly and finally, i get it !


Thanks to ludacrisvp and his  AHCI Enabler - Beta MCP79.dmg (just followed the instructions in the PDF file that comes with it)

Thanks to DisizDream and his fix to avoid the "unsupported chipset" error


For the records : 

I have a 13'' MacBook Pro 5.5 (late 2009 i think) with NVidia MCP79 chipset and just change the stock HDD for a Samsung SSD 850 EVO 500GB

The SSD was detected as a 3Gb drive under OSX 10.6.8 and as a IDE drive under win 7 pro x64


Samsung Magician benchmarks:

before -> seq read: 188 | seq write: 195 | rand read:   8126 | rand write: 15037

after   -> seq read: 284 | seq write: 208 | rand read: 47453 | rand write: 40729


I'm using the Standard SATA AHCI1.0 controller for now, as i don't know if i can get a better one.

But still, i now have my SSD working at the best my MBP can use it (so i think)


thanks again !

Link to comment
Share on other sites

  • 1 month later...

Has anyone tried "AHCI Enabler - MCP79" with Windows 10 ? Does it work ?


Thanks !


Not that I can figure out. I tried two different methods. Both failed.

My setup:

MacBookPro5,1 (Late-2008, 2.93GHz, 8GB) Yosemite with Samsung 500GB EVO SSD


BEFORE INSTALLING WINDOWS 10 (Boot Camp Drivers NOT installed, clean copy)

1. Installed Windows 8 Pro  (No changes to the registry were necessary as the only listed entry was IastorV and it was set to 0.

2. Booted back to OSX (Yosemite) and ran the AHCI Enabler (MCP79 for Nvidia).

3. Returned to Windows 8. No new devices were detected so I manually changed the IDE driver to the Microsoft Standard AHCI Driver (Rebooted).

4. I then installed Samsung Magician (850 EVO) which didn't throw the "AHCI" warning. Also trim was running and set to "0" So AHCI was functioning (or at least emulating) From what I could see, everything functioned well enough.

5. I then tried to upgrade to Windows 10. On boot, It went straight to the Repair screen and gave me the choice to run various repair methods, revert previous installation, or reboot.

6. On next boot, It threw me back to Windows 8 with a failed upgrade "BOOT" error.


I assumed because Windows 8 was installed in IDE mode, that when the drivers switched to AHCI, Windows 10 installer crapped out. So I attempted to do a clean install of Windows 8 after running AHCI Enabler, hoping the install would go through in AHCI mode. A clean install (non-formatting, just install over same partition) wipes the MBR changes the enabler makes.



I ran the AHCI Enabler (MCP79) After upgrading to Windows 10. This method won't send you to a repair screen, rather it will BSOD to INACCESSIBLE_BOOT_DEVICE.


I think the only option at this point is to use GRUB or possibly rEFIt / rEFInd boot selectors that allow you to set AHCI parameters (e.g. setpci). Only if I knew what these parameters are for the Late-2008 (Unibody). Same as Early-2009?

The SSD and "trying" to enable AHCI is the last hurrah for this fellow, I hope I can get it working...

Link to comment
Share on other sites

  • 3 weeks later...

I'm using a 2011 iMac 27" to run Windows7 x64 bootcamp. I have done the registry tweaks (although the key iAstor is not available, but iAstor is--I think it's because Intel RST drivers are not installed yet).


Anyways whenever I patch the MBR using the patchedcode.bin from Gav Mack nothing happens. It boots back into Windows without changing the SATA driver to AHCI. The device manager still displays the same sata controller, and the Samsung Magician software says AHCI is not enabled.

I have tried all of the different MBR patches on the internet. AHCI Enabler.dmg says "chipset not supported". Here is the chipset I am running:
Intel® 6 Series/C200 Series Chipset Family 4 port Serial ATA Storage Controller - 1C00
Even when I boot using an Ubuntu LiveCD I have tried all of the setpci commands and lspci never shows the controller switching into AHCI mode. It always stays in IDE mode.
When I boot using EFI only Ubuntu it shows the sata controller in AHCI mode however, but I can't install Windows7 X64 in EFI mode because I believe this iMac has a EFI 1.x firmware which isn't supported by Windows 7 x64.
I have also tried updating the driver to a SATA AHCI driver, then applying the MBR patch but it still does not work. Anyone have any suggestions or fixes? Thanks so much!


Link to comment
Share on other sites

  • 2 months later...

I have a MacBook Pro 3,1 running El Capitan on a Kingston HyperX SSD. I've been running into some issues with the SSD, and I'm hoping that the new firmware Kingston put out might be able to fix it. However, I can't update the firmware without AHCI. I am running Windows XP in Bootcamp. 


The chipset is ICH8-M. After studying this entire thread and looking online for days, I've been able to (I think?) enable AHCI using the steps here and the AHCI Enabler. I want to give a huge thanks to ludacrisvp, johnsocks and whoever else has put in their efforts into this :)


The problem I'm running into: I don't even know if AHCI is successfully activated, even though the SATA chipset driver in Device Manager has changed (I had to change this by force, and I did not have any existing registry keys to change). I was running into problems with BSOD's in XP after running the AHCI Enabler from another partition (Snow Leopard), until I booted back into my El Capitan partition, disabled Paragon NTFS, and tried it from there. It worked without a BSOD! 


The reason I don't know for certain if AHCI is properly enabled is that when I run Kingston's firmware updater, I get the same error that I got before enabling AHCI. It's confusing to me. I've looked up the error as well (I will rerun the firmware update and post an attachment so you know what I'm talking about) and I cannot find anything on it, and I have a feeling that Kingston will not support me on this.


How can I tell for sure if AHCI is enabled? Also, does anybody know what this firmware update error means?


I am very frustrated as I've spent so much time trying to get this to work... I am using this very old thread to hopefully garner a response from one of you brave souls  :) Any help would be appreciated. 

Link to comment
Share on other sites

  • 4 months later...
  • 3 months later...

hi all,


i'm running a mbp early 2011 upgraded to two ssd-s, osx on one, and windows 10 (mbr install) on the other.

(do note, that i did previously have an efi win 10 install on it, which used ahci "out of the box", but the dedicated graphics didn't work, so i reinstalled in mbr/legacy mode) 


i'd like to enable ahci in win 10.

tried running the app from osx (el capitan), but i can only select the "system reserved" partition (disk0s1), bootcamp (disk0s2) is not in the dropdown list, and even with that one selected, the modify button is grayed out.

i'd have no problems using scripts or the command line, but can't dig up the ahci.sh script (or a patchcode that would match my system). 


please advise! thanks in advance.

Link to comment
Share on other sites

  • 1 month later...

Hi all! Sorry for my english, it's not my native language.

Could you help me a little, please.
I have Macbook Pro late 2011 /Intel 6 series chipset/.
 I installed Windows 7 x64 on SSD /Crucial MX200 500Gb/, 
and OS X El Capitan is on the same SSD. 
Windows 7 running in IDE mode. 
Please, write me short instruction, what should i do for get AHCI mode.
 Step by step... understand english is difficult for me :)
P. S. AHCI enabler says "Unsupported chipset"   /Intel 6 series chipset/
i have black screen and blinking I_, that's all.
In the terminal a see "not mounted". How can i mount it back?
Thank you very very much for any help
Link to comment
Share on other sites

  • 2 years later...

Hi everybody, although it´s a very old topic I hope for an answer.

As posted here, the AHCI_enabler.dmg seems to work even for old MacBook Pros with Nvidia Nforce Chipset. Unfortunately it´s the wrong driver for me, as I own a MacBook Pro 2010 (Model 7,1) which was shipped with the MCP89 (instead of MCP79) sata chip. So it says "wrong chipset" while running it.

Would it be difficult to write this dmg again with the MCP89 driver? As I´m not so much a programmer, I wonder if I could ever handle this.

I really tried a lot of things to get the AHCI mode running, but had no luck.


Hoping for an answer, greetz Oli

Link to comment
Share on other sites


  • Create New...