Jump to content

[Guide] Asus P5Q-EM


17 posts in this topic

Recommended Posts

Asus new m-atx board the P5Q-EM is a great choice for Leopard since

almost everything works except the integrated GFX and Marvel PATA controller.


But you will have to flash your bios with the one provided below because of

the DSDT in the original bios won't let you boot OSX.





Model: P5Q-EM

Chipset: Intel G45/ICH10R

Memory: DDR2 1066/800/667/533MHz

FSB: 1333/1066/800MHz

VGA: Intel Graphics Media Accelerator X4500 integrated - Not supported.

Audio: Realtek 1200 - Supported with Tarugas HDAenabler

LAN: Realtek 8111C Lan - Suported

IEEE 1394: Agere L-FW3227 2 x IEEE 1394 - Supported

USB: 12 x USB 2.0 ports - Supported

EXP Slot: 1x PCI-E x16 v2 l 2x PCI-E x1 l 1 PCI

SATA: 6 x SATA 3.0 Gb/s ports - All 6 works in AHCI but not in ICH10 mode and Raid.

PATA: Marvell 6102 2 x PATA - Works.


Drivers needed for Audio and Lan - P5Q.zip

DSDT modified bios thanks to BiTRiP - P5Q_EM_0202_Modded_By_BiTRiP.ROM.zip


I'm trying to mod the latest bios 0302 myself, but don't know if I have the guts to try it :/

Link to comment
Share on other sites

  • 3 weeks later...

The above modified bios is verified.


On Jas 10.5.4 client/server SSE2 SSE3


Before installation of mod'ed bios, the OS loading process hung, without loading the os (the installation was no problem using AHCI hard drive access mode)


After bios flashing with the mod'ed bios (from windows) the OS loaded like a charm 8-)

Link to comment
Share on other sites

  • 4 weeks later...

Hi Allsop & others... Did you ever get BIOS 0402 modified to work, as I had the original 0402 installed & the install didn't work. Tried your 0202 modified bios & it worked, so I just wondering...

Also, whenever I try & update to 10.5.4 & 10.5.5 I lose the audio. I try using the option in the updates to "just restore audio" and it doesn't work, as well as reinstalling the above drivers but nothing seems to work. Any ideas ?





Link to comment
Share on other sites

  • 3 weeks later...

I see Allsop got OriginalMACNUT (OMN) to patch the later 1406 bios in the OMN's DSDT BIOS FIX Thread.


It's available on OSXCORES under the desktop page.


Main Page: http://www.osxcores.site50.net/index.html


Link to P5QEM 1406 DSDT Mod Bios:



I tried it and it does work.

I'm able to boot-132 (extensions to use still in progress) and install off of retail 10.5.4.

Link to comment
Share on other sites

A quick note while I'm working on the boot-132 image.


I've installed 10.5.4 retail and the 10.5.5 upgrade.

The native AppleIONetworkingFamily works fine for this board.


The 8111C shares the same id as a Realtek 8168 (which is already in the apple kexts).


You can also use the "real" Realtek RTG v2.0 mac package if you want.

No need for modified kexts for ethernet.


Having trouble with the audio using the package in the first post.

It's one of Taruga's ALC8xx Leopard kexts and pinning down which one.

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...
  • 2 weeks later...
  • 2 weeks later...

Just bought P5Q-EM with E8400 yesterday. Before I try my P5B and work fine with OSX :lol:


ICH10R @ AHCI mode.

Sound work with Allop's driver, thx. (Will test S/PDIF and mic if i have time)

Lan work without driver

Display is Asus 7600GS 512MB, flash mod bios here get QE support.

If i choice NVinject 512MB when install iDeneb, cause no QE support. After several time install, I find when I select X1600 PCIE, not select any nVidia made my mod 7600GS full work QE!!!! (Because i have a X1600, but can get it work.... black screen no signal when load osx)


Marvell IDE work when boot and install, after enter OSX, IDE DVD is missing, install kext from this post, work fine.

USB work.

Shutdown restart need patch, also at this post. (Share with P5Q, Thx RoberT XeS)

Sleep work, Sleep Display work.

Firewire work.


I have a question, why my internal SATA HDD's icon look like a external HDD's icon? any idea?

Link to comment
Share on other sites

iDeneb 1.3 (OSX 10.5.5) work on P5Q-EM (BIOS 0202 patched)!


EFI-X and original OSX 10.5.5 DVD work on P5Q-EM (BIOS 0202 patched)???



I had been searching for an answer, but now I have finally found out by just trying it out myself. I have OS X Leopard 10.5.6 installed and working perfectly (aside from the audio) on my ASUS P5Q-EM mobo using an EFi-x module and the 1406 dsdt modded bios. I am triple booting windows vista, windows xp, and OS X Leopard on my machine with a E8400 3.0ghz intel core2duo, 4gb ram, three 500gb hdd's, and an EVGA GeForce 9800gtx (Only because there is no support for my gtx 260 yet). I had to use the 1406 modded bios (0202 modded bios also worked, but wanted a more recent bios version) to get it to install from the leopard retail install disc, and also to get it to boot from the hdd leo is on. Couldn't get audio to work even with the audio kexts posted in this forum. Will just get an Efix compatible usb audio card. LAN works fine without any drivers. Hope this helps out others that are also searching for answers to this question.


UPDATE! I put a cheap $5.00 usb audio card that I bought off ebay on my system and the audio works perfectly now. Never did get any alc1200 kexts to work on my system. I'm definitely happy with this solution though.

Link to comment
Share on other sites

Fixed, is a problem of my KVM's audio cable...... hammer.gif


Hello all, i find that audio quality is very bad on OSX with P5Q-EM, when I play mp3 with itunes, sound like playing a 16kbps file, anybody have this experience?
Link to comment
Share on other sites

  • 2 weeks later...
Soo, does it work?







Guide for Installing MAC OS X Leopard Retail Here



Guide for Installing MAC OS X Leopard IDeneb / iATKOS Here


Link to comment
Share on other sites


  • Create New...