Jump to content

How to install Kalyway 10.5.3 Update Without a problem!


jivhg
 Share

38 posts in this topic

Recommended Posts

First. Before we start, back up the following extensions and bundles :D

 

/System/Library/Extensions/AppleAHCIPort.kext

/System/Library/Extensions/AppleACPIPlatform.kext

/System/Library/Extensions/IOSerialFamily.kext

/System/Library/SystemConfiguration/PowerManagement.bundle

/System/Library/Extensions/IOAHCIFamily.kext

 

All of that is VERY Important.

 

Download the Kalyway 10.5.3 ComboUpdate from somewhere (torrent sites)

 

Just read the readme first :D

 

1. Install the kalyway update. (DO NOT REBOOT YET)

 

2. Open the Kernels installer

 

3. Install the kernel for you. (If unsure install vanilla for Intel core2duo based cpu)

 

4. Take these extensions and put them in their old spot:

/System/Library/Extensions/AppleAHCIPort.kext

/System/Library/Extensions/IOSerialFamily.kext

/System/Library/SystemConfiguration/PowerManagement.bundle

 

Also, take AppleACPIPowerSource.kext frm ACPIPlatform.kext and put it in it's old spot (/system/library/extensions/AppleACPIPlatform.kext/Contents/Plugins/)

 

5. Repair Permissions with this terminal command:

 

~sudo -s

~chown root:wheel /System/Library/Extensions/AppleAHCIPort.kext /System/Library/Extensions/IOSerialFamily.kext /System/Library/SystemConfiguration/PowerManagement.bundle /System/Library/Extensions/AppleACPIPlatform.kext/Contents/Plugins/AppleACPIPowerSource.kext /System/Library/Extensions/IOAHCIFamily.kext

 

~chmod -R 775 /System/Library/Extensions/

 

POST-INSTALLATION

 

6. After you reboot, at the darwin prompt, type, "update -v"

 

7. If you have booted, and you get errors saying kexts where improperly installed, download pcwiz's OSXTools Utility and Clear Extensions Cache and set permissions on extensions folder and reboot. If that doesn't work, download "KextHelper b7" and install them with that.

 

OSXTools Utility can be found at:

 

http://forum.insanelymac.com/index.php?showtopic=104754

 

8. If you are having trouble booting, tell me your problem. And what is the last thing it says at the "-v" after rebooting.

 

 

***9. If you get "still waiting for root device" boot with "-f" and follow step 7

 

10. If you have an nVidia Card, and CI + QE Don't work, install Diabolik's nvKush.

 

IF YOU HAVE ANY PROBLEMS, FEEL FREE TO POST.

 

SOUND DRIVERS MAY NEED TO BE RE-INSTALLED ASWELL

 

THIS GUIDE IS ENTIRELY BY ME, AND WILL NOT BE COPIED, UNDERSTOOD?

Link to comment
Share on other sites

May I PLEASE copy and paste the commands you have here, then I do not have to retype them?

or, are they also "copyrighted"?

:thumbsup_anim:

 

 

SticMAN

 

........

THIS GUIDE IS ENTIRELY BY ME, AND WILL NOT BE COPIED, UNDERSTOOD?

Link to comment
Share on other sites

HP530 Leo4All v3. Just updated with Kalyway 10.5.3 without any trics/scripts/bckup. Working at now with any problem. Microphon didn't work before and doesn't work now :-)

Link to comment
Share on other sites

May I PLEASE copy and paste the commands you have here, then I do not have to retype them?or, are they also "copyrighted"? :P SticMAN
HA, good observation. My answer is,NO, I TORTURE YOU! Just kidding, go ahead :D
Will it work if my graphics card is Nvidia 7200 GS? Because I tried and failed.
Your NVIDIA Graphics will work if you delete nVInject and install NVKUSH
Link to comment
Share on other sites

HA, good observation. My answer is,NO, I TORTURE YOU! Just kidding, go ahead :D Your NVIDIA Graphics will work if you delete nVInject and install NVKUSH

 

 

I tried NVKUSH but it did'nt work. I also tried following the steps given to update from original 10.5.3 Combo Update from apple. But failed in that too. Is there any way to get Kalyway Combo Update work with my graphics card.

Link to comment
Share on other sites

I am to this step right here:

 

Also, take AppleACPIPowerSource.kext frm ACPIPlatform.kext and put it in it's old spot (/system/library/extensions/AppleACPIPlatform.kext/Contents/Plugins/)

 

And I'm lost because I can't find AppleACPIPowerSource.kext and the "old spot" does not exist...

 

Any help?

Link to comment
Share on other sites

Update worked for me, thanks for the additional info. Like the person above I didn't need to swap any kext, I just installed the update and kernal per included instructions. I did have to reboot and type update -v and then reboot again to get everything straight. I'm just happy that our OSX community is very quick with the updates..good stuff. :P

Link to comment
Share on other sites

OT: How did you manage to install Leo on your HP in the first place? :P I've tried it on my brother's HP pavilion, which looks just like yours eccept it has the trackpad in the center of the inner bottom case (model dv6520eo, or something like that)

 

I tried Kalyway, Leo4All, iATKOS and patched retail version, with no success.

Link to comment
Share on other sites

I am to this step right here:Also, take AppleACPIPowerSource.kext frm ACPIPlatform.kext and put it in it's old spot (/system/library/extensions/AppleACPIPlatform.kext/Contents/Plugins/)And I'm lost because I can't find AppleACPIPowerSource.kext and the "old spot" does not exist...Any help?
SOme installs had them removed for some reason, jsut ignore.
OT: How did you manage to install Leo on your HP in the first place? :blink: I've tried it on my brother's HP pavilion, which looks just like yours eccept it has the trackpad in the center of the inner bottom case (model dv6520eo, or something like that)I tried Kalyway, Leo4All, iATKOS and patched retail version, with no success.
I'm a "GURU" :P almost there.
any help?
Specify
I tried NVKUSH but it did'nt work. I also tried following the steps given to update from original 10.5.3 Combo Update from apple. But failed in that too. Is there any way to get Kalyway Combo Update work with my graphics card.
What is your graphics card.
Link to comment
Share on other sites

First. Before we start, back up the following extensions and bundles :)/System/Library/Extensions/AppleAHCIPort.kext/System/Library/Extensions/AppleACPIPlatform.kext/System/Library/Extensions/IOSerialFamily.kext/System/Library/SystemConfiguration/PowerManagement.bundle/System/Library/Extensions/IOAHCIFamily.kextAll of that is VERY Important.Download the Kalyway 10.5.3 ComboUpdate from somewhere (torrent sites)Just read the readme first :D1. Install the kalyway update. (DO NOT REBOOT YET)2. Open the Kernels installer3. Install the kernel for you. (If unsure install vanilla for Intel core2duo based cpu)4. Take these extensions and put them in their old spot:/System/Library/Extensions/AppleAHCIPort.kext/System/Library/Extensions/IOSerialFamily.kext/System/Library/SystemConfiguration/PowerManagement.bundleAlso, take AppleACPIPowerSource.kext frm ACPIPlatform.kext and put it in it's old spot (/system/library/extensions/AppleACPIPlatform.kext/Contents/Plugins/)5. Repair Permissions with this terminal command:~sudo -s~chown root:wheel /System/Library/Extensions/AppleAHCIPort.kext /System/Library/Extensions/IOSerialFamily.kext /System/Library/SystemConfiguration/PowerManagement.bundle /System/Library/Extensions/AppleACPIPlatform.kext/Contents/Plugins/AppleACPIPowerSource.kext /System/Library/Extensions/IOAHCIFamily.kext~chmod -R 775 /System/Library/Extensions/POST-INSTALLATION6. After you reboot, at the darwin prompt, type, "update -v"7. If you have booted, and you get errors saying kexts where improperly installed, download pcwiz's OSXTools Utility and Clear Extensions Cache and set permissions on extensions folder and reboot. If that doesn't work, download "KextHelper b7" and install them with that.OSXTools Utility can be found at:http://forum.insanelymac.com/index.php?showtopic=1047548. If you are having trouble booting, tell me your problem. And what is the last thing it says at the "-v" after rebooting.***9. If you get "still waiting for root device" boot with "-f" and follow step 710. If you have an nVidia Card, and CI + QE Don't work, install Diabolik's nvKush.IF YOU HAVE ANY PROBLEMS, FEEL FREE TO POST.SOUND DRIVERS MAY NEED TO BE RE-INSTALLED ASWELLTHIS GUIDE IS ENTIRELY BY ME, AND WILL NOT BE COPIED, UNDERSTOOD?
sorry for the 1st blank replyI am getting a very different error than what I have been reading.First off Dell Dimension 4600cIntel P4 @ 3.01GHzMy HD is partitionedWhen I run Kalyway, I get to the set up screen, I click English (US), click the next couple of screens, then it reverts me back to the start screen of the set up?I also tried the iATKOS (r2) got that to install, but can not get it to boot no matter what I try.....any tips keep getting the blinking curser, when I try some of the other methods (-v ect...) I get a reboot or shutdown sequenceI have formatted and reformatted many times trying the different possible combo's with the different install DVD'sHelp please, I really do not know what I am missingthanks
Link to comment
Share on other sites

I don't replace:

/System/Library/Extensions/AppleAHCIPort.kext

/System/Library/Extensions/AppleACPIPlatform.kext

/System/Library/Extensions/IOSerialFamily.kext

/System/Library/SystemConfiguration/PowerManagement.bundle

/System/Library/Extensions/IOAHCIFamily.kext

 

update over,

found that enter mac must use update, otherwise, mac will reboot again and again.

How can I do?

 

and if these files must be replaced, can you offer your AppleAHCIPort.kext,AppleACPIPlatform.kext,IOSerialFamily.kext,SystemConfiguratio

/PowerManagement.bundle,IOAHCIFamily.kext files.

Link to comment
Share on other sites

SOme installs had them removed for some reason, jsut ignore.I'm a "GURU" :P almost there.SpecifyWhat is your graphics card.
Nvidia Gefore 7200 GS
sorry for the 1st blank replyI am getting a very different error than what I have been reading.First off Dell Dimension 4600cIntel P4 @ 3.01GHzMy HD is partitionedWhen I run Kalyway, I get to the set up screen, I click English (US), click the next couple of screens, then it reverts me back to the start screen of the set up?I also tried the iATKOS (r2) got that to install, but can not get it to boot no matter what I try.....any tips keep getting the blinking curser, when I try some of the other methods (-v ect...) I get a reboot or shutdown sequenceI have formatted and reformatted many times trying the different possible combo's with the different install DVD'sHelp please, I really do not know what I am missingthanks
The problem might be that it is not able to find the boot information on your hdd. Install the Darwin Boot Loader from iATKOS Installer DVD. After that reboot with option -s after pressing F8. Try these commands:fdisk -e /dev/rdisk0 (0 is the first disk, if you have other disk use the number accordingly)flag <partition number where leopard is installed>updatewritequitrebootThis might solve your problem
Link to comment
Share on other sites

Your NVIDIA Graphics will work if you delete nVInject and install NVKUSH.

 

How to delete nVInject?

(Mine is nVidia Quadro NVS 135M.

I install NVKUSH without deleting nVInject, and it doesn't work.

Btw,The card worked fine when 10.5.2.)

Link to comment
Share on other sites

Nvidia Gefore 7200 GSThe problem might be that it is not able to find the boot information on your hdd. Install the Darwin Boot Loader from iATKOS Installer DVD. After that reboot with option -s after pressing F8. Try these commands:fdisk -e /dev/rdisk0 (0 is the first disk, if you have other disk use the number accordingly)flag <partition number where leopard is installed>updatewritequitrebootThis might solve your problem

 

 

 

this did not seem to work

 

One guide that I read stated that there should be something under disk utilities that specifies install options, I do not have anything like that in the install utilities screen.

Link to comment
Share on other sites

Thanks for the guide, it worked almost perfectly for me (Kalyway 10.5.1 straight to 10.5.3).

 

I say "almost" because there was a weird little error: after installing the update, but before rebooting, I lost sudo rights in the terminal. This was really weird, because I could still authorize copying files through the GUI, but I could not issue any commands using sudo in terminal. I tried going to System Preferences and clicking on "Accounts", and this was broken as well (could not launch the Accounts preferences pane).

 

I avoided using the terminal by just copying the kexts in the gui and then using Disk Utility to repair the permissions. After rebooting and updating, I was able to sudo again, and my Accounts prefs re-appeared. So, just in case anyone else has this problem - don't panic when you can't use sudo, just do everything through the gui and it should work again after you update.

Link to comment
Share on other sites

IF YOU HAVE ANY PROBLEMS, FEEL FREE TO POST.

 

SOUND DRIVERS MAY NEED TO BE RE-INSTALLED ASWELL

 

THIS GUIDE IS ENTIRELY BY ME, AND WILL NOT BE COPIED, UNDERSTOOD?

 

i think this is hilarious... u steal osx (doesnt matter if you own a legit copy... it's still illegal) and then u say this wont be copied like you own it?... its the same complaint ppl make about copying others' warez... give me a break...

 

thanks for the guide though... hope it works...

Link to comment
Share on other sites

  • 4 weeks later...

How were you guys able to do a flawless update per kalyway's instructions? To go forward with the install, it tells you it has to restart after the update. There is no option not to restart after the update starts. How do you do the update, but keep it from restarting so you can choose the kernel? Also, I use the sleep kernel which is intel/amd sse2, sse3. Is that also included in the kalyway 10.5.3 update? I have an NVidia 8800GT, so I will probably have video problems from what I have been reading. Anyone care to lend an assist?

Link to comment
Share on other sites

I have an 8800, tried the update and my video is toast. It killed my OGL. Now I have to erase everything and go back to 10.5.2. Wanted .3 for the iPhone SDK, I guess I can do without until a more reliable upgrade is available!!!!

 

NM

Link to comment
Share on other sites

OK, my battery meter is working now - thanks so much for the guide.

One question - my USB will recognize drives but not devices (like mouse of keyboard) after boot. If I restart with them in there, it will see them. The old Kalyway 10.5.2 never did that, and i've tried replacing everything in the extensions folders that had USB or IO in it with the backups, no luck.

Any help would be greatly appreciated.

Thanks

Link to comment
Share on other sites

 Share

×
×
  • Create New...