Jump to content

Jmicron + IDE + DVD = Problem

10 posts in this topic

Recommended Posts

Hi guys,


I'm using Kalyway 10.5.1 + Vanilla + EFI + updates = 10.5.2

All works perfect... sound, network, bluetooth, after a couple of tweakings.


The only issue I have, is that can't get to work the internal IDE DVDR I have.

I've tried to use my external Firewire/USB DVDR, but for some weird reason, all apps tells me that is not superdrive, can't write, unstable, etc etc (works great on Ubuntu/XP/etc).


For this reason, I need to get the internal IDE DVD working. I've tried it all (I think)... couldn't make it work.

The Hardware info detects nothing under ATA devices (and the DVD is the only ATA unit I have).


My Motherboard is MSI P965 Platinum.


Any clue?


Thanks in advance.

Link to comment
Share on other sites

I have Leo4Allv3 installed on my HP Compaq Presario v6000. Everything but wireless (known 3945 issue) and internal IDE-ATA dvd drive works. And, same as you, the dvd drive isn't even detected. Drive is recognized under Tiger - but not Leopard ... trying to figure that one out now ...

Link to comment
Share on other sites

I've been looking around everywhere for a solution to this issue, but seems nobody has the real fix (none worked for me yet tho).

So far I'm about to give up on this... if someone has a solution, at least for the external USB/FW drive to get rid of the "Interface Error:-50 The Connection Is Not Stable" Toast error (but the same happens on all apps trying to write DVDs) I would be really glad.



Link to comment
Share on other sites



tried every one since they came out, im on P965T-A, which ofcourse is JMicron controlled.


but im sure the nice people of the OSX86 community will be ride along side me.


In my opinion, (if it matters) when i boot up i get the usual boot.plist error, with countless burned images from other machines.


the only option for me to install on, is my network card. i think its my network rom, thing is even with both disabled, it still shows.


my guess is external drives are what is the essence to install it on jmicron.


problem i come across is, even dvd drives dont show in bios at all, they only show once the computer has booted. perhaps its an understanding of JMicron i need. and the controller from sata to raid, make no difference to me.


have tried all -extensions (x,s,v,f etc..)

some people complain of root device error.. if only.. if only :D


Take Care

Link to comment
Share on other sites

Thank you all.

Tried it already.

The key you sent me only allowed me to boot via IDE instead of using AHCI. Therefore, still can't see my IDE DVD Writer.


If anyone has any suggestion, I'm all ears!



Link to comment
Share on other sites

  • 2 weeks later...

There is something with the JMicron.

I have a S-ATA HDD and a IDE DVD drive.

I had the JMicron as IDE and could install Leo and everything was fine, even burning DVDs. But sometimes I had a Panic freeze because I have 4GB of Ram (I think that it was that). So I changed the JMicron from IDE mode to AHCI and solved the Panic problem. Just that when I tried to access my DVD Drive it destroyed my HDD partition...

From now I'll try to install all again but setting the JMicron as AHCI from the beginning. I'll check about the JMicronATA.kext.

I hope it works, if not it would be a kind of paradox :(

Link to comment
Share on other sites

I have a Jmicron 20360/20363 controller it has allways worked nice. You have to add your device ID inside JmicronATA.kext to enable IDE support, and inside AppleAHCIPort.kext to enable AHCI. If you get bad support once you've done this, look on your slave/master settings and also the connector where is plugged the device, some configurations work better than some others. For me, DVD is plugged on the middle of the strap as slave, the HD is plugged on the end, as master. Everything is fine for both devices, the only problem is that boot from DVD doesn't work, tho it work from HD.

Link to comment
Share on other sites


  • Create New...