Jump to content

[HOW TO] ATI Radeon HD 2400 / 2600 / 2900 / 3850 / 3870 on Leopard


  • Please log in to reply
559 replies to this topic

#501
hatty

hatty

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
So I just did a retail install from a flash drive. It seems to be working but the signal refresh rate from the video card to the monitor is too high it shows it as being 75hz and the monitor only supports 60. is this something this would fix or totally different problem?

#502
lostfootage

lostfootage

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I have a HP Pavilion a6750f and I'm just trying anything to get it to work. I've come to the conclusion that I will have to mod one of the flavors of OSX86 to fit my hardware. I've had parshall success with ideneb getting past all error but I never make it to the cool mac "welcome" animation.

Could some one please just point me in the right direction.

here are the specs.
http://h10025.www1.h...n...428&lang=en

-Thanks
-Lostfootage

#503
donte

donte

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

i followed the instructions down to the "T" still no go

my set up retail mac DVD install 10.5 did online updates to 10.5.8

my card is a ATI RAIDEON 256MB (PCI Express 1.0 x16: ATI Radeon HD 2400 XT (Dell) ) according to EVEREST also according to Everest the PCI ID is 1002-94C1 / 1028-0D02 (Rev 00)

followed the tut but no CI/QE no kext loaded!!!

someone please assist me before i go bald pulling out my hair...

thanks



Do i need to flash the VGA bios?, a point in the right direction would be appreciated..

#504
guimenez

guimenez

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Iv got a HD2600 installed from a 10.5.6 hackintosh DVD. I have added some kext to get network to run and that works fine. But graphics. It runs in 1024x768 but not anything else. Im not sure where too look. Is this
a graphic card problem or is there any display drivers that handles that?


how you made the installation?

i have hd 2600 and tried the ipc 10.5.6 final but always freeze saying i must restart the system.

can you explain me how to?

thanks

#505
mrgold

mrgold

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

[/list]Step by step guide:[list=1]
[*]Get Natit (attached to this post)
[*]Extract the archive and copy Natit.kext to /System/Library/Extensions
[*]Locate ATIRadeonX2000.kext in /System/Library/Extensions, Open /System/Library/Extensions/ATIRadeonX2000.kext/Contents/Info.plist with the editor of your choice and add the PCI ID of your card (if it is not already in there). Save.
[*]Open Terminal (if you haven't already done so) and type:

cd /System/Library/Extensions
sudo chown -R root:wheel *
sudo chmod -R 755 *
sudo rm /System/Library/Extensions.mkext
sudo rm /System/Library/Extensions/Caches/com.apple.kext.info
[*]You are done. Reboot and pray :dev:


I HAVE 2 QUESTIONS
1. Im using hd3870, do i need to add my device id to AtiRadeonx2000.kext ? Isnt it for 2xxx series?
2. I am updated osx to 10.6.2 and when i tried to use these commands on terminal it says no such file/folder for 3rd and 4th command.
sudo rm /System/Library/Extensions.mkext
sudo rm /System/Library/Extensions/Caches/com.apple.kext.info
there is no such file as extensions.mkext and com.apple.kext.info
My System Is: P5W-DH deluxe, sapphire hd3870, snow leopard 10.6.2 updated from 10.6.0, chamaleon 2.0.0 RC4, PCI efi v.8
I reformatted and setted up my system about 45 times in last 4 days.
-Now system is working really fine in safe mode.
-When i start normal mode, it loads everything correct and stops on white screen before login.
-if i dont update to 10.6.2, and install 3800 pkg installer, everything looks fine but it loops at login window and cannot login ever.

PLEASE GUYS I NEED REAL HELP

#506
mrgold

mrgold

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I HAVE JUST FOUND A WAY TO GET WORKED ATI HD3870 ON MAC OS X 10.6
1. Clean install 10.6.0 (Do not install any graphic enabler kext) System will open safe mode only..
2. Open in safe mode(-x command on startup) and update to 10.6.2 and restart again
3. Download HD3800 Series install package BUT DO NOT INSTALL
4. Right click to that package with Pacifist to extract inside.
5. Use kext.helper app to load all the kext inside except opengl.
6. Restart you pc in safe mode again
7. Thats all done. You can restart normally..
8. Thanks for all helpers on this site.. (lastExile, mcsmart etc...)

#507
themaestro

themaestro

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey, I tried this and all installed ok but I have no acclerated support? no extended desktop and only one resolution, any ideas?

I HAVE JUST FOUND A WAY TO GET WORKED ATI HD3870 ON MAC OS X 10.6
1. Clean install 10.6.0 (Do not install any graphic enabler kext) System will open safe mode only..
2. Open in safe mode(-x command on startup) and update to 10.6.2 and restart again
3. Download HD3800 Series install package BUT DO NOT INSTALL
4. Right click to that package with Pacifist to extract inside.
5. Use kext.helper app to load all the kext inside except opengl.
6. Restart you pc in safe mode again
7. Thats all done. You can restart normally..
8. Thanks for all helpers on this site.. (lastExile, mcsmart etc...)



#508
mrgold

mrgold

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I have finally found the way to get HD 3870 fully worked on Snow Leopard 10.6.2!!
Trust me this is last and works excellent (: No resolution or opengl problems, no fan noise everything works fine..
Installed 10.6 and updated to 10.6.2
NO other graphic enabler will be loaded!!

Step by step guide:
  • Get Natit and ATI3800Controller.kext (attached to this post)
  • Extract the archive and copy them to /System/Library/Extensions
  • Delete ATIRadeonX2000.kext in /System/Library/Extensions
  • Open Terminal (if you haven't already done so) and type:
    cd /System/Library/Extensions
    sudo chown -R root:wheel *
    sudo chmod -R 755 *
    sudo rm /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext
  • You are done.
Additional files

Attached Files



#509
vadorone

vadorone

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

I have finally found the way to get HD 3870 fully worked on Snow Leopard 10.6.2!!
Trust me this is last and works excellent (: No resolution or opengl problems, no fan noise everything works fine..
Installed 10.6 and updated to 10.6.2
NO other graphic enabler will be loaded!!

[/list]Step by step guide:

  • Get Natit and ATI3800Controller.kext (attached to this post)
  • Extract the archive and copy them to /System/Library/Extensions
  • Delete ATIRadeonX2000.kext in /System/Library/Extensions
  • Open Terminal (if you haven't already done so) and type:
    [code=auto:0]cd /System/Library/Extensions
    sudo chown -R root:wheel *
    sudo chmod -R 755 *
    sudo rm /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext
  • You are done.
Additional files


When you mention typing those commands into terminal do I have to do one line at a time or do I just select the whole thing and paste it in and hit enter? Thanks for sharing your success I'm STOKED!

#510
mrgold

mrgold

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

When you mention typing those commands into terminal do I have to do one line at a time or do I just select the whole thing and paste it in and hit enter? Thanks for sharing your success I'm STOKED!

You need to enter one by one as mcsmart entered.. I guess we need to thank to him first ..

#511
vadorone

vadorone

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

You need to enter one by one as mcsmart entered.. I guess we need to thank to him first ..


So I used the kakewalk method from usb stick and updated to 6.2 through apple software update.

Followed your instructions but still only safemode works.

The problem is a no smoking type sign at the grey apple on startup. Is this related to my graphics card or something else?

Thanks man.

I also get an error when doing the terminal commands that says kexts were not installed properly.

Any ideas? ..Probably something very nooby.

#512
vadorone

vadorone

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
still cant get this to work.. anyone have any ideas for me?

#513
mrgold

mrgold

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

So I used the kakewalk method from usb stick and updated to 6.2 through apple software update.

Followed your instructions but still only safemode works.

The problem is a no smoking type sign at the grey apple on startup. Is this related to my graphics card or something else?

Thanks man.

I also get an error when doing the terminal commands that says kexts were not installed properly.

Any ideas? ..Probably something very nooby.


I guess you need to update by software updater, cause the size is different with the downloadable one.
1. Install 10.6.0
2. Open in safe mode and update 10.6.2
3. Then use this method.
I am using vanilla kernel thats all..

#514
vadorone

vadorone

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

I guess you need to update by software updater, cause the size is different with the downloadable one.
1. Install 10.6.0
2. Open in safe mode and update 10.6.2
3. Then use this method.
I am using vanilla kernel thats all..


That is exactly what I've done. With the kakewalk install, I'm wondering if I'm not using a vanilla kernel. Do you happen to know if there is a flag I can type at boot to load the vanilla kernel? How did you do your 10.6 install? Thanks again.

#515
mrgold

mrgold

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
snowleodvd.iso from the pirate bay

#516
banini_jeque

banini_jeque

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts
mrgold, is the ATI3800Controller you have modified at all? It appears to be the same size and version at the standard one in 10.6.2.

#517
ufo_all

ufo_all

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts
I guess.. ATI HD Radeon 2400 pcie not working in SL... if u try above guide.. and reboots it goes white screen.. have to boot in safe mode but SL doesnt support...

#518
Big Apple Fan

Big Apple Fan

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Good day!
Is there any way to make Sapphire Radeon HD 3650 AGP8X 512MB to work on Leopard 10.5.6? I can't upgrade to 10.5.7/10.5.8 .
Many Thanks!

#519
faheus

faheus

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
how it looks with a 2400 under .5.8 ?

i must Update for iPad

#520
ToBeMac

ToBeMac

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
  • Location:Alexandria, Egypt

I have finally found the way to get HD 3870 fully worked on Snow Leopard 10.6.2!!
Trust me this is last and works excellent (: No resolution or opengl problems, no fan noise everything works fine..
Installed 10.6 and updated to 10.6.2
NO other graphic enabler will be loaded!!

Step by step guide:

  • Get Natit and ATI3800Controller.kext (attached to this post)
  • Extract the archive and copy them to /System/Library/Extensions
  • Delete ATIRadeonX2000.kext in /System/Library/Extensions
  • Open Terminal (if you haven't already done so) and type:
    cd /System/Library/Extensions
    sudo chown -R root:wheel *
    sudo chmod -R 755 *
    sudo rm /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext
  • You are done.
Additional files



Does that mean you managed to get QE/CI and OpenCL all working?!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy