Jump to content

Need testers for one of the components of next v2.00 Patcher


  • This topic is locked This topic is locked
313 replies to this topic

#301
firos

firos

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hi! Any ideas for Toshiba Satellite p100-425.
No sound from Conexant HDA. Id: 5045.
Can't even remember all the things I tried.


Thank you.

#302
Puntoboy

Puntoboy

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

FIXED Now i've full sound without mute button problem on AD1981 and Laptop HP NC6400 !!!!!!!!!!



Here's the magic file

Do not forget to repair permissions, delete cache ...

Can anyone make a .pkg file for this ? (i'm too lazy and tired now...)


I've tried this on my 6720s and it doesn't work I'm afraid. System Profiler reports that there is no built-in audio.

#303
Pink Waters

Pink Waters

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 213 posts
  • Gender:Male
anybody have the latest hdaudio.kext?
the links are not available

#304
kimaca

kimaca

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
where is the HDAudio.kext

#305
Zapata

Zapata

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
I'm getting crackling nioses when playing audio with this driver when using batteries. Seems there is something with powersaving and this kext.

HP Compaq nc8430, Core 2 Duo (CPUS=1), Centrino Duo, 10.5.6, AppleAzaliaFixAD1981_Installer.zip

#306
shuurai

shuurai

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Would love to test it out. I have Asus W5A with ALC880 currently not working/can be found with any thing.

#307
Toasted Logic

Toasted Logic

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Orlando, FL
Can someone please post the HDAudio.kext again? I know this is an abandoned project, but I've tried everything to get my ALC663 to work and I'd like to give it a shot.

#308
jjduro

jjduro

    Almocinho grátis é que era

  • Members
  • PipPipPipPipPipPipPip
  • 877 posts
  • Gender:Male
  • Location:Sandes de presunto � bem bom

Can someone please post the HDAudio.kext again? I know this is an abandoned project, but I've tried everything to get my ALC663 to work and I'd like to give it a shot.


this is just a probe. Not the complete driver

Attached Files



#309
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,714 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
Hy Taruga.. i didn't see any kext in post#1.. could you send me those kext or the patcher v2 because it have been 2 weeks since I'm crazy to make my alc888 s/t (laptop acer) working.. I don't think i'll have all of the device working perfectly.. but the mike ... gosh. . .

I read about the graphviz and writing manually the entire node connection on the various kext.. but it's very paranoid!!

thanks..
and .. good job!!! really.

#310
jjduro

jjduro

    Almocinho grátis é que era

  • Members
  • PipPipPipPipPipPipPip
  • 877 posts
  • Gender:Male
  • Location:Sandes de presunto � bem bom

Hy Taruga.. i didn't see any kext in post#1.. could you send me those kext or the patcher v2 because it have been 2 weeks since I'm crazy to make my alc888 s/t (laptop acer) working.. I don't think i'll have all of the device working perfectly.. but the mike ... gosh. . .

I read about the graphviz and writing manually the entire node connection on the various kext.. but it's very paranoid!!

thanks..
and .. good job!!! really.


This isn't the best place to ask for drivers.. but still.. go to: http://osxupdate.blogspot.com/

#311
ole2

ole2

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:Grenoble, France
compaq mini 700 with IDT HDAudio.kext output and Linux ALSA dump in attachment

HDAudioDevice[0x33ca000]::initHardware(0x314aa00)
At the beginning , there was silence.
Now, there is hope! (Taruga)

HD Audio D27:F0 Irq: 16 VID: 8086, PID: 27d8
VID/PID : 0x111d7608
Subsystem : 0x103c361a
Revision : 0x00100102
Node count: 0x00010001
FGroupType: 0x00000101
Nid 14 caps: 0x00400100
Nid 1a caps: 0x0030010d
Nid 1e caps: 0x00400301
Nid 1f caps: 0x00400701
PinComplex 14: 0x40f000f1
PinComplex 15: 0x00000000
PinComplex 16: 0x00000000
PinComplex 17: 0x00000000
PinComplex 18: 0x40f000f2
PinComplex 19: 0x40f000f3
PinComplex 1a: 0x00000000
PinComplex 1b: 0x00000000
PinComplex 1e: 0x40f000f4
PinComplex 1f: 0x40f000f5
M 0xb : 0x00000000
M 0xc : 0x00000000
M 0x14 : 0x00000000
Warning: Invalid corb size (0)
Warning: Invalid rirb size (0)
Output Streams: 4, Input Streams: 4, Bidirectional Streams: 0 64Bit: 1
HDAudioDevice[0x33ca000]::free()

Attached Files



#312
SuperJudge

SuperJudge

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Albany, Georgia

Taruga: Well, the HD Audio Bus can support multiple devices, Audio, Modem, HDMI, etc
At the moment, it seems I can only communicate with the audio codec if its in address 0.
I have to get access to a pc with an audio codec in a different address to improve the code or else Ill have to make a manual option for codecs at other addresses as I need to know where they are to program the codec right.

Why is this important ? For ex. for codecs that show input and output devices but dont work at all, they need some code to modify codec parameters so they can work properly. And this is only one example.

ALSA Sound's /proc entry from SLAX on my GA-EP43-UD3L was on codec#2, and shows up as address 2 in the codec dump; might that have anything to do with it?

Attached Files



#313
michaspoli

michaspoli

    Spo

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Interests:Have Fun
CodecDump Lenovo R60 with knoppix6

Codec: Analog Devices AD1981
Address: 0
Vendor Id: 0x11d41981
Subsystem Id: 0x17aa2025
Revision Id: 0x100200
No Modem Function Group found
Default PCM:
rates [0x7f]: 8000 11025 16000 22050 32000 44100 48000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Default Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
GPIO: io=4, o=0, i=0, unsolicited=1, wake=0
IO[0]: enable=0, dir=0, wake=0, sticky=0, data=1
IO[1]: enable=0, dir=0, wake=0, sticky=0, data=1
IO[2]: enable=0, dir=0, wake=0, sticky=0, data=1
IO[3]: enable=0, dir=0, wake=0, sticky=0, data=1
Node 0x02 [Audio Output] wcaps 0x30311: Stereo Digital
Converter: stream=5, channel=0
Digital:
Digital category: 0x0
PCM:
rates [0x60]: 44100 48000
bits [0x2]: 16
formats [0x5]: PCM AC3
Delay: 3 samples
Connection: 2
0x01* 0x04
Node 0x03 [Audio Output] wcaps 0x441: Stereo
Converter: stream=5, channel=0
Power: setting=D0, actual=D0
Processing caps: benign=1, ncoeff=70
Node 0x04 [Audio Input] wcaps 0x100511: Stereo
Converter: stream=0, channel=0
SDI-Select: 0
PCM:
rates [0x7f]: 8000 11025 16000 22050 32000 44100 48000
bits [0x6]: 16 20
formats [0x1]: PCM
Power: setting=D0, actual=D0
Connection: 1
0x15
Node 0x05 [Pin Complex] wcaps 0x400187: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Amp-Out vals: [0x2a 0x2a]
Pincap 0x0001173f: IN OUT HP EAPD Detect Trigger ImpSense
Vref caps: HIZ 50 GRD 80
EAPD 0x0:
Pin Default 0xc3014110: [Both] Line Out at Ext Left
Conn = 1/8, Color = Green
DefAssociation = 0x1, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x40: OUT VREF_HIZ
Unsolicited: tag=00, enabled=0
Connection: 2
0x03 0x0e*
Node 0x06 [Pin Complex] wcaps 0x400185: Stereo Amp-Out
Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x0000001f: OUT HP Detect Trigger ImpSense
Pin Default 0x422140f0: [N/A] HP Out at Ext Front
Conn = 1/8, Color = Green
DefAssociation = 0xf, Sequence = 0x0
Pin-ctls: 0xc0: OUT HP
Unsolicited: tag=00, enabled=0
Connection: 2
0x03 0x0e*
Node 0x07 [Pin Complex] wcaps 0x400104: Mono Amp-Out
Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Amp-Out vals: [0x80]
Pincap 0x00000010: OUT
Pin Default 0x591311f0: [N/A] Speaker at Int ATAPI
Conn = ATAPI, Color = Black
DefAssociation = 0xf, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x40: OUT
Connection: 1
0x0f
Node 0x08 [Pin Complex] wcaps 0x400083: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Pincap 0x00001727: IN Detect Trigger ImpSense
Vref caps: HIZ 50 GRD 80
Pin Default 0xc3a1502e: [Both] Mic at Ext Left
Conn = 1/8, Color = Red
DefAssociation = 0x2, Sequence = 0xe
Pin-ctls: 0x24: IN VREF_80
Unsolicited: tag=00, enabled=0
Node 0x09 [Pin Complex] wcaps 0x400187: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Amp-Out vals: [0xbf 0xbf]
Pincap 0x00001737: IN OUT Detect Trigger ImpSense
Vref caps: HIZ 50 GRD 80
Pin Default 0x418130f0: [N/A] Line In at Ext Rear
Conn = 1/8, Color = Blue
DefAssociation = 0xf, Sequence = 0x0
Pin-ctls: 0x20: IN VREF_HIZ
Unsolicited: tag=00, enabled=0
Connection: 2
0x03* 0x0e
Node 0x0a [Pin Complex] wcaps 0x400301: Stereo Digital
Pincap 0x00000010: OUT
Pin Default 0x014411f0: [Jack] SPDIF Out at Ext Rear
Conn = RCA, Color = Black
DefAssociation = 0xf, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x40: OUT
Connection: 1
0x02
Node 0x0b [Audio Selector] wcaps 0x300101: Stereo
Connection: 6
0x03 0x0c 0x09 0x0e* 0x05 0x18
Node 0x0c [Audio Mixer] wcaps 0x200101: Stereo
Connection: 2
0x1e 0x1f
Node 0x0d [Audio Selector] wcaps 0x30010c: Mono Amp-Out
Amp-Out caps: ofs=0x0f, nsteps=0x0f, stepsize=0x0b, mute=1
Amp-Out vals: [0x80]
Connection: 2
0x10* 0x16
Node 0x0e [Audio Mixer] wcaps 0x200101: Stereo
Connection: 8
0x0d 0x11 0x12 0x13 0x1a 0x1b 0x1c 0x1d
Node 0x0f [Audio Mixer] wcaps 0x200100: Mono
Connection: 1
0x0b
Node 0x10 [Beep Generator Widget] wcaps 0x700000: Mono
Node 0x11 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x15 0x15]
Connection: 1
0x03
Node 0x12 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x08
Node 0x13 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x09
Node 0x14 [Power Widget] wcaps 0x500500: Mono
Power: setting=D0, actual=D0
Connection: 13
0x0d* 0x0e 0x0f 0x10 0x13 0x14 0x15 0x16 0x17 0x18 0x19 0x1a 0x1d
Node 0x15 [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 8
0x0c* 0x09 0x0e 0x0f 0x19 0x05 0x18 0x17
Node 0x16 [Pin Complex] wcaps 0x400000: Mono
Pincap 0x00000020: IN
Pin Default 0x59f311f0: [N/A] Other at Int ATAPI
Conn = ATAPI, Color = Black
DefAssociation = 0xf, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x20: IN
Node 0x17 [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x00000027: IN Detect Trigger ImpSense
Pin Default 0x599311f0: [N/A] Aux at Int ATAPI
Conn = ATAPI, Color = Black
DefAssociation = 0xf, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x20: IN
Unsolicited: tag=00, enabled=0
Node 0x18 [Pin Complex] wcaps 0x400187: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x3d, nsteps=0x3f, stepsize=0x05, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x00001737: IN OUT Detect Trigger ImpSense
Vref caps: HIZ 50 GRD 80
Pin Default 0x41a190f0: [N/A] Mic at Ext Rear
Conn = 1/8, Color = Pink
DefAssociation = 0xf, Sequence = 0x0
Pin-ctls: 0x24: IN VREF_80
Unsolicited: tag=00, enabled=0
Connection: 2
0x03* 0x0e
Node 0x19 [Pin Complex] wcaps 0x400001: Stereo
Pincap 0x00000020: IN
Pin Default 0x9933e120: [Fixed] CD at Int ATAPI
Conn = ATAPI, Color = White
DefAssociation = 0x2, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x20: IN
Node 0x1a [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x05
Node 0x1b [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x17
Node 0x1c [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x18
Node 0x1d [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x19
Node 0x1e [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Connection: 1
0x08
Node 0x1f [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x80 0x80]
Connection: 1
0x18



Audio-Out is not the Problem. But i want Microfon. Where can i have the patcher v2 for testing?
Thanks for your work...

#314
nephrone

nephrone

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Can anyone please give me the link to HDAudio.kext..taruga's link is down..I tried with different linux codec dumps but it didnt work for my Conexant HDAudio device. Please help me..





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy