Jump to content

HP Dv6000 & Dv9000 Intel Only


  • Please log in to reply
528 replies to this topic

#521
BslBryan

BslBryan

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Actually, ridiculously easy. Retail 10.6.3 upped to 10.6.6, Chameleon bootloader and nawcom mod cd. Everything works pretty much OOTB. I messed with a few things, like getting my Intel Pro/100 VE ethernet to show up, then I came across a SL problem that wouldn't let me connect to the internet or server but that was easy enough to fix.

So, here goes:
HP dv6226us (Intel Pentium Dual-Core)
Snow Leopard 10.6.6 via Retail 10.6.3 cd, Nawcom bootmod cd v03, Chameleon Bootloader, and Software Update.

What works:
Graphics/Resolution/QECI
Ethernet
Wireless
Firewire
Trackpad (including two finger scroll and two finger side scroll)
All USB ports
DVD drive
Internal Speakers
Internal Mic
Headphone jack
Multimedia Buttons
Fn Keys
Oh yeah, the keyboard

What Doesn't Work:
Sleep
Restart occasionally takes a while

Not Tested:
Remote Control
Time Machine (though I'm sure it will work)

My machine doesn't have a built-in webcam unfortunately so I don't know if it would work OOTB or not on similar machines.

#522
sw170

sw170

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 212 posts
  • Gender:Male
  • Location:UK
Hi BslBryan,
sounds good!
How about brightness+SUN logo ? Full battery support ? Pstates and Cstates ?
Sleep should work on your machine with DSDT, try create one with Linux LiveCD

#523
BslBryan

BslBryan

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Clear difference between cstates and pstates, no problem with hd or fan making noise in times of idle.
No sun logo, but brightness changes. That's all I really care about. The function's there. I would be more upset if I had the logo but no functionality. ;-)

I don't put my computer to sleep normally but it might be a nice idea. I've got a couple linux distros hanging around here. I used Ubuntu's latest long term stable (10.04) a lot when ethernet wasn't showing up in OSX (so I could dl kexts) so it's actually right here.

Really what I'd like to do is find a way to bake the startup sound into an EFI emulator or replace pcspkr with the startup sound. I also have thought about using afplay to load and play a sound when (in verbose mode) the kexts are loading up, so it would chime a little after the white screen, but before login.

EDIT: Yes, full battery support as well. At least, I did. I removed AppleHPET.kext from /S/L/E because it was conflicting with my ethernet kext, but that was my choice.

#524
NSCXP2005

NSCXP2005

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 594 posts
  • Location:Manchester UK
Hi BslBryan,

Would you be able to tell us all what kexts you used to get your setup working?

I would love to install Snow Leopard on my HP Pavillion dv6000

Thanks

NSCXP2005

#525
demoniac

demoniac

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
  • Location:Norway
Ahh... Finally back to this forum.

I'm currently writing from my DV9575 with 10.6.6.

Anyone know how to get audio working? I got it working on 10.5.8, but people say that the kexts will cause a KP.


I think it's a Realtek ALC268.

Please, anyone?

EDIT:

HAHA! I got it working!
This will work for DV6000 and DV9000, I just replaced AppleHDA in S/L/E and ran Kext Utility. I guess it can be installed in /extra/extensions so that you don't overwrite when updating OSX.
Attached File  AppleHDA.kext.zip   604.26KB   119 downloads

#526
hmiem81

hmiem81

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hey all,

I'm actually running 10.5.8 on my DV 6875se but I really want to move to 10.6. Any advice?

#527
extremeae

extremeae

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
I'm happy to report that my DV6500T now runs iATKOS Lion 10.7.1 wonderful! I can say it's quite fast and speedy over 10.5.8. I never had much luck with 10.6.x(crashed a lot) so yeah 10.7.1 is nice!

The only patch or editing I needed to make was the volume control slider. You have to edit a couple of lines in voodooHDA plist for the volume control slider to work correctly. Other than that, everything else works!

UPDATE: The only issue I'm having now is the CMOS time reset. The times keeps resetting. I tried all the AppleRTC fix I can find and none seems to resolve the issue. For the time being, I'm restoring 10.5.8 image until I can find a fix.

#528
newstar55a

newstar55a

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
just successfully installed lion using ##### + ##### + DSDT...

just a bit stability issues about hibernation using "ForceWake=y"

anyone knows this?

#529
pee2thejay

pee2thejay

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hi, all!

I recently installed Snow Leopard 10.6.3 (then updated to 10.6.7) on my DV9700, and I need some help getting shutdown to work!

I have the EvOreboot kext installed, but I do not think it is making a difference!

I used #####, but I am thinking of using a DSDT file, is this the best way to go?

Thanks!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy