Jump to content

Work x1950gt pro ! Dev_ID = 0x72801002 and 0x72881002 !


  • Please log in to reply
1885 replies to this topic

#1841
ontheset

ontheset

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
it didnt work for me....it did nothing.




Phew, it was a bumpy ride, but I finally managed to get my X1950Pro to work under Snow Leopard 10.6.5

The exact model of my card is 512MB Dual DVI AGP Saphire Radeon X1950 Pro
http://www1.sapphire...p...d=168&grp=2
Currently, at start-up Natit.ext recognize it as ATY, Prionace (7280 vendor code)

I've tried various methods including:

* Installing the original Bronya 10a504 driver :: this resulted in screens painted in solid gray that strangely enough still featured a moving mouse cursor

* Then I tried the minimal patching method proposed here:
http://www.insanelym...hp/t223631.html
which is also used in the recent prepackaged drivers uploaded by Plan3r http://goo.gl/mj1lb
This method is reported to work by many users, but on my machine it resulted in gray screens (no mouse this time)
I've tried it with or without the jaminmc extensions: http://goo.gl/qatKD

* Finally, I noticed a recently uploaded driver for X1950GT that was based on the Bronya's stuff:
http://www.kexts.com...nly_10.6.5.html
With some binary diff-ing and investigation I was able to produce a similar updated Bronya driver for 10.6.5, but for X1950Pro cards. QE/CI is enabled and there should be no difference in the final performance of the different methods since this driver still makes minimal modifications to the vanilla mac os extensions.

* README:
Download, unpack and run Install.command
If anything goes wrong, boot in single user mode and execute Restore.command



#1842
e_November

e_November

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 1 posts
For x1950GT (id 7288) only
10.6.6
Attached File  ATI_1950GT_10.6.6.zip   546.93KB   210 downloads

#1843
bluluiSs

bluluiSs

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
Works GREAT!

On Sapphire X1950PRO, Asus P5E with Snow Hazard 10.6.2.

#1844
hundorten

hundorten

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
For Tiger 10.4.11 - ATI_X1950Pro_1011 deleted, please re-upload this :D

#1845
xboxtreme

xboxtreme

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I have an ATi Radeon X1950PRO 256 (7280)
Does not work on 10.6.6 Does anyone have the kext?
The kext of 10.6.5 does not work
Thanks

#1846
schneeleopard

schneeleopard

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
  • Gender:Male
I'm interested too in this kext!

#1847
foxman

foxman

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Here are my kexts for x1950 7280 working in the 32/64 bit under 10.6.6. :)

1. Use Chameleon 2.0 RC5 r700 by Kabyl with experimental
ATI GraphicsEnabler support from ##### 3.2.

2. In Chameleon control panel enable graphic support.

3. Instal kexts via KextHelper.

reboot

http://www.mediafire...w7qkcxhhmv99h14

add:If you do not use graphic Enabler from chameleon, use Natit, or Evoenabler for display resolution.

#1848
ChildOfInsanity

ChildOfInsanity

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Czech Republic
x1950Pro 7280 - KP for your kexts with the Chameleon r700 by Kabyl. What card do you have?
What do you mean by: "It should work with everything off grapgic enabler and use Natit, or Evoenabler for display resolution." Should I USE Natit or Evoenabler or NOT? Because I get it working in 32bit with natit with sleep, in 64bit I have QE/CI but no resolution and no sleep.

Here are my kexts for x1950 7280 working in the 32/64 bit under 10.6.6. ;)

1. Use Chameleon 2.0 RC5 r700 by Kabyl with experimental
ATI GraphicsEnabler support from ##### 3.2.

2. In Chameleon control panel enable graphic support.

3. Instal kexts via KextHelper.

reboot

http://www.mediafire...w7qkcxhhmv99h14

add:It should work with everything off grapgic enabler and use Natit, or Evoenabler for display resolution.



#1849
ZPK

ZPK

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:Russia/Yaroslavl
how about 10.6.7 ?)

#1850
leopard69

leopard69

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

how about 10.6.7 ?)


Works for my Sapphire x1950Pro. After upgrading from 10.6.6 I just had to replace the AtiRadeonx1000 & Ati1900Controller Kexts with the ones linked in foxman's post (http://www.mediafire...w7qkcxhhmv99h14)

HTH

#1851
foxman

foxman

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
This is new kexts for 10.6.7 ;)

http://www.mediafire...ry698z016c66zio

To enable change graphic resolution must be instaled Chameleon
with Graphics Enabler is allowed.

Works in 32/64 Bits mode.

#1852
adv_j

adv_j

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
What about Radeon X1950 GT (id 7288). Can I try kext for 7280 after install 10.6.7 update?

#1853
palagroup

palagroup

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

This is new kexts for 10.6.7 :)

http://www.mediafire...ry698z016c66zio

To enable change graphic resolution must be instaled Chameleon
with Graphics Enabler is allowed.

Works in 32/64 Bits mode.




Hi, I'm using x1950 Pro (7280), and I dunno how to use the Chamaleon approach, but I managed to have 10.6.7 With QE/CI But only 1024x768 Resolution.

The Foxman drivers didn't work with my setup, or require #####, or something else. I tried updating Chamaleon, and enabling the Graphics Enabler, and it seems to freeze the screen on boot, so I cannot work beyond that.

My steps:
1. Install SnowOSX Universal 10.6
2. Install MacOS 10.6.7 Combo Update
3. Install Zahary's drivers for 10.6.5 as in
http://www.insanelym...00#entry1614287

Now I'm trying to get full resolution using either EVOEnabler (When I find out how) or any other suggestion from you guys.

I'm just trying to keep this as simple as I can.

Luck.

#1854
Goron

Goron

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 328 posts
  • Gender:Male
  • Location:somewhere out there ...

This is new kexts for 10.6.7 :D

http://www.mediafire...ry698z016c66zio

To enable change graphic resolution must be instaled Chameleon
with Graphics Enabler is allowed.

Works in 32/64 Bits mode.



Kind of works:

with your kexts, i get resolution change, rotation and dual screen, but no qe/ci at all :)

How did you manage to enable QE/CI?

#1855
bigb1979

bigb1979

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

This is new kexts for 10.6.7 :)

http://www.mediafire...ry698z016c66zio

To enable change graphic resolution must be instaled Chameleon
with Graphics Enabler is allowed.

Works in 32/64 Bits mode.


Hey Foxman!

Your drivers working for my x1950 pro

however i have some strange Artefacts from time to time since 10.6.6.

Any ideas what this could be ???


Thanks !!!

#1856
themax

themax

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Hi!!!

This work for Lion??

Any one tested?

#1857
palagroup

palagroup

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

This is new kexts for 10.6.7 :angel:

http://www.mediafire...ry698z016c66zio

To enable change graphic resolution must be instaled Chameleon
with Graphics Enabler is allowed.

Works in 32/64 Bits mode.



I need some help on this.

As far as I can see, after installing this package, on my machine it freezes the screen on the rolling-star Apple logo on startup, but the OSX doesn't hang or freeze at all.

I know this because I see the hard drive activity. Even more, I managed to log in to my user account blindly, so I cannot see anything on screen.

Is this because some Power Management setting I don't know how to turn off?

Could Anybody help me on this??

I'm running a 1950 pro (7280) on 10.6.7 using only SnowOSX Universal 10.6 and the Combo Update.

What I have so far, as I put in a previous post, is 10.6.7 QE/CI OK, BUT 1024x768 Stuck.

Thkx...

#1858
Max_NL

Max_NL

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Everything broke with 10.6.8. Did somebody get it working again?
Trying but untill now no success... :-(

Update: if I use kexutil then it says that __vtable ZTV29R520 Powerplaymanager is malformed.
The kext ATI1900Controller.kext is not loaded.

#1859
bigb1979

bigb1979

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
Lion ?? Does this work on 10.7.0 ?? Anyone ??

#1860
Emofis

Emofis

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
works on my 10.6.7 with foxman's kexts+azerelbn chameleon rc4(maybe i've misspelled it)+graphics enabler
any news about 10.7?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy