Jump to content

Work x1950gt pro ! Dev_ID = 0x72801002 and 0x72881002 !


  • Please log in to reply
1885 replies to this topic

#1421
Bryon80

Bryon80

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Awesome, thank you so much for the update. Works like a charm ;)

#1422
MTZeon

MTZeon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Location:Portugal
Hi there Bronya,

I've updated the drivers and OpenGL framework for 10.5.5 and installed your drivers. It doesn't work on my PowerColor X1950Pro AGP card, it does boot up but all I get is a blue screen and I can move the mouse around but no desktop. My card uses dual-dvi, and I use a converter from dvi to vga in order to connect to my monitor.

Can you help?

Thanks.

EDIT: IT WORKS!!! I've managed to make a combination of your drivers and other drivers and I now have a fully working X1950PRO AGP card working and recognized as AGP!!! I'll post ASAP the files for those that are interested :) Thank you so much Bronya!

#1423
MTZeon

MTZeon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Location:Portugal
Ok, here are the files I used after upgrading my Leopard to 10.5.5 (just the OpenGL.framework - which is included with latest Bronya's drivers - and the drivers):

http://www.sendspace.com/file/dxs6hr

Enjoy. Feel free to add it to the first post Bronya, I think many AGP users of X1950Pro will be thankfull :)

Some proof:

Attached File  x1950proagp.png   951.03KB   152 downloads

#1424
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 917 posts
  • Gender:Male

Ok, here are the files I used after upgrading my Leopard to 10.5.5 (just the OpenGL.framework - which is included with latest Bronya's drivers - and the drivers):

http://www.sendspace.com/file/dxs6hr

Enjoy. Feel free to add it to the first post Bronya, I think many AGP users of X1950Pro will be thankfull :)

Some proof:


Ok , i add driver . )))

#1425
lyon25

lyon25

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Thanks, BRONYA and MTZeon, for this good job.
My card, Sapphire X1950 Pro AGP finally work with everything ok, QE/CI, dual display's, Rotation, change the resolution... :) .

MTZeon forget to include the OPENGL.framework in the package for the AGP driver, i let the complet instalation here: MTZeon_X1950Pro_AGP.zip

Thanks, Again.

#1426
MTZeon

MTZeon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Location:Portugal
:) Glad to hear that it worked :P Finally, after almost six months!

I didn't include the OpenGL framework because I think we might need to update the framework on the future and didn't want to have to rebuild the zip file every time it changed :D Also, they are already included on Bronya's drivers, so I left them out. I've downloaded tho your file, and saved it as a backup, in case I need to reinstall this all over again :D

Trying to build a boot-132 cd in order to install retail DVD I have with the settings to this mobo+vga+sound+wifi :D

#1427
djwild

djwild

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Spain
Update with Leo 10.5.5, works great!!!!

YOU..... ARE..... THE..... BEST!!!!

Thanx so much!!!!!

#1428
polyacryl

polyacryl

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
Hello people,

I still do not get it right. I have a Saphirre x1950 GT (PCI Express, 256MB, id 7288) and tried various combinations of Bronya's driver for 10.5.5 and 10.5.3. If I only install Bronya's driver for 10.5.5 I get a kernel panic. If I use ATIRadeon* from Bronya's 10.5.3 package in combination with the rest of the 10.5.5 package, I get a blue screen and a mouse cursor and nothing happens.

I am really confused about which are the right files for my graphics card. Please help me, I really would appreciate it. Thank you.

Edit: After testing some more last night, I think that it is ATIRadeonX1000.kext which is causing the kernel panic at boot up. I tested all of the other files in various combinations, without success, but without kernel panic, too.

#1429
starimage

starimage

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male
  • Location:Russia
Saphirre x1950 GT (PCI Express, 256MB id 7288) пока не работает :( Либо синий экран (со старыми драйверами), либо кернеллпаник (с новыми). ОЧень надеюсь на Вашу поддержку .

#1430
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 917 posts
  • Gender:Male
Kernel panic ?
ok , maybe tomorrow or two day tomorrow...

#1431
polyacryl

polyacryl

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
Here is a picture of the kernel panic I mentioned above. Maybe it provides some useful information.

Posted ImagePosted Image

#1432
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 917 posts
  • Gender:Male

Here is a picture of the kernel panic I mentioned above. Maybe it provides some useful information.


OMG ! TNX . I found problem ... Please wait for 7288 !

#1433
General_Cartman

General_Cartman

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
  • Location:The Confederacah! (Melbourne, Victoria, Australia)
Works like a charm on my X1950 pro! Bronya, you are the man! Thanks a lot!

#1434
Alex HQuest

Alex HQuest

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 184 posts
  • Gender:Male
Coming back from sleep does not quite work.

ASCII art time (I'm currently at work and didn't took any picture while at home):

Only 1st quarter of my screen is "working", others are (B)lack.

+-------+-------+
|	   |   B   |
+-------+-------+
|   B   |   B   |
+-------+-------+

However, on this "working" quarter, I have lots of purple lines flashing randomly. I can move mouse, click on Apple logo and chose to sleep/power down/restart, and machine does obeys to these requests. But it is otherwise unusable.

Can someone else test sleep with a X1950 Pro/GT card, and report his/her findings?

Bronya, any log/output I may need to provide you to help fixing this issue?

Regards.

#1435
Nadeem

Nadeem

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Why sleep isnt working with this card ?

I have fan spinning at full speed after wake from sleep.

#1436
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 917 posts
  • Gender:Male
HI !
Try the it driver for 0x7288 Attached File  ATIRadeonX1000.zip   548.85KB   476 downloads!


Alex HQuest, Nadeem, sorry i dunno ((( for sleep .

Here is a picture of the kernel panic I mentioned above. Maybe it provides some useful information.

Posted ImagePosted Image



Your kernel 9.2.2 ! You should have kernel 9.5.0 !

#1437
TomBuntu

TomBuntu

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts

HI !
Try the it driver for 0x7288 Attached File  ATIRadeonX1000.zip   548.85KB   476 downloads!


Alex HQuest, Nadeem, sorry i dunno ((( for sleep .




Your kernel 9.2.2 ! You should have kernel 9.5.0 !


Hi Bronya,

I am having the exactly same problem with my X1900XT after installing your latest driver. Kernel panic! Any ideas? Thank you.

-Tom

#1438
empty skull

empty skull

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,544 posts
  • Gender:Male
  • Location:Italy

Hi Bronya,

I am having the exactly same problem with my X1900XT after installing your latest driver. Kernel panic! Any ideas? Thank you.

-Tom


for ati x1900xt

for the 10.5.5 see this
for the 10.5.4 see this

#1439
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 917 posts
  • Gender:Male
empty skull, tnx for help . I have no time ...

#1440
empty skull

empty skull

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,544 posts
  • Gender:Male
  • Location:Italy
tnx at you for your work !!! good work !

Bronya you have idea for work two ATI card ? i have tested but i reconfused the ram , efi .. but don't read the monitor ...

i have use the efi string ...
ATI Radeon X1950 Series:

  Modello Chipset:	ATI Radeon X1950 Series
  Tipo:	Monitor
  Bus:	PCIe
  Larghezza Lane PCIe:	x16
  VRAM (totale):	512 MB
  Fornitore:	ATI (0x1002)
  ID dispositivo:	0x7244
  ID revisione:	0x0000
  Versione driver EFI:	01.00.219
  Monitor:
Acer AL2216W:
  Risoluzione:	1680 x 1050 @ 60 Hz
  Profondit:	Colore 32-bit
  Core Image:	Hardware accelerato
  Monitor principale:	S
  Mirror:	Spento
  Online:	S
  Quartz Extreme:	Supportata
  QuartzGL:	Supportata
  Rotazione:	Supportata
Mostra connettore:
  Stato:	Nessun monitor collegato

ATI x1950xt 2 card EFI: ( ho chiamato io cosi la scheda per identificazione ) 

  Modello Chipset:	ATI x1950xt 2 card EFI
  Tipo:	Monitor
  Bus:	PCIe
  Larghezza Lane PCIe:	x1
  VRAM (totale) :256 MB
  Fornitore:	ATI (0x1002)
  ID dispositivo:	0x7244
  ID revisione:	0x0000
  Revisione ROM:	113-B2250F-207
  Versione driver EFI:	01.00.207
  Monitor:
Mostra connettore:
Mostra connettore:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy