Jump to content

Christmas Miracle ! Juhui !


  • Please log in to reply
9 replies to this topic

#1
scotch12

scotch12

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hi All,

after installing OSX several times, trying out patches, fixes and so on .....
The best result i could get was:

Audio working but only Stereo (edited kext)
Network working (using skge.kext)
Firewire working out of the box
USB Working out of the box
ICH8 Support
Jmicron PATA and SATA working (edited kext)

ATI X1950XTX 512MB , no dual screen, have to use DVI to VGA adapter, QE and CI supportet, resolution 1600x1024
(not native resolution, would be 1680x1050, but was not possible)

This was already a good working mac, but not perfect enough for me, so i was thinking about to stop
that project.
Last try with a Nvidia (7900GS) card from a friend:
Put in the card and made a new installation.
Installed Natit for Nvidia and patched the other things (audio, nic ....)
Result:
DVI out is working, Dual Head only Mirror mode, power saving not working and my Monitors were recognized correctly !!

Ok this is better than with the ATI Card, but to buy a new Nvidia Card just for a better working mac clone ? NO !

So, the test with the Nvidia Card was interesting but thats it, and i changed my ATI back into the machine.
Bootet up in to OSX without to change somthing.
And Voila, DVI was working and a the resolution was 1024x768 not changeable.
Now, copied the natit_edited kext file into the Extensions folder, cleaned up the system and reboot.

And to my large astonishment, everything is now perfect !!!
Full Dual Head Support, DVI out for both LCD's, powersaving is working, QE and CI support !!! Juppiiiii !!!
I am so Happy now !! Nearly a perfect mac clone !!

mery christmas to all

Marcus

PS: see my screenshots !!

Attached Files



#2
Wayland

Wayland

    Broadcast Engineer

  • Gurus
  • 421 posts
  • Location:CA
Very Few have these cards to play with, so they might not top the most wanted cards... but congrats! Good to see this card working!!!




Hi All,

after installing OSX several times, trying out patches, fixes and so on .....
The best result i could get was:

Audio working but only Stereo (edited kext)
Network working (using skge.kext)
Firewire working out of the box
USB Working out of the box
ICH8 Support
Jmicron PATA and SATA working (edited kext)

ATI X1950XTX 512MB , no dual screen, have to use DVI to VGA adapter, QE and CI supportet, resolution 1600x1024
(not native resolution, would be 1680x1050, but was not possible)

This was already a good working mac, but not perfect enough for me, so i was thinking about to stop
that project.
Last try with a Nvidia (7900GS) card from a friend:
Put in the card and made a new installation.
Installed Natit for Nvidia and patched the other things (audio, nic ....)
Result:
DVI out is working, Dual Head only Mirror mode, power saving not working and my Monitors were recognized correctly !!

Ok this is better than with the ATI Card, but to buy a new Nvidia Card just for a better working mac clone ? NO !

So, the test with the Nvidia Card was interesting but thats it, and i changed my ATI back into the machine.
Bootet up in to OSX without to change somthing.
And Voila, DVI was working and a the resolution was 1024x768 not changeable.
Now, copied the natit_edited kext file into the Extensions folder, cleaned up the system and reboot.

And to my large astonishment, everything is now perfect !!!
Full Dual Head Support, DVI out for both LCD's, powersaving is working, QE and CI support !!! Juppiiiii !!!
I am so Happy now !! Nearly a perfect mac clone !!

mery christmas to all

Marcus

PS: see my screenshots !!



#3
jccool

jccool

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts
Hello, I have an X1950xtx and want to have dvi support w/o buying an nvidia card, can you post the moddified natit ketxt and write how to use it,

Thank You,
Jccool

#4
gu3d3s

gu3d3s

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 441 posts
  • Location:Fort-CE-BR
Hi, mery christmas to all

Congratulations man! you make a drean off all hacintosh user...

Now if possible, send more inforation, and all files used in your system...

[]'s

#5
BarryBar

BarryBar

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 118 posts
Congratulations!

Because I am also considering to buy a x1950 xtx I would like to know whether your xtx is from ATI or from another vendor?

#6
scotch12

scotch12

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hi BarryBar,

i am using the ASUS EAX1950XTX/HTVDP/512M

will post my files later today.

this card is running nearly perfect.
the only disadvantage is that the fan always runs with 100%


Marcus

#7
scotch12

scotch12

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Here are the kext i am using for my X1950XTX 512MB

Marcus

Attached Files



#8
BarryBar

BarryBar

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 118 posts

Here are the kext i am using for my X1950XTX 512MB

Marcus





Thanks a lot, Marcus for the info and the uploaded files.

#9
pulse00

pulse00

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Thank you so much! Finally this card is up and running :D


One question though... is there a way to control the fan speed? when i boot into osx, the fan seems to be at max speed, which is quite loud. also, i'm not so sure if it's good for the cards lifetime to keep running at max speed.

#10
roger santos

roger santos

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Brazil
it worked for me too
but the noisy fan (at max speed) is a problem =/





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy