Jump to content

OSX on HP Pavilion Elite

- - - - -

  • Please log in to reply
95 replies to this topic

#1
Icchan-san

Icchan-san

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Puerto Ordaz, Venezuela
Step 1 Getting Ready

- Download and Burn the DVD image iAtkos v5i.
- Download and Extract the BIOS v5.17 MOD or BIOS v5.23 MOD make sure your Motherboard model is Asus IPIBL-LB. If your PC is similar but your motherboard is Asus IPIBL-LA you can try this BIOS 5.08 MOD, this is not a MOD bios but work perfect :dev: (Thx, igotjshoe)
- Download and Extract Afuwin
- Prepare your Partition or your Hard Disk to install Leopard

Step 2 Modding the Bios

Here some pics:


Posted ImagePosted Image


To flash the ROM Bios you have to open Afuwin make sure you are the administrator, here is the info with pics

This is what you have to do in Afuwin, make sure your not running weird programs:

IMPORTANT: Make a Backup of your BIOS

Posted Image

Be careful about the BIOS Flashing, if you dont wanna flash the BIOS just try cpus=1 in darwin

Step 3 Installing Leopard

Click Here for Screenshots!

- Restart your computer and go to the BIOS
- Go to Advanced Tab, set your SATA1 Controller Mode to AHCI Mode
- Now go to the Power Tab and Enable the processor's XD Features, Saving and Exit.
- Boot into the DVD by pressing ESC key at the BIOS Prompt and the installer should load now.
- Select your Language
- Use Disk Utility from the Utilities menu. In Disk Utility, Select your Partition, and format you should choose Mac OS Extended (Journaled). After partitioning, quit Disk Utility to return to the Leopard Installer. Important: Partitioning the disk erases the entire disk, so make sure you back up your important files first.

Step 4 - Customize (Updated 09/01/09)

iAtkos V5i Main System
Bootloader:
- PC Efi v9
X86 Patches:
- Decrypters:
-- AppleDecrypt
- SMBIOS Drivers:
-- Apple SMBIOS Enablers:
--- SMBIOS-EFI
- Disabler.kext
- OHR
- PS/2 (For these with PS2 Keyboard/Mouse)
- Remove Thermal Kexts
Drivers:
- VGA
-- NVinject
-- nVidia:
--- EFI String for nVidia:
---- 8600 GT 512MB
System:
- SATA/IDE:
-- Intel AHCI SATA

- Leopard will now install. This can take a while, so be patient.
- It will ask you to Reboot and dats it.

Step 5 Dual Boot

Theres alot of forums about this, google is your friend.

PPost Installation (Updated 09/01/09)

You'll need to install the driver for the Wireless
Wireless: HERE (Ralink RT73)

Fixing Audio and Sleep for OSX 10.5.6 (Updated 09/01/09)

Audio: HERE (ALC888S)
Sleep Issue: HERE
Video: HERE (8400-8800)

How to fix unknown processor string in "About this Mac"

go to System/Library/CoreServices/Resorces/English.lproj

You will find a file "AppleSystemInfo.string" open it using TextMate and find "UnknownCPUKind" = "Unknown";
replace unknown with the type of your processor for example, Intel Core2 Quad. make sure you change only letters only not the special characters like =, " or ;. Save it, it will ask for your permission, enter your password and you are all set, no need to reboot.

How to change "About this Mac Graphic"

To use these you need to backup the current MacOSX.tif in /System/Library/CoreServices/loginwindow.app/Contents/Resources and then delete MacOSX.tif

Then rename the file you download to MacOSX.tif and copy it to /System/Library/CoreServices/loginwindow.app/Contents/Resources

Then fix permissions.

Logout and login then view About This Mac.

And Check HERE for lots of icons Posted Image

TIPS:
About Leopard Fails Sleep when idle, some apps like Paragon NTFS or MacFuse can affect the OS, try deactivating them and thats it, this Issue even affect the MacBook Pro.

Heres a Preview: YouTube - Running Leopard on HP Pavilion Elite

Update: After Mod you can install any version, even retail version Posted Image

Posted Image

P.D: Sowwy about my English and Good Luck :graduated:

#2
Guest: tsh9_*

Guest: tsh9_*
  • Guests
Hi,I tried to install Leopard on my HP Pavilion Elite m9250f by following your instructions but unfortunately, it was not successful.- I've downloaded and burned the DVD image of Leo4all v3- I've set the HD to AHCI Mode.- Booted into the DVD by pressing ESC key at the BIOS Prompt but the installer does not load.- My system reboots over and over ...I did not flash the BIOS ... I don't really want to mess with that.Could you please tell, what I can do I'm noob !Thanks!

#3
Icchan-san

Icchan-san

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Puerto Ordaz, Venezuela
Without flashing the BIOS you can try with JaS 10.5.4, without any flags after installation u have to type in darwin cpus=1 to boot and dats it baby, enjoy LeopardPD: About Afuwin, u can backup ur BIOS, for fully funcionality try MOD, u can always go back to ur original BIOS using Afuwin if u make ur backup :thumbsup_anim:

#4
Guest: tsh9_*

Guest: tsh9_*
  • Guests
Thanks, I will try that this week-end !Thanks again ...

#5
Guest: tsh9_*

Guest: tsh9_*
  • Guests
Hi Icchan-san,I've finally decided to flash my bios ...I've been able to install leopard but when it reboots after the installation my monitor goes black.Could you tell me in the customize screen in the installation process what options did you checked?Thanks for you're help !

#6
Icchan-san

Icchan-san

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Puerto Ordaz, Venezuela
Hey there tsh9, go to your BIOS, in Advanced Tab, set your SATA1 Controller Mode to AHCI Mode, then go to Power Tab and Enable the processor's XD Features. Save and Exit. Boot into the DVD, at this point check the Step 3, in the customize screen, I check:
  • Kernel: Vanilla Kernel 9.2.2
  • AppleSMBIOS: DDR800
  • Audio: ALC888 (just work for 2.1 and need patch for HDA, look in this forum for toruga's thread)
  • Graphics Drivers: NVinject - Nvidia 8600 GT 512mb (you have to download another one after installation, http://scottdangel.com/blog/?p=15)
  • Network Drivers: Dont Check anything and download the one in the tutorial
  • ACPIPlatform: Stock version 1.2.1
If you MOD your BIOS dont need to use any flag to boot after this Installation, and as I said in the tutorial you can even try Retail Version, good luck and enjoy Leo :PHere is a little motivation... http://i455.photobuc...ma/Picture3.png

#7
Guest: tsh9_*

Guest: tsh9_*
  • Guests
Hi Icchan-san,I was able to install Leopard and everything works... If you were right next to me I would have kissed U !You mentioned that after the Mod I can install any version of Leopard, even retail version. Can I also update Leopard throught "Mac OSX software update"Thanks man !

#8
Icchan-san

Icchan-san

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Puerto Ordaz, Venezuela
Yeah, just with the retail version, with other u have to download the package and do a couple stuff... but its not a big deal :PI'm glad it works for u ^.^ enjoy.

#9
Guest: Guest: bpoecell_*_*

Guest: Guest: bpoecell_*_*
  • Guests
I flashed my bios and now I get a Default bios settings have been loaded due to bios update or checksum issue. every time i set the hd to ACHI it gives me that and i can't install. any suggestions?

#10
Guest: Guest: bpoecell_*_*

Guest: Guest: bpoecell_*_*
  • Guests
Also I can't install Windows anymore, when I try it only shows two gigabytes of space and doesn't see either of my 320 gig hard drives.

#11
Icchan-san

Icchan-san

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Puerto Ordaz, Venezuela
Hi bpoecell, do u have this computer? or one similar? Can u tell me your PC SpectsAbout Windows, did u try setting your BIOS to RAID again?

#12
Guest: tsh9_*

Guest: tsh9_*
  • Guests
Hi icchan-san,I was wondering what "combo update" did you use to go from 10.5.2 to 10.5.5.Thanks again, you have been a great help for a noob like me.

#13
Guest: Guest: bpoecell_*_*

Guest: Guest: bpoecell_*_*
  • Guests
It's an HP Pavillion Elite m9300t with the Asus IPIBL-LB motherboard. I'm back into windows now, but bios is still messed up. When you flashed you bios, did you flash the main bios image, or all blocks?

#14
Icchan-san

Icchan-san

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Puerto Ordaz, Venezuela

Hi icchan-san,I was wondering what "combo update" did you use to go from 10.5.2 to 10.5.5.Thanks again, you have been a great help for a noob like me.

Hi tsh9, you need this one Desktop Combo Update 10.5.5 Theres tutorials in this forum about updating, just follow the steps and cross your fingers ^.^

#15
Icchan-san

Icchan-san

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Puerto Ordaz, Venezuela

It's an HP Pavillion Elite m9300t with the Asus IPIBL-LB motherboard. I'm back into windows now, but bios is still messed up. When you flashed you bios, did you flash the main bios image, or all blocks?

Ok check the Post again... hope it helps

#16
Guest: Guest: bpoecell_*_*

Guest: Guest: bpoecell_*_*
  • Guests
Thanks Icchan-san :thumbsup_anim: . That other page out flashing the bios was kind of vague, I'm sure I did something wrong.

#17
Guest: Guest: bpoecell_*_*

Guest: Guest: bpoecell_*_*
  • Guests
It works beautifully now! Which wireless driver did you install from the three that download in that package?

#18
Icchan-san

Icchan-san

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Puerto Ordaz, Venezuela

It works beautifully now! Which wireless driver did you install from the three that download in that package?

Great News! you have to use the latest one, 10.5.x. enjoy

#19
brycedemise

brycedemise

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Alright, first off I would just like to thank you deeply for your helpful forum. After like 8 failed attempts using the new iDeneb v1.3 I read through your helpful post and VOILA! It works like a charm. I just got done playing quake 4 on my new mac pro with my 8500gt card working beautifully. However I still have two issues, one being kindve huge to me. The wifi, I have used the driver the provided and it didnt work in 10.5.5 which is what iDeneb installs into. I've even tried a few other custom ralink installs and still nothing. Is there something I'm missing? Is there something I'm supposed to do to turn it on?Also, I have a TV tuner card with a nice remote and I was wondering if maybe there was a way to use it in OS X? Probably not, but it would hella sweet to be able to use my remote and maybe the TV tuner card for my cable so I can record shows. I have an m9252p so I'm sure the hardware is different then yours, but still thanks SOOOOOO much with what patches I should install, the modded BIOS (which I used) and the AHCI hint in the bios. On one last note, does sleep work on yours? I only installed the vanilla kernel but sleep doesnt work really on my system.Thanks!-Bryce

#20
Icchan-san

Icchan-san

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Puerto Ordaz, Venezuela
Hi brycedemise, this tuto its kinda old XD but yeh everything works in mine, shut down, restart, sleep, read the post installation part to get the wireless driver :DWell I dont know whats yours, maybe you have another one, can you tell me your wireless chipset?I will update this post today





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy