Jump to content

Vaio Still Waiting For Root Device


  • Please log in to reply
7 replies to this topic

#1
geocool

geocool

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Location:Greece
My Notebooks is Sony Vaio VPCEB1S1E

Its sata controller is Intel Corporation Series 5/3400 series chipset AHCI.
I've searched its vendor and it is already in AppleAHCIPort, so I believe that AHCI is working ( bios doesn't have option to change,IDE,SATA,RAID and also notebook doesn't have IDE on it)

My Problem:
I'm trying to install Mountain Lion.
At first i had a PCI Configuration stuck problem. I solved it by replacing AppleACPIPlatform IOPCIFamily from osx 10.6.7 version.Now I stuck on "still waiting for root device".
I tried to install from usb by removing all other hard drives.
I tried to install from hard drive by removing usb and other hard rives

Flags I Tried: -v -x npci=0x2000 busration=17 GraphicsEnabler=No UseKernelCache=No darkwake=0 PCIRootUID=0 rd=disk0s1 and some more that I can't remember.

Kexts I Tried: IOUSBFamily.kext found on topic talking about the same problem and the AHCI_Extetended_Injector.


I read that "Still Waiting For Root Device" is related to reading USB or Hard Drive problem.

Can someone tell me what the problem may be and/or a possible way to fix it ?
Thanks In Advance For Your Time.


Update:
LSPCI Output:

00:00.0 Host bridge [0600]: Intel Corporation Core Processor DRAM Controller [8086:0044] (rev 02)
00:01.0 PCI bridge [0604]: Intel Corporation Core Processor PCI Express x16 Root Port [8086:0045] (rev 02)
00:16.0 Communication controller [0780]: Intel Corporation 5 Series/3400 Series Chipset HECI Controller [8086:3b64] (rev 06)
00:1a.0 USB controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b3c] (rev 05)
00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 05)
00:1c.0 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 [8086:3b42] (rev 05)
00:1c.1 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 [8086:3b44] (rev 05)
00:1c.2 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 [8086:3b46] (rev 05)
00:1c.5 PCI bridge [0604]: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 [8086:3b4c] (rev 05)
00:1d.0 USB controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b34] (rev 05)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev a5)
00:1f.0 ISA bridge [0601]: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller [8086:3b09] (rev 05)
00:1f.2 SATA controller [0106]: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller [8086:3b29] (rev 05)
00:1f.3 SMBus [0c05]: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller [8086:3b30] (rev 05)
00:1f.6 Signal processing controller [1180]: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem [8086:3b32] (rev 05)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Madison [Radeon HD 5000M Series] [1002:68c1]
01:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI Redwood HDMI Audio [Radeon HD 5000 Series] [1002:aa60]
02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
03:00.0 SD Host controller [0805]: Ricoh Co Ltd MMC/SD Host Controller [1180:e822]
03:00.1 System peripheral [0880]: Ricoh Co Ltd R5U2xx (R5U230 / R5U231 / R5U241) [Memory Stick Host Controller] [1180:e230]
03:00.4 SD Host controller [0805]: Ricoh Co Ltd MMC/SD Host Controller [1180:e822]
04:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB] [11ab:4381] (rev 11)
3f:00.0 Host bridge [0600]: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers [8086:2c62] (rev 02)
3f:00.1 Host bridge [0600]: Intel Corporation Core Processor QuickPath Architecture System Address Decoder [8086:2d01] (rev 02)
3f:02.0 Host bridge [0600]: Intel Corporation Core Processor QPI Link 0 [8086:2d10] (rev 02)
3f:02.1 Host bridge [0600]: Intel Corporation Core Processor QPI Physical 0 [8086:2d11] (rev 02)
3f:02.2 Host bridge [0600]: Intel Corporation Core Processor Reserved [8086:2d12] (rev 02)
3f:02.3 Host bridge [0600]: Intel Corporation Core Processor Reserved [8086:2d13] (rev 02)

Update2:
Added An Image
Posted Image

#2
3.14r2

3.14r2

    The Round One

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,333 posts
  • Location:Molvania
Pleas post the LSPCI output.

BTW "PCI Configuration" problem in most cases can be solved using npci=0x2000 flag.

"Still waiting" error usually indicates that OS can not use the disk controller properly. This could be a driver or hardware related issue.

#3
Tikifg

Tikifg

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
I know it sounds strange, but I solved the "waiting for root device" by unplugging and re-inserting my USB stick with the installer on.

#4
geocool

geocool

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Location:Greece
I updated my first post with lspci output.
About PCI Configuration and waiting for root device, i'v used any possible combination of flags before starting changing kexts to fix them. :)

Edit:
I also tried what Tikifg said with no luck.

#5
geocool

geocool

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Location:Greece
I managed to install Mac OS X lion , without the error "still waiting for root device" ,so this problem must be related to Mountain Lion.
I've coped some kexts from Lion to Mountain Lion USB, like "IOUSBFamily" and some other ,but no luck.

#6
Pockets69

Pockets69

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Apparently your bios can't take over the USB, you need to boot with USBBusFix=Yes and all the other arguments relevant to your case, in mine, i just need the USBBusFix=Yes and -x -v (my laptop never booted the installer out of safe mode, although it worked great with no safe mode needed afterwards).

#7
geocool

geocool

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Location:Greece
Thanks for your answers.
Unfortunately the combination of flags you suggested didn't work. What version of mountain lion did you install ?

#8
kvonlinee

kvonlinee

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts

you can put the kext


GenericUSBXHCI USB 3.0

http://www.osx86.net...do=file&id=3745


in Extra/Extentions then run my fix/myhack then it will be ready.


in your usb installer





discussion in




http://www.insanelym...-x-with-source/




and let see.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy