Jump to content

Problema pós 10.6.8

10.6.8 problema problem video graphics kernel legacy

  • Please log in to reply
17 replies to this topic

#1
Pietro

Pietro

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Boa tarde,
Estava seguindo a instalação do Mac por este tópico, pois possuo um GX620 também, pois então estava tudo correndo bem, pulei a parte do vídeo pois o graphicsenabler do myhack já o habilitou, e não uso o vídeo onboard, até aí tudo bem, rodei o myfix, e reiniciei sem problemas e sem o CD do i boot legacy, até a parte da atualização, fiz tudo como mandava, não reiniciei, apaguei o 'chocolate_kernel', e instalei o legacy do próprio tópico. Pois agora ao reiniciar meu computador o mac não funciona, a tela fica 'estranha', com umas listras brancas e pretas com pontos rosas azuis e verdes bem pequenos, vou postar uma foto logo, mas por favor quem já souber o problema, me ajude. Não tenho windows instalando no mesmo computador... Somente o MAC e esse computador com windows.

@edit
tá ai como fica a tela depois do boot...
Posted Image

Edited by Pietro, 28 December 2012 - 03:52 PM.


#2
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

dá uma boa leitura aki e aplica, deves ter de inserir o dev id nas kext da nvidia

http://www.insanelym...nvidia-geforce/

bom hack

#3
Pietro

Pietro

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
oi
me desculpe mas como posso bootar o imac para poder inserir a dev id? com algum comando no boot creio eu, porem qual?

#4
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

talvez com

-v GraphicsEnabler=No

ou com o cd de boot k usaste para instalar

bom hack

#5
Pietro

Pietro

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
oi
e me desculpe pelo incomodo, mas novamente preciso de ajuda, dentro da info.plist da kext, existe a key IOPCIPrimaryMatch e é ela que deve ser editada, e conforme o post http://www.insanelym...nvidia-geforce/
devo inserir 0xDevIdVenId, porem existem muitas keys dentro do <string> e todas dividas por um ";", por exemplo: 0x00f010de&amp ;0xfff0ffff. E qual delas devo editar, todas? E as de antes ou depois do ";"?
obrigado pela atenção

#6
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

faz uma copia das kext originais

e mete so teu

0xdevid10de

precisas de instalar e reparar as permissões das kext depois de editadas.

bom hack

#7
Pietro

Pietro

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
oi,
e denovo, não deu certo... Copiei o info.plist da kext, editei, e colei, reparei as permissões pelo disk utility e reiniciei, e continuou com o mesmo problema, fiz algo errado?

#8
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

são 2 as kext

nv*50hal
nvresman

bom hack

#9
Pietro

Pietro

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
oi
porem na kext NVDAResman não existe key IOPCIPrimaryMatch para inserir a id, como devo proceder ou estou fazendo algo errado ainda?

#10
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

1 imagem vale + k mil palavras

Attached File  Captura de ecrã 2012-12-28, s 17.59.31.png   36.28KB   10 downloads Attached File  Captura de ecrã 2012-12-28, s 18.01.13.png   33.28KB   15 downloads

depois tens de usar

GraphicsEnabler=Yes

bom hack

#11
Pietro

Pietro

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
oi

acho que estou com algum problema na minha NVDAResman.kext pois olhe:
Posted Image


não existe IOPCIPrimaryMatch... O que eu posso fazer agora?

#12
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

cara nem com imagem...

tá 1 sem e outra com

muda o nome

uma tem iopcimatch > iopciprimarymatch é a mesma chave e na mesma kext

bom hack

#13
Pietro

Pietro

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
oi,
me desculpe, mas não há nada semelhante, olhe só o meu info.plist do NVDAResman.kext:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">

<plist version="1.0">

<dict>

<key>CFBundleDevelopmentRegion</key>

<string>English</string>

<key>CFBundleExecutable</key>

<string>NVDAResman</string>

<key>CFBundleGetInfoString</key>

<string>NVDAResman 1.6.36.10 (256.00.35f11)</string>

<key>CFBundleIdentifier</key>

<string>com.apple.NVDAResman</string>

<key>CFBundleInfoDictionaryVersion</key>

<string>6.0</string>

<key>CFBundleName</key>

<string>NVIDIA Resman Kernel Extension</string>

<key>CFBundlePackageType</key>

<string>KEXT</string>

<key>CFBundleShortVersionString</key>

<string>1.6.36</string>

<key>CFBundleSignature</key>

<string>????</string>

<key>CFBundleVersion</key>

<string>6.3.6</string>

<key>IOKitPersonalities</key>

<dict>

<key>NVRM</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.NVDAResman</string>

<key>IOClass</key>

<string>NVDA</string>

<key>IOMatchCategory</key>

<string>IOFramebuffer</string>

<key>IONameMatch</key>

<array>

<string>NVDA,NVMac</string>

</array>

<key>IOParentMatch</key>

<dict>

<key>IOPropertyMatch</key>

<dict>

<key>NVCLASS</key>

<string>NVDA</string>

</dict>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

</dict>

<key>IOProbeScore</key>

<integer>60000</integer>

<key>IOProviderClass</key>

<string>IONDRVDevice</string>

</dict>

</dict>

<key>OSBundleCompatibleVersion</key>

<string>1.2.0</string>

<key>OSBundleLibraries</key>

<dict>

<key>com.apple.iokit.IOGraphicsFamily</key>

<string>1.5</string>

<key>com.apple.iokit.IONDRVSupport</key>

<string>1.5</string>

<key>com.apple.iokit.IOPCIFamily</key>

<string>2.4</string>

<key>com.apple.kpi.bsd</key>

<string>9.0.0</string>

<key>com.apple.kpi.iokit</key>

<string>9.0.0</string>

<key>com.apple.kpi.libkern</key>

<string>9.0.0</string>

<key>com.apple.kpi.mach</key>

<string>9.0.0</string>

</dict>

<key>OSBundleRequired</key>

<string>Safe Boot</string>

</dict>

</plist>


o que fazer?
obrigado

#14
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

me manda as 2 kext juntamente com teu dev id

bom hack

#15
Pietro

Pietro

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
oi

aqui está as kexts (NVDANV50Hal pois minha placa de vídeo é acima da 8 (9500gt) e a NVDAResman.
dev id= 0640

Attached Files



#16
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

tenta com estas

Attached File  Kexts.zip   5.2MB   3 downloads

bom hack

#17
Pietro

Pietro

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
oi,
não funcionou, copiei as kexts e rodei o myfix, porém não funcionou, reiniciei o imac e houve o mesmo problema, mesmo usando o graphicsenabler=yes, imagina alguma outra solução?

#18
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

tenta com as kext originais

começa pela nvenabler

1 de cada vez

http://www.osx86.net...4.html?langid=1

bom hack





Also tagged with one or more of these keywords: 10.6.8, problema, problem, video, graphics, kernel, legacy


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy