Jump to content

Audio ALC888 and 5.1 channels , patch AppleHDA.kext

applehda alc888 audio 5.1 ep41-ud3l

  • Please log in to reply
No replies to this topic

#1
hackintosh1984

hackintosh1984

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Poland, Zamosc
Hello


I'm have problem in Mountain Lion with sound on ALC888 in EP41-UD3L and not run audio 5.1. Only 2 channel works - screen photo file I add to this post. Now use this file https://www.dropbox....pleHDA.kext.zip




In Lion, my sound was working perfectly using only AppleHDA + Plataform.xml + layout888.xml all added with HDA Wizard (link to this files:)

https://www.dropbox....0y9u/alc888.zip




I test more metod:

For Mountain Lion I make this (and not works for me - is't audio):
Posted Image VCH888
Posted 29 July 2012 - 04:38 PM


You need to rename layout888.xml to layout12.xml and edit inside layout12.xml to be as following

<key>LayoutID</key>
<integer>12</integer>

get perl script from zlib.pl.zip (by Revogirl, R.I.P.)

(compress)
perl zlib.pl deflate layout12.xml > layout12.xml.zlib


also;
perl zlib.pl deflate Platforms.xml > Platforms.xml.zlib

copy *.xml.zlib to /System/Library/Extensions/AppleHDA.kext/Contents/Resources/




------------------
------------------
And link to oryginal (not patched) AppleHDA.kext for Mountain Lion :

https://www.dropbox....z%20ML%20GM.zip


Please help me. Thanks.

Attached Files







Also tagged with one or more of these keywords: applehda, alc888, audio, 5.1, ep41-ud3l


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy