Jump to content

AMD dual graphics 6950 supported


  • Please log in to reply
94 replies to this topic

#41
qwrt

qwrt

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
still no way to boot with GE=yes with one HD6950 ? :(

boring white screen... ^^

#42
Jakweeze

Jakweeze

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
I'm sorry, I don't mean to be a jerk here, but is there any one that speaks english as a native language able to get it working? If so, could you write a step by step guide on how it was achieved with preferably say:

A) 1x6950/6970 1xHD3000 (since a lot more people have this combo than the following)
B) 2x6950/6970's

I personally run option (A) but could potentially figure out the steps and rewrite it if someone gave clear cut instructions from start to finish instead of a semi jibberish post (again no offense as english isn't your primary language buddy!) Furthermore the downloads are very mismanaged and all over the place, it wouldn't take much effort to clean them up into two downloads only, one for 10.7 and one for 10.8 with appropriately labeled folders in them that say "Step 1" then "Step 2" with kexts or what have you for each step in that folder!

#43
iGoodw1n

iGoodw1n

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
I have Intel HD3000 in my Core i5 2500K and MSI 6950. After installing OS X ML I can boot only with -x flag. What i need to install to disable my discrete videocard. I want to use only intel 3000 GPU.

#44
elidoe89

elidoe89

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
I have one issue, youtube freezes after about 10 seconds, when I move the progress bar it works again then after 10 secs it stops.
6950 on 10.7.5 using the guide on page 1.

#45
Phathak

Phathak

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
Anyone in here got their 6950 working under 10.8? Everywhere on the web people seem to be saying that it's supported but I can't find a proper guide that says how to fully make it work.

#46
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 543 posts
  • Gender:Male
  • Location:Treviso
Hello everyone, I'm trying to go with the HD6950 video card on my ML compoter in signature, I read your topic but I did not understand much, would you be so kind as to explain how to do (Sorry for my english but unfortunately I speak Italian)

#47
moob

moob

    InsanelyMac Protégé

  • Donators
  • 58 posts
  • Gender:Male
  • Location:Fiumicino, Italy

Hello everyone, I'm trying to go with the HD6950 video card on my ML compoter in signature, I read your topic but I did not understand much, would you be so kind as to explain how to do (Sorry for my english but unfortunately I speak Italian)

Hi i'm also italian, 6950 work for me with HD2500 set as primary gpu.
Basically run the boot with an intel HD (HD2000/2500/3000/4000 are fine) set as primary card by bios after the login screen unplug cable from intel HD and switch to 6950. In addition to this must be injected also a custom DSDT for the correct recognition of the card.

Posted Image

But now I've changed my video card so I can not help more.

Attached the DSDT code to add.

Attached Files



#48
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,021 posts
  • Gender:Male
Please post a IOreg.

#49
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 543 posts
  • Gender:Male
  • Location:Treviso
how did you make running this board with mountain, which kext you used
thanks

#50
moob

moob

    InsanelyMac Protégé

  • Donators
  • 58 posts
  • Gender:Male
  • Location:Fiumicino, Italy

But now I've changed my video card so I can not help more.

Please post a IOreg.


i switched to Radeon HD 7870 but i saved an old IOREG

localhost:~ unkonown$ ioreg | grep ATY
    | |   |   | +-o ATY,Gibba@0  <class AtiFbStub, id 0x1000002d5, registered, matched, active, busy 0 (5489 ms), retain 8>
    | |   |   | +-o ATY,Gibba@1  <class AtiFbStub, id 0x1000002d6, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | +-o ATY,Gibba@2  <class AtiFbStub, id 0x1000002d7, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | +-o ATY,Gibba@3  <class AtiFbStub, id 0x1000002d8, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | +-o ATY,Gibba@4  <class AtiFbStub, id 0x1000002d9, registered, matched, active, busy 0 (0 ms), retain 8>

how did you make running this board with mountain, which kext you used
thanks

I used the DSDT injection and nothing else.

#51
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 543 posts
  • Gender:Male
  • Location:Treviso
and how you entered the dsdt injection, I do not know how

#52
moob

moob

    InsanelyMac Protégé

  • Donators
  • 58 posts
  • Gender:Male
  • Location:Fiumicino, Italy

and how you entered the dsdt injection, I do not know how

http://rampagedev.wordpress.com/2012/07/01/how-to-inject-your-amdati-graphic-card-into-a-dsdt-36-2/

#53
lidiano

lidiano

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 543 posts
  • Gender:Male
  • Location:Treviso
You wanted this file

volevi questo file

Attached Files



#54
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,021 posts
  • Gender:Male

You wanted this file

volevi questo file

You wanted this file

volevi questo file


And this just shows that it is not working at all...

#55
IDefusee

IDefusee

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hi, I have my 6950 working on all 3 monitors (with built in radeon hd 3000 to boot and swap over vga cables). However, i can only boot in safe mode and booting in normal mode gives me a white screen on all the monitors plugged into the 6950. THe monitor plugged into the IGP shows the login screen, however after logging in it reboots.

System Details:
10.8 Mountain Lion
AMD Kernel (AMD Phenom II 1090t)
8GB RAM
MSI Twin Frozr II 6950 2GB (2 monitors plugged in via displayport > vga [active] and 1 plugged in via dvi to vga)

Im using the kexts from this thread and booting with:

-v -f -x GraphicsEnabler=no npci=0x3000 PCIRootUID=0

and no DSDT.

#56
mYrN

mYrN

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Any progress? I don't have build in graphics, is there a way to have hardware acceleration with two 6950's still?

#57
jackpot21

jackpot21

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hi! I'm italian, so sorry for my bad english.
I have a MBP retina with ML and pc with these spec:
mobo -> asus p6x58d-premium
ram -> corsair 24gb ddr3
cpu -> i7 920
hdd -> samsung ssd 830 256gb
graph cards: 2x hd 6950 in crossfire.

Now, i've installed ML in this pc, replacing the 2x 6950 with a 3870. After this i've found this post and I try to install the kext etc.. for my hd 6950 (I just tried with a single 6950), but when I reboot with GE=yes,
always appears the white screen :(

This is the way that I try:
- install osx with myhack (3870, ge=no) -> ok
- install the 7 kexts in the first post (3870, ge=no) -> ok
- replace the graphs card with 1x 6950 ge=no -> ok
- reboot and set ge=yes -> white screen :(

I also try installing the Oleg_Tr's patched kexts, but with ge=yes and 6950 installed, appears withe screen :(

Can someone help me pls?
Thanks a lot! :)

PS: the openGL viewer show me always "apple software render" with 0mb of graphs memory

#58
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 319 posts
  • Gender:Male
Hi jackpot try this bios setting primary boot first intuit 2nd slot start windows log in then restart mac clear white screen

#59
jackpot21

jackpot21

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hi jackpot try this bios setting primary boot first intuit 2nd slot start windows log in then restart mac clear white screen


Sorry but I haven't windows :(

#60
blackwalker

blackwalker

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 371 posts
sorry, but i miss the correct steps i have to do,
written in the first post! :help:





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy