Jump to content

[AMD] 10.7.3 Guide - Experimental Only

AMD Lion 1073 Guide Kernel

  • Please log in to reply
209 replies to this topic

#41
Devout

Devout

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts

~snip


what boot flags are you using?

#42
nerdkiller14

nerdkiller14

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
Can anyone help me whenever I use V4 of mach_kernel my pc resets. but when I use V5 it loads but only to USB portion and then is says "Still waiting for root device". thanks for any help in advance

#43
Tejaswi Rohit

Tejaswi Rohit

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male

Can anyone help me whenever I use V4 of mach_kernel my pc resets. but when I use V5 it loads but only to USB portion and then is says "Still waiting for root device". thanks for any help in advance


Post your PC's Config.

Make sure your HDD is set to AHCI mode in the BIOS and connected to the first SATA port :)

#44
nerdkiller14

nerdkiller14

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts

Post your PC's Config.

Make sure your HDD is set to AHCI mode in the BIOS and connected to the first SATA port :)


CPU:AMD fx-8120 4.7ghz
MEM: 8 GB DDR3 1333
HD: 80 GB SATA AHCI
MB: Sabertooth 990fx
CASE: CM HAF 932
GPU: Galaxy 560 Ti

Boot Flags for V5 I am using are: -legacy -v -f npci=0x3000

Posted Image

#45
iceblade112

iceblade112

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

what boot flags are you using?


-v npci=0x3000

arch=i386

or

-legacy -v npci=0x3000

arch=i386

or

or

-v -legacy npci=0x3000



#46
nerdkiller14

nerdkiller14

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts

-v npci=0x3000

arch=i386

or

-legacy -v npci=0x3000

arch=i386

or

or

-v -legacy npci=0x3000


as stated above

-legacy -v -f npci=0x3000

V4 just reads HFS+ when this is done is just restarts.
V5 gets past this goes to AppleUSBOHCI check sleep compatibility and then still waiting on root device as shown by my picture above.

My install procedure was :
1. Use Macbook Air and install OSX LION 10.7.3 (from app store not Iatkos) on Sata HD using a SATA to USB
2. Install chameleon boot loader and replaced mach_kernel
3. Put HD in computer and tried to boot.

#47
Devout

Devout

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts

as stated above

-legacy -v -f npci=0x3000

V4 just reads HFS+ when this is done is just restarts.
V5 gets past this goes to AppleUSBOHCI check sleep compatibility and then still waiting on root device as shown by my picture above.

My install procedure was :
1. Use Macbook Air and install OSX LION 10.7.3 (from app store not Iatkos) on Sata HD using a SATA to USB
2. Install chameleon boot loader and replaced mach_kernel
3. Put HD in computer and tried to boot.


Sounds good, but have you actually went into BIOS and set the Hard drive Sata Port to AHCI mode instead of IDE/Raid.

#48
nerdkiller14

nerdkiller14

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
Yes I have my SATA III is set to AHCI and i cannot change SATA II (idk what it is). I have to controllers on my board the SATA III one is SB950 and the SATA II one is JBmicron 362.
I have tried both and neither work (same problem0

(Just as a Side note by (SATA III) I mean REV III which runs at 6 GB/s. By (SATA II) I mean 3 GB/s.

#49
deDante

deDante

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Yogyakarta, ID
confirmed working :

- Phenom II X2 555BE unlock to Phenom II X4 B55
- Vaikoo VA-880G
- 4GB DDR3
- MSI GTX460 Hawk

thanx for the tutorial...

#50
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,168 posts
  • Gender:Male

-v npci=0x3000

arch=i386

or

-legacy -v npci=0x3000

arch=i386

or

or

-v -legacy npci=0x3000

your panic is from sleep enabler try remove it

#51
nerdkiller14

nerdkiller14

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts

Sounds good, but have you actually went into BIOS and set the Hard drive Sata Port to AHCI mode instead of IDE/Raid.


Please read above post also I don't have any Custom kexts installed.

#52
Justin Edwards

Justin Edwards

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
so I compiled two kernels with 10.7.3 xnu source and the original creators diff, and some of anv's and nawcom's diffs
http://www.mediafire...ca8xkkj2xd32y93

System for me in 32-bit is running smooth, but the kernel, pure 64-bit that I compiled is acpi kernel panic -__-
Please can people test and report bacl? I really want to see if this worked even a little better :)

#53
Justin Edwards

Justin Edwards

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
PLEASE LET ME KNOW IF ANYONE IS DOWNLOADING IT TO TEST, I am so anxious, I really don't want my hard work to have gone to waste, i spent all day editing the patches and stufff :P

#54
Tejaswi Rohit

Tejaswi Rohit

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male

PLEASE LET ME KNOW IF ANYONE IS DOWNLOADING IT TO TEST, I am so anxious, I really don't want my hard work to have gone to waste, i spent all day editing the patches and stufff :P


Doing it right away :D :)

- Installed the 32bit Kernel. The system booted up fine :) I find the scrolling a bit laggy and all other system animations to be laggy too o.O The native apps don't start after x minutes :( :'(

- Installed 64bit Kernel, just KP nothing else :(

Thanks for your work :) I hope you release a perfect kernel :')

#55
BaSsie86

BaSsie86

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
  • Gender:Male
  • Location:Netherlands
Hello All,

I am know how! and have Snow Leopard 10.6.8 64bits works on my Amd Phenom X2 II550 (unlock 4 cores) and MSI 790FX-GD80 work all good only sound not all good.
10.7.2 dmg install and mach_kernelv5 and dp2 finder.

Have now work!.

Only i see that problem to welcome back and mouse gray background waiting long and not start.
Think i now problem videocard?

AMD Phenom X2 II 550 (2 cores have bios unlock 4 cores and work).
MSI 790FX-GD80
2x MSI 5750 1GB DDR3
2x 4GB DDR3 Corsair 1333mhz
2x 500GB WD Black
1x 1TB WD Green
1x 750GB WD Green

#56
Devout

Devout

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts

Hello All,

I am know how! and have Snow Leopard 10.6.8 64bits works on my Amd Phenom X2 II550 (unlock 4 cores) and MSI 790FX-GD80 work all good only sound not all good.
10.7.2 dmg install and mach_kernelv5 and dp2 finder.

Have now work!.

Only i see that problem to welcome back and mouse gray background waiting long and not start.
Think i now problem videocard?

AMD Phenom X2 II 550 (2 cores have bios unlock 4 cores and work).
MSI 790FX-GD80
2x MSI 5750 1GB DDR3
2x 4GB DDR3 Corsair 1333mhz
2x 500GB WD Black
1x 1TB WD Green
1x 750GB WD Green


What flags are you using, use verbose mode. "-v". Sound is not good because you need to set right busratio or it will be fuzzy.

#57
iceblade112

iceblade112

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

your panic is from sleep enabler try remove it


N00B Question: How?

#58
MacFaulty

MacFaulty

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 156 posts
  • Gender:Male
  • Location:Netherlands
  • Interests:Programming, programming, programming... AND scripting :)

N00B Question: How?


Try to boot with pmVersion=0 and if you can get into Lion go to /S/L/E and remove SleepEnabler.kext.

Hope this helps

#59
Devout

Devout

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts

Try to boot with pmVersion=0 and if you can get into Lion go to /S/L/E and remove SleepEnabler.kext.

Hope this helps


You can do this or if you have a windows partition, boot up in Windows buy and install macdrive, and then reboot and you should be able to access your mac drives from within Windows. Delete the kext in /System/Library/Extensions/

REMEMBER, if you follow either of this routes you must repair permissions after, it can create problems rather then solve afterwards.

#60
iceblade112

iceblade112

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

Try to boot with pmVersion=0 and if you can get into Lion go to /S/L/E and remove SleepEnabler.kext.

Hope this helps


Works!!!


You can do this or if you have a windows partition, boot up in Windows buy and install macdrive, and then reboot and you should be able to access your mac drives from within Windows. Delete the kext in /System/Library/Extensions/

REMEMBER, if you follow either of this routes you must repair permissions after, it can create problems rather then solve afterwards.


I don't think VirtualBox and MacDrive like each other.





Also tagged with one or more of these keywords: AMD, Lion, 1073, Guide, Kernel


3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy