Jump to content

Problems after updating to 10.7.3 (from 10.7.2)

10.7.3 kext not working help

  • Please log in to reply
11 replies to this topic

#1
s.sirio

s.sirio

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
Dear All,

before updating my retail install to 10.7.3 (I was 10.7.2) I had a fully funcional pc where the old problem with the USB ports and the Shoot Down were correctly looked after by these kexts:

VoodooSDHC.Kext
Ev0reboot.Kext

Now I have the same kexts in the folder but I have the problems below:

- If the computer goes to sleep on wake it will restart with a black screen
- When I turn it off it will restart
- The card reader is not working any longer
- The Right usb port if I plug in a mouse will not work, if I plug in a USB SD Card Reader the card gets read immediatelly.

As anyone a solution or where to look to understand bettere the problem?

Thanks

#2
Chatlink

Chatlink

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Netherlands
Boot with -v and look for any errors with these kexts. Is there any attempt in the first place to load these kexts...

#3
s.sirio

s.sirio

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
Chatlink, thanks for the very quick reply.

Where should I look for errors on the kext? Is there an error log or similar?

Where shall I check if the kext are correctly loaded?

Thanks in advance.

#4
Chatlink

Chatlink

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Netherlands
Yes you can view the log "live" by typing "-v" in the bootloader. There will be a lot of scrolling text so you might miss it.

If so:
  • Reboot and remember when you started the pc
  • open an application called "console"
  • Click on something like "view log filelist". Then select the file kernel.log
  • copy past the stuff in it starting at the time you rebooted.
  • upload a txt file inside your post and i will take a look. Please dont paste all the stuff inside your post. (or use something like pastebin).
I found you XD: http://tonymacx86.co...=48101&p=307822

#5
s.sirio

s.sirio

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
Hi,

just got home and extracted the Kernel Log, I had a look myself but is like giberish to me, hopefully it will make more sense to you.
thanks and regards

Attached Files



#6
Chatlink

Chatlink

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Netherlands
Well, noticed two things.

For the sdcard:

Feb 9 17:53:28 localhost kernel[0]: VoodooSDHCI ::: an SDHCI driver for Ricoh, TI, and JMicron SD Host Controllers ::: rev 20091008
Feb 9 17:53:28 localhost kernel[0]: VoodooSDHCI: initializing SD host controller
Feb 9 17:53:28 localhost kernel[0]: VoodooSDHCI: failed to create an interrupt source

So it doesn't load. I dont get very happy about the lack of forum activity of the sdhci. Unbelievable that this: (http://forum.voodoop...board,14.0.html) is all.

The evoreboot.kext is causing the weird reboot behaviour, you need a dsdt. The same for your gfx card. The nvenabler shouldn't be necessary for your card.

Without searching on your name i found this thread http://www.insanelym...howtopic=272934.

It almost seems like you are the only one with that notebook, must be a hard one.

Anyway. I don't have any experience yet with dsdt's but if i read myself in a little.... In two weeks i will have lot of free time so then I might be able to help you compiling a dsdt.

#7
s.sirio

s.sirio

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
thanks for the support, I will keep on with my search and update the post if I reach a solution.. It is a shame that the driver is no longer loading... It was so usefull..

#8
s.sirio

s.sirio

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
Hey there,

I have narrowed down the problem above, this is not directly caused by 10.7.3 update but rather by the voodooSDHC.kext. Infact as soon as I have deleted that, which was not loding anyway, and reboot the mouse and the restart was working just fine. The problem I need to sort now is how to get the ricoh sd card reader to work, as anyone got any idea? Maybe DSDT patch? A different kext?
thanks in advance

#9
adi4joy

adi4joy

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hi all,

I updated from 10.7.2 to 10.7.3 and lost ATA and front USB functionality. I have 2 DVD drives that aren't recognized anymore. My mobo is an Asus P5QL PRO with 4 GB RAM. Everything worked perfectly on 10.7.2. Which kext(s) should I look at?

Any help is appreciated.

#10
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,123 posts
  • Gender:Male
  • Location:Brazil
If they are PATA drives connected to the Marvell 6102 controller, find and install SuperVIAATA.kext.

#11
rjosxasus

rjosxasus

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
Does anyone know how to solve a bootcache control problem? I've been running in RAID 0 with no problems, and since updating from 10.7.2 to 10.7.3 I get this flag when it boots:

BootCacheControl

:

Unable to open

/var/db/BootCache.playlist



followed by repeated "invalid sandbox profile for PID"



#12
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,123 posts
  • Gender:Male
  • Location:Brazil
You should start a new topic, make sure you put RAID 0 in the title so that other people with a RAID setup will see it.





Also tagged with one or more of these keywords: 10.7.3, kext not working, help


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy