Jump to content

DSDT MSI X58 pro-e [no ALC889 working with AppleHDA]

sound MSI X58 pro-e DSDT audio ALC889 voodoo multibeast

  • Please log in to reply
No replies to this topic

#1
wodorost

wodorost

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hi

I tried my best with DSDT and followed all tutorials for this MoBo i could find, but they allways point to the Voodoo kext. Unfortunately this sollution is simply not good enough for me. I have very strong noise in my spekers with all the voodoo kexts and it is vital to me that the sound is clean.

Soo if You have a sollution better then I then I would be glad to hear it [sic!]

So far i installed retail 10.7 with the live DVD (regae) then did the combo 10.7.2. With my DSDT.aml copied to the desktop I used ##### 4.2.1 and checked:

+ user DSDT Install
+ System Utilities
- Drivers
  - Kexts
    - Audio
      - Realtek ALC8xx
        + ALC8xxHDA
        + AppleHDARollback
    - Disk
      + 3rdPartySATA
      + Jmicron36x ATA
    - Network
      + Realtek Gigabit...

I see in SystemUtil that the HDA kext is working (I see input and output choices) but i can't hear a thing.

The system is stable so far (no booting in verbose mode to avoid kernel panic as before) but still no clean sound, well no sound at all...

Any help will be nice!!!

There is a DSDT for MSI X58 pro-e in attachment (extracted in linux and patched with DSDTeditor and debugged in DSDT SE





Also tagged with one or more of these keywords: sound, MSI X58 pro-e, DSDT, audio, ALC889, voodoo, multibeast

  Topic Stats Last Post Info

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy