Jump to content

Anyone with LION on Dell Precision 690 ? -Yes ME :)

Dell Precision 690 Lion

  • Please log in to reply
36 replies to this topic

#1
Trututu

Trututu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Warsaw/Poland
Hi,

I have already installed Leopard (iDeneb - vanilla kernel) on my Dell Precision 690.
Few days ago I have menaged to install and fully update retail version of Snow Leopard.

Now I'm thinking about installing Lion on my Dell.
Installation was fine (using iAtkos L2 distro), then I have used ##### to install DSDT and some additional kexts. But after restart I can not boot from Lion partition.
Everything is fine for few seconds then computer restarts and I even can not read what caused the problem.

Any one here with some success with installing Lion on DELL PRECISION 690 ?

cheers

UPDATE

I have LION 10.7.2 from iAtkos L2 installed and running, but after every restart I have to do -v boot flag, because otherwise I get kernel panic, no idea why.


UPDATE 2

Lion 10.7.2 perfectly running on Dell Precision 690.
I have decided to use Retail Lion + xMove + DSDT + Audio Kext.
What I did:
1) Install retail 10.7.0 (using this http://www.insanelym...howtopic=265900 as quite)
- I had to modify AppleLSIFusionMPT.kext for my SAS controller
2) Install combo update to 10.7.2
3) Install combo update 10.7.2 fix (Mac OS X Lion 10.7.2 Update Fixer.pkg) and again manually modify AppleLSIFusionMPT.kext (Update did replace it with new).
4) Add DSDT (I have used DSDT from my running SL - see attachment) to Extra folder on root, to prevent Lion from resetting my BIOS
5) Add VooDooHDA and EvOreboot.kext from ##### 4.2

Oh and I should mention that my starting point was running SL 10.6.8

Attached Files



#2
silicman

silicman

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Good job. My bro donate me this old guy next few days. I'll try what you say. Thanks again!

#3
editor123

editor123

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Great job, Trututu. I also have Dell precision 690, and I try several times to install Leopard, Snow Leopard, even Lion, but without any success. Everytime when installation disc start to load files for installation, computer restart immediately.

Can you give me some hints how to install, please... I try with ##### and retail Sow Leopard install disc, also Lion iAtkos L2, iDeneb for Leopard... Maybe its a problem with my BIOS settings, which I update with last one (I think its a A08).

Please, help!

#4
Trututu

Trututu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Warsaw/Poland
Thanks All !!

I didnt know that there is so much interet in instaling OSX on dell 690.

So detailed quide will be done - but Im very busy, so you will have to wait.

My path was.

Leopard from iDeneb 10.5.6 vanilla kernel with SMBIOS kext (It was very long time ago so Im not sure about what was checked during install of Leopard, but Im sure that under CUSTOMIZE window I decided for Chameleon bootloader, Vanilla kernel and somethng more, maybe It was SMBIOS or something like that, but for sure dont try to install sound kext, graphics etc during first install, try to install it as clean as possible and then you will try to fix some issues with devices one by one) - some Kexts etc to make sound and graphics running, oh and some modification of

AppleLSIFusionMPT.kext for SAS drives to apear


Than from running Leopard I have installed Snow Leopard from retail DVD and before restart I did use M U L T I B E A S T to add evoReboot, new bootloader and Voodoo sound kexts.


Than having fully runnning SL -

Retail Lion + xMove + DSDT + M U L T I B E A S T for evoReboot.


Few days ago I have done a new install of Lion using same method but this time using retail lion 10.7.3 (new one) with success :)




BIOS doesnt metter (Im running my dell on A03 BIOS - very very OLD one, and have perfectly running SnowLeo, Lion and Win7x64.


In BIOS all you should set is AHCI mode for SATA drives and turn of onboard LAN, don;t use PS2 mouse or keyboard, you can but there you will have to force osx to work with PS2 devices



I know its a chaos but I have no time to stop by and write it better way :) cheers



#5
Trututu

Trututu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Warsaw/Poland
Tomorrow I will try to instal OS 10.8 MOUNTAIN LION on DELL PRECISION 690 ... If its gonna be succes it means that I will stay with my DELL for next few years.
Will let you know...and propably will start new topic

#6
editor123

editor123

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Thanks for reply, I hope it will be a success... I will try your method tonight to install Leopard, and Snow Leopard. I will let you know tommorow, and probably (with success) I will need that modification for AppleLSIFusionMPT.kext for SAS.

#7
Trututu

Trututu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Warsaw/Poland
Drives connected to SAS controller will be visible by OSX but don't try to use SAS Hardware RAID option, It will not work ever.
I will put LSI next here soon, now there is some error here and I can not upload files.


Oh here it is...

Attached Files



#8
editor123

editor123

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Thanks for kext, Trututu.
I have some success with Leopard and Snow Leopard, but...
Now, my biggest problem is how to boot, and how to make system to see both procesorss. I installed Snow Leopard Hazard 10.6.2, but after install, at the first boot computer goes to restart. Finaly, I give a command in a boot option cpus=1, and in system info it writen one Core2duo processor 3.00 Ghz. Also, it see only 2Gb of DDR, and I have 6Gb. In identifier it writen iMac 9,1.
So my next step will be retail Snow Leopard 10.6.3, but I don't know which bootloader to install.
Btw, your kext for SAS working.
I'll inform you how it goes.

#9
loubrucker

loubrucker

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hi there,

I have followed your instructions very closely - but I'm having an issue. Here is my setup - maybe you can shed some light.



- Precision 690 w/ 1x 1.6 ghz Xeon
- 2 Graphics card alternatives (I don't believe this is the problem; tried both) 8400GS + Quadro FX


I can install using a Uniboot (######) 10.7.3 or 10.7.0 flash drive - this goes smoothly every time. I'm going to skip to 10.7.3 experience since its almost identical to my 10.7.0 experience.


Installed Uniboot 10.7.3. Install, reboot, use Uniboot to load Macintosh HD - machine boots fine. Install Chameleon - reboot, take out Uniboot - machine restarts automatically seconds after it begins the boot. I'm thinking this problem might have something to do with the SAS controller and its drivers - but I can't seem to get around it. I've installed your DSDT and your SAS file that you attached here. After doing that (and installing chameleon) machine goes into this "can't get 3 seconds past the boot process and auto-restarts). Every time.

If I don't install chameleon, I can boot off the Uniboot as many times as I want.

Thanks for any help.

#10
Trututu

Trututu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Warsaw/Poland
I'm back to bussines...
Any one still needs any help with instalation of Lion on Dell Precision 690?
If so, during the incoming weekend I will prepare some new infos, upload kexts dsdt etc. to my FTP
Since my last posts I have had few major Kernel Panics, but now everything is working and stable again - Im running 10.7.4 now.
cheers

#11
loubrucker

loubrucker

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

I'm back to bussines...
Any one still needs any help with instalation of Lion on Dell Precision 690?
If so, during the incoming weekend I will prepare some new infos, upload kexts dsdt etc. to my FTP
Since my last posts I have had few major Kernel Panics, but now everything is working and stable again - Im running 10.7.4 now.
cheers


yes - I do still need some help. I've made 3 hackintosh's before and have never had this much trouble with a conversion. I'd be very happy to follow your guidance on this 690. Would love to be up and running.

#12
Trututu

Trututu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Warsaw/Poland
For now I wil give you all my Extensions and my Extra folder.
http://pawel.truchan...Exten_Extra.zip

In this file you will need to change EFI string for graphic card, to get my string I was using EFI studio 9
org.chameleon.Boot.plist

In BIOS turn off build-in NIC and PS2 ports and COM ports, set grives mode to AHCI

For you, loubrucker I believe you should use one of your hackintoshes or a real MAC and install Lion 10.7.4 on a separate drive, after that You have my working Extensions directory, so just put it in place, run ###### and as Destination set newly installed Lion, and mark
  • UserDSDT Install /you have to put my DSDT.aml file on desktop before/
  • System Utilities -> Repair Permissions
  • Drivers & Bootloader -> Bootloaders -> Chimera

This shou;d do the trick...let me know.
cheers

#13
loubrucker

loubrucker

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

For now I wil give you all my Extensions and my Extra folder.
http://pawel.truchan...Exten_Extra.zip

In this file you will need to change EFI string for graphic card, to get my string I was using EFI studio 9
org.chameleon.Boot.plist

In BIOS turn off build-in NIC and PS2 ports and COM ports, set grives mode to AHCI

For you, loubrucker I believe you should use one of your hackintoshes or a real MAC and install Lion 10.7.4 on a separate drive, after that You have my working Extensions directory, so just put it in place, run ###### and as Destination set newly installed Lion, and mark

  • UserDSDT Install /you have to put my DSDT.aml file on desktop before/
  • System Utilities -> Repair Permissions
  • Drivers & Bootloader -> Bootloaders -> Chimera
This shou;d do the trick...let me know.
cheers


would you mind emailing me ? @ gmail.com ? thanks a ton - really appreciate your help.

#14
Trututu

Trututu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Warsaw/Poland
I 've hed some kernel panic today and this is my ...

... update for org.chameleon.boot.plist file

<key>Kernel Flags</key>
<string>PCIUID=1</string>

This make my osx runnning again

I can mail you but what's your address ...
or maybe send me some questions at gentlyborn(at)gmail.com

btw.
####### = m u l t i b e a st

#15
ciencia02

ciencia02

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
need help installing lion on my 690 I have try to use retail lion with nawcom, chimera loader , chameleon and my computer keeps rebooting , I went ahead an try Iatkos L_2 but no luck what so ever I don't get to pass from the apple loading screen.

#16
NµLL

NµLL

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Location:Amerikastan
Thanks so much, working on a Dell 690 2 x Xeon 5355. SL working great. Here's another place I have been visiting:

http://www.sinisterm...cision-690.html

Not sure why his last posts are incomplete, but still a good source of 690 hackintosh info.

I am also using onboard NIC with this kext:

http://www.osx86.net...do=file&id=2515

Will report back. Still working on SAS kext/Nvidia kexts stabilizing.

Here's a geek bench (32 only): http://browser.prima...ekbench2/912041

#17
Trututu

Trututu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Warsaw/Poland
Hi,

here are links for my EXTENSIONS and my EXTRA folders. I'm using it with 10.7.5

http://pawel.truchan.../Extensions.zip
http://pawel.truchan...l/osx/Extra.zip

Hope someone will find that useful.
Of course you should use your own DSDT file, but maybe my will be good enough to start.

My Dell is running stable with 10.7.5 (boot time 52 seconds :) including BIOS startup / SAS disabled/ )

#18
Stellair

Stellair

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 375 posts
  • Gender:Male
Any luck with Mountain Lion on dell 690 yet?

#19
xameleon

xameleon

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
of course! :moil:
just download the 10.8 dmg version(NOT 10.8.2 or appstore) :hammer:
restore the dmg on a usb flash disk :moil:
and after run this
http://www.osx86.net...kintosh_v2.html
when the setup ends just boot and install the mountain lion :star_sunglasses:
for icloud/facetime need to add hex bootflags with efiStudio for lan AND need to customize your smbios.plist with Chameleon Wizard :star_sunglasses:
for sound i use VoodooHDA :star_sunglasses:
for Graphics card i have an Nvidia Quadro 2000(working fine with hex bootflag with EFISTUDIO and GraphicsEnabler=Yes) :star_sunglasses:
for Onboard LAN look this kext http://www.insanelym...river-3264-bit/ need to modify the device ID to yours :star_sunglasses:
for SAS controller need to modify the AppleLSIFusionMPT.kext :star_sunglasses:



so on MY dell precision 690..
my problems are: :help:
some kernel panics (if the system forced shutdown and need to boot first time on safe mode to fix permisions i dont know how to fix that) :wallbash:
i cant use newer chameleon bootloader i just getting kernel panic :wallbash:
i have Apple Wireless keyboard/trackpad and need to have connected a usb keyboard only for chameleon bootloader :wallbash: :wallbash: :wallbash: :wallbash:

#20
Trututu

Trututu

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:Warsaw/Poland
Everything is fine... but can someone give me working LAN kext?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy