Jump to content

{Guide} DELL INSPIRON N5110

* * * * * 16 votes

  • Please log in to reply
2398 replies to this topic

#1181
rishabh22

rishabh22

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:New Delhi, India

Yes i used the guide and finally the trackpad worked but no usb mouse yet so no problem thanks:)..i will try your method of switchrex because sometimes artifacts appear and will post results..finally i get boot 0 error if i boot from the HDD so i have to boot from the USB stick to log in ML..the question is did the solution that Mohamed posted in the Guide here http://www.insanelym...-way-to-fix-it/ worked for you or anybody here?..thanks in advance :)

Hey can please tell me how you got the touchpad working? I have the same problem that you were earlier having(usb mouse works though). I am using the vodoops2 kext in the post install zip. I had it working earlier but then had to reformat and now it won't work :(
Edit
This was happening when i was booting from usb.
When i boot from hdd, even my keyboard does not work(USB ps2 still works)
Seems as though it is not being able to read the voddoops2 kext at all and was using some kext from the usb to make the keyboard work.
I don't even see an appleps2 kext :/
PS And Yeah that boot0 method worked fine for me

#1182
weihaolin

weihaolin

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi, does anyone have problem with restart when disabled the Nvidia card? I have a L502x, it's hd3000+gt540m, the restart works ok when the gt540m is loaded, however when I disabled it using the _OFF and _PS3 method, the restart wont work any more. Any suggestions? Thanks in advance.

#1183
nateless

nateless

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Interests:.
Hello, did everything and got a working os. but when i've added 2GB ddr3, it goes sleep at logon screen, removing DSDT solves it, but os looses all nice stuffs. Can anyone help me with DSDT, what should I correct to fix it?

notebook has only intel hd3000 card, with i3 2310M cpu, it worked fine with 2GB RAM, but with 4 goes to sleep.

#1184
Torianin

Torianin

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Dell Wireless DW1702 AR5B195 WiFi + BLUETOOTH will this work with mac os x ? OCZ 128GB 2,5 SATA SSD Vertex 4 is this ssd need special kext or programs to work fine with mac os x ?

#1185
duongphuc125

duongphuc125

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
wait for new guide :wink2:

#1186
mokeev1995

mokeev1995

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Russia, Yaroslavl
  • Interests:MacOSX, Apple, Microsoft, Windows, New Computer technologies
There was one small problem... I don't know if it's already solved.
Spoiler


My dell stop after this moment... now I already format my disk and trying to reinstall. I use all kexts in post install zip. When I boot with "-f" the system works great.
but before deleting PXHCD.kext system don't boot successfull and with "-f", only with "-x"...

#1187
nanotech

nanotech

    InsanelyMac Protégé

  • Members
  • PipPip
  • 76 posts

There was one small problem... I don't know if it's already solved.

Spoiler


My dell stop after this moment... now I already format my disk and trying to reinstall. I use all kexts in post install zip. When I boot with "-f" the system works great.
but before deleting PXHCD.kext system don't boot successfull and with "-f", only with "-x"...


Same problem faced me it was solved completely by booting with -x -v or UseKernelCache=No then repair permissions via disk utility
you must use your SSDT-4

#1188
M.O.S

M.O.S

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male

There was one small problem... I don't know if it's already solved.

Spoiler


My dell stop after this moment... now I already format my disk and trying to reinstall. I use all kexts in post install zip. When I boot with "-f" the system works great.
but before deleting PXHCD.kext system don't boot successfull and with "-f", only with "-x"...

bro u can use this
NullCPUPowerManagement.kext
FakeSMC.kext
in s/l/e
work for me !!

Same problem faced me it was solved completely by booting with -x -v or UseKernelCache=No then repair permissions via disk utility
you must use your SSDT-4

good idea <3

#1189
sexyass

sexyass

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
I have discovered another solution for artifacsts. Im on 10.8.2
I booted GraphicsEnabler=Yes
(I have Nvidia card too but disabled by dsdt)
After boot like this all artifacts are gone. I used switchresx but it didnt help. Also it seems to me the speed increase. Here is the change I noticed in system info and profiler.
w/o graphicsenabler there is no word mobile but after enabling there is
I solved the problems with fckin artefacts. finally.

Switchresx never helped me because my default frequency of the lcd was 76.smthing and the vendor of my screen is LGD whatever
Posted Image
Posted Image

#1190
moni

moni

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hello.
I found this site desperately seeking help for installing Apple OS X onto my laptop - Dell Inspiron n5110, CPU CORE - I7 2670QM. The main problem here is that I don't have physical access to a real Apple MAC OS so I simply cannot make bootable USB disk with it and can't begin the installation as adviced in the first message. Please tell me what to do. Writing .dmg file as raw image results of no bootable usb. I managed to write bootable image from another torrent in thepiratebay but it stops with the prohibity sign and the Apple logo. What I did so far was just to install the patched BIOS.

I will be very grateful if you can help me providing I probably won't get my hands on real Mac in the foreseeable future.

Sincerely
Moni

#1191
Vahagn-Doc

Vahagn-Doc

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

Hello.
I found this site desperately seeking help for installing Apple OS X onto my laptop - Dell Inspiron n5110, CPU CORE - I7 2670QM. The main problem here is that I don't have physical access to a real Apple MAC OS so I simply cannot make bootable USB disk with it and can't begin the installation as adviced in the first message. Please tell me what to do. Writing .dmg file as raw image results of no bootable usb. I managed to write bootable image from another torrent in thepiratebay but it stops with the prohibity sign and the Apple logo. What I did so far was just to install the patched BIOS.

I will be very grateful if you can help me providing I probably won't get my hands on real Mac in the foreseeable future.

Sincerely
Moni


Hi Moni and welcome to insanely mac!
You've two solutions:
1. Let me tell you how I created my first USB bootable flash drive. I installed Mac OS X 10.6, there're already made DVD bootable images on the internet for hackintosh. Install 10.6 and keep in mind that it doesn't need to work properly. You just need it for creating USB drive.

2. Another option is to get hackintosh DVD for 10.8, which you can get from torrent trackers. Install 10.8 and later update it to 10.8.2 and do everything listed on the first page.


#1192
sureshtrb

sureshtrb

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:dammam
Dell inspiron 1545 kernel panic during install
kernel flag -v com.apple.driver.AppleACPIPlatform....

tried DSDT=No -v -f
hang at
AppleACPIBatteryManager Loading...
AppleACPIBatteryDevice Loading...
Help please

Even if i pass through also in disk utility the hard disk is not recognised!!??
Advice please

#1193
sexyass

sexyass

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
i have tested and found out that the bt on centrino natively works from even cold boot but wifi doesn't. on atheros wise-versa. now i have both cards removed and am thinking about soldering them. i used apple mouse with atheros bluetooth but its really laggy but all gestures work normal

edit-- i fixed the lag, i just turned of wifi, moved my mouse, and turned it on again, Tadaaa, no {censored} lag anymore... Magic mouse the best..
this is explained as : wifi and bt are on the same card and their signals are simal or whatever, or maybe it had smthing to do with power supply

#1194
rishabh22

rishabh22

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:New Delhi, India

Hey can please tell me how you got the touchpad working? I have the same problem that you were earlier having(usb mouse works though). I am using the vodoops2 kext in the post install zip. I had it working earlier but then had to reformat and now it won't work :(
Edit
This was happening when i was booting from usb.
When i boot from hdd, even my keyboard does not work(USB ps2 still works)
Seems as though it is not being able to read the voddoops2 kext at all and was using some kext from the usb to make the keyboard work.
I don't even see an appleps2 kext :/
PS And Yeah that boot0 method worked fine for me

Can someone please help me with this? A laptop is pretty useless without the mouse and touchpad working :(

#1195
sureshtrb

sureshtrb

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:dammam
Removed AppleACPIBatteryManager & AppleACPIBatteryDevice kexts from E/E
now using cpus=2 DSDT=No -v -x
struck at waiting for root device loop....
Help please


edit:

When i disconnect the HDD from the system and connect thro USB, ML starts.
Waiting for help to solve "still waiting for root device" issue, when the HDD is assembled in the system.

attached the photos taken during successful boot thro USB connection

Waiting for support

Attached Files



#1196
mokeev1995

mokeev1995

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
  • Gender:Male
  • Location:Russia, Yaroslavl
  • Interests:MacOSX, Apple, Microsoft, Windows, New Computer technologies

Hello.
I found this site desperately seeking help for installing Apple OS X onto my laptop - Dell Inspiron n5110, CPU CORE - I7 2670QM. The main problem here is that I don't have physical access to a real Apple MAC OS so I simply cannot make bootable USB disk with it and can't begin the installation as adviced in the first message. Please tell me what to do. Writing .dmg file as raw image results of no bootable usb. I managed to write bootable image from another torrent in thepiratebay but it stops with the prohibity sign and the Apple logo. What I did so far was just to install the patched BIOS.

I will be very grateful if you can help me providing I probably won't get my hands on real Mac in the foreseeable future.

Sincerely
Moni

Hi, Moni!
You can install Mac OS x Lion to your laptop and create your bootable USB device. It was work for me. I don't know if is there ISO image on the pirate bay, but at Russian bit torrent tracker there is good image, which I write on DVD and install them. I can give you torrent file of it. And there is the second solution. You can download ready to use Mac os x for VMware and try to create your USB from it.

-----------------------
Sorry for my English

#1197
atlfmv7

atlfmv7

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
I have a N5110 with a 2450m, I followed the guide perfectly, but when I go to install, my computer goes to sleep and then sits at a black screen if i wake it up. It doesn't quite make it to the install setup screen. Does anyone have any suggestions? Thanks for all your hard work!

EDIT:

I tried doing a clean install without the extra files, and was able to get to the setup screen, so it must be related to them. I also noticed that it does get to the installation screen, but the back-light to the monitor turns off, and then forces the computer to sleep. If i wake it, it goes back to that screen but still doesnt turn the backlight on, and then goes back to sleep. I don't have an nvidia card, just the Intel hd3000, and switched the files as apart of the customization process. Anyone have any ideas or fixes that they know of? Again, thanks to everyone for their contributions to this guide!



Regards,
Ryan

#1198
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 829 posts
  • Gender:Male

I have a N5110 with a 2450m, I followed the guide perfectly, but when I go to install, my computer goes to sleep and then sits at a black screen if i wake it up. It doesn't quite make it to the install setup screen. Does anyone have any suggestions? Thanks for all your hard work!

EDIT:

I tried doing a clean install without the extra files, and was able to get to the setup screen, so it must be related to them. I also noticed that it does get to the installation screen, but the back-light to the monitor turns off, and then forces the computer to sleep. If i wake it, it goes back to that screen but still doesnt turn the backlight on, and then goes back to sleep. I don't have an nvidia card, just the Intel hd3000, and switched the files as apart of the customization process. Anyone have any ideas or fixes that they know of? Again, thanks to everyone for their contributions to this guide!
You need the extra folder with Smbios.plist and org.chameleonboot.plist for the install.


Regards,
Ryan

I don´t know, which SMBios you are using. Try to use MBP 8,2. If this does not work, remove AppleIntelSNBGraphicsFB.kext from /S/L/E of your install device. But keep the kext on your device. Should be something related with the pinout of the kext. Boot with options GE= no -v -f.

You need extra folder with SMBios.plist and org.Chameleon.Boot.plist for installing.

Have fun.

#1199
TheEnthusiast

TheEnthusiast

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts

Touchpad fixed sensitivity but not muti-touch. t cant' scroll
and Webcam led turn on but not work


I also have the same problem. I explore the contents of the original voodoops2 controller on the first page with this one and noted some differences within the info.plist of the ALPSMultitouch.kext, if that is of any help. There is also an ACPIPS2Nub.kext that is not present in the original voodoops2.

#1200
atlfmv7

atlfmv7

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

I don´t know, which SMBios you are using. Try to use MBP 8,2. If this does not work, remove AppleIntelSNBGraphicsFB.kext from /S/L/E of your install device. But keep the kext on your device. Should be something related with the pinout of the kext. Boot with options GE= no -v -f.

You need extra folder with SMBios.plist and org.Chameleon.Boot.plist for installing.

Have fun.


Thanks for your reply. I'm using the SMBios from the no nvidia attachment on the first page. And I'm sorry, I'm fairly new to this, so I'm not quite sure what MBP 8,2 is. Thanks for your help!





4 user(s) are reading this topic

1 members, 2 guests, 1 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy