Jump to content

GA-G31M-ES2L


  • Please log in to reply
48 replies to this topic

#1
JoQ

JoQ

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Hi!

I'm about to try out Lion on my computer running Snow Leopard (which runs great!)
I got a Gigabyte GA-G31M-ES2L, anyone tried if LAN, sound and so on works? And what kexts do you use?
Also, does the Intel Dual Eore E5200 work as it did with Snow Leopard or is the support for non Core 2 Duo gone?

Thanks!

#2
cruncx

cruncx

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:portugal
  • Interests:Jazz<br /><br />Mac<br /><br />Linux<br /><br />...

Hi!

I'm about to try out Lion on my computer running Snow Leopard (which runs great!)
I got a Gigabyte GA-G31M-ES2L, anyone tried if LAN, sound and so on works? And what kexts do you use?
Also, does the Intel Dual Eore E5200 work as it did with Snow Leopard or is the support for non Core 2 Duo gone?

Thanks!



Hi!

I have the same board and works like a charm.

Here are the kexts
Extensions instalar em S/L/E

Extra

Make your own DSDT

#3
viciouzex

viciouzex

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:East Tennessee
I used to have the G31M-ES2L now I have G41M-ES2L.

if i remember correctly if you have rev 1.0 your LAN is Realtek chipset but if its higher like 1.1 or higher its an Atheros LAN chipset.
Incase you run into the problem where your lan does not want to work.

#4
JoQ

JoQ

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Sounds great!
Anyone else who's got other result or good kexts? I need to get Optical and Coax sound running.

How about my processor, is it possible to run Lion on a Pentium Dual Core E5200 at the moment? Or isn't it natively supported?

Thank you!

#5
mhchan2002

mhchan2002

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
can share the guide on it? tq

#6
FilBip

FilBip

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Location:Toulouse France
Lion does run with pentium DC E5200 on my ga-g31m-s2l :)
and speedstep is OK with Chameleon.

Sounds great!
Anyone else who's got other result or good kexts? I need to get Optical and Coax sound running.

How about my processor, is it possible to run Lion on a Pentium Dual Core E5200 at the moment? Or isn't it natively supported?

Thank you!



#7
JoQ

JoQ

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Yes, my E5200 runs fine, and now I've got Lion up and running.
With the only exception, no sound.
Is it anyone who's got a GA-G31M-ES2L that's rev 1.1?
Would love to have your DSDT if you got sound up and running trough it.

Is there anyone who has almost all fixes in their DSDT? Like network, sound etc.
Atm. I use the RealtekR1000SL.kext to get LAN working. Want to use as few kexts as possible.

Please do help?!

#8
dakku

dakku

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
Edit: Managed to get it up and running.

Has anyone managed to get sleep working?
I tried the new sleepenabler in /Extra/Extensions but my system didnt wake up, went into a reboot loop.

#9
beatoven

beatoven

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

Edit: Managed to get it up and running.

Has anyone managed to get sleep working?
I tried the new sleepenabler in /Extra/Extensions but my system didnt wake up, went into a reboot loop.


You didn't answer your own question. I was waiting for an answer :D Did you use the first guide that's with USB?
About the sleepenabler, try pmversion=23 or sleepenablerNG.

#10
dakku

dakku

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts

You didn't answer your own question. I was waiting for an answer :) Did you use the first guide that's with USB?
About the sleepenabler, try pmversion=23 or sleepenablerNG.


Sorry, I got a bit over excited after getting everything working that I didnt come back to the site :) I did manage to get sleep working by putting the new sleepenabler in S/L/E. Everything works :)

#11
beatoven

beatoven

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

I did manage to get sleep working by putting the new sleepenabler in S/L/E. Everything works :)


Lovely. For me, weirdly, sleep worked fine by itself. Audio didn't. After fighting with multiple kexts and packages, I decided to try inputting arch=i386 in the kernel flags and that fixed it. I'm not running in full 64bit anymore but at least I have sound.

#12
JoQ

JoQ

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
I'm having trouble with SATA-disks showing up as ATA and not as SSD like my SSD should, have anyone got a solution?

Could you check yours?

[URL=http://imageshack.us/photo/my-images/827/skrmavbild20110716kl151.png/]Posted Image

Where it says , Protocol : ATA

#13
beatoven

beatoven

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

I'm having trouble with SATA-disks showing up as ATA and not as SSD like my SSD should, have anyone got a solution?
Could you check yours?
Where it says , Protocol : ATA


I have the exact same issue as yours (same SSD) and I have no idea on how to fix it.

#14
dakku

dakku

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
Is anyone experiencing slow internet speeds with Lan? I seem to be getting normal speed in Snow Leopard but really slow in Lion

#15
ryudo423

ryudo423

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
I also have a G41M-ES2L with an e5300 cpu. I want to upgrade from 10.6.8 so i can keep all my data without having to do a clean install. For those of you that hav had some success, what's the best method to do this?? many thanks

#16
dakku

dakku

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts

I also have a G41M-ES2L with an e5300 cpu. I want to upgrade from 10.6.8 so i can keep all my data without having to do a clean install. For those of you that hav had some success, what's the best method to do this?? many thinks


I used the install-without-usb method since I dont have an 8GB USB, but I suppose you could use any method, as long as your using the right kexts it should be all good.

#17
baller2319

baller2319

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male
How did you guys get the audio working for this board? Also what kexts are you using?

#18
linuxjackie

linuxjackie

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
hello ±
i am using GA-G31M-ES2C
lan and sound is still a problem .. ;)
any help for me ?
thanks a lots

#19
dakku

dakku

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
After a week of having everything working, Sleep is no longer working for me. Computer goes to sleep but doesnt wake, it goes into a reboot loop and after pulling the power plug out I get CMOS checksum error.

I read on a few other threads and they posted a solution by patching the AppleRTC.kext but it doesnt seem to be working for me.

Could someone thats got sleep working please post their DSDT or how they managed to get it working? I am running 64bit kernel.

#20
cedriclocqueneux

cedriclocqueneux

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts

Hi!

I have the same board and works like a charm.

Here are the kexts
Extensions instalar em S/L/E

Extra

Make your own DSDT


I installed Lion on my GA-G31M-ES2L v1, all is ok, but i don't have sound, with yours kext or other, in 64 bit.

Any idea ?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy