Jump to content

BCM5722, BCM5754/M, BCM5755/M, BCM5787/M and BCM5906/M NIC driver (32/64-bit)


  • Please log in to reply
237 replies to this topic

#81
tbplayer

tbplayer

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male

Here you go for pci14e4,16b5 BCM57785


What version is this build?

#82
FransNetwork

FransNetwork

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
  • Location:United Kingdom
Anyone tried this out on a Broadcom NetXtreme 57xx Gigabit for many Dell systems GX520 and Optiplex t3400 is two of them :)

#83
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male
I did a new BCM5722d.kext. I just a little change the source code. It's only do for x64-systems.
I also fixed the stop after an intence traffic, but I can mistaking. So that/
Let me know if my fix doesn't work(I'll try to correct it)
#define DEVICEID_BCM5722 0x165A
#define DEVICEID_BCM5754 0x167A
#define DEVICEID_BCM5754M 0x1672
#define DEVICEID_BCM5755 0x167B
#define DEVICEID_BCM5755M 0x1673
#define DEVICEID_BCM5787 0x169B
#define DEVICEID_BCM5787M 0x1693
#define DEVICEID_BCM5906 0x1712
#define DEVICEID_BCM5906M 0x1713
#define DEVICEID_BCM57780 0x1692
Put this driver into the IONetworkingFamily->Plugins->.
http://www.osx86.net...do=file&id=3605

Attached Files



#84
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male
Damn it! I couldn't fix the problem with intense traffic.

#85
adlan

adlan

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
sorry for the long hiatus, I really don't have much time to maintain it. Now i have a bit time to get back into it.
I'm aware of the problem. However I cannot promise any fix anytime soon as I'll have to dig through the code again after a long time.

#86
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male
Do you know help me for my Broadcom Wifi ?
V: 14e4
D: 4365

#87
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male

Do you know help me for my Broadcom Wifi ?
V: 14e4
D: 4365

Up , I need Answer

#88
ajochope

ajochope

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
BCM5722D.kext
156.876 bytes 164 KB
i386 and x86_64 version

BCM5722D.kext
Not working (I am rookie hackintosh)
78Kb
x86_64 version only

Dell Optiplex 330 with Mountain Lion 10.8.2 working!!!
Install on S/L/E using Kext Wizard

Edited by ajochope, 07 March 2013 - 02:39 PM.


#89
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male

Now i have a bit time to get back into it.

The Stoping of work is the last problem on your driver. If you will fix it, I will be jubilant, and many others users as well.
I hope that you will find a bit time and to amend this problem.

#90
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male
I think that the problem is with the Global maximum connection.
The point is that when I use transmission(bittorrent client) with 370 connections. I downloaded easily 6.5Gb. But when I had set up 600 connections, BCM5722D stopped working.
kFlowControlDisabled = 1,
.....
kMediumTypeIndexAuto = 1,
It didn't help
kMaxPacketSize = kIOEthernetMaxPacketSize + 4,
kTxBDCount = 512,
kRxBDCount = 512,
kTxMaxSegmentCount = 384, // 0.75 *ring size(512) = 384
kRxMaxSegmentCount = 1,
kWatchDogTimeout = 5000 // ms
Increasing of these numbers lead to the Kernel panic
Maybe should we increase the global limit of connection.
Maybe should we increase these number. I didn't understand what is that.
enum
{
kAutoNegotiationDelay = 50,
kAutoNegotiationTimeout = 10000
};
Does that part of code correlate with number of connections?

#91
andrewygj

andrewygj

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Thank you so much! Works on

BCM57788 on 10.8.3.


Vendor ID: 14e4
Device ID: 1691

#92
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male
Hi everybody. I have a good news. It seems that problem with stoping during an intense traffic was solved with the help of apianti.
Immense thanks him for it.
http://www.projectos...rt=0#entry29694
Was
DebugLog("%lu -> %u segments, %u free, consumer index: %u",
             mbuf_pkthdr_len(m),
             segmentCount,
             txFreeSlot,
             txLocalConsumerIdx);
status = kIOReturnOutputStall;
became

DebugLog("%lu -> %u segments, %u free, consumer index: %u",
mbuf_pkthdr_len(m),
segmentCount,
txFreeSlot,
txLocalConsumerIdx);

status = kIOReturnOutputDropped;
Change the BCM5722D.ccp.
I ask to check this.
You can download new driver from here as well
http://www.osx86.net...do=file&id=3605

Attached Files



#93
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male
Corrected four warnings. Now the code is clean.
Add four times this code to PHY.cpp
default:
  break;

Attached Files



#94
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male
Added more devices. Now driver supports 13 devices :thumbsup_anim: :dev:
{ DEVICEID_BCM5722, "BCM5722 NetXtreme Server Gigabit Ethernet" },
{ DEVICEID_BCM5754, "BCM5754 NetXtreme Gigabit Ethernet" },
{ DEVICEID_BCM5754M, "BCM5754M NetXtreme Gigabit Ethernet" },
{ DEVICEID_BCM5755, "BCM5755 NetXtreme Gigabit Ethernet" },
{ DEVICEID_BCM5755M, "BCM5755M NetXtreme Gigabit Ethernet" },
{ DEVICEID_BCM5787, "BCM5787 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM5787M, "BCM5787M NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM5906, "BCM5906 NetLink (TM) Fast Ethernet" },
{ DEVICEID_BCM5906M, "BCM5906M NetLink (TM) Fast Ethernet" },
{ DEVICEID_BCM57788, "BCM57788 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM5784, "BCM5784 NetLink Gigabit Ethernet" },
{ DEVICEID_BCM57785, "BCM57785 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM57781, "BCM57781 NetLink (TM) Gigabit Ethernet" },
{ DEVICEID_BCM57780, "BCM57780 NetLink (TM) Gigabit Ethernet" },
#define DEVICEID_BCM5722				 0x165A
#define DEVICEID_BCM5754				 0x167A
#define DEVICEID_BCM5754M				 0x1672
#define DEVICEID_BCM5755				 0x167B
#define DEVICEID_BCM5755M				 0x1673
#define DEVICEID_BCM5787				 0x169B
#define DEVICEID_BCM5787M				 0x1693
#define DEVICEID_BCM5906				 0x1712
#define DEVICEID_BCM5906M				 0x1713
#define DEVICEID_BCM57788				 0x1691
#define DEVICEID_BCM5784				 0x1698
#define DEVICEID_BCM57785				 0x16b5
#define DEVICEID_BCM57781				 0x16b1
#define DEVICEID_BCM57780				 0x1692

Attached Files



#95
seige232

seige232

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
The driver is still having the same load issue. I'm working on a hard drive that needed information migrated through the network, namely 97GB on full duplex at 1000baseT, and it cuts out every single time, also interrupts wireless. Once the driver cuts out, I lose all remote access to the Latitude D630 (NVidia). I have it running Lion 10.7.5. All updates applied. Installed this driver in place of the old Adlan one, and that is the result. Any thoughts?

It is a problem, because that is the only machine that can do this job that we have, and I have it deployed across the city at my office, which closes its doors at 5p everyday, and its a pain to have to keep driving 40 minutes to reset the machine to reinitialize the driver for limited access.

Any help is appreciated.

-Seige

#96
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male

The driver is still having the same load issue. I'm working on a hard drive that needed information migrated through the network, namely 97GB on full duplex at 1000baseT, and it cuts out every single time, also interrupts wireless. Once the driver cuts out, I lose all remote access to the Latitude D630 (NVidia). I have it running Lion 10.7.5. All updates applied. Installed this driver in place of the old Adlan one, and that is the result. Any thoughts?

It is a problem, because that is the only machine that can do this job that we have, and I have it deployed across the city at my office, which closes its doors at 5p everyday, and its a pain to have to keep driving 40 minutes to reset the machine to reinitialize the driver for limited access.

Any help is appreciated.

-Seige

Try this.
kFlowControlDisabled = 1,
kMediumTypeIndexAuto = 1,
Is your Lion x32 or x64? What type of card do your have exactly?
How work BCM5722d with the last modification(v2.2)
Does it stop during working of torrent-client?
If test1BCM5722d doesn't help, write about the problem here, please.
http://www.projectos...rt=0#entry29694

Attached Files



#97
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male
v2.3 fixed problem in Xcode that had impeded to compline it for x32 machines.
Added supporting for Snow_Leopard.
-------
SnowLeopard x32, x64
Lion x32, x64
Mountain Lion, x64

Attached Files



#98
Tinkergnome

Tinkergnome

    InsanelyMac Protégé

  • Donators
  • 31 posts
  • Gender:Male
  • Location:Pensacola, Fl
Hey Alex i have yet to try your version of the drive but i am running into the device not built in issue on my 5752 do you think it would fix it or do you have any pointers to fix it

i am on 10.8.2 Dell Precision 690 2 x4 xeon 16GB ram ASUS HD6670

have tried kernelflag builtin=yes with deleting files as well as interfaces rebooting and re-adding them
have added efi code into bootloader
neither have seemed to fix the issue will try you version 2.3 on new install partition when i finish making a new installer

#99
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 700 posts
  • Gender:Male

Hey Alex i have yet to try your version of the drive but i am running into the device not built in issue on my 5752 do you think it would fix it or do you have any pointers to fix it

i am on 10.8.2 Dell Precision 690 2 x4 xeon 16GB ram ASUS HD6670

have tried kernelflag builtin=yes with deleting files as well as interfaces rebooting and re-adding them
have added efi code into bootloader
neither have seemed to fix the issue will try you version 2.3 on new install partition when i finish making a new installer

Hello. I added your card to the code{ DEVICEID_BCM5752, "BCM5752 NetLink ™ Gigabit Ethernet" },. Are your device id 1600? If so, please try this one that I've attached.

Attached Files



#100
mattrk

mattrk

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Thanks for writing this driver. It saved me a ton of time. This driver is working on the following system:

Dell Precision 390
-OS X Mountain Lion 10.8.3
-Core 2 Duo
-Broadcom 5754 NIC

I used Kext Wizard to install. Worked immediately after a reboot.

Thanks again!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy