Jump to content

HDMI und 10.6.3 gelöst!


  • Please log in to reply
23 replies to this topic

#1
goodbye losers

goodbye losers

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 260 posts
ich hab bei mir ein nvidia.rom file für meine grafikkarte gezogen, dieses in den extra ordner gepackt und in die com.apple.boot.plist die einträge hinzugefügt:



<key>GraphicsEnabler</key>
<string>Yes</string>
<key>VideoROM</key>
<string>nvidia.rom</string>
<key>VBIOS</key>
<string>yes</string>



die einträge für die grafik aus der dsdt.aml entfernen und auch die einträge der grafik aus der com.apple.boot.plist entfernen, sofern man denn einträge vorgenommen hat. und das geile daran ist, man hat unter 10.6.3 wieder HDMI!!! yes, yes, yes jetzt will ich nur noch CUDA für Mac...hier gibts irgenwas, muß mich da aber erst mal rein lesen.

http://forums.nvidia...hp?showforum=75

das romfile ist für eine 8800gt hab ich im anhang. einfach in nvidia.rom umbenennen, oder so lassen und in der boot.plist anstatt nvidia.rom den namen des files.

das geht natürlich auch bei allen anderen karten die apple verbaut hat. man muß nur das jeweilige romfile für seine karte finden. hier ein paar ältere http://themacelite.w...m/wikidownloads

ich empfinde jetzt auch das die karte besser flutscht! hab jetzt beim booten auch diesen kurzzeitigen blackscreen bevor er ins desktop übergeht nicht mehr. und die karte wird jetzt auch im hardwaremonitor angezeigt. wenn cuda jetzt noch geht (ist doch glaub ich die hardwareunterstützung) dann wäre das enorm!

Attached Files



#2
eberts

eberts

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts

das geht natürlich auch bei allen anderen karten die apple verbaut hat. man muß nur das jeweilige romfile für seine karte finden.


Für die GT120 aus dem Mac Pro scheint es nicht so einfach zu sein, ein ROM zu finden. Hat zufällig jemand ein ROM dump zur hand?

#3
goodbye losers

goodbye losers

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 260 posts
die 120gt ist rebranded. ist sozusagen eine 9500gt. 130gt=9600gt...vielleicht hilft dir das weiter.

#4
eberts

eberts

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts
Yep, ich such deshalb für meine 9500GT ein rom der GT120 :) Hätte das gerne mal gecheckt mit dem Black-screen, der taucht hier nämlich auch noch auf vor dem Login. Allerdings weiß ich auch nicht, ob das Mac-Rom überhaupt funzt, da meine Karte DDR2 hat und die GT120 hat DDR3. Wenn ich eins finde, werde ich reporten ;)

#5
artsin

artsin

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
Ich habe eine 8800GTS und mit der MacPro8800GT.ROM läuft es aber der Ruhezustand geht dann nicht mehr und leider geht dann nur ein DVI Ausgang.

Ruhezustand in Verbindung mit der MacPro8800GT.ROM = Der Monitor geht nicht mehr an wenn ich vom Ruhezustand wieder hochfahre. Bei beiden DVI Ausgängen.

8800GTS Anschlüsse in Verbindung mit der MacPro8800GT.ROM = Es geht nur ein DVI Ausgang (ihnen). Bei den äußeren DVI Ausgang geht der Monitor nicht mehr an.


PS. Sonst läuft alles wie immer. Ich kann mir entlich ein gekauften Film über iTunes ankucken in in Verbindung mit der MacPro8800GT.ROM ohne die MacPro8800GT.ROM bleibt das Bild grau beim abspielen von gekauften Filmen bei iTunes.

Soweit ich weiss hat doch Apple keine 8800GTS verbaut. Stimmt das? Wenn nein hat einer eine rom Datei für eine 8800GTS?

#6
goodbye losers

goodbye losers

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 260 posts
apple hat keine 8800gts verbaut nur 8800gt. und bei mir geht auch alles! in einem anderen forum hat ein user mit ner 8800gts das gleiche problem mit sleep und dem einen dvi...

Yep, ich such deshalb für meine 9500GT ein rom der GT120 :) Hätte das gerne mal gecheckt mit dem Black-screen, der taucht hier nämlich auch noch auf vor dem Login. Allerdings weiß ich auch nicht, ob das Mac-Rom überhaupt funzt, da meine Karte DDR2 hat und die GT120 hat DDR3. Wenn ich eins finde, werde ich reporten ;)


ich check mal bei meinen kumpels ob die in ihrem imac ne 120er drinnen haben und versuche das rom zu erstellen. 2-4 mac´s wären da ne option. nur hab ich keine ahnung mit welchem tool ich das mache für mac os x...

#7
Nexos™

Nexos™

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,706 posts
  • Gender:Male
ich würde es so wie bei windows probieren
startcd erstellen
booten
und mit nem nvidia flash tool das rom der graka auf einen stick speichern

so wie hier beschrieben: http://www.insanelym...p...t&p=1316687

nur mittels usbstick und bootcd, falls das booten vom stick nicht klappt,
eventuelle musst du da noch was am bootloader verändern, da der imac ja nen efi hat und kein bios

#8
flames

flames

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
hat jemand HDMI mit einer 9800gtx/9800gtx+/gts250 hinbekommen?
meine xfx 9800gtx+ 512mb 2xDVI hat immer noch kein bild mit dvi zu hdmi adaptern.
mit dvi zu vga adaptern leidet jedoch die bildqualität bei 1920x1200 auflösung sehr.

#9
goodbye losers

goodbye losers

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 260 posts

hat jemand HDMI mit einer 9800gtx/9800gtx+/gts250 hinbekommen?
meine xfx 9800gtx+ 512mb 2xDVI hat immer noch kein bild mit dvi zu hdmi adaptern.
mit dvi zu vga adaptern leidet jedoch die bildqualität bei 1920x1200 auflösung sehr.



hast du es mal nach meiner anleitung im ersten post probiert? ich glaube das funktioniert mit deiner karte auch...9800GTX

#10
artsin

artsin

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
Hallo all,

hat den einer mit eine 8800GTS oder xxxGTS mit einer Rom Datei 100 % zum laufen gebracht ohne die Probleme die ich im Post #5 erwähnt habe?

#11
flames

flames

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
bigfish, danke.
ich habe alles genauso gemacht wie du beschrieben hast, bis auf die videorom datei, die habe ich aus meiner graka ausgelesen statt deine o.g. macpro datei zu nehmen.
ich bin mir net sicher, ob das zu hardwareseitigen beschädigung führen könnte, wenn ich eine rom von 8800gt für ne 9800gtx nehme.
der verlust der 16 pipes wäre ja egal, vorallem da es sich ja nur auf osx mit der geladenen rom auswirkt, in osx brauche ich sowieso keine gewaltige leistung. in windows (zocken) hätte ich ja alle 128 pipes aktiv.
würden sich denn die 16 pipes überhaupt ausschalten, wenn ich die macpro8800gt rom nehme? die ist ja nur dazugeladen und nicht geflasht in die graka...naja, fragen über fragen, danke für die hilfe.

im grunde bin ich ein dsdt fetischist, werd mal gucken ob sich das vbios in dsdt gfx0 device einbauen lässt ^^
ich war früher immer glücklich mit der dsdt lösung für die graka, weil da wusste ich ganz genau was drin steht, habs ja selbst gemacht. was jedoch der bootloader mit graphicsenabler=y ganz genau tut is mir ubekannt, ich gehe davon aus, dass er auch nur infos aus dem vbios der graka ließt und nen efi inject macht xD

und noch eine letzte frage, muss graphicsenabler=y sein, wenn doch sowieso das vbios rom reingeladen wird und osx sich daraus infos holen kann? werd ich mal gleich testen!

#12
flames

flames

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
so, der trick ist tatsächlich in der macpro8800gt vbios, damit funktionieren meine beiden monitore einwandfrei auf dvi2hdmi. und graka scheint sich damit wohl zu fühlen, der lüfter verhält sich jedoch etwas anders, ich meine er wäre etwas lauter geworden am anfang, geht jedoch nach wenigen sekunden wieder runter. der langzeit test wirds zeigen xD

ich gehe davon aus, dass mir niemand mit einer macpro9800gtxplus.rom aushelfen kann? :(
werd leicht wuselig beim gedanken, dass die 8800gt rom drin ist. der sysprof zeigt mir jedoch 9800gtx an!

vielen dank für funktionierende hdmi!
gruß
flames

#13
PhilippCryser

PhilippCryser

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts
Dankesehr:)

#14
zorro7000

zorro7000

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:germany
Hallo Gemeinde, ich hänge mal wieder fest. Mein Samsung und die Graka wollen nicht.

Was muß ich hier einstellen damit die Profis mir helfen könnten?


sh-3.2# ioreg |grep -i display
| | | +-o display@0 <class IOPCIDevice, id 0x1000001cb, registered, matched, active, busy 0 (7637 ms), retain 16>
| | | +-o NVDA,Display-A@0 <class IONDRVDevice, id 0x1000002a2, registered, matched, active, busy 0 (535 ms), retain 10>
| | | | +-o display0 <class IODisplayConnect, id 0x100000383, registered, matched, active, busy 0 (4 ms), retain 5>
| | | | | +-o AppleDisplay <class AppleDisplay, id 0x100000385, registered, matched, active, busy 0 (2 ms), retain 6>
| | | +-o NVDA,Display-B@1 <class IONDRVDevice, id 0x1000002a3, registered, matched, active, busy 0 (288 ms), retain 8>
| | | | +-o display0 <class IODisplayConnect, id 0x100000388, registered, matched, active, busy 0 (2 ms), retain 5>
| | | | +-o AppleDisplay <class AppleDisplay, id 0x10000038a, registered, matched, active, busy 0 (1 ms), retain 6>
| +-o IODisplayWrangler <class IODisplayWrangler, id 0x10000011b, registered, matched, active, busy 0 (38 ms), retain 6>


sh-3.2# kextstat |grep -i nv
61 0 0xffffff7f80919000 0x7000 0x7000 com.apple.driver.AppleEFINVRAM (1.3.0) <42 7 5 4 3>
67 2 0xffffff7f80974000 0x2ba000 0x2ba000 com.apple.NVDAResman (6.1.0) <66 17 9 5 4 3 1>
68 0 0xffffff7f80c2e000 0x40d000 0x40d000 com.apple.nvidia.nv50hal (6.1.0) <67 4 3>


Was muß rein? Was ev.raus aus dem System. Ich sehe Bios, Boot Chamelon und wenn das auf die Auflösung geschaltet wird schwarz :(

Vielen Dank bereits für eure Mühe. Sollte ich eine andere kaufen?Wo könnte noch weitere Fehler verbaut sein?

Hier ein dump aus NVEnabler: init : begin
NVEnabler: probe : probe
NVEnabler: probe : ROM shadow enable
NVEnabler: probe : patch PRAMIN
NVEnabler: False ROM signature: 0x0100
NVEnabler: probe : patch PROM
NVEnabler: dcb table at offset 0x85f2
NVEnabler: dcb numentries 10
NVEnabler: Raw DCB entry 0: 02000300
NVEnabler: Raw DCB entry 1: 01000302
NVEnabler: Raw DCB entry 2: 04011310
NVEnabler: Raw DCB entry 3: 010223f1
NVEnabler: numentries = 10 num_outputs = 4
NVEnabler: 2 not grouped
NVEnabler: 3 not grouped
NVEnabler: Channel 1: 03
NVEnabler: Channel 2: 0c
NVEnabler: DEBUG Model found: GeForce 8600 GT
NVEnabler: DEBUG VRAM: 512
NVEnabler: DEBUG Setting property @0,compatible

NVEnabler: DEBUG Setting property @0,device_type

NVEnabler: DEBUG Setting property @1,compatible

NVEnabler: DEBUG Setting property @1,name

NVEnabler: DEBUG Setting property @1,device_type

NVEnabler: DEBUG Setting property @0,name

NVEnabler: DEBUG Setting property device_type

#15
iLeopod

iLeopod

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
  • Gender:Male
  • Location:Germany
  • Interests:ileopod.wordpress.com
hi,
hab den 8800 gt rom für meine 9800 gt genommen bis jetzt läufts gut. Denkt ihr das es zu Problemen kommen kann? Im SystemProfiler sieht man dies Attached File  Sysinfo.tiff   116.3KB   69 downloads. Wie kann ich den Namen meiner Grafikkarte feststzen?

Gruß iLeopod

#16
GermanDJ

GermanDJ

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Hai,

ich habe auch das DVI auf HDMI Problem.

Habe das ROM eingebunden und es wird auch geladen. (beim Startbildschirm ist der Apfel mit Pixelwirwar überdeckt.

Sobald ich den DVI Stecker rann stecke, friert der Rechner ein.

Habe eine 8500GT 512MB Vram.

Kann jemand helfen?

LG

EDIT:

Habe in der boot.plist (s/l/sc) die EFI sachen raus gelöscht. Hat nicht funktioniert! Bekam nur noch Grafikwirrwar. Der Rechner stratete immer wieder neu. Habe es wieder rückgängig gemacht.

#17
goodbye losers

goodbye losers

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 260 posts

hi,
hab den 8800 gt rom für meine 9800 gt genommen bis jetzt läufts gut. Denkt ihr das es zu Problemen kommen kann? Im SystemProfiler sieht man dies Attached File  Sysinfo.tiff   116.3KB   69 downloads. Wie kann ich den Namen meiner Grafikkarte feststzen?

Gruß iLeopod


wie es aussieht hast du vergessen in deiner boot plist den graphics enabler auf yes zu stellen, da deine karte nicht angezeigt wird im profiler...

<key>GraphicsEnabler</key>
<string>Yes</string>

oder du hast kein pc-efi?

#18
FuManchu84

FuManchu84

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
Ist der Trick jetzt in der speziellen ROM von bigfish versteckt, oder kann ich auch meine selbst ausgelesene ROM von meiner Graka nehmen bzw. muss ich die ROM irgendwie modifizieren, dass HDMI funzt? Habe eine 8600 GT und werde das heue Nachmittag mal ausprobieren.

Ach, und nochwas: Mittlerweile ist ja schon 10.6.4 draußen. Geht es damit auch?

#19
FuManchu84

FuManchu84

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
Die Methode von bigfish hat bei mir leider nichts gebracht (habe die 8600 GT). Ich habe es genau nach der Anleitung gemacht (Grafikinformationen aus der DSDT.aml entfernt und die paar Zeilen zur com.apple.boot.plist hinzugefügt). Ich habe es sowohl mit der Original-Rom meiner Grafikkarte (über GPU-Z unter Windows ausgelesen) als auch mit der Rom von bigfish probiert - beides mal mit dem gleichen Ergebnis. DVI funktioniert einwandfrei und bei HDMI ein Blackscreen. Habt ihr noch irgendwelche Ideen?

Muss ich wirklich die 8800 GT haben, damit es funktioniert???

#20
GermanDJ

GermanDJ

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Was ist wenn ich die Kexte von 10.6.2 wieder installiere. Ob es dann klappt mit DVI -> HDMI ? Und wenn ja welche muss ich nehmen?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy