Jump to content

Welcome to the SigmaTel 9200 Driver Initiative!


  • This topic is locked This topic is locked
358 replies to this topic

#21
waynoworlater

waynoworlater

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I have a Dell Inspiron 6400 with Sigmatel 9200...My only problems with OSX are secure wireless connections and this sound card..I'm here to test whenever. Thanks again for doing this...

#22
james2mart

james2mart

    InsanelyMac Sage

  • Retired Developers
  • 344 posts
Unfortunately, when I was working in terminal, I accidentally rm -R'ed my entire source code directory. One file was open, which was the largest, but I still lost alot of code.

Fortunately, I needed to rewrite it anyway because it didn't work correctly.

Just another bump in the road.

#23
thursday77

thursday77

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Unfortunately, when I was working in terminal, I accidentally rm -R'ed my entire source code directory. One file was open, which was the largest, but I still lost alot of code.

Fortunately, I needed to rewrite it anyway because it didn't work correctly.

Just another bump in the road.


Argh, that sucks.. but I guess you're making some progress as you know it wouldn't work correctly before..

Good luck!

#24
bliss

bliss

    we have done with P.O.W.E.R.

  • Members
  • PipPipPipPipPip
  • 334 posts
  • Gender:Male
  • Location:Germany
really great job. wish i could help you, but i cant code.

#25
Arcanis

Arcanis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
I would like to help too but my coding skills are limited to data structures only lol (2nd year of information engineering, and the first year we only took maths/physics)..

I'll still take a look to the BSD driver and see if I can do something, I don't like giving only words of support, I actually wanna help to this project.

Good luck, I really appreciate your efforts :whistle:

#26
james2mart

james2mart

    InsanelyMac Sage

  • Retired Developers
  • 344 posts
This kext is built to give information to you for you to post back here. That's all that it does. This kext is designed for the SigmaTel 9200, but should work for anyone with an ICH7 chip, device id=27d88086.

This kext reports the device ID of any HDA codec of any brand as long as it meets the specifications of the Intel HDA Standard.

Even If you do not have a SigmaTel 9200, you can use this program to read your HDA Codec device ID.

If you DO have a 9200, This kext will report correct values for pin widgets inside your audio codec.

To load this kext, RESTART YOUR COMPUTER with all AppleAzalia and AppleHDA kexts disabled. this is the only way to get the information stored in your codec's verb table by bios. Then open up terminal and browse to the folder where the kext is. use
#sudo -s 
password: <---- type your password when sudo asks for it
#chown -R root:wheel SigmaTelAudioDriver.kext && chmod -R 755 SigmaTelAudioDriver.kext
to set the permissions. then, open up another terminal (COMMAND+N) and type:
#tail -f /var/log/system.log
go back to the first terminal and type:
#kextload SigmaTelAudioDriver.kext
you will see the other terminal window scroll. Find the indicated information and post it here for driver development. If you have problems with this sequence post here. Others may assist you, but I dont have the time to help newcomers load kexts (sorry). Please report any SuperClass Changed kextloading errors. This was built on 10.4.7 so if you are running anything prior to 10.4.6 this may not run.

Later.

Attached File  SigmaTelAudioDriverV2.kext.zip   135.65KB   495 downloads
Attached File  SigmaTelAudioDriverV3.kext.zip   135.92KB   758 downloads

Edited by james2mart, 11 July 2006 - 10:29 PM.


#27
Diodak

Diodak

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
hmmm... where is this kext? ;)

#28
james2mart

james2mart

    InsanelyMac Sage

  • Retired Developers
  • 344 posts
sorry. forgot to add it. I'm forgetful. Will add later tonight when I get to a wired connection... :-\

#29
thursday77

thursday77

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
DAMN I have been fiddling around with installing mac os x the whole day (trying to dualboot) and now I finally have it installed, I can't use the key '#' & I think I'm doing this wrong.. I don't have an idea about how to boot with these things you told disabled.. can someone be more specific?

thanks

#30
james2mart

james2mart

    InsanelyMac Sage

  • Retired Developers
  • 344 posts
the # simply shows that you are supposed to enter the commands at a terminal, you dont actually press the # key.

To disable the two kexts, go to /System/Library/Extensions and rename the two files that I told you from ****.kext to *****.kext.disabled. this disables them but does not delete them.

#31
thursday77

thursday77

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
okay thanks.. I just moved the two kexts to USB stick and deleted them because I was unable to rename them (clicking on the filename and than typing just lets os x select another file with the letter of the pressed key)

so rebooted.. than used the terminal, but I don't know these unix commands on how to browse to the file dir of Sigmatelaudiodriver.kext (I placed it on my install disk where the folders: applications, library, system and users are located..)

help? I'm almost there giving you the outputs :graduated:

btw, isn't the '&&' in that first line a typo?

#32
rodolfo

rodolfo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Jul 11 09:40:58 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x3524300]::initHardware(0x2e2b300)
Jul 11 09:40:58 rodolfos-computer kernel[0]: -vvvvvv-SUBMIT INFORMATION STARTING HERE-vvvvvv-
Jul 11 09:40:58 rodolfos-computer kernel[0]: deviceID/VendorID: 0x83847690
Jul 11 09:41:00 rodolfos-computer kernel[0]: Your codec is not a matching codec.
Jul 11 09:41:00 rodolfos-computer kernel[0]: -^^^^^^-SUBMIT INFORMATION CONTAINED HERE-^^^^^^-
Jul 11 09:40:58 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x3524300]::free()


Using Dell Inspiron 9400
Mac OSX 10.4.7

#33
james2mart

james2mart

    InsanelyMac Sage

  • Retired Developers
  • 344 posts

okay thanks.. I just moved the two kexts to USB stick and deleted them because I was unable to rename them (clicking on the filename and than typing just lets os x select another file with the letter of the pressed key)

try right click-> rename

so rebooted.. than used the terminal, but I don't know these unix commands on how to browse to the file dir...

"cd" means change directory. if you put the kext on the desktop, simply open the terminal, sudo -s, and then type "cd Desktop" then proceed with the instructions.

btw, isn't the '&&' in that first line a typo?

no.


Jul 11 09:40:58 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x3524300]::initHardware(0x2e2b300)
Jul 11 09:40:58 rodolfos-computer kernel[0]: -vvvvvv-SUBMIT INFORMATION STARTING HERE-vvvvvv-
Jul 11 09:40:58 rodolfos-computer kernel[0]: deviceID/VendorID: 0x83847690
Jul 11 09:41:00 rodolfos-computer kernel[0]: Your codec is not a matching codec.
Jul 11 09:41:00 rodolfos-computer kernel[0]: -^^^^^^-SUBMIT INFORMATION CONTAINED HERE-^^^^^^-
Jul 11 09:40:58 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x3524300]::free()
Using Dell Inspiron 9400
Mac OSX 10.4.7



Sorry rodolfo, should work now for device ID 0x83847690. I had a typo in the code. New kext is attached to Post #1.

#34
thursday77

thursday77

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Jul 11 09:40:58 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x3524300]::initHardware(0x2e2b300)
Jul 11 09:40:58 rodolfos-computer kernel[0]: -vvvvvv-SUBMIT INFORMATION STARTING HERE-vvvvvv-
Jul 11 09:40:58 rodolfos-computer kernel[0]: deviceID/VendorID: 0x83847690
Jul 11 09:41:00 rodolfos-computer kernel[0]: Your codec is not a matching codec.
Jul 11 09:41:00 rodolfos-computer kernel[0]: -^^^^^^-SUBMIT INFORMATION CONTAINED HERE-^^^^^^-
Jul 11 09:40:58 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x3524300]::free()


Okay thanks, I got some useless information out of this.. I can't find ANY word matching rodolfo's output...
Hm almost downloaded the 10.4.7 update.. I will try again if I have my 10.4.6 updated..

btw, I don't see the option 'rename' when rightclicking on a file.. Bleh, lots of things are faulty in my installation.. also the Core Image and Quartz Extreme are not supported according the system preferences, while I have an Intel GMA 900..

#35
james2mart

james2mart

    InsanelyMac Sage

  • Retired Developers
  • 344 posts

Okay thanks, I got some useless information out of this.. I can't find ANY word matching rodolfo's output...
Hm almost downloaded the 10.4.7 update.. I will try again if I have my 10.4.6 updated..

btw, I don't see the option 'rename' when rightclicking on a file.. Bleh, lots of things are faulty in my installation.. also the Core Image and Quartz Extreme are not supported according the system preferences, while I have an Intel GMA 900..


please try the new kext i added an hour ago.

#36
thursday77

thursday77

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
the same useless {censored} with that one..

#37
james2mart

james2mart

    InsanelyMac Sage

  • Retired Developers
  • 344 posts

the same useless {censored} with that one..


what did system.log say? I need to see what it said for me to give you any assistance...

#38
rodolfo

rodolfo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Jul 11 11:10:55 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x261d100]::initHardware(0x21a0200)
Jul 11 11:10:55 rodolfos-computer kernel[0]: -vvvvvv-SUBMIT INFORMATION STARTING HERE-vvvvvv-
Jul 11 11:10:55 rodolfos-computer kernel[0]: deviceID/VendorID: 0x83847690
Jul 11 11:10:55 rodolfos-computer kernel[0]: Your codec is not a matching codec.
Jul 11 11:10:55 rodolfos-computer kernel[0]: -^^^^^^-SUBMIT INFORMATION CONTAINED HERE-^^^^^^-
Jul 11 11:10:55 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x261d100]::free()


using the v2 kext you posted

#39
james2mart

james2mart

    InsanelyMac Sage

  • Retired Developers
  • 344 posts

Jul 11 11:10:55 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x261d100]::initHardware(0x21a0200)
Jul 11 11:10:55 rodolfos-computer kernel[0]: -vvvvvv-SUBMIT INFORMATION STARTING HERE-vvvvvv-
Jul 11 11:10:55 rodolfos-computer kernel[0]: deviceID/VendorID: 0x83847690
Jul 11 11:10:55 rodolfos-computer kernel[0]: Your codec is not a matching codec.
Jul 11 11:10:55 rodolfos-computer kernel[0]: -^^^^^^-SUBMIT INFORMATION CONTAINED HERE-^^^^^^-
Jul 11 11:10:55 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x261d100]::free()
using the v2 kext you posted


hrm. give v3 a shot. it should give me a little help debugging that for you. be SURE to DELETE the previous version! also try putting it in a different directory.

#40
rodolfo

rodolfo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Im pretty sure i deleted old kext

kext v1 info:
Jul 11 09:40:58 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x3524300]::initHardware(0x2e2b300)
Jul 11 09:40:58 rodolfos-computer kernel[0]: -vvvvvv-SUBMIT INFORMATION STARTING HERE-vvvvvv-
Jul 11 09:40:58 rodolfos-computer kernel[0]: deviceID/VendorID: 0x83847690
Jul 11 09:41:00 rodolfos-computer kernel[0]: Your codec is not a matching codec.
Jul 11 09:41:00 rodolfos-computer kernel[0]: -^^^^^^-SUBMIT INFORMATION CONTAINED HERE-^^^^^^-
Jul 11 09:40:58 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x3524300]::free()

kext v2 info
Jul 11 11:10:55 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x261d100]::initHardware(0x21a0200)
Jul 11 11:10:55 rodolfos-computer kernel[0]: -vvvvvv-SUBMIT INFORMATION STARTING HERE-vvvvvv-
Jul 11 11:10:55 rodolfos-computer kernel[0]: deviceID/VendorID: 0x83847690
Jul 11 11:10:55 rodolfos-computer kernel[0]: Your codec is not a matching codec.
Jul 11 11:10:55 rodolfos-computer kernel[0]: -^^^^^^-SUBMIT INFORMATION CONTAINED HERE-^^^^^^-
Jul 11 11:10:55 rodolfos-computer kernel[0]: SigmaTelAudioDevice[0x261d100]::free()

initHardware code is not the same between 2 logs
Also I restarted between the 2 versions





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy