Jump to content

Marvell 88e8057 Kext


  • Please log in to reply
20 replies to this topic

#1
x500

x500

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I am currently in the process of finishing up my install of 10.6 retail using Empire EFI on my EVGA P55 FTW, with a GTS 250. It has Dual Gigabit lan using the Marvell 88E8057 chipset. Right now I am using the Rosewill EasyN1 for internet access, but it is painfully slow since the wireless here sucks. Is there any way I can get this working? I've tried installing some other Marvell Kexts, but they didn't work.
Any idea's?

#2
x500

x500

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
If anyone needs me to do anything on my end, I can do whatever.

#3
Hassan Rai

Hassan Rai

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
X500, you're the only person i could find using the EVGA P55 FTW (so far) on this forum. Can you report what is working and what is not for you on this board?

I'm sorry i'm not in a position to help with the Marvel kexts, but i'm considering building a system with the EVGA motherboard you have and i'm wondering if it is easy or hard to install on it. Which guide/thread did you use for help with installing on this board?

#4
Boombeng

Boombeng

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 598 posts
  • Gender:Male
  • Location:France
Hello,

You can add your ID in Yukon2.kext or use a plist kext to patch your ID on the fly, that's what I do for my 88E8056 marvel controler

Try to instal this kext in S/L/E and report if it works, I added your ID in the plist, but maybe 88e8057 is too different and it won't work...

cheers

Attached Files



#5
SomeJumper

SomeJumper

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Hello,

You can add your ID in Yukon2.kext or use a plist kext to patch your ID on the fly, that's what I do for my 88E8056 marvel controler

Try to instal this kext in S/L/E and report if it works, I added your ID in the plist, but maybe 88e8057 is too different and it won't work...

cheers



It didn't work for me in snow leopard =(

#6
Rod G.

Rod G.

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I have the same problem so I just went out and bought usb to ethernet adapter For $19.00 and it works great!

#7
ScorpionMkd

ScorpionMkd

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Ok I got some progress here!

I'm using the same ethernet adapter on my sony laptop, iDeneb v1.6

I modified IONetworkingFamily.kext and changed 88E8056 ID to 88E8057 ID

The network card got detected, but it says "cable unplugged" all the time

Anyone has a clue??

Attached Files



#8
verynice

verynice

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Location:Canada
I have the Yukon 88e8071 I wish I could get that working

#9
Fitseries3

Fitseries3

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Is there any update on getting the 8057 to work?

#10
viv

viv

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
hi all,

I am also working hard to bring my 88e8057 lan card. Still no luck. Installed somme AppleYukon.kext from this forum...It detects my card with 2-3 errors and showing cable is unplugged.

Any body who can help in this?

Will post the dmesg 2mro.

#11
stalvatero

stalvatero

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Same problem here.

I installed Hazard 10.6.1, and all works fine, but this damned Marvel Yukon 88E8057.

Any help?

#12
sf3000

sf3000

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Same problem here.

I installed Hazard 10.6.1, and all works fine, but this damned Marvel Yukon 88E8057.

Any help?


i need this also for evga p55 mobos..

#13
GuyPicks

GuyPicks

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
I'm looking for x58 mobo.

If I find one I'll definetly post.

Surely someone has made a 88e8057 kext for os x.

#14
GuyPicks

GuyPicks

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Any updates on this yet?

#15
tj_jackson

tj_jackson

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts
  • Gender:Male
  • Location:Brasil - SP
I have a Evga Classified SR-2 and am having the same problem

Not Detect the two network cards Marvel 88E8057

#16
dude120

dude120

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
same problem as the above poster. Need this kext for my sr-2. 

#17
tj_jackson

tj_jackson

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts
  • Gender:Male
  • Location:Brasil - SP
not ethernet, not updates = bugs prograns final cut studio 3

#18
Lord_Richard_2

Lord_Richard_2

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:WI
I have tried to edit the Yukon2 kext to match the 88E8057 ethernet adapter using EditPad Lite, but it did not work. I changed the vender/model ID's i got from device manager in windows, and i even changed the yukon 2 name from .....53 to ......57 and also corrected the name in the
info.plist file under IONetworkingFamily.kext.

Have any of you got any ideas? EFI string? or is that only for Graphics?
And what about a DSDT patch?

I cannot get mac to recognize an ethernet card is installed. I have hazard snow leopard 10.6.6i and i got my ALC275 audio working.

I have a sony VPCF13FYX with an i7 740QM board with nvidia 425m.
I attached the kext for ALC275 if anybody needs it.

Attached Files



#19
MadSkillzMan

MadSkillzMan

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Any luck anywhere guys? Rather than just posting and doing nothing ive been studying the source code for the 8001 driver on the other thread. wonder how hard it'd be to modify...

Also, just an FYI, i know linux supports it now, so if we could find a source code...

#20
Frank Nitty

Frank Nitty

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 131 posts
  • Gender:Male
  • Location:Rock Town
  • Interests:iHustle
does anyone have the Marvell Yukon 88E8057 installation kext, because i need it?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy