Jump to content

Geforce 7600 GT EFI Strings & Snow Leopard


  • Please log in to reply
11 replies to this topic

#1
djspacee

djspacee

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Worcestershire, UK
Hi guys,

If anybody has got any gefore 7600GT working using EFI strings help would be very much appreciated. I've got snow leopard fully working with DSDT by following this excellent guide, (http://www.insanelym...howtopic=184367) but for some reason my no EFI strings that i try (which I have got in com.apple.Boot.plist in my /Extra folder), taken from two sources, will work.

The first source of EFI strings for my card is

http://www.insanelym...howtopic=113967

The second source I've tried is EFI studio and neither do the trick.

infact, the first source was the only string that gave me a working graphics for Leopard and not the one from EFI studio, but it was worth trying anyway.

I know that the 7600 GT does work with snow leopard and EFI strings because it has been confirmed here and in quite a few other places that I've read...

http://wiki.osx86pro...p;printable=yes

I've also tried modifying the com.apple.Boot.plist in SystemConfiguartion, tried using identical copies of them in both locations, nethier helped. Iv've also tried NVDANV50Hal.kext and 0.2.1 NVInject in my /Extra/Extensions folder but to no avail.

Any help would be very much appreciated.

Thanks

This is my current com.apple.boot.plist (the same EFI string working fine on my leopard installation).

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=x86_32</string>
<key>device-properties</key>
<string>6c0200000100000001000000600200000d00000002010c00d041030a010000000101060000010
101060000007fff04001e00000072006f006d002d007200650076006900730069006f006e0000002
e
0000004e7669646961204765466f7263652037363030204754204f70656e474c20456e67696e6520
5
b4546495d22000000400030002c006400650076006900630065005f00740079007000650000000b0
0
0000646973706c6179100000004e00560043004100500000001800000004000000000003000c0000
0
000000007000000000e0000006e0061006d00650000000b000000646973706c61791400000040003
0
002c006e0061006d0065000000120000004e5644412c446973706c61792d41100000006d006f0064
0
065006c0000001a0000004e7669646961204765466f72636520373630302047540e0000004e00560
0
50004d00000020000000010000000000000000000000000000000000000000000000000000001400
0
000400031002c006e0061006d0065000000120000004e5644412c446973706c61792d42200000004
0
0031002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d61
6
3220000005600520041004d002c0074006f00740061006c00730069007a006500000008000000000
0
001020000000400030002c0063006f006d00700061007400690062006c00650000000e0000004e56
4
4412c4e564d616322000000400031002c006400650076006900630065005f0074007900700065000
0
000b000000646973706c61791c0000006400650076006900630065005f0074007900700065000000
0
f0000004e5644412c506172656e74</string>
</dict>
</plist>

#2
kdm

kdm

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
hi djspacee, any news with the 7600GT driver?
thx you

#3
snakeman

snakeman

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts

hi djspacee, any news with the 7600GT driver?
thx you




Actually guys it will work fine if you switch to i386 mode in your com.apple.boot.plist


Here is my file

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot Banner</key>
<string>No</string>
<key>Default Partition</key>
<string>hd(0,2)</string>
<key>Graphics Mode</key>
<string>1280x1024x32@60Hz</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>PciRoot</key>
<string>0</string>
<key>RestartFix</key>
<string>YES</string>
<key>SystemID</key>
<string>UUID here</string>
<key>Theme</key>
<string>Nice</string>
<key>arch</key>
<string>i386</string>
<key>device-properties</key>
<string>your-string-here<string/>
</dict>
</plist>


Adjust to your taste keep in mind this is with my custom dsdt.aml
file for a p5k flashed to a p5k®
I would like to thank scrax A true guru for all the help with dsdt.aml

Cheers, I need to figure out how to do a hardware signature ;)


snakeman

#4
Martin C

Martin C

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Hi djspacee,

Did you figure it out? I have also have 7600 GT (256mb) and am having trouble getting QE/CI to work.

Thanks,
MC.

#5
fpdesigner

fpdesigner

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:italy

Hi djspacee,

Did you figure it out? I have also have 7600 GT (256mb) and am having trouble getting QE/CI to work.

Thanks,
MC.


I have the same card ge force 7600 gt , on xxx 10.5.6 perfect like in 10.4.8 jas , yesterday i have tried iportable snow on a usb key and , the gefoce don't go in extended monitor , i , can't change the resolution i can ave two desktop .

I have installed the classic nvidia driver , i don't . have efi , i don't have mach_kernel , someone can help me ?

i have patched DSDT, THE USB KEY WORK , but i want to fix audio and video .

#6
Mak 1

Mak 1

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
<key>Kernel Flags</key>
<string>arch=x86_32</string>


The problem why your graphics card does not work is that you must put arch=i386 instead of arch=x86_32.

i have 7600 GT 256Mb and i am using it with snow leopard 10.6.3. QE working perfect even i can play call of duty 4 and tomb raider anniversary. So the problem is, this card is not working under 64 bit mode so you have to boot your OS in 32 bit mode. I am in search to fix this and make my card work in 64 bit mode.

Don't worry about 64 bit programs they will still work in 32 bit OS. I have tested a lot of applications and they work with no problem either 64 or 32 bit.

Here's my com.apple.boot.plist You can use it if you want.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot Banner</key>
<string>No</string>
<key>DSDT</key>
<string>/dsdt.aml</string>
<key>Graphics Mode</key>
<string>1920x1080x32</string>
<key>Hide Partition</key>
<string></string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>PciRoot</key>
<string>1</string>
<key>SMBIOS</key>
<string>/Extra/smbios.plist</string>
<key>Theme</key>
<string>Default</string>
<key>Timeout</key>
<string>10</string>
<key>arch</key>
<string>i386</string>
<key>device-properties</key>
<string>6c0200000100000001000000600200000d00000002010c00d041030a0100000001010600000101010600
00007fff04001e00000072006f006d002d007200650076006900730069006f006e0000002e0000004e766964696120476
5466f7263652037363030204754204f70656e474c20456e67696e65205b4546495d22000000400030002c00640065007
6006900630065005f00740079007000650000000b000000646973706c6179100000004e0056004300410050000000180
0000004000000000003000c00000000000007000000000e0000006e0061006d00650000000b000000646973706c61791
4000000400030002c006e0061006d0065000000120000004e5644412c446973706c61792d41100000006d006f0064006
5006c0000001a0000004e7669646961204765466f72636520373630302047540e0000004e00560050004d00000020000
0000100000000000000000000000000000000000000000000000000000014000000400031002c006e0061006d006500
0000120000004e5644412c446973706c61792d4220000000400031002c0063006f006d00700061007400690062006c00
650000000e0000004e5644412c4e564d6163220000005600520041004d002c0074006f00740061006c00730069007a00
65000000080000000000001020000000400030002c0063006f006d00700061007400690062006c00650000000e000000
4e5644412c4e564d616322000000400031002c006400650076006900630065005f00740079007000650000000b000000
646973706c61791c0000006400650076006900630065005f00740079007000650000000f0000004e5644412c506172656
e74</string>
</dict>
</plist>

Just add your graphics card EFI string if you have different card. This is for 7600 GT 256Mb.

Note: The easiest way to test if QE working or not is adding widget to dashboard. if ripple effect appears when you drop widget then you have your QE working.


My Specs.

OS
-Snow Leopard 10.6 Retail Disk. 10.6.3 Combo Update installed (with update guide provided by Netkas.org).
-Chameleon RC4 (installed with lizard.app)+ DSDT.aml (for CMOS reset fix)

HARDWARE
-MSI P965 NEO
-MSI NVIDIA GeForce 7600 GT
-TwinMOS 2GB Ram
-INTEL Core 2 du E6420 2.13 Ghz

Some APPLICATIONS
-Creative Suite Deign Premium CS5 (64 bit) - working perfect
-Ableton Suite 8 (32 Bit) - working perfect
-Kaspersky Antivirus 8 (32 Bit) - working perfect
-Toast 10 Titanium (32 Bit) - working perfect
-ILife (imovie, idvd, iweb etc.)- working perfect
-IWork (pages, keynote, numbers)- working perfect

Screen Shot

Attached File  Screen_shot_2010_06_08_at_5.44.19_PM.jpg   96.72KB   106 downloads

#7
martin_gall

martin_gall

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
  • Gender:Male
Hummm... In your opinion, is there any hope of waiting for the right kext that will run in 64-bit under 10.6.3, for the 7600 GT ? I'm so disapointed !!! ^_^

#8
Pencemen

Pencemen

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Hummm... In your opinion, is there any hope of waiting for the right kext that will run in 64-bit under 10.6.3, for the 7600 GT ? I'm so disapointed !!! :angel:


ugh!

#9
Mak 1

Mak 1

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male

Hummm... In your opinion, is there any hope of waiting for the right kext that will run in 64-bit under 10.6.3, for the 7600 GT ? I'm so disapointed !!! :(




U dont have to worry things if you dont have more than 4GB RAM. if you have less than 4gb either in 64 or 32 bits the OS will work the same way and the applications as well. And in addition most of the popular applications doesnt have 64 bit compatibility so 64 doesnt bother then just use it 32. those who have 64 needs more ram they also need more graphics memory and cpu power. so i dont think those 64 applications are stisfied with 256mb vga. but i think 32 applications are fully satisfied .in suumary if you can boot in native 64 with 7600gt and test it with native 64 app then go back to 32 bit mode and test it with the same 64 app --> No difference. Only thoes apps use more RAM power then VRAM will have diffrence. I mean if u use VGA powered apps than dont get disappointed about it. but if u use RAM powered apps than u can only use 4gb in 32 mode.

I think this little explanation helps you to see the picture.

I use 64 and 32 bit apps and i now updated to 10.6.4. Everyting works fine again.

but i will still looking for native 64 bit mode with 7600gt.not to see how well it works but to see it is possible.there is a chance because it is working in 32.

Instead of waiting u can use it and keep your eye on forums for the solution. or u can choose another alternatives like improving your vga which is compatible with 64bit or For real deal get a REAL APPLE MAC Computer and get more than you want (if you have enough $) --> thats exactly what i am going to do soon. :)

#10
jerry88599

jerry88599

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

U dont have to worry things if you dont have more than 4GB RAM. if you have less than 4gb either in 64 or 32 bits the OS will work the same way and the applications as well. And in addition most of the popular applications doesnt have 64 bit compatibility so 64 doesnt bother then just use it 32. those who have 64 needs more ram they also need more graphics memory and cpu power. so i dont think those 64 applications are stisfied with 256mb vga. but i think 32 applications are fully satisfied .in suumary if you can boot in native 64 with 7600gt and test it with native 64 app then go back to 32 bit mode and test it with the same 64 app --> No difference. Only thoes apps use more RAM power then VRAM will have diffrence. I mean if u use VGA powered apps than dont get disappointed about it. but if u use RAM powered apps than u can only use 4gb in 32 mode.

I think this little explanation helps you to see the picture.

I use 64 and 32 bit apps and i now updated to 10.6.4. Everyting works fine again.

but i will still looking for native 64 bit mode with 7600gt.not to see how well it works but to see it is possible.there is a chance because it is working in 32.

Instead of waiting u can use it and keep your eye on forums for the solution. or u can choose another alternatives like improving your vga which is compatible with 64bit or For real deal get a REAL APPLE MAC Computer and get more than you want (if you have enough $) --> thats exactly what i am going to do soon. ;)


Hello:

I have an exactly same card with you, but I have been failed for dozens of time which can not install the driver for this graphic card, neither the resolution can not adjust or the QE/CI can not enable, now the system is crashed again in this early morning. I am wondering if you could help me on this. I am using Boot Think to load the snow leopard and try different kext which all failed. My email is: jerry88599@gmail.com and looking forward for your reply.

The hardware ID for my graphic card is:

0x0391

Thanks again.

#11
Mak 1

Mak 1

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male

Hello:

I have an exactly same card with you, but I have been failed for dozens of time which can not install the driver for this graphic card, neither the resolution can not adjust or the QE/CI can not enable, now the system is crashed again in this early morning. I am wondering if you could help me on this. I am using Boot Think to load the snow leopard and try different kext which all failed. My email is: jerry88599@gmail.com and looking forward for your reply.

The hardware ID for my graphic card is:

0x0391

Thanks again.




Try to use chameleon rc4 and dont forget to configure your com.apple.boot.plist add your vga efi string as i hav written above or copy whole lines to com.apple.boot.plist. i will send u detailed info 2 ur mail when i have time to write it.

#12
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 5,857 posts
  • Gender:Male
  • Location:Brazil

U dont have to worry things if you dont have more than 4GB RAM. if you have less than 4gb either in 64 or 32 bits the OS will work the same way and the applications as well.


Actually it should work the same way with up to 32GB RAM, I think you must be confusing Snow Leopard with Windows.
Read this article:
http://osxbook.com/b...ow-leopard-k64/





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy