Jump to content

Lifehacker Guide with GA-EP45-UD3P Motherboard


  • Please log in to reply
2370 replies to this topic

Poll: GA-EP45-UD3P / Core 2 Quad / 9800gtx Experience (406 member(s) have cast votes)

Are you Booting SL

  1. Stable - No Problems (196 votes [47.80%])

    Percentage of vote: 47.80%

  2. Stable - Minor Issues (142 votes [34.63%])

    Percentage of vote: 34.63%

  3. Unstable - Kernel Panics (26 votes [6.34%])

    Percentage of vote: 6.34%

  4. Not Booting (46 votes [11.22%])

    Percentage of vote: 11.22%

Vote Guests cannot vote

#2361
sirlou

sirlou

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Wow! I had not checked this thread for ages, and came back on a whim (mostly b/c my old SL hack is feeling kinda sluggish lately) and lo and behold there are major developments!

So, just so I understand, you guys installed CLOVER (per the instructions posted) and then were able to install Mtn Lion from the straight Apple installer, and then just patch audio (as with 10.6.8?, or how) and install the listed RealtekRTL81xx.kext, and viola?

That sounds liek a dream come true. :)

sirlou

#2362
D-an-W

D-an-W

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 417 posts
I changed the Audio layout in my DSDT and now I don't even need to patch AppleHDA.kext

There are now only three kexts used here, FakeSMC.kext (Can't not use this!), RealtekRTL81xx.kext (For onboard LAN) and AHCI_3rdParty_SATA.kext (To correctly name my 3rd party SATA III adapter).

With Clover installed on a USB stick, I can boot a vanilla Mountain Lion 10.8.2 installer on the same USB and the proceed to install OS X without any issue at all.

The only other file I patch is com.apple.mDNSResponder.plist to stop the machine waking from sleep every few hours to check the network but this is optional of course.

#2363
sirlou

sirlou

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Nice! I have an extra 650gb SATA disk laying around so I think I will buy Mtn Lion on my Mini and then try this in the next week or so. Would be a nice way to stay current without having to invest in further hardware b/c to be honest my demands are not so great that my E8400 can't handle it.

I may bug you D-an-W if I run into any problems, but given it'll be on a test drive I'm hoping I can sort it out via trial and error.

sirlou

#2364
sirlou

sirlou

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
OK real quick question for you folks using CLOVER. I ran into a little problem so I though I would discuss before trying again.

I downloaded it, installed it to a formatted fat32 USB stick using the BIOS install type setup, and then was able to boot from it off the USB stick no problem. The stick showed my main Lifehacker 10.6.8 SL drive, my Win 7 drive, and my backup Lifehacker 10.6.8 SL USB drive (vanilla working system).

All seemed good until I tried to boot my main drive. It crashed somewhere during the fsck (not sure what was wrong with my file system exactly except there was an errant AverMedia file in /Library/LaunchDaemons/. In any event the boot froze, and then when I restarted my install was hosed - it had somehow wiped out my BIOS setting (it took me a frantic few minutes to realize this, lol - and I had to re-do my bios per the LH instructions and then all was well again.

Have not tried again, b/c I thought I'd ask here first about what exact setting you guys used on your Clover installs (which check boxes you used), and also if either of you have experienced such a crash when you tried to run clover. My though is to re-try the current install of clover on my USB with my main drive unplugged and just see if I can boot the vanilla SL install and/or windows disks.

Also I had another question...once you get 10.8 installed, did you install clover to your main drive to bootload from it? Do do you need to?
Can you just go back to another bootloader you like, like Chameleon or Chimera?

My plan is to install 10.8 via clover to a newly formatted drive, then just copy over my files and such once the system is up and running. Then superdup the working 10.8 onto my backup drive, and leave my old 10.6.8 intact ...just in case. ;)

Your thoughts and advice on this would be appreciated. :)

#2365
Tober

Tober

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Sirlou, I ened up having some issues with clover and wasn't able to get updated to 10.8.2. I ended up swithcing to Kakewalk since it supports our board and things have been much smoother for me. Sorry, I can't reallly give a whole lot of advise on Clover.

#2366
D-an-W

D-an-W

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 417 posts
sirlou, I will PM you a link to the files I use to install 10.8.2 on a blank drive, the only thing I have removed is the Serial number as I use a genuine one (See "NEEDSERIALHERE" in Config.plist, two places) and I commented out my 1920x1200 resolution setting in rEFIt.conf as I don't know your native setting.

For installation I use it on a USB stick installed with the default settings but don't forget to format the stick as advised in the installer replacing the * with the number of your USB stick...

Need to format as Fat32 on Win or on Mac as below.
1. Erase as MS-DOS (FAT) with Disk Utility first.
2. diskutil list
3. diskutil unmount /dev/rdisk*s1
4. newfs_msdos -v Fat32 -F 32 /dev/rdisk*s1
5. diskutil mount /dev/rdisk*s1

The USB files are the same as the files I used once installed but you can remove this "EFI/OEM/EP45-UD3P/Kexts/10.8/IONetworkingFamily.kext" (It's not needed after you run Kext Utility) and you install it to the hidden EFI partition on the boot drive but we will get to this once you are booting from USB ok.

I will also include my custom DSDT which gives me audio without any patching and I have removed AHCI_3rdParty_SATA.kext as I don't know if you have that add-on SATAIII adapter
Once installed the only thing I edit in 10.8.2 is com.apple.mDNSResponder.plist to prevent the system waking from sleep every few hours to check the network connections.

Basically, install Clover USB with the default settings and then delete the EFI folder it creates, replace it with the one I send and give it a shot, if things don't seem to work I will take some shots of my BIOS settings as a start point.

My hardware is below...

#2367
JTG78

JTG78

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts
  • Gender:Male
  • Location:Ohio

Just thought I'd chirp in and see if anyone is still following this thread. 

 

I'm stil using the Lifehacker build I put together in Sept 2009, and in fact, I'm in the process of getting it to run OS 10.9  (It's currently running 10.8.4)  I (mostly) succeessfully installed 10.9 on my test HD yesterday evening, using the myHack utility pinned in the 10.9 installation forum. I intend to ensure it's working correctly over the next day or so before I try the installation on my main boot SSD.



#2368
HAVEC

HAVEC

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 122 posts
  • Location:Marin County, CA

Just thought I'd chirp in and see if anyone is still following this thread. 

 

I'm stil using the Lifehacker build I put together in Sept 2009, and in fact, I'm in the process of getting it to run OS 10.9  (It's currently running 10.8.4)  I (mostly) succeessfully installed 10.9 on my test HD yesterday evening, using the myHack utility pinned in the 10.9 installation forum. I intend to ensure it's working correctly over the next day or so before I try the installation on my main boot SSD.

 

My Oct 2009 Cartri SL 10.6.8 is alive and well.  I built a Lion Hackentosh Tony Mac ##### but it was too high maintenance.  Plus I don't need all that cloud BS.  



#2369
RC

RC

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Los Angeles

Ok.

 

So I am ready to upgrade to Mountain Lion.

 

I am currently still running my Cartri SL 10.6.8 rig.  Like Havec, this system is still running like gangbusters.  

 

Anyway, I purchased Mountain Lion, but I am unable to log into the app store to download it.  I've searched the interwebs and this seems like a common problem even with folks who have a "legit" system.  I've tried most of the published fixes to no avail.

 

Any ideas?



#2370
RC

RC

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Los Angeles

Well, I was able to log into the app store on a "real" Mac at work and was able to download the installer and make a bootable USB stick from it.  Now, when I try to install, I get a message that my computer is not compatible.  Im guessing this is an issue with the serial number.  

 

Im going to try a smbios.plist and see how things work out...



#2371
HAVEC

HAVEC

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 122 posts
  • Location:Marin County, CA

Bad News for SL.  According to ars technica no more updates for SL.  I don't use my Catri rig all that much but it nice to have a Mac when you need it.  New is not necessarily better and I didn't have very good luck with the Tony Mac Lion system that I built so I'm going to stick with this rig until it no longer works which might be a long time. Or not.







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy