Jump to content

Gigabyte GA-G41M-ES2L


  • Please log in to reply
19 replies to this topic

#1
ruy.benton

ruy.benton

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Hi,

Thanks for great support.

This board is the best ;)

1) Kalyway 10.5.2 and iPC 10.5.6 select R1000 for LAN, Azalia (Realtek ALC888B) for sound and ICHx SATA drivers. In iPC select PS/2 fix if you use keyboard and mouse - PS/2.

Or you can edit Sound Kext:

nano AppleAzaliaAudio.kext/Contents/Info.plist

<key>Realtek ALC880/ALC860 Codec Driver</key>
........
<key>IOHDAudioCodecVendorID</key>
<string>0x10ec0887 0x10ecffff 0x11d4ffff 0x14f1ffff 0x8384ffff</string>

nano AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/Contents/Info.plist

<key>IOPCIPrimaryMatch</key>
<string>0x27D88086</string>



2) Leo4AllVx, Jas xxxx and others. Install and then copy the Lan, Sound Kext to the /System/Libray/Extensions from other systems or edit AppleAzaliaAudio.kext.

If you don't select R1000 Kext. You get a loop "Do you already own a mac?"
and you need to enter in single mode and
"touch /private/var/db/.AppleSetupDone"



3) Leopard Retail DVD - follow the tutorial for BOOT-132 and then copy R1000 for LAN, Azalia (Realtek ALC888B) for sound from a full working system (see previews notes) or edit AppleAzaliaAudio.kext.

If you need any help, please drop me a line :D

Best regards,

Ruy

#2
saucow

saucow

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Hi,

Thanks for great support.

This board is the best :)

1) Kalyway 10.5.2 and iPC 10.5.6 select R1000 for LAN, Azalia (Realtek ALC888B) for sound and ICHx SATA drivers. In iPC select PS/2 fix if you use keyboard and mouse - PS/2.

Or you can edit Sound Kext:

nano AppleAzaliaAudio.kext/Contents/Info.plist

<key>Realtek ALC880/ALC860 Codec Driver</key>
........
<key>IOHDAudioCodecVendorID</key>
<string>0x10ec0887 0x10ecffff 0x11d4ffff 0x14f1ffff 0x8384ffff</string>

nano AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/Contents/Info.plist

<key>IOPCIPrimaryMatch</key>
<string>0x27D88086</string>



2) Leo4AllVx, Jas xxxx and others. Install and then copy the Lan, Sound Kext to the /System/Libray/Extensions from other systems or edit AppleAzaliaAudio.kext.

If you don't select R1000 Kext. You get a loop "Do you already own a mac?"
and you need to enter in single mode and
"touch /private/var/db/.AppleSetupDone"



3) Leopard Retail DVD - follow the tutorial for BOOT-132 and then copy R1000 for LAN, Azalia (Realtek ALC888B) for sound from a full working system (see previews notes) or edit AppleAzaliaAudio.kext.

If you need any help, please drop me a line :)

Best regards,

Ruy


Hi I have the same board, and I have installed 10.5.7 with iaktos v7, did you manage to get the G41m or the integrated video card working?


-Thank You

#3
ruy.benton

ruy.benton

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

Hi I have the same board, and I have installed 10.5.7 with iaktos v7, did you manage to get the G41m or the integrated video card working?


-Thank You


Hi saucow,

We have a Linux (source):

http://intellinuxgraphics.org

We try to build the mac version.



If you and other people ask for support ... Intel will release a BSD version of X4500.

So write like me to Intel intel-gfx @ lists.freedesktop.org:

" Dear sir,

I buy your products for many years, please provide drivers for GMA X4500 for
FreeBSD, NetBSD, OpenBSD and Darwin...
...
"


Best regards,
Ruy

#4
hawaii50

hawaii50

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts

Hi,

Thanks for great support.

This board is the best :)

1) Kalyway 10.5.2 and iPC 10.5.6 select R1000 for LAN, Azalia (Realtek ALC888B) for sound and ICHx SATA drivers. In iPC select PS/2 fix if you use keyboard and mouse - PS/2.

Or you can edit Sound Kext:

nano AppleAzaliaAudio.kext/Contents/Info.plist

<key>Realtek ALC880/ALC860 Codec Driver</key>
........
<key>IOHDAudioCodecVendorID</key>
<string>0x10ec0887 0x10ecffff 0x11d4ffff 0x14f1ffff 0x8384ffff</string>

nano AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/Contents/Info.plist

<key>IOPCIPrimaryMatch</key>
<string>0x27D88086</string>



2) Leo4AllVx, Jas xxxx and others. Install and then copy the Lan, Sound Kext to the /System/Libray/Extensions from other systems or edit AppleAzaliaAudio.kext.

If you don't select R1000 Kext. You get a loop "Do you already own a mac?"
and you need to enter in single mode and
"touch /private/var/db/.AppleSetupDone"



3) Leopard Retail DVD - follow the tutorial for BOOT-132 and then copy R1000 for LAN, Azalia (Realtek ALC888B) for sound from a full working system (see previews notes) or edit AppleAzaliaAudio.kext.

If you need any help, please drop me a line :)

Best regards,

Ruy



Ruy,

I've got this motherboard and I followed the DSDT method to install from a Leopard retail dvd. I think this is what you mean in your option 3 above. Can you provide some details about how to get the sound working? Where can I find AppleAzaliaAudio.kext? or, Azalia (Realtek ALC888b) from a full working system?

Best,
h50

#5
ruy.benton

ruy.benton

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Hi

Good news - LAN.

You can use R1000 or download the reallllllllllll tek driver from:

http://www.realtek.c...p;GetDown=false

Ver. 2.0.3



Don't use both !!!!!!!!!!!!!!!

Best regards,

Ruy

#6
ruy.benton

ruy.benton

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Hi,

Sound

Dump from Ubuntu:
_______________________________________________________________________________
Codec: Realtek ALC887
Address: 2
Vendor Id: 0x10ec0887
Subsystem Id: 0x1458a002
Revision Id: 0x100202
...
_______________________________________________________


1 - From Kalyway 10.5.2 and iPC 10.5.6 select Azalia (Realtek ALC888B), and you can use AppleAzaliaAudio.kext in Vanilla install (delete or move AppleHDA from /S/L/Extensions) but only 2 channels - Stereo.

2 - Voodoo 0.2.2 - mic don't work. http://code.google.com/p/voodoohda (0.2.1 beta) mic work.
Move or delete AppleHDA from /S/L/Extensions

3 - With DSDT.aml - Line out, Head, Mic, etc work perfect, AppleHDA - Vanilla in /S/L/Extensions.
We need to create DSDT.aml (in /Extra) following the guide in "Building a DSDT for GA-EP45-DS3L v1.4",
and tmongkol instructions (DSDT.dsl):
"... change CodecID from 283904136 (0x10EC0888) to 283904135 (0x10EC0887).Change LayoutID from 888 to 887 or whatever you like.Change layout-id in DSDT from 0x78, 0x03, 0x00, 0x00 to 0x77, 0x03, 0x00, 0x00 in case you use LayoutID as 887."

My DSDT.aml (report sucess or ...) and LegacyHDA_ALC888B.zip from a guru.



Best regards,

Ruy

Attached File  DSDT.rar   6.12KB   552 downloads
Attached File  LegacyHDA_ALC888B.zip   12.09KB   789 downloads

#7
roberdo

roberdo

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
I want to share my experience with this mobo.
Since I'm a hackintosh noob I used both iDeneb 10.5.8 and iAtkos 10.5.7
Both worked, but with different small issues.

My components:
-Mainboard 775: GigaByte GA-G41M-ES2L
-CPU 775 Core 2 Duo: Intel Core 2 Duo Prozessor E8200 Boxed
-NVIDIA GeForce 9: Gainward GF9800GT Green
-HDD SATA: Western Digital WD6400AAKS 640 GB
-Case: SilverStone SUGO SG02B-F
-Memory DDR2-800: Corsair DIMM 4 GB DDR2-800 Kit
-Power Supply 400 Watt: be quiet! Straight Power E6 350W
-DVD-Burner SATA: LG GH-22NS

First I installed Win 7 and created/activated a new partition for Leo.
with iAtkos everything worked out of the box, means LAN, Sound (line out), Graphic. However after Apple-Update power-off when shutdown didn't work anymore. And there were some problems accessing NTFS partitions.

Therefore I decided to intall a fresh iDeneb 1.6 (10.5.8). Just choose Azalia for sound and Realtek R100 for LAN, works perfect.

I have only one problem left: With this Sound driver I can adjust the volume, but cannot change any Sound configuration. The icon in the control panel is greyed and cannot be activated. No problem for me, because there is no need for me to change any of the system-sounds. I have seen there are updates for the sound kext, but don't know how to deactivate existing kext and install a new one (you remember - I'm a noob).

Apple-Update works without any problems.

I really like my new PC with Dual-Boot and I can recommend this mobo.

Update Oct 4th: Plenty of time on a stormy and rainy Sunday afternoon resultet in a fully working OS X 10.5.8. Thanks for all the helfpul topics in this forum.

#8
Tobbe32

Tobbe32

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

I want to share my experience with this mobo.
Since I'm a hackintosh noob I used both iDeneb 10.5.8 and iAtkos 10.5.7
Both worked, but with different small issues.

My components:
-Mainboard 775: GigaByte GA-G41M-ES2L
-CPU 775 Core 2 Duo: Intel Core 2 Duo Prozessor E8200 Boxed
-NVIDIA GeForce 9: Gainward GF9800GT Green
-HDD SATA: Western Digital WD6400AAKS 640 GB
-Case: SilverStone SUGO SG02B-F
-Memory DDR2-800: Corsair DIMM 4 GB DDR2-800 Kit
-Power Supply 400 Watt: be quiet! Straight Power E6 350W
-DVD-Burner SATA: LG GH-22NS


Which graphic driver did you use for your 9800GT ?

#9
morrison

morrison

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
i, like most of you, have this board.
i just want to know how to enable my keyboard in the IPC boot selection
what does 'select ps2 fix' mean. (do i have to source on of these outdated pieces of ****?)
how do i select ps2 fix without a key board


but needless to say thank for the info. i do know nothing and would like your help. sorry to sound ignorant,
a positive message is a good thing

#10
morrison

morrison

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
sorry you might just as well ignore me i soon found the fix you spoke of in the bios

no waccas!

#11
paulette1234

paulette1234

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 24 posts
  • Gender:Female
  • Location:Ontario Canada
Total newbie here to the project. I recently found this thread and it sounded successful to try to build this box.
I purchased the following barebones setup.

http://www.tigerdire...AIN#detailspecs

To proceed i need...
1. Suggestions to what video card to purchase?
2. What disto to use or download if absolutely necessary,I am on dial-up?

I have downloaded iATKOS_5i
and uphuck_10.4.9_v1.4i_r2.iso
I have access to a copy retail leopard 10.5 dvd

Please make suggestions so i can join the mac user turned pc user because of cost OSX86 project.

#12
roberdo

roberdo

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

Which graphic driver did you use for your 9800GT ?


Really easy, just add an EFI string to your boot.plist. You can do it manually:

http://forum.netkas....php?topic=222.0

I did it automatically with a tool called =OSX86Tools (you can find it here or in google).
Very easy, just a few mouse clicks and everything worked fine, including QE&R and dual monitor support.

Total newbie here to the project. I recently found this thread and it sounded successful to try to build this box.
I purchased the following barebones setup.

http://www.tigerdire...AIN#detailspecs

To proceed i need...
1. Suggestions to what video card to purchase?
2. What disto to use or download if absolutely necessary,I am on dial-up?

I have downloaded iATKOS_5i
and uphuck_10.4.9_v1.4i_r2.iso
I have access to a copy retail leopard 10.5 dvd

Please make suggestions so i can join the mac user turned pc user because of cost OSX86 project.


1.) Nearly all current Nvidia cards are reported to work. I have decided to purchase a 9800GT (it's the same as an 8800GT) - powerful and cheap and natively supported (only EFI string is needed - that's it).

2.) You can find many topics in this forum explaining how to install with a retail DVD (vanilla). I decided to make it easier and used latest iAtkos (10.5.7). Very easy automatic install with chameleon boot loader, vanilla kernel, LAN, Sound worked out of the box. Updated to 10.5.8 with one remaining issue: Sleep does not work - I don't need it.
You can even choose navit video driver during install. GT9800 worked with it. I deleted this driver an added an EFI-String (see above).

Good luck!

#13
ruy.benton

ruy.benton

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

Hi,

Thanks for great support.

This board is the best ;)


Everything work in Vanilla 10.6.2, with a ATI HD 4850, Nvidia 9400, 7300.



If you need any help, please drop me a line :D

Best regards,

Ruy

#14
DanielMor

DanielMor

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Mexico

I want to share my experience with this mobo.
Since I'm a hackintosh noob I used both iDeneb 10.5.8 and iAtkos 10.5.7
Both worked, but with different small issues.

My components:
-Mainboard 775: GigaByte GA-G41M-ES2L
-CPU 775 Core 2 Duo: Intel Core 2 Duo Prozessor E8200 Boxed
-NVIDIA GeForce 9: Gainward GF9800GT Green
-HDD SATA: Western Digital WD6400AAKS 640 GB
-Case: SilverStone SUGO SG02B-F
-Memory DDR2-800: Corsair DIMM 4 GB DDR2-800 Kit
-Power Supply 400 Watt: be quiet! Straight Power E6 350W
-DVD-Burner SATA: LG GH-22NS

First I installed Win 7 and created/activated a new partition for Leo.
with iAtkos everything worked out of the box, means LAN, Sound (line out), Graphic. However after Apple-Update power-off when shutdown didn't work anymore. And there were some problems accessing NTFS partitions.

Therefore I decided to intall a fresh iDeneb 1.6 (10.5.8). Just choose Azalia for sound and Realtek R100 for LAN, works perfect.

I have only one problem left: With this Sound driver I can adjust the volume, but cannot change any Sound configuration. The icon in the control panel is greyed and cannot be activated. No problem for me, because there is no need for me to change any of the system-sounds. I have seen there are updates for the sound kext, but don't know how to deactivate existing kext and install a new one (you remember - I'm a noob).

Apple-Update works without any problems.

I really like my new PC with Dual-Boot and I can recommend this mobo.

Update Oct 4th: Plenty of time on a stormy and rainy Sunday afternoon resultet in a fully working OS X 10.5.8. Thanks for all the helfpul topics in this forum.




Hello, reading about GigaByte GA-G41M-ES2L apparently is working well.
But I would like better microprocessor
Cheap Grafica which I recommend
X86 Mac Snow Leopard - Leopard


GigaByte GA-G41M-ES2L
Intel Core 2 Quad Q8300 2.5 GHz
Kingston HyperX 2GB (2 x 1GB) DDR2 SDRAM (1066MHz - PC2-8500) Dual Channel Kit
Western Digital 500GB, 7200 RPM, 8MB Buffer
LG burner, Serial ATA DVD + RW

#15
U377V

U377V

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Hello, reading about GigaByte GA-G41M-ES2L apparently is working well.
But I would like better microprocessor
Cheap Grafica which I recommend
X86 Mac Snow Leopard - Leopard


GigaByte GA-G41M-ES2L
Intel Core 2 Quad Q8300 2.5 GHz
Kingston HyperX 2GB (2 x 1GB) DDR2 SDRAM (1066MHz - PC2-8500) Dual Channel Kit
Western Digital 500GB, 7200 RPM, 8MB Buffer
LG burner, Serial ATA DVD + RW


My components:
DESKTOP PC:
-Monitor - ACER 1440 X 900 resolution
-Mainboard 775: GigaByte GA-G41M-ES2L
-CPU 775 Core 2 Duo: Intel Core 2 Duo Prozessor
-OnBoard Audio
-OnBoard Lan

Everything is working fine, even my audio HD (headphones) In/Out..
except for
--OnBoard Display - GMA X4500 Dev Id 2e32

What is the best solution for that...
I have tried all of the possible kexts modification, installing CHAMELEON (all versions) even GrubX...

it's still not working...

#16
ebuyc

ebuyc

    InsanelyMac Protégé

  • Donators
  • 4 posts

Hi

Good news - LAN.

You can use R1000 or download the reallllllllllll tek driver from:

http://www.realtek.c...p;GetDown=false

Ver. 2.0.3



Don't use both !!!!!!!!!!!!!!!

Best regards,

Ruy


Members get the realtek driver here: http://www.insanelym...p...st&id=69220

#17
rhejura

rhejura

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
[quote name='ruy.benton' date='Jul 23 2009, 01:55 AM' post='1206646']
Hi,

Thanks for great support.

This board is the best :P

1) Kalyway 10.5.2 and iPC 10.5.6 select R1000 for LAN, Azalia (Realtek ALC888B) for sound and ICHx SATA drivers. In iPC select PS/2 fix if you use keyboard and mouse - PS/2.

hello
i am new into this forum and also to mac. i was using ubundu-10.5 and windows -7. then a friend said me that mac os leopard 10.5.6 is great OS to install, so with his help and others i finally managed to install it. i got everything except sound and ur post allowed me to get the perfect sound. thank u for that.. now i have only one problem remaining. my graphics driver is not installed it. i am using the same board for graphics, have not installed any new video cards. so i like to know is there any graphical driver update available for this version? or if i update from this version to 10.5.8, will my driver be available in that version?
thanx and regds
raj

#18
Clickr OButtons

Clickr OButtons

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
I am having a very hard time with this board. I bought it to replace an aging server and was intending to run Leopard Server on it. I have tried a number of install packages from boot-132 to some of the D41M-ES2L specific packages.

I can consistently boot to the Aurora screen and then it hangs with a spinning beach ball, seemingly refusing to start the installer itself. It seems like it's a permission issue, but with the graphic up, I can't see what the problem is.

This is a Rev 1.4 board. One thing I notice is that ACPI cannot be explicitly set, although it has an optimized setting that is supposed to enable the setting.

The other problem I consistently see with all packages if I boot with -v is that the fasksmc cannot be installed for some reason.

Has anyone else seen and resolved these problems?

Thanks.

-clickr

#19
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
Who with a rev 1.4 has the front mike jack working?

#20
ontheslab

ontheslab

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Brisbane, Australia
HI, Has anyone done a 10.6.8 update on the ES2L as yet?

How did is go? Any trouble?

Thank you!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy