Jump to content

ATI Radeon HD4350 PCIe


  • Please log in to reply
242 replies to this topic

#161
ANARCHiNTOSH

ANARCHiNTOSH

    Loldermort!!!!

  • Members
  • PipPipPipPip
  • 221 posts

The green Apple is a very big problem. I installed "Star Wars The Force Unleashed" and all the graphics are green, and sometimes pink, except the sky and characters :(

Its really ;) . It might be an idea to try using ATI kexts from 10.6.2 (before the green apple appeared) with device-id added to ATI4500Controller and ATIRadeonX2000. As far as i remember though it didnt work.
Im trying to develop an efistring, but my efforts have so far been fruitless. Its in my sig if you want to check the progress

ANARCHiNTOSH, can we put these kext in Extra/Extensions (instead of S/L/E) ? Thanks !

No, they have to replace the ATI kexts in S/L/E/
Also, with these, i added device-id to 4500controller, so you can remove ATI4350.Fix.kext from /E/E/

#162
ertepechis

ertepechis

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Atlanta, GA
cam somebody just upload .kexts files that actually work and what about the beta booter from netkas? the link is invalid i need this card for my business oh and 10.6.2 kexts please

#163
Grim Reaper

Grim Reaper

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts
  • Gender:Male
  • Location:Toronto, Canada (Crack smoking Mayor Rob Ford's city)
Follow the instructions, exactly, at this posting: http://www.insanelym...p;#entry1495307

You may have to do a little tuning like I did which I posted in that topic's thread.

Bon courage!



cam somebody just upload .kexts files that actually work and what about the beta booter from netkas? the link is invalid i need this card for my business oh and 10.6.2 kexts please



#164
ertepechis

ertepechis

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Atlanta, GA

Follow the instructions, exactly, at this posting: http://www.insanelym...p;#entry1495307

You may have to do a little tuning like I did which I posted in that topic's thread.

Bon courage!




thnx it seems this might work but there iss a little difference... my card is 1 gig so this might throw it off a little

#165
youmolo

youmolo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
First of all I'd like to thank everyone here for making this possible, especially ANARCHiNTOSH for writing the guide. I just got my PowerColor ATI 4350 512MB to run at full HD. Followed his guide to get it working.

Here's what I did:

  • Install OSX 10.6, Chamelon RC4 (refer guide above), and edit com.apple.boot.plist file (refer guide above)
  • Boot to safe mode
  • Install the combo update 10.6.3
  • Remove System/Library/Extensions/SleepEnabler.kext (VERY IMPORTANT, else it will cause a kernel panic)
  • Install ATI4350.Fix.kext from the guide above
  • Run kextutility and reboot. You should be booting into osx with full video support.

Now I'm running 1920x1080 on HDMI with full video acceleration. As for the green apple issue, I disabled transparency on the menu bar (System Pref > Desktop) so I don't see the green apple anymore.

I'm using a Biostar P4M890-M7 mobo with an Intel E2140. Everything works right out of the box except for the graphics card which I finally got working. Thanks again!

#166
ryudo423

ryudo423

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
just purchased this card.....lets hope i can get it to work when it arrives in a day or two... anyone have any success on getting it to work properly with 10.6.4???

#167
ANARCHiNTOSH

ANARCHiNTOSH

    Loldermort!!!!

  • Members
  • PipPipPipPip
  • 221 posts

just purchased this card.....lets hope i can get it to work when it arrives in a day or two... anyone have any success on getting it to work properly with 10.6.4???

for 10.6.4 i have found no way to get it to work other than replacing all ati kexts in System/Library/Extensions with those from 10.6.3

currently the card is best on 10.6.2

10.6.3 works, but you have a green apple in the top left of screen. their are some opengl anomalies, (photoshop is completely green, and apparently games are as well). 10.6.4 retains this problem

this is the guide for 10.6.2/10.6.3

this is the update guide for 10.6.4

you have to use the graphicsenabler function. i am sporadicly attempting to make an efistring that would solve the green apple problem, but ive been unsuccessful so far.

#168
ertepechis

ertepechis

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Atlanta, GA
To all those who have followed these forums i have come with a solution!!!!!!!!!!

anarchintosh has come up with a way to successfully enable this card with qe/ci but i modified his explanation for more use with amd processors

the technique is still the same but for some reason amd users seem to have minor difficulties with this

note... this also works on intel processors

this will work on both 10.6.2 or 10.6.3 pc's

for proof that this method has worked for me, there is a photo attached below of my about this mac while running final cut pro in the background

step 1[lets get started]

If you are on 10.6.3
*Just install the ati4350.fix.kexthat is in the archive with kext utility(found at http://www.insanelym...p...t&id=69895)
*kext utility can be found at http://www.insanelym...p...st&id=50182


If you are on 10.6.2
*follow instuctions for 10.6.3 but then navigate to /System/Library/Extensions using the finder.
*Right click on ATIRadeonX2000.kext and select "show package contents"
*Open up contents folder
*Edit Info.plist using the default text editor or text wrangler(text wrangler is more recommended though and can be found at http://www.barebones...ts/TextWrangler
*Add 0x954f1002 directly after <string> which is underneath IOPCIMatch. Save file.
*Move to trash /System/Library/Caches/com.apple.kext.caches (this file might not be there as it wasnt there for me but do not panic... just continue on)

step 2[BOOTy butt butt]
For only DVI monitors
*install the Chameleon-RC3 with PC-EFI 10.6 Installer or you may use the netkas beta booter
For only VGA monitors
*install the Chameleon-RC4 Installer

Install the bootloader to your OSX86 hdd( in my case external usb hdd)

step 3[got you by the string]

*navigate to and open the file /Library/Preferences/SystemConfiguration/com.apple.Boot.plist
*Add an entry that looks like this to your com.apple.boot.plist(backup just in case)
<key>GraphicsEnabler</key>
<string>Yes</string>
*anarchintosh has uploaded one AS AN EXAMPLE NOT FOR REAL USE http://www.insanelym...p...st&id=72105
*[++note++ you can use this file IF AND ONLY IF YOU ARE USING THE MACH KERNAL as i did but if not careful it may brick your machine]

step 4[simple yet necessary]

*navigate to /Extra/Extensions.mkext
*only delete the extensions.mkext
*empty trash for good measure
*if it is not there as it was on my machine then do not bother with this step

step 5[the finisher]

*run kext utility for 5-15 minutes or until you are told by kext utility to have a good day/night
*reboot you machine while praying to god
*open up web browser to youtube and watch something in full screen
*if and only if video seems to go at 2 fps then qe/ci has not been enabled... so move onto step 6

step 6[only if you got teabagged]
*navigate back to your ATIRadeonX2000.kext(this is what enables qe/ci) wich can be found at /System/Library/Extensions
*right click then show package contents
*open up the folder then open up info.plist
*check for imperfections(like the dev-id's not written right)
*if you found imperfections then fix them
*if you did not find imperfections then try installing an atiradeonx2000.kext using kext utility(but not recommended) the file can be found here(http://www.insanelym...e=post&id=73831) but only install the x2000.kext and let kext utility repair permissions again
*restart and pray to god once more

step 7[what makes you think you're done?]
*go ahead and change resolution(to test if ait4500.kext has been loaded properly)
*watch a youtube video(to test if atiradeonx2000.kext was loaded proplerly)
*if you cant access the internet then go to screensaver options and test the flurry screensaver
*in 10.6.3 it has been reported that you get the green apple on the top left of your screen

for dualscreen on this card you will need to look into the forums for efi string development(i have seen success but no url for you guys... sorry)
anarchintosh has started a forum on this subject
http://www.insanelym...howtopic=219362

Attached Files



#169
ANARCHiNTOSH

ANARCHiNTOSH

    Loldermort!!!!

  • Members
  • PipPipPipPip
  • 221 posts

for dualscreen on this card you will need to look into the forums for efi string development(i have seen success but no url for you guys... sorry)
anarchintosh has started a forum on this subject
http://www.insanelym...howtopic=219362

yh i think the problem is that bootloaders cant be frakked to properly support dual screen for ATi cards, because its a really hard job coding GraphicsEnabler. its annoying that ATi efistrings are so much more complicated than nVidia strings. nVidias cards may often be slower/more expensive, but i really appreciate how much less {censored} they need in their drivers....

#170
ertepechis

ertepechis

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Atlanta, GA

yh i think the problem is that bootloaders cant be frakked to properly support dual screen for ATi cards, because its a really hard job coding GraphicsEnabler. its annoying that ATi efistrings are so much more complicated than nVidia strings. nVidias cards may often be slower/more expensive, but i really appreciate how much less {censored} they need in their drivers....


it looks like efi strings are always more problomatic because i have a 512mb evga geforce 9400gt graphics card(didnt work out of the box but when enabled, it was problematic) and creating an efi string for that was easy and i saw that this hd 4350 card was compatible with this 10.6.2 system when i booted up my dvd and i thought creating an efistring was the way to go but it turns out that this is a gray area for any radeon graphics card so it might be hard to do this task wih the so little information at hand(in comparison to nvidia graphics chipsets) especially with specific cards

#171
plipli

plipli

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
ertepechis, at which step should I do the update ? combo update or Apple Software update ? Thanks.

#172
SFly

SFly

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Casper, Wy USA
  • Interests:Computers, Cars, ext


step 3[got you by the string]

*navigate to and open the file /Library/Preferences/SystemConfiguration/com.apple.Boot.plist
*Add an entry that looks like this to your com.apple.boot.plist(backup just in case)
<key>GraphicsEnabler</key>
<string>Yes</string>
*anarchintosh has uploaded one AS AN EXAMPLE NOT FOR REAL USE http://www.insanelym...p...st&id=72105
*[++note++ you can use this file IF AND ONLY IF YOU ARE USING THE MACH KERNAL as i did but if not careful it may brick your machine]

Hmm, I don't have a "Preferences" folder in my system library, I did find that file in my "Extra" folder but didn't seem to work, any ideas?

#173
ertepechis

ertepechis

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Atlanta, GA

Hmm, I don't have a "Preferences" folder in my system library, I did find that file in my "Extra" folder but didn't seem to work, any ideas?


hmm, thats impossible if you got mac osx running, u probably have it hiding, download houdini for mac and try to find it, it should be there

you sure u couldnt move it to trash?, try cutting it to the desktop... if that doesn't work then boot into safe mode using the -x flag

ertepechis, at which step should I do the update ? combo update or Apple Software update ? Thanks.


NO SOFTWARE UPDATE, this could box ur system... try doing the combo update before you start(i made that mistake myself)

++note++ this fix works on 10.6.4 but i havnt done it yet so i cant give you much details

#174
plipli

plipli

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
@SFly, press Apple+shift+G in the finder and paste /Library/Preferences/SystemConfiguration.

@ertepechis, how do you know it works if you haven't done it :blush:

#175
SFly

SFly

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Casper, Wy USA
  • Interests:Computers, Cars, ext

@SFly, press Apple+shift+G in the finder and paste /Library/Preferences/SystemConfiguration.

lol not sure how what will work as a apple key (im still new at this) but I think Ill try plugging in my G3's keyboard and give that a try


EDIT:

OK I did find it and inserted:
"<key>GraphicsEnabler</key>
<string>Yes</string>"

but when I run kext utility it ends up saying it cant create a file, here is the text from it:

ProductName: Mac OS X ProductVersion: 10.6.2 BuildVersion: 10C540
Kernel: Darwin Kernel Version 10.2.0: Tue Nov 3 10:35:19 PST 2009
Bootargs: boot-uuid=A98B8373-295C-34AB-98BB-FC0797277123 rd=*uuid -v
Model ID: MacBookPro5,5
CPU Signature: Ox6FD (1789)
CPU TYPE: Intel® Core™2 Duo CPU T5850 @ 2.16GHz
Core: 2260(2260) MHz x 8.4(8.4) Bus: 266 MHz FSB: 1064 MHz
Cache L2: 2 Mb
RAM: 4096 Mb
SwapUsage: total = 64.00M used = 0.00M free = 64.00M (encrypted)
HibernateMode: 27
User: DJSFly on Christopher-Turks-MacBook-Pro.local

Start working: Sun Jul 25 13:59:40 MDT 2010
Detected ... MAC OS X "Snow Leopard".

Task: Full service for "/System/Library/Extensions/"
and "/Extra/Extensions" folders.

Repair Permissions for "/System/Library/Extensions" ... Done.
-- Total processed: 5484 files for 43 sec.
kext: 353
plugin: 23
bundle: 20
ppp: 10

Remove kexts caches ... Done.

Preventive removal sleepimage file ... Done.

Waiting system rebuild "Snow Leo" "Extensions.mkext" ... Done
-- Build time = 18 sec.


Search "/Extra/Extensions/" folder ... Found.

Task: Pack "/Extra/Extensions"
to "/Extra/Extensions.mkext"

Repair Permissions for "/Extra/Extensions" ... Done.
-- Total processed: 1 files for 0 sec.
kext: 0
plugin: 0
bundle: 0
ppp: 0

Search "Extensions.mkext" ... Not Found.

Packing new "Extensions.mkext" ...



#176
ertepechis

ertepechis

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Atlanta, GA

@SFly, press Apple+shift+G in the finder and paste /Library/Preferences/SystemConfiguration.

@ertepechis, how do you know it works if you haven't done it :)

Anarchintosh said he's done it on 10.6.4

lol not sure how what will work as a apple key (im still new at this) but I think Ill try plugging in my G3's keyboard and give that a try


EDIT:

OK I did find it and inserted:
"<key>GraphicsEnabler</key>
<string>Yes</string>"

but when I run kext utility it ends up saying it cant create a file, here is the text from it:


hmm i didnt see a problem, it looks like it ran smoothly, but didnt finish... how long have you had it running? give it at least 10 or at the most 20

ANYONE WITH SPECIFIC PROBLEMS SHOULD SEND ME AN EMAIL(FROM THERE ILL GIVE YOU MORE SPECIFIC INFORMATION)

IM FOLLOWING SEVERAL THREADS AND ITS HARD TO KEEP UP

#177
ryudo423

ryudo423

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
wanted to report back and say that ive got the card fully enabled on 10.6.2 thanks to the guide by Anarchintosh.... thanks for all the hard work.. will be checking back once the card can be utilized in 10.6.4.. which will hopefully be sooner than later!! thanks again!

#178
ytrox

ytrox

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 501 posts
  • Gender:Male
  • Location:Italy

Hmm, I don't have a "Preferences" folder in my system library, I did find that file in my "Extra" folder but didn't seem to work, any ideas?


you must go in /Library, not system/library

#179
ytrox

ytrox

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 501 posts
  • Gender:Male
  • Location:Italy
4350 EFI STRING???

Hi all!
I'm new here... searched for infos about the HD4350, but found almost nothing...
Can anyone update me about drivers, patches or obscure magic rituals for getting this video card to work with two displays?

Thanks!


My card has seen in System profiler like an ATI 4670 in 10.6.4. anybody has the same problem? I still maintain 10.6.2 without green apple.

#180
ertepechis

ertepechis

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male
  • Location:Atlanta, GA

4350 EFI STRING???



My card has seen in System profiler like an ATI 4670 in 10.6.4. anybody has the same problem? I still maintain 10.6.2 without green apple.


we are all working on that, for now youll have to use graphics enabler





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy