Jump to content

Nvidia GTX 295 support


  • Please log in to reply
69 replies to this topic

#61
OSboots

OSboots

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Same Problem here with a P5Q Deluxe + GTX295
Everythings Ok with 10.6.6 but after 10.6.7 Monitor sleep hangs video.
I can use ssh to connect to the computer, All services working, just the video is hang.
Regards

#62
uachu

uachu

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Hello, forgive my English, I use a translator.

I have GTX 295 Single-PCB running on Snow Leopard, by efi string in com.apple.boot.plist and NVGTX295.Fix.kext in E / E.
Lion I installed and followed the same steps to install the GTX 295, but the screen goes black. Lion works because I give volume and listen.

Any ideas?

Again, forgive my English

Thanks!

#63
Village Idiot

Village Idiot

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
So I have a P6T with a GTX 295. 10.6.4 is installed and I'm going to update to 10.6.8 on a cloned drive. Do I just update and reinstall the 295 kext?

#64
meroy

meroy

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
The following maybe of help for folks running 10.6.7 or earlier with a NVIDIA GTS/GTX 2xx graphics card and wanting to update to 10.6.8.

Prior to the 10.6.8 update, download two kexts by nawcom http://prasys.info/l...s_by_nawcom.zip

Unzip the file and use Kext Helper to install both EvilAppleACPIPlatform.kext and EvilIOPCIFamily.kext to /Extra/Extensions.

This ensured my GTX 295 graphics card will continue to work after the 10.6.8 update. No changes were needed to my boot plist file which has the EFI string for my GTX 295 card.

Thanks to nawcom for providing the two kexts.

The system sleep is failing though under 10.6.8 for me with this method. However, the display can sleep and wake up without any problems with Apple's native 10.6.8 drivers.

- meroy

#65
meroy

meroy

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
At last, success is achieved with 10.6.8 and a GTX 295 card (Single PCB edition).

http://www.insanelym...p...t&p=1717189

Note: The culprit was was with the device-type. Each GPU is different. The one having display connections is set to NVDA,Parent and the other to NVDA,GeForce.

#66
MastaG

MastaG

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Working great here too.

See my post: http://www.insanelym...p...t&p=1718867

For the dual-cb edition both device-type keys need to be set to:

<key>device_type</key>
<string>NVDA,Parent</string>

You can remove the:
<key>name</key>
<string>NVDA,Parent</string>

#67
behiii

behiii

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
i installed lion 10.7 on my external hard disk
rampage || Extreme
corei7 920
12 gb corsei 1600
GTX295


every thing linke network,sound... are ok...
but graphic is strange
at the system profiler know that there is a gtx295 with 896 mb but the resolution in not right and there is no QE/QI???
is there anyway to make it right or i had to buy another vga...


another ques...? which vga in good for lion and mac... be pro plz... :D???

#68
windtaker

windtaker

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Bumping up this one.

Im using Snow leopard with a dual GPU GTX 295 and it works fine, then i tried to install Lion with Digital Dreamers guide and everything seems perfect except the Graphics. so i google and google and tried some stuff until i get to the " computer reboots" state.

So.. any success someone to get this card functional? =)

#69
harvieb

harvieb

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
any solutions for the CO-OP card gtx 295 896mb

im at my wits end with this card, it boots into the black screen with the NVIDIA drivers from their site, doesnt go any further

2 evil kext and nvenabler/nvgtx295enabler.kext dont work and simply give me a kernel panic, which is resolved by removing those kexts

EFI string i cant seem to generate one which works, everything ive tried regarding meroys EFI seems not to want to work, anything im doing wrong?

#70
ErOSx86

ErOSx86

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
So I have managed to get mine to operate somewhat in 10.7.3... it was done by installing the official lion nVidia drivers and using Graphics Enabler = yes... no other strings or kexts where required... the only caveat was that the output on mine only comes from the HDMI port, not the DVI... but it does work full acceleration and is only probably running one of the GPUs, but it is at least a starting point





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy